RPi - problem med DDClient och locales

Trädvy Permalänk
Medlem
Plats
Långtbortistan
Registrerad
Mar 2007

RPi - problem med DDClient och locales

Jag har två hallonpajer hemma; den ena kör jag MusicBox och DNS-server på, den andra håller jag på att konfigurera för att använda som backup-maskin (skall placeras hos mina föräldrar). För att underlätta åtkomsten tänkte jag att det kunde vara smidigt att använda en dynamisk DNS till den så att jag slipper försöka luska ut ip-numret efter t.ex. ett strömavbrott. Att installera DDclient gick snabbt och smidigt på backup-pajen, jag har provkört den mot Loopia och den uppdaterar min subdomän som den skall.

Efter att jag fått det att fungera kom jag att tänka på att det vore ju smidigt om jag kunde SSH:a hem också så jag installerade DDclient även på den andra Raspberryn och kopierade in ddclient.conf från backup-pajen. Det fungerar dock inte alls, inte ens när jag kör "sudo ddclient" för att manuellt tvinga den att uppdatera domänen. Jag har provat att ändra i backup-pajens ddclient.conf så att den uppdaterar det domännamn jag tänkte ha hemma och det fungerar bra så felet ligger i min ände.

Vid något tillfälle fick jag ett felmeddelande om att "locales is broken" men jag är osäker på om det är därför DDclient inte fungerar. Jag försökte återställa locales med raspi-config men det gav bara ännu fler felmeddelanden, "locales is broken or not fully installed". Jag försökte sedan på ett antal olika sätt installera om locales men jag hittade inget som fungerade. Är det någon som har ett förslag på vad som kan vara fel?

Det finns bara två sorters hårddiskar: de som har gått sönder och de som skall gå sönder.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003
Skrivet av zarkov:

Jag har två hallonpajer hemma; den ena kör jag MusicBox och DNS-server på, den andra håller jag på att konfigurera för att använda som backup-maskin (skall placeras hos mina föräldrar). För att underlätta åtkomsten tänkte jag att det kunde vara smidigt att använda en dynamisk DNS till den så att jag slipper försöka luska ut ip-numret efter t.ex. ett strömavbrott. Att installera DDclient gick snabbt och smidigt på backup-pajen, jag har provkört den mot Loopia och den uppdaterar min subdomän som den skall.

Efter att jag fått det att fungera kom jag att tänka på att det vore ju smidigt om jag kunde SSH:a hem också så jag installerade DDclient även på den andra Raspberryn och kopierade in ddclient.conf från backup-pajen. Det fungerar dock inte alls, inte ens när jag kör "sudo ddclient" för att manuellt tvinga den att uppdatera domänen. Jag har provat att ändra i backup-pajens ddclient.conf så att den uppdaterar det domännamn jag tänkte ha hemma och det fungerar bra så felet ligger i min ände.

Vid något tillfälle fick jag ett felmeddelande om att "locales is broken" men jag är osäker på om det är därför DDclient inte fungerar. Jag försökte återställa locales med raspi-config men det gav bara ännu fler felmeddelanden, "locales is broken or not fully installed". Jag försökte sedan på ett antal olika sätt installera om locales men jag hittade inget som fungerade. Är det någon som har ett förslag på vad som kan vara fel?

Står det någon i loggen på den maskinen som inte fungerar?

| Citera för svar! | Gilla bra inlägg! |

Trädvy Permalänk
Medlem
Plats
Långtbortistan
Registrerad
Mar 2007

Ja, genom att köra

ddclient -daemon=0 -debug -verbose -noquiet

fick jag fram att den icke-fungerande pajen saknade ett paket för att köra ssl i perl:

FATAL: Error loading the Perl module IO::Socket::SSL needed for SSL connect. FATAL: On Debian, the package libio-socket-ssl-perl must be installed.

.

Sen jag installerat paketet fungerar det.

Jag vet dock fortfarande inte vad som är fel med mina locales...

@MusicBox ~ $ sudo dpkg-reconfigure locales perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_US.UTF-8", LC_ALL = "en_US.UTF-8", LANG = "en_US.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory /usr/sbin/dpkg-reconfigure: locales is broken or not fully installed

Vad skall jag leta efter i loggen och var? I /var/log men vilken fil?

Det finns bara två sorters hårddiskar: de som har gått sönder och de som skall gå sönder.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003
Skrivet av zarkov:

Ja, genom att köra

ddclient -daemon=0 -debug -verbose -noquiet

fick jag fram att den icke-fungerande pajen saknade ett paket för att köra ssl i perl:

FATAL: Error loading the Perl module IO::Socket::SSL needed for SSL connect. FATAL: On Debian, the package libio-socket-ssl-perl must be installed.

.

Sen jag installerat paketet fungerar det.

Jag vet dock fortfarande inte vad som är fel med mina locales...

@MusicBox ~ $ sudo dpkg-reconfigure locales perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_US.UTF-8", LC_ALL = "en_US.UTF-8", LANG = "en_US.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory /usr/sbin/dpkg-reconfigure: locales is broken or not fully installed

Vad skall jag leta efter i loggen och var? I /var/log men vilken fil?

Så får jag också ibland beroende på vilken ssh klient jag använder.

testa följande

apt-get update
apt-get dist-upgrade
apt-get install --reinstall debconf locales-all

| Citera för svar! | Gilla bra inlägg! |

Trädvy Permalänk
Medlem
Plats
Långtbortistan
Registrerad
Mar 2007
Skrivet av BrusE:

Så får jag också ibland beroende på vilken ssh klient jag använder.

testa följande

apt-get update
apt-get dist-upgrade
apt-get install --reinstall debconf locales-all

Tack, jag körde något liknande igår och det verkar som om det fungerar nu. Jag fick läsa på lite om "apt-get dist-upgrade" och inser att det nog är ett bättre kommando än upgrade när man som jag gör det alltför sällan.

Det finns bara två sorters hårddiskar: de som har gått sönder och de som skall gå sönder.