Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

Plasma 5.x - buggigt?

Testade en ren Arch med Plasma 5.4 häromdagen men ack så buggigt det verkar. Är det en beta bara eller RC eller liknande?
Kör vanligtvis Xfce som går som tåget utan incidenter, men med plasma hänger datorn sig helt så strömknappen är enda utvägen. Inte ens CTRL+ALT+F2 funkar.
Någon mer som upplevt liknande med just Plasma?
BTW varför har inte Plasma en egen Wiki-sida på Arch wikin? KDE har ju inget med Plasma att göra längre, då de inte är kompatibla.
Verkar som det inte är riktigt klart ännu.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
~/Karlstad
Registrerad
Dec 2005

Upplever lite samma faktiskt, känns inte helt färdigt.
Fryser ibland, fönster stängs ner, fönster startar inte m.m.
Jag hoppas det jobbas på detta fortfarande då jag gillar det i övrigt!
Lirar Arch i grunden också.

Bara gammalt skräp...

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av bardbard:

Upplever lite samma faktiskt, känns inte helt färdigt.
Fryser ibland, fönster stängs ner, fönster startar inte m.m.
Jag hoppas det jobbas på detta fortfarande då jag gillar det i övrigt!
Lirar Arch i grunden också.

Jag gillar verkligen GUI:t men jag får köra Xfce med compton och infinality-bundle så länge, så känns det helt okej. Dock lider jag av tearing lite nu och då. Speciellt på YouTube, har testat alla trix med att disabla vsync HW acceleration m.m.

i7
GTX
4K

Trädvy Permalänk
Inaktiv
Registrerad
Mar 2015
Skrivet av bardbard:

Upplever lite samma faktiskt, känns inte helt färdigt.
Fryser ibland, fönster stängs ner, fönster startar inte m.m.
Jag hoppas det jobbas på detta fortfarande då jag gillar det i övrigt!
Lirar Arch i grunden också.

Jag gav upp helt när Kubuntu spottade ut sig att vyerna inte kunde hittas. Ändå hade jag bara installerat VLC och GIMP i terminalen och slösurfat samtidigt när jag skulle till och öppna inställningar. Det blev droppen för mig.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Yepp, KDE5 är tyvärr riktug buggig och undviker den som pesten.

KDE5 kör man för att buggtesta och rapportera buggar.

Dator: i7 4960x | 32GB | Asus Rampage IV Formula | GTX 1080
OS: Slackware 64-bit current + multilib

Trädvy Permalänk
Medlem
Plats
~/Karlstad
Registrerad
Dec 2005

Kommer väl säkert bli ordning på det med tiden får man ju hoppas. Ska väl tillägga att jag inte har problem så ofta som det låter, kanske 2 gånger i veckan max. Körde Openbox innan och det krånglade iof aldrig men men, ska man ha lull-lull får man riskera lite också

Bara gammalt skräp...

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

@bardbard:
iknande för mig. Hände inte var gång eller dag, men sista gången var när jag loggade in och startade Chromium liiiite för snabbt. Då ville inte datorn mer.
Då blev det i med bootstickan och köra install igen. Denna gång Xfce. Som jag gillar förvisso.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
~/Karlstad
Registrerad
Dec 2005

@Dockland
Kanske skulle ta och prova xfce. Något jag stör mig på är att kde5 tar mycket resurser i idle.
I Openbox låg jag på kanske 170Mb i Ram-användning, i KDE typ 1200Mb. Antar att Xfce ligger däremellan.
Är detta jag gillar med Linux, lätt att prova olika DE's utan att behöva installera om hela datorn.

Pacman DE
nano xinitrc
reboot
win!

Bara gammalt skräp...

Trädvy Permalänk
Medlem
Registrerad
Apr 2012
Skrivet av bardbard:

@Dockland
Kanske skulle ta och prova xfce. Något jag stör mig på är att kde5 tar mycket resurser i idle.
I Openbox låg jag på kanske 170Mb i Ram-användning, i KDE typ 1200Mb. Antar att Xfce ligger däremellan.
Är detta jag gillar med Linux, lätt att prova olika DE's utan att behöva installera om hela datorn.

Pacman DE
nano xinitrc
reboot
win!

Eller så byter du till tty2 och skriver
killall Xorg && exit
Sen startx, boom. Annan DE/WM.
Om du är så lagd kan du ju även köra flera olika DE/WM's på olika tty's

Trädvy Permalänk
Medlem
Registrerad
Jun 2007

Hade också problem med nya KDE och plasma 5(+). Hela datorn hängde sig. Lösningen var att installera Nvidias egna grafikdrivrutin istället för befintliga nouveau.

Edit: Min teori var att eftersom plasma är mer grafiskt krävande så triggas buggar i nouveau. Vilket stämde. Nouveau fungerar nämligen utan allvarliga problem i xfce och lxde.

Trädvy Permalänk
Entusiast
Plats
Stockholm
Registrerad
Jul 2007

Jag kör Arch Linux med KDE plasma 5.4, och det fungerar helt problemfritt. Har inga som helst problem.
En av de bättre KDE-versionerna på länge.

Vad för buggar stöter ni på mer exakt?

Att "det inte är klart" är väl en sanning med modifikation.
De flesta, men inte alla KDE-applikationerna har inte konverterats över till det nya KDE Frameworks 5.x (kf5). Det finns fortfarande ett fåtal appar som fortfarande är kompilerade mot det lite äldre KDE libs 4.x (klibs4)
Men KDE 5.x är 100% bakåtkompatibelt så det är egentligen inga problem. Det är bara en tidsfråga innan alla officiella applikationerna har konverterats till kf5.

Tillägg:
Däremot har jag upptäckt att alla miljöer som använder de senaste OpenGl-funktionerna är oerhört ostabila med nVidias senaste drivrutiner. Det är inte bara KDE, utan ett flertal miljöer som lider av detta, och problemet ligger hos nVidia... och i vanlig ordning vägrar de erkänna det.

Bästa programmen till Linux - v2.0
Linux-guide: Val av grafisk miljö. (Att välja distribution).
-
Everyone should have a SGoC in their systems (SGoC: SysGhost on a Chip)

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av bardbard:

@Dockland
Kanske skulle ta och prova xfce. Något jag stör mig på är att kde5 tar mycket resurser i idle.
I Openbox låg jag på kanske 170Mb i Ram-användning, i KDE typ 1200Mb. Antar att Xfce ligger däremellan.
Är detta jag gillar med Linux, lätt att prova olika DE's utan att behöva installera om hela datorn.

Pacman DE
nano xinitrc
reboot
win!

Min Xfce använder runt 360-420MB clean boot. Sedan upp mot 7-800 efter några dagars användning. Btrfs på home (mest för att testa, dock inga sub volumes) Kör själv systemd-boot (gamla gummiboot) och lightdm som greeter. Har lagt in quiet splash i boot-strängen så jag kallbootar på 4-5 sekunder
Och stabilt.

i7
GTX
4K

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Fire_Ice:

Hade också problem med nya KDE och plasma 5(+). Hela datorn hängde sig. Lösningen var att installera Nvidias egna grafikdrivrutin istället för befintliga nouveau.

Edit: Min teori var att eftersom plasma är mer grafiskt krävande så triggas buggar i nouveau. Vilket stämde. Nouveau fungerar nämligen utan allvarliga problem i xfce och lxde.

Själv kör jag ren Intel-grafik på NUC:en. IRIS6100 eller vad de nu heter Broadwell-varianten.

i7
GTX
4K

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av SysGhost:

Jag kör Arch Linux med KDE plasma 5.4, och det fungerar helt problemfritt. Har inga som helst problem.
En av de bättre KDE-versionerna på länge.

Vad för buggar stöter ni på mer exakt?

Att "det inte är klart" är väl en sanning med modifikation.
De flesta, men inte alla KDE-applikationerna har inte konverterats över till det nya KDE Frameworks 5.x (kf5). Det finns fortfarande ett fåtal appar som fortfarande är kompilerade mot det lite äldre KDE libs 4.x (klibs4)
Men KDE 5.x är 100% bakåtkompatibelt så det är egentligen inga problem. Det är bara en tidsfråga innan alla officiella applikationerna har konverterats till kf5.

Tillägg:
Däremot har jag upptäckt att alla miljöer som använder de senaste OpenGl-funktionerna är oerhört ostabila med nVidias senaste drivrutiner. Det är inte bara KDE, utan ett flertal miljöer som lider av detta, och problemet ligger hos nVidia... och i vanlig ordning vägrar de erkänna det.

Symptom: Det som händer mer exakt är att desktopen fryser helt. Keyboard slutar svara och det verkar inte finnas någon time out på detta. CPU-fläktarna går upp till 100% och jag kan inte göra någonting alls. Väntade första gången ca 15-20 minuter för att se om det skulle släppa, men inget hände så jag gjorde hard reboot.

Vad jag gjorde när detta skedde: Lite olika. En gång när jag öppnade file manager (vad den nu heter i plasma) en gång när jag startade chromium. En gång när jag ändrade tema till "dark" vad den nu heter.
Sista gången var "chromium-incidenten" då rullade jag om Arch på nucen.

HW: Intel NUC5i7RYH (Broadwell) 16 GB RAM, PCIe SSD på 250GB (951:an AHCI)
Men som sagt, i Xfce upplever jag inga problem.
Jag hade förvisso kunnat dumpa loggfilerna efter krascherna och felsökt lite mer baserat på den infon, men vill inte ha en DE som kraschar lite nu och då så det fick bli Xfce som jag kört ett bra tag på olika distar utan incidenter.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Jag har fått känslan att det mest är grafikrelaterade buggar. När jag körde ett AMD grafikkort med open source drivrutiner funkade det bra. Sedan när jag bytte till nvidia grafikkort med proprietära drivrutiner har det varit buggigt. Gjorde nyligeb en nyinstallation av Arch på en HP Elitebook 2540P med intel grafik och där känns det helt stabilt.

Men av denna tråden att döma verkar ju inte heller intel alltid vara stabilt. Hur som helst tycker jag det blivit något bättre på sistone så förhoppningsvis fixas det buggar och blir bättre med tiden.

XFCE är numera mitt andrahandsalternativ eftersom jag gillar KDE5 med plasma trots buggarna. Många av mina favoritprogram är gjorda för KDE så det känns bra att köra dem native om man säger så.

Edit: Vissa buggar har försvunnit sedan jag återgått till standardtemat Breeze. Antagligen är väl detta mer buggtestat eftersom många inte orkar bry sig om att ändra grafiktema.