Hur skriver jag < och > på ett amerikanskt keyboard med Svenska som språk?

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011

Hur skriver jag < och > på ett amerikanskt keyboard med Svenska som språk?

Jag köpte en kina tablet och fick då med ett amerikanskt tangentbord. Dock har jag ställt in till Svenska i Windows och för det allra mesta funkar det bra förutom när jag kodar. Större än och mindre än symboler används ganska ofta men jag förstår inte hur jag skriver dessa.

Symbolerna finns ju nere i högra delen bredvid bokstaven m, men jag jag kan inte på något sätt få det att skrivas ut när jag trycker på dem.
Nere till vänster finns ju symbolerna på ett svenskt layout men dessa tangenter saknas ju helt i detta fallet.

Stationär:Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02
Laptop: Jumper ezbook 3 pro
Mobil: Xiaomi Redmi Note 3 pro SE

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010

Skift + , trycker du för <, Skift + . trycker du för >.

EDIT: Missförstog frågan. Hur ser tangentbordet ut, vilka knappar har du? Sitter det till exempel en knapp till vänster om 1an ovanför bokstavstangenterna?

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av ToJa92:

Skift + , trycker du för <, Skift + . trycker du för >.

Tyvärr, allt jag får är ; och : när jag trycker på Shift och dem.

Såhär er det ut: http://www.aliexpress.com/item-img/Original-Cube-i7-Stylus-ke...

Bilden är nästan korrekt,den har utelämnat några knappar som funkar som extraknappar om man håller inne Fn eller trycker på numlock, men ingen av dem är de tecken jag letar efter.

Stationär:Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02
Laptop: Jumper ezbook 3 pro
Mobil: Xiaomi Redmi Note 3 pro SE

Trädvy Permalänk
Tangentbordskonnässör
Plats
Överallt
Registrerad
Sep 2005

Om det är när du kodar du behöver <> tecken så är det ju bara att köra på US ANSI som språk i din IDE/editor.
Jag kör själv med ANSI och kodar med den layouten, 100 gånger bättre och det tog typ en eftermiddag att vänja sig.

Annars får du lägga till fler inmatningsspråk i Windows och skifta till US när du behöver skriva dessa tecken. Tror det är ALT + SHIFT för att byta mellan språken i Windows.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010

Prova ~-tangenten till vänster om siffran 1, vill minnas att med svenska inställt så kan den tangenten eventuellt motsvara den tangent som sitter till höger om vänster skift på tangentbord med ISO-layout. Fungerar inte det så saknas tangenten helt, eftersom ISO-layouten har en extra tangent jämfört med ANSI-layouten. Se: http://deskthority.net/wiki/ANSI_vs_ISO#Layouts.

EDIT: Om det inte fungerar kan du använda exempelvis SharpKeys (som fungerar hela vägen upp till Windows 10) för att göra om tangenten till vänster om 1 till den tangent som normalt sitter till höger om vänster skift-tangent.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Tangentbordskonnässör
Plats
Överallt
Registrerad
Sep 2005
Skrivet av ToJa92:

Prova ~-tangenten till vänster om siffran 1, vill minnas att med svenska inställt så kan den tangenten eventuellt motsvara den tangent som sitter till höger om vänster skift på tangentbord med ISO-layout. Fungerar inte det så saknas tangenten helt, eftersom ISO-layouten har en extra tangent jämfört med ANSI-layouten. Se: http://deskthority.net/wiki/ANSI_vs_ISO#Layouts.

Det fungerar inte i Linux iaf. Har inte windows så kan inte testa det i windows med ANSI tangentbord.
Men som du säger så är det ju en tangent mindre på US layout, och det är just "<>" tangenten bredvid vänster shift som fattas.

Trädvy Permalänk
Medlem
Registrerad
Jun 2015

Enkel men ful lösning är att byta till amerikansk layout medan du kodar. Eftersom det är just den knappen som saknas om du kör svensk layout på ett amerikanskt tangentbord så är det lite jobbigt att komma åt :/

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av huttala:

Om det är när du kodar du behöver <> tecken så är det ju bara att köra på US ANSI som språk i din IDE/editor.
Jag kör själv med ANSI och kodar med den layouten, 100 gånger bättre och det tog typ en eftermiddag att vänja sig.

Annars får du lägga till fler inmatningsspråk i Windows och skifta till US när du behöver skriva dessa tecken. Tror det är ALT + SHIFT för att byta mellan språken i Windows.

Detta lät riktigt smart och ska provas!

Skrivet av ToJa92:

Prova ~-tangenten till vänster om siffran 1, vill minnas att med svenska inställt så kan den tangenten eventuellt motsvara den tangent som sitter till höger om vänster skift på tangentbord med ISO-layout. Fungerar inte det så saknas tangenten helt, eftersom ISO-layouten har en extra tangent jämfört med ANSI-layouten. Se: http://deskthority.net/wiki/ANSI_vs_ISO#Layouts.

EDIT: Om det inte fungerar kan du använda exempelvis SharpKeys (som fungerar hela vägen upp till Windows 10) för att göra om tangenten till vänster om 1 till den tangent som normalt sitter till höger om vänster skift-tangent.

Funkar dessvärre inte med den tangenten. Om jag ska mappa om något så behöver jag egentligen 2 knappar. Kan man inte lägga till något mer på fn tangenten?

Skrivet av Whaleman:

Enkel men ful lösning är att byta till amerikansk layout medan du kodar. Eftersom det är just den knappen som saknas om du kör svensk layout på ett amerikanskt tangentbord så är det lite jobbigt att komma åt :/

Går ju, men lite omständigt.

___________________

Testade Sharpkeys men fick inte det att fungera. Jag lyckades mappa bort knapparna helt så det blev helt tomma...

SHIFT+ALT går ju ganska bra för att ändra snabbt, men hur ändrar man språket/layouten i Eclipse? Hittar inget om det.

Stationär:Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02
Laptop: Jumper ezbook 3 pro
Mobil: Xiaomi Redmi Note 3 pro SE

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Prova att ställa teckenkodningen till UTF-8, i Linux blir amerikansk och svenskt tangentbord lika, enda skillnaden är om du har stor eller liten enter-tangent. Ett alternativ är engelsk storbritanien, då är Alt-Gr + Z och X <>. Engelska USA med stumma tangenter är den som har <> brevid M i skiftläge.

För mig fungerar alla tangentbord, förutom Å, Ä, Ö med annat än svensk layout i UTF-8. (Viket kan ordnas med specialtecken-inställningar.)

Windows is not doing our work seriously
——————————————————————
AMD FX 8150 | ASUS Sabertooth 990FX | 32 GB RAM | ASUS radeon 7970 @ 1 GHz
9 000 GiB i media | NEC PA301W @ 2560x1600 | Kör linux os

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av OldComputer:

Prova att ställa teckenkodningen till UTF-8, i Linux blir amerikansk och svenskt tangentbord lika, enda skillnaden är om du har stor eller liten enter-tangent. Ett alternativ är engelsk storbritanien, då är Alt-Gr + Z och X <>. Engelska USA med stumma tangenter är den som har <> brevid M i skiftläge.

För mig fungerar alla tangentbord, förutom Å, Ä, Ö med annat än svensk layout i UTF-8. (Viket kan ordnas med specialtecken-inställningar.)

Menar du i Eclipse? Det funkar inte.

Stationär:Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02
Laptop: Jumper ezbook 3 pro
Mobil: Xiaomi Redmi Note 3 pro SE

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

@Baxtex: Jag menar som default i Windows.

Windows is not doing our work seriously
——————————————————————
AMD FX 8150 | ASUS Sabertooth 990FX | 32 GB RAM | ASUS radeon 7970 @ 1 GHz
9 000 GiB i media | NEC PA301W @ 2560x1600 | Kör linux os