Stäng av DHCP på ComHems modem CH7486E

Permalänk
Medlem

Stäng av DHCP på ComHems modem CH7486E

Hej!

Jag har ComHem's senaste modem/router "CBN CH7486E Wireless Voice Gateway" (firmware version 5.510.5.6).
Den har en inbyggd DHCP v4-server.

Är det nån som vet hur man stänger av DHCP-servern?

Min plan är nämligen att sätta upp en Raspberry Pi som DHCP-server och då måste RPi få vara authoritative. Jag antar ComHems DHCP just nu är authoritative, så då lär de krocka. Därför vill jag stänga av ComHem.

På de tidigare ComHem-modemen fanns det hemliga sidor man kunde surfa in på och få tillgång till fler inställningar.
Känner nån till nått liknande?

Mvh, Reyhn

Permalänk
Rekordmedlem
Skrivet av Reyhn:

Hej!

Jag har ComHem's senaste modem/router "CBN CH7486E Wireless Voice Gateway" (firmware version 5.510.5.6).
Den har en inbyggd DHCP v4-server.

Är det nån som vet hur man stänger av DHCP-servern?

Min plan är nämligen att sätta upp en Raspberry Pi som DHCP-server och då måste RPi få vara authoritative. Jag antar ComHems DHCP just nu är authoritative, så då lär de krocka. Därför vill jag stänga av ComHem.

På de tidigare ComHem-modemen fanns det hemliga sidor man kunde surfa in på och få tillgång till fler inställningar.
Känner nån till nått liknande?

Mvh, Reyhn

Om du BARA ska ha en egen dhcp server (varför ?) så är det nog enklast att bara ställa om så Compalens dhcpserver inte delar ut adresser inom det område där din pi ska göra det, dvs låt den vara på men bara dela ut 1 adress som du sedan "reserverar" till nått som i verkligheten inte ingår i lanet.
Bryggar du Compalen så måste du ju även ha en egen router.
Sidan 28 >
https://www.comhem.se/blob/85822/2/manual-compal-h7486e-data....

Permalänk
Forumledare

*Tråd flyttad*
/moderator

Permalänk
Medlem
Skrivet av mrqaffe:

Om du BARA ska ha en egen dhcp server (varför ?) så är det nog enklast att bara ställa om så Compalens dhcpserver inte delar ut adresser inom det område där din pi ska göra det, dvs låt den vara på men bara dela ut 1 adress som du sedan "reserverar" till nått som i verkligheten inte ingår i lanet.
Bryggar du Compalen så måste du ju även ha en egen router.
Sidan 28 >
https://www.comhem.se/blob/85822/2/manual-compal-h7486e-data....

Inte egentligen svaret på min fråga, men det löste problemet! (:
Smart tänkt, det fungerade utmärkt. Min egen DHCP-server får nu den enda adress som delas ut av Compal (via MAC-adressen), och DHCP-servern delar ut resten.

Tack för hjälpen!

Permalänk
Medlem

@Reyhn: Hej, late to the party men hellre än att starta en ny tråd ställer jag frågan direkt till någon som löst mitt problem:
Jag är ute efter EXAKT samma lösning som du (ska köra pi-hole på en pi och vill använda den som DHCP-server på ett likadant modem/gateway som din).

MEN

Jag förstod inte riktigt hur man uppnår den fastställda lösningen.

I DHCP-serverinställningarna ska jag låsa pi:en via mac-address till ett lan-ip 192.168.0.X för att sedan sätta settings i bilden ovan som

Starting Local Address: 192.168.0.X
Number of CPEs: 1
Lease Time: 0

Har jag förstått det rätt då? Gör det att resten av enheterna på nätverket kommer routa sin trafik via pihole och att sagda pihole delar ut lokala ip-adresser istället för att comhems DHCP-server gör det?

Mvh Niklas

Permalänk
Medlem
Skrivet av Release:

Starting Local Address: 192.168.0.X
Number of CPEs: 1
Lease Time: 0

Har jag förstått det rätt då? Gör det att resten av enheterna på nätverket kommer routa sin trafik via pihole och att sagda pihole delar ut lokala ip-adresser istället för att comhems DHCP-server gör det?

Kul att jag inte är den enda som tänker i de banorna. (:

Jag minns nu längre inte exakt hur jag gjorde, och eftersom mitt experiment är avslutat så är det inte konfigurerat så längre. Jag vill dock minnas att jag gjorde nästan exakt som du föreslår.

Starting Local Address: 192.168.0.2
Number of CPEs: 1
Lease Time: 86400

Jag tilldelade RPi:ns MAC-adress 192.168.0.2 i listan "Reserved IP Addresses" på samma sida.
Lease time tror jag inte har nån betydelse egentligen, eftersom RPi:n alltid kommer få samma IP. Dock vet jag inte vad "0" innebär. Routern kanske behandlar 0 särskilt? Jag brukar sätta ett dygn (86400s) om jag inte har nån anledning att sätta något annat iaf.

Eftersom RPi:ns DHCP var "authoritative", så skedde resten av tilldelningen automatiskt från den, och jag minns inte att jag hade några krångligheter med det. Gör du så här så borde det fungera!

Permalänk
Medlem

@Reyhn: Värde 0 borde innebära permanent, alltså inget avslut. Jag testar så får vi väl se. Tack för svaret!