Lollipop - stänga av de stora klumpiga notiserna?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2006

Lollipop - stänga av de stora klumpiga notiserna?

Tidigare kom en minimal ikon som notis i statusfältet högst upp, whatsapp eller SMS eller whatever.
Nu med Lollipop kommer stora fula blaffor till notiser allra högst upp, och drar man ner rullgardinen så finns notisen ej där, utan man måste sträcka sig ända till toppen av skärmen, eller vänta en stund till den försvinner av sig själv för då poppar den upp som en vanlig liten notis.

På låsskärmen får man i alla fall valet att stänga av dessa, men då ser man inga notiser alls istället!
Det är antingen eller som gäller tydligen.

De dyker ju även upp om man kollar film o.s.v. vilket är sjukt störigt.
Finns ingen fix på detta, för att få tillbaka de gamla diskretare notiserna?
Utan att roota alltså.

MCP - MCTS - CCNA (expired)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2006

Finns visst en app som ska fixa detta, ska nog testa den, kanske klarar sig med gratisversionen t.o.m.

https://play.google.com/store/apps/details?id=com.jamworks.no...

EDIT: Äsch verkar inte funka.
Funkar på deras egna test-notification man kan skicka, men meddelanden från WhatsApp kommer fortfarande som en stor vit blaffa i överkant. Får sällan andra notiser så vet ej om just WhatsApp som inte vill funka :/

MCP - MCTS - CCNA (expired)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2006

Ah, det verkar däremot funka att stänga av i WhatsApp, UTAN tredjeparts program!
Enligt vissa funkar det endast om ljud i WhatsApp är av, men det har jag alltid av så osäker på det.

Det gäller att ändra "Aviseringsruta" från "Ingen pop-up", då denna logiskt nog ger just en popup, till "Bara när skärmen är Av".
Då slipper man stora popupen i överkant som lägger sig över allt annat och dessutom visar vad för meddelande du fått!

Finns fler tips och lite olika metoder i tråden här inne.

http://forums.androidcentral.com/android-5-0-lollipop/462892-...

EDIT: Fast då får man stora ljusa popups när skärmen är avstängd istället såklart...det om något lär ju både käka batteri och orsaka inbränningar, plus ingen vidare privacy där heller

Jag blockerar WhatsApp notiser helt, det verkar va enda enkla lösningen så länge, i Lollipop.
För vanliga SMS finns annan inställning i settings om att inaktivera messaging preview eller nåt.

MCP - MCTS - CCNA (expired)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2006

Jag har noll koll på sånt här, men kanske testar detta ändå, om det är vad som krävs för att få en normalt fungerande mobil med normala små anonyma notiser.

Citat:

you could actually use this command in android ADB (no need for root):
adb shell settings put global heads_up_notifications_enabled 0

Make sure: You have installed android ADB
You have already connected your smartphone & have "USB debugging" option enabled
Check if the device is already connected using command "adb devices" connect you phone open cmd type abd device then type the above command

EDIT: En lite snyggare beskrivning här.

http://forum.xda-developers.com/android/general/howto-4-to-di...

EDIT2: Det funkar!
Fixare en note-to-self och bjussar på den ifall nån annan vill ha en kort hands-on beskrivning.

Ladda ned och installera SDK Tools, "installer_r24.4.1-windows.exe", från developer.android.com
Välj från programmet att ladda ned paketen "Android SDK Tools" och "Android SDK Platform-tools".
Leta upp adb.exe, som under installationen ligger under platform-tools.

Koppla in mobilen och slå på USB-felsökning (under utvecklaralternativ).
Starta en cmd som admin och kör "adb devices" för att verifiera att mobilen hittas.
Kör sedan "adb shell settings put global heads_up_notifications_enabled 0"
Sedan "adb kill-server" för att stänga ner den tjänsten, så klagar inte datorn när man vill koppla ur mobilen.

Klart! Inga fler stora blaffor över skärmen med privata meddelanden som lägger sig över allt annat, utan bara vanliga små notiser i statusfältet som förr i tiden
För att slå på skiten igen kör man väl troligen samma kommando med en "1"

MCP - MCTS - CCNA (expired)