Hjälp med installation av mjukvara till kontrollerkort

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014

Hjälp med installation av mjukvara till kontrollerkort

Hej!

Har länge velat gå över till linux som host på min server men det har alltid varit en sak som hindrat mig, nämligen att jag inte reder ut att installera management-mjukvarorna till mina två kontrollerkort.

Glad nybörjare på linux skall tilläggas men börjar lära mig terminalen osv mer och mer, så hjälp på pucko-nivå uppskattas...

Har sedan en tid tillbaka kört Mint med KDE på två burkar här hemma, och gillar det så kanske den distron som jag borde köra även på servern eftersom jag börjar lära mig den.

Mjukvarorna jag vill installera är:
http://docs.avagotech.com/docs/15.08.01.02_Linux-64_MSM.gz
https://www.adaptec.com/en-us/speed/raid/storage_manager/asm_...

Det jag tror mig förtstått vara problemet är att mjukvarorna är kompilerade för RedHat och SUSE, eller?
Samt att det saknas en massa dependencies?

Vill någon vara vänlig och förklara för mig hur jag ska gå till väga för att installera dessa mjukvarorna på helst Mint (KDE), alt Ubuntu eller Debian?

Tacksam för hjälp!

/Berra

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014

Well, var ju enkelt att installera Adaptec Storage Manager i Fedora och openSUSE iom att dem bygger på rpm, men vart sjutton tar programmet vägen?! :S
hittar det inte någonstans förutom katalogen där det installerats, men hittar inte vart och hur jag startar det?

Har kört det i vms, så kontrollerkorten är inte "anslutna" (Vt-d) om det har med saken att göra?

Lsi's mjukvara har jag inte lyckats installera dock...
Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Sep 2009

Nu har inte jag en sån kontroller själv men har du installerat rpm paketen borde du ha en mapp under /usr som heter StorMan.
Ett peka-klicka gui borde du ha när du kör /usr/StorMan/StorMan.sh som root

Kör Archlinux

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014
Skrivet av /bin/sh:

Nu har inte jag en sån kontroller själv men har du installerat rpm paketen borde du ha en mapp under /usr som heter StorMan.
Ett peka-klicka gui borde du ha när du kör /usr/StorMan/StorMan.sh som root

Jo jag har varit i den mappen och både dubbelklickat på den filen samt försökt starta den i terminalen som robot men det händer inget när jag gör det..?

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014

I openSUSE står det bara "there is no specialized application for files of the type skalskript"?
Är det för att sh inte är installerat då?

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Sep 2009

Jo det borde det vara.
Men om du öppnar terminalen.
Gör dig till rootanvändare

su - root

Ställer dig i mappen

cd /usr/StorMan

och sen kör

sh StorMan.sh

I Linux är det viktigt att du skriver exakt rätt, Den är känslig för stora och små bokstäver och för att köra en fil i den mappen du står i så måste du ha ./ framför alternativt köra skriptet med sh innan som exemplet innan.

Kör Archlinux

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014
Skrivet av /bin/sh:

Jo det borde det vara.
Men om du öppnar terminalen.
Gör dig till rootanvändare

su - root

Ställer dig i mappen

cd /usr/StorMan

och sen kör

sh StorMan.sh

I Linux är det viktigt att du skriver exakt rätt, Den är känslig för stora och små bokstäver och för att köra en fil i den mappen du står i så måste du ha ./ framför alternativt köra skriptet med sh innan som exemplet innan.

Tack för att du försöker hjälpa mig, uppskattas!
Ska testa detta i morgon eller på söndag, jobbar sent varje kväll i helgen men ska försöka få tid till det.
Tack, återkommer med resultat...

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014
Skrivet av /bin/sh:

Jo det borde det vara.
Men om du öppnar terminalen.
Gör dig till rootanvändare

su - root

Ställer dig i mappen

cd /usr/StorMan

och sen kör

sh StorMan.sh

I Linux är det viktigt att du skriver exakt rätt, Den är känslig för stora och små bokstäver och för att köra en fil i den mappen du står i så måste du ha ./ framför alternativt köra skriptet med sh innan som exemplet innan.

Där satt den! Det var det jag behövde köra för att få igång Adaptecs mjukvara, tusen tack!

Någon idé på hur jag ska gå tillväga för att installera Lsi's mjukvara? Där var det en massa dependencies och grejer som behövdes tydligen...

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Sep 2009

Jag har ingen större erfarenhet av SUSE men däremot Redhat och CentOS som är besläktade.
Där brukar jag installera lösa paket med yum så löser den alla beroenden.

yum localinstall paket.rpm

Det borde finnas något motsvarande i SUSE... jag googlede lite... Kan det vara zypper man använder?

zypper install paket.rpm

Kör Archlinux

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014
Skrivet av /bin/sh:

Jag har ingen större erfarenhet av SUSE men däremot Redhat och CentOS som är besläktade.
Där brukar jag installera lösa paket med yum så löser den alla beroenden.

yum localinstall paket.rpm

Det borde finnas något motsvarande i SUSE... jag googlede lite... Kan det vara zypper man använder?

zypper install paket.rpm

Hmm, intressant! Ska kolla upp detta under morgondagen om jag får tid.
Tack återigen för hjälpen!

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014
Skrivet av /bin/sh:

Jag har ingen större erfarenhet av SUSE men däremot Redhat och CentOS som är besläktade.
Där brukar jag installera lösa paket med yum så löser den alla beroenden.

yum localinstall paket.rpm

Det borde finnas något motsvarande i SUSE... jag googlede lite... Kan det vara zypper man använder?

zypper install paket.rpm

Provade lite i CentOS nu, Adaptecs var ju superenkelt att installera återigen.
Men när jag försöker installera Lsi's så får jag fortfarande problem med beroenden.
Den säger att jag behöver "libssl.so.4() (64bit)" och "libcrypto.so.4() (64bit)"..?

Skickades från m.sweclockers.com

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Maj 2014

Sådär ja, löste det!
Fick jaga rätt på "openssl097a-0.9.7a-9.x86_64.rpm" via google och installera det först, det löste beroendet. Sedan installera "libstdc++34-3.4.0-1.i386.rpm" och sist Lsi's manager.

Stort tack till dig @/bin/sh för all hjälp!

Klient: ASUS Maximus VI Formula | Intel i7 4770K @ 4.5GHz | Corsair Vengeance Pro 4x4GB 2133MHz @ 2400MHz | Gigabyte GTX 970 G1 Gaming | A-Data 128GB M.2 | Samsung 850Pro 256GB | Intel 530 180GB | NZXT H630 | Cutom H20-loop ½"
Server: Supermicro X9SRL-F | Intel Xeon E5-2680v2 10c/20t | 8x8GB Samsung DDR3 ECC RDIMM | 2xLSI 9207-8i | 6x4TB WD Red RAID10 | 3x Intel 520 120GB | X-Case eXtra Value 424