Stuttering under 3D i Ubuntu

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2001

Stuttering under 3D i Ubuntu

Hej,
Jag har nyligen installerat Ubuntu 15 i min maskin. Har stora problem med stuttering i 3D-grafik.
Det är alltså okej framerate, men det rycker till hela tiden.

Har inte ändrat mycket i operativet, så inställningar bör vara standard, med undantag för pålagda uppdateringar.
Jag har lagt in nvidias propreitära drivrutin, version 352.63

Så här ser mina frametimes ut om jag kör exempelvis furmark (GpuTest), men det är samma i andra applikationer med.

Jag har prövat följande, utan resultat:
Stänga av vsync för opengl i nvidia-inställningarna
Sätta nvidia-drivrutinen på "Prefer maximum performance"
köra renice på furmark till -15.

Verktyget jag använder för att mäta finns här:
https://github.com/ValveSoftware/voglperf

Min hårdvara:
Dell 2713HM 2560x1440@60Hz ansluten via DP.
Geforce GTX 670 2GB, drivrutin 352.63
Intel Core i5 760 @ 4GHz
16GB DDR3 @ 1600MHz
Gigabyte GA-P55-USB3

Maskinen har inga som helst problem att köra spel mjukt under windows.

Några idéer om vad det skulle kunna vara eller hur jag går vidare med min felsökning?

Ubuntu | 1440p IPS | 7700k | 1080ti | 32GB@3.6GHz | 960 Pro 1TB | Xonar STX

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av sniglom:

Hej,
Jag har nyligen installerat Ubuntu 15 i min maskin. Har stora problem med stuttering i 3D-grafik.
Det är alltså okej framerate, men det rycker till hela tiden.

Har inte ändrat mycket i operativet, så inställningar bör vara standard, med undantag för pålagda uppdateringar.
Jag har lagt in nvidias propreitära drivrutin, version 352.63

Så här ser mina frametimes ut om jag kör exempelvis furmark (GpuTest), men det är samma i andra applikationer med.
http://i.imgur.com/C3SxAVO.png
Jag har prövat följande, utan resultat:
Stänga av vsync för opengl i nvidia-inställningarna
Sätta nvidia-drivrutinen på "Prefer maximum performance"
köra renice på furmark till -15.

Verktyget jag använder för att mäta finns här:
https://github.com/ValveSoftware/voglperf

Min hårdvara:
Dell 2713HM 2560x1440@60Hz ansluten via DP.
Geforce GTX 670 2GB, drivrutin 352.63
Intel Core i5 760 @ 4GHz
16GB DDR3 @ 1600MHz
Gigabyte GA-P55-USB3

Maskinen har inga som helst problem att köra spel mjukt under windows.

Några idéer om vad det skulle kunna vara eller hur jag går vidare med min felsökning?

Körde senaste furmark och här kommer mina frametimes. Vilken opengl version körde du samt har du testat att köra senaste version? Har du Vsync på i unity/compiz?

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3466Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2001

Hej
glxinfo | grep "OpenGL version"
OpenGL version string: 4.5.0 NVIDIA 352.63

Senaste version av vad? Drivrutinen är den senaste som jag kan välja ur interfacet, det kanske finns nyare hos nvidia, det har jag inte kollat.

Prövade att slå av vsync med ccsm och startade där efter testet. Fortfarande stuttering.

Ubuntu | 1440p IPS | 7700k | 1080ti | 32GB@3.6GHz | 960 Pro 1TB | Xonar STX