Ubuntu 15.10 död efter patch (2st)

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Ubuntu 15.10 död efter patch (2st)

Patchade glad i hågen 2 av mina Ubuntu 15.10 som vanligt och startade om, problemet är bara att dom kommer inte upp igen. Eftersom jag har backup av den ena (den andra spelar ingen roll) så vet jag att det är någon patch som kommit de senaste dagarna som har ihjäl den. Samma sak händer nämligen igen när jag återställer från backup och provar att patcha igen. Jag tror att det är när X startar som det ballar ur. 14.04 påverkas inte.

i7-8700k | ASUS ROG Strix Z370-F Gaming | 4x8GB Corsair Vengeance LPX 3200 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U14S | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

Prova patcha via guit? Och se om du kan identifiera vilken patch det är som fuckar det. Och anmäl det sedan till canonical. Har du någon hårdvara gemensam för dem båda? Vad händer när den bootar? Svart skärm? Prova boota från en tidigare kernel i menyn.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Aug 2002
Skrivet av fragwolf:

Prova patcha via guit? Och se om du kan identifiera vilken patch det är som fuckar det. Och anmäl det sedan till canonical. Har du någon hårdvara gemensam för dem båda? Vad händer när den bootar? Svart skärm? Prova boota från en tidigare kernel i menyn.

Det var via GUIt jag patchade.

Tänkte ta en patch i taget men när jag valde första i listan (Complete Generic Linux Kernel and headers (4.2.0.30.33)) så laddade den kanske inte helt otippat ner resten av kernel-patcharna och då rasade det igen. Är väl tveksamt om man kan lägga på en i taget där gissar jag.

Den bootar och allt ser normalt ut tills ungefär när den borde visa inloggningen i GUI, då är det bara svart skärm.

Gemensam hårdvara är VMware Player 12

i7-8700k | ASUS ROG Strix Z370-F Gaming | 4x8GB Corsair Vengeance LPX 3200 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U14S | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Då borde man kunna nedgradera patcharna.
http://www.howtogeek.com/117929/how-to-downgrade-packages-on-...

Även om X inte startar bör man kunna komma åt en terminal, exempelvis via ssh.
Men att sätta paket på hold är mer en tillfällig lösning för det brukar inte fungera i längden. Men förhoppningsvis fixas problemet i någon framtida patch. Det kan i och för sig vara lite småjobbigt att hitta vilket paket som orsakar problemet. Kanske någon grafikdrivrutin eller ny version av xorg?

Hade själv ett liknande problem i mitt Arch Linux för en tid sedan. Då var det displaymanagern (inloggnings- och sessionshanteraren) i Plasma desktop som vägrade fungera på min dator så det slutade med att jag bytte till en annan display manager istället. Kanske finns någon logg från din senaste boot att kolla för att se vad som går snett?

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

@Micke O:
Okej det låter som något med grafiken. Kolla i uppdateringarna om du kan se nått där som har med det att göra. Eller nån xserver skit. Eller så kan du prova med att vänta med att uppdatera par dagar. Ifall det är flera som har problem så lär de väl fixa det så har du tur så ersätter de uppdateringen så nästa gång du försöker så får du den fixade

du borde kunna boota till terminalen och kolla i nån logg för att se om du kan identifiera problemet där.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

En alternativ väg att gå.

Om du startar upp datorn, när skärmen blir svart så trycker du Ctrl+Alt+F1 så bör du få en terminal, logga in och om du vill ta bort ubuntus skrivbordhanterare med alla konfigfiler och börja om från början. (vilket kan funka ibland).

Så gör du så här.

sudo apt-get purge ubuntu-desktop
sudo apt-get install ubuntu-desktop

Sen kan du börja om från början och konfa ditt gui. Denna metod har funkat några gånger för mig vid liknande fel.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Det verkar vara efter "Linux kernel extra modules for version 4.2.0 on 64-bit x86 SMP" som det rasar. Håller på att återställa så att jag kan bekräfta.

Korrigering, de bootar så långt att jag ser "ubuntu" och alla 5 prickarna under lyser upp, sedan fastnar den.

Edit: Jepp, det är när man installerat uppdateringen ovan det rasar. Ctrl+Alt+F1 funkar inge bra. Vet inte om jag slår det vid tillfälle under boot eller vad det kan vara.

Eftersom jag har 2 häckar med exakt samma symptom så lär jag inte vara ensam (de är heller inte klonade eller så).

Ska prova att först avinstallera Open-VM-Tools eftersom jag sett errors som jag tror har med dem att göra.

i7-8700k | ASUS ROG Strix Z370-F Gaming | 4x8GB Corsair Vengeance LPX 3200 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U14S | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX

Trädvy Permalänk
Medlem
Registrerad
Apr 2013

http://ubuntuhandbook.org/index.php/2014/01/boot-into-text-co...
Kan vara nåt om det nu är grafiken som krånglar.

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Hade inget med Open-VM-Tools att göra.

Fick igång den jag inte har backup på genom att boota på en äldre kernel, ser inte detta lite märkligt ut? Den senaste avviker ju.

dpkg -l linux-image* | cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==================================-============-============-==============================================================
un linux-image <none> <none> (no description available)
un linux-image-3.0 <none> <none> (no description available)
ii linux-image-4.2.0-25-generic 4.2.0-25.30 amd64 Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii linux-image-4.2.0-27-generic 4.2.0-27.32 amd64 Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii linux-image-4.2.0-30-generic 4.2.0-30.35 amd64 Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii linux-image-extra-4.2.0-25-generic 4.2.0-25.30 amd64 Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii linux-image-extra-4.2.0-27-generic 4.2.0-27.32 amd64 Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii linux-image-extra-4.2.0-30-generic 4.2.0-30.35 amd64 Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii linux-image-generic 4.2.0.30.33 amd64 Generic Linux kernel image

Edit: Jepp, det är 4.2.0.30 som knasar. 27 funkar utmärkt.

Edit2: flera med samma problem: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1548867
och: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1548587

i7-8700k | ASUS ROG Strix Z370-F Gaming | 4x8GB Corsair Vengeance LPX 3200 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U14S | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX

Trädvy Permalänk
Medlem
Registrerad
Aug 2002

Fixad kernel släppt idag. Funkar nu.

Tack för ert engagemang!

i7-8700k | ASUS ROG Strix Z370-F Gaming | 4x8GB Corsair Vengeance LPX 3200 | ASUS GeForce GTX 1070 Dual OC | Intel 520 480GB | WD Black 3TB | Noctua NH-U14S | Fractal Design ARC | Be-Quiet Straight Power BQT E9 CM 680W | LG BH08LS20 | ASUS Xonar Essence STX