Svag wifi-signal Linux Mint 17.3 Cinnamon

Trädvy Permalänk
Medlem
Registrerad
Okt 2007

Svag wifi-signal Linux Mint 17.3 Cinnamon

Tjena Sweclockers!
Efter jag bytte från Windows 10 till Linux Mint 17.3 Cinnamon edition så har min signalstyrka på wifi minskat markant. Jag kan knapp ansluta till högskolans nätverk och i mitt hem där jag brukade ha 80-90% har jag nu runt 40-50%. Hemma fungerar det OK, men inte alls så bra som tidigare.
Problemet är att jag tappar min anslutning titt som tätt när jag är i skolan. Har ca 30-40% här och får "random" disconnects ibland vilket är väldigt frustrerande.

Har sett att en del har samma/liknande problem men har ej hittat någon lösning. Tänkte om någon av er kanske vet något om detta. Tack på förhand!

EDIT: Jag dualbootar windows 10 med mint, och i Windows har jag inga problem med mitt wifi.

Citat:

inxi -Fxz
System: Host: Tony-Laptop Kernel: 3.19.0-32-generic x86_64 (64 bit gcc: 4.8.2)
Desktop: Cinnamon 2.8.6 (Gtk 3.10.8~8+qiana)
Distro: Linux Mint 17.3 Rosa

Machine: System: FUJITSU product: LIFEBOOK AH531
Mobo: FUJITSU model: FJNBB0F
Bios: FUJITSU // Phoenix v: 1.28 date: 01/30/2012

CPU: Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977
clock speeds: max: 3100 MHz 1: 839 MHz 2: 856 MHz 3: 991 MHz
4: 853 MHz

Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes

Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic

Network: Card-1: Intel Centrino Wireless-N 1030 [Rainbow Peak]
driver: iwlwifi v: in-tree: bus-ID: 01:00.0
IF: wlan0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 07:00.0
IF: eth0 state: down mac: <filter>

Drives: HDD Total Size: 250.1GB (20.3% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB

Partition: ID-1: / size: 193G used: 39G (22%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6

RAID: No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors: System Temperatures: cpu: 56.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A

Info: Processes: 190 Uptime: 1:03 Memory: 1279.5/5880.4MB
Init: Upstart runlevel: 2 Gcc sys: 4.8.4
Client: Shell (bash 4.3.111) inxi: 2.2.28

Ryzen 1700 @3,8Ghz 1,342V | Corsair Vengeance LPX 2x8Gb (CMK16GX4M2B3000C15) | Asus Prime x370 Pro | MSI GTX 770 2GB SLI

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2002

Prova stänga av power management och/eller N-nätet.
http://blog.linuxjunkie.com/blog/2012/04/11/linux-and-the-int...

Prova byta drivrutin till iwlagn.

Det är ett vanligt problem med det kortet tyvärr.

Trädvy Permalänk
Medlem
Registrerad
Okt 2007

@Agile: Tack! Har vridit av power management redan och blev ingen förändring, tyvärr. Har ej provat annan drivrutin dock, men kan göra det när jag kommer hem!

Lite mera info om nätverkskortet:

*-network beskrivning: Trådlöst gränssnitt produkt: Centrino Wireless-N 1030 [Rainbow Peak] tillverkare: Intel Corporation physical id: 0 bus info: pci@0000:01:00.0 logiskt namn: wlan0 version: 34 serienummer: 4c:80:93:3f:95:d5 bredd: 64 bits klocka: 33MHz förmågor: pm msi pciexpress bus_master cap_list ethernet physical wireless konfiguration: broadcast=yes driver=iwlwifi driverversion=3.19.0-32-generic firmware=18.168.6.1 ip=XXX.YYY.41.74 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn resurser: irq:28 memory:f1500000-f1501fff

Även hört att det kan hjälpa att uppgradera kernel versionen. Vet dock ej hur man gör detta då jag aldrig gjort det förut. Men får kolla lite när jag kommer hem.

Ryzen 1700 @3,8Ghz 1,342V | Corsair Vengeance LPX 2x8Gb (CMK16GX4M2B3000C15) | Asus Prime x370 Pro | MSI GTX 770 2GB SLI

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2002

Provade du stänga av N-nätet också? G har ju bättre räckvidd.

Trädvy Permalänk
Medlem
Registrerad
Okt 2007
Skrivet av Agile:

Provade du stänga av N-nätet också? G har ju bättre räckvidd.

Yes, det har jag gjort. Uppdaterade även kerneln til 4.4.2 nyss. Tror inte det blev någon skillnad där heller, tyvärr :/

Ryzen 1700 @3,8Ghz 1,342V | Corsair Vengeance LPX 2x8Gb (CMK16GX4M2B3000C15) | Asus Prime x370 Pro | MSI GTX 770 2GB SLI

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2002

Kanske bästa lösningen är att byta ut wifi-kortet.

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

Eller prova någon annan dist?

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!