Ubuntu 16.04 släpps med nytt app-format

Trädvy Permalänk
Inhibitor
Registrerad
Dec 1999

Ubuntu 16.04 släpps med nytt app-format

Senaste versionen av operativsystemet Ubuntu fokuserar huvudsakligen på utvecklare och support under lång tid, men några användarfokuserade funktioner bjuds det ändå på.

Läs hela artikeln här

Observera att samma trivselregler gäller i kommentarstrådarna som i övriga forumet och att brott mot dessa leder till avstängning. Kontakta redaktionen om du vill uppmärksamma fel i artikeln eller framföra andra synpunkter.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Jan 2011

"Canonical avser inte att lösa problemet" Vilket beror på att de inte kan lösa problemet. fglrx är en stängd drivrutin. Inte heller AMD har för avsikt att lägga till stöd för nyare X.org-versioner i fglrx. AMD satsar numera på AMDGPU-drivrutinen. Tanken är att AMDGPU ska gå att använda för vanligt folk runt mitten av året, lite synd att det blir ett glapp i stödet fram tills den blir stabil dock.

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av dlq84:

"Canonical avser inte att lösa problemet" Vilket beror på att de inte kan lösa problemet. fglrx är en stängd drivrutin. Inte heller AMD har för avsikt att lägga till stöd för nyare X.org-versioner i fglrx. AMD satsar numera på AMDGPU-drivrutinen. Tanken är att AMDGPU ska gå att använda för vanligt folk runt mitten av året, lite synd att det blir ett glapp i stödet fram tills den blir stabil dock.

FGLRX har inte fungerat korrekt sen ja aldrig.... Dock lär det bli intressant sen när AMDGPU Pro lanseras på riktigt.

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3600Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Jun 2003

Om man sitter med Ubuntu server 14.04 LTS är det alltså bara att köra en do-release-upgrade?

c[_]

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av superapan:

Om man sitter med Ubuntu server 14.04 LTS är det alltså bara att köra en do-release-upgrade?

Ett tag sen jag körde Ubuntu men man måste väl gå in på software sources för att ändra "latest" för att den skall uppgradera. Eller kanske den kommer hoppa över till nästa LTS...

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3600Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Feb 2010
Skrivet av Commander:

Ett tag sen jag körde Ubuntu men man måste väl gå in på software sources för att ändra "latest" för att den skall uppgradera. Eller kanske den kommer hoppa över till nästa LTS...

det var även för mig ett par år sen, men på ubuntu så finns det nåt form av verktyg för att uppdatera, utan att manuellt ändra sources (som man gör i debian)

Desktop: AMD Ryzen 5 1600X / 16GB RAM / GTX 1080 / 3TB lagring
Server: Intel Pentium G4400 / 4GB RAM / 11TB lagring

Trädvy Permalänk
Medlem
Registrerad
Sep 2011

@superapan: Ja men du behöver köra med -d för annars uppgraderar den inte. Det är först när 16.04.1 kommit ut som det går att köra utan -d. Gissar att det är en säkerhetsfunktion.

Med andra ord "do-release-upgrade -d"

Trädvy Permalänk
Medlem
Registrerad
Apr 2011
Citat:

En något tråkigare nyhet är att AMD inte stöder Ubuntu 16.04 och företagets officiella grafikdrivrutin, oftast kallad fglrx, fungerar därmed inte alls i det nya systemet. AMD:s befintliga drivrutiner stödjer inte versionen av fönsterhanteraren X.org som används i Ubuntu 16.04, och Canonical avser inte att lösa problemet. Radeon-ägare får därmed vända sig till de öppna drivrutinerna.

"The fglrx driver is now deprecated in 16.04, and we recommend its open source alternatives (Radeon and AMDGPU). AMD put a lot of work into the drivers, and we backported kernel code from Linux 4.5 to provide a better experience. When upgrading to Ubuntu 16.04 from a previous release, both the fglrx driver and the xorg.conf will be removed, so that the system is set to use either the AMDGPU driver or the Radeon driver (depending on the available hardware)," said Canonical.

Softpedia

Jag förstår inte riktigt vad Sweclockers menar skulle vara tråkigt med detta? Antagligen tycker man det om man inte använt fglrx. AMDGPU/RadeonSI är redan nu god nog att använda för de flesta.

Citat:

Den enhetliga användarmiljön Unity 8 ingår dock inte i Ubuntu 16.04.

Nej men den finns som tillval.

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Jun 2003
Skrivet av Commander:

Ett tag sen jag körde Ubuntu men man måste väl gå in på software sources för att ändra "latest" för att den skall uppgradera. Eller kanske den kommer hoppa över till nästa LTS...

Jag kör som sagt server utan GUI.

@MrMart: Tack!

c[_]

Trädvy Permalänk
Medlem
Registrerad
Apr 2011
Skrivet av superapan:

Jag kör som sagt server utan GUI.

@MrMart: Tack!

Vågar du göra det? Ta isf ordentligt med backup. jag kör en server med 14.04 och den går som en klocka. Vet inte om jag villa pilla med den. Vad är fördelarna? 14.04 har väl säkerhetsuppdateringar till 2019?

Trädvy Permalänk
Teknikorakel 🎮
Andreas Eklöv
Plats
Stockholm
Registrerad
Dec 2015

@Durkadur: Precis som @dlq84 är inne på ovan blir det ju ett glapp mellan fglrx och när AMDGPU lanseras skarpt. AMD har ju en stökig historik med halvbakade drivrutiner för Linux, och att de helt skippar stöd för en ny version av den största Linuxdistributionen för konsumenter pekar ju tyvärr på att deras engagemang i Linux-plattformen fortfarande inte är där den borde vara. Men ja, förhoppningsvis blir deras arbete med AMDGPU-drivisarna både bättre och mer konsekvent än vad det har varit tidigare.

"We're with the press, hired geeks!"
Raoul Duke, Fear n' Loathing in Las Vegas

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av loevet:

@Durkadur: Precis som @dlq84 är inne på ovan blir det ju ett glapp mellan fglrx och när AMDGPU lanseras skarpt. AMD har ju en stökig historik med halvbakade drivrutiner för Linux, och att de helt skippar stöd för en ny version av den största Linuxdistributionen för konsumenter pekar ju tyvärr på att deras engagemang i Linux-plattformen fortfarande inte är där den borde vara. Men ja, förhoppningsvis blir deras arbete med AMDGPU-drivisarna både bättre och mer konsekvent än vad det har varit tidigare.

Mja engagemang är nog fel ord då de är mer engagerade i Linux och Open Source än vad Nvidia någonsin är och kommer vara. Men som sagt deras FGLRX är patetisk när det kommer till stöd för Xorg och Kernel.

Förhoppningsvis lär det funka mycket bättre med AMDGPU Pro.

Skrivet av Kattus:

det var även för mig ett par år sen, men på ubuntu så finns det nåt form av verktyg för att uppdatera, utan att manuellt ändra sources (som man gör i debian)

Missade att det var server men för mig är det lite magi på Ubuntu. Då även om jag körde apt-get update && apt-get upgrade -d så visade fortfarande GUI updatern att det paket kvar att uppdatera.

(( En av många anledningarna till att jag tröttnade och drog även servern till Arch ))

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3600Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Jan 2011
Skrivet av loevet:

@Durkadur: Precis som @dlq84 är inne på ovan blir det ju ett glapp mellan fglrx och när AMDGPU lanseras skarpt. AMD har ju en stökig historik med halvbakade drivrutiner för Linux, och att de helt skippar stöd för en ny version av den största Linuxdistributionen för konsumenter pekar ju tyvärr på att deras engagemang i Linux-plattformen fortfarande inte är där den borde vara. Men ja, förhoppningsvis blir deras arbete med AMDGPU-drivisarna både bättre och mer konsekvent än vad det har varit tidigare.

Jag vet inte om jag håller med helt här. Historiskt (med fglrx) har det varit så att den drivrutinen har funkat halvdant. RadeonSI (Open Source) är dock den öppna drivrutin som har bäst stöd för OpenGL (4.3 i skrivande stund, skulle inte bli förvånad om 4.5 kommer i år eller i början av nästa). De har till och med slagit Intel, som annars brukar vara snabbast, på fingrarna här. AMDGPU är ytterligare ett exempel där de försöker utöka stödet ytterligare för linux.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jan 2011
Skrivet av Durkadur:

Vågar du göra det? Ta isf ordentligt med backup. jag kör en server med 14.04 och den går som en klocka. Vet inte om jag villa pilla med den. Vad är fördelarna? 14.04 har väl säkerhetsuppdateringar till 2019?

Halva poängen med LTS är ju att man slipper uppgradera hela tiden.

Stationär:Asrock P67 Extreme 4 | i5 2500K@4,5Ghz | Asus GTX 970 black | 2x Intel 520 180gb, 2x WD blue 5tb | 8GB Corsair XMS3 + 8GB Hyper x Fury | EVGA Supernova G2 750W Gold | Silverstone FT02
Laptop: Jumper ezbook 3 pro
Mobil: Xiaomi Redmi Note 3 pro SE

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av loevet:

@Durkadur: Precis som @dlq84 är inne på ovan blir det ju ett glapp mellan fglrx och när AMDGPU lanseras skarpt. AMD har ju en stökig historik med halvbakade drivrutiner för Linux, och att de helt skippar stöd för en ny version av den största Linuxdistributionen för konsumenter pekar ju tyvärr på att deras engagemang i Linux-plattformen fortfarande inte är där den borde vara. Men ja, förhoppningsvis blir deras arbete med AMDGPU-drivisarna både bättre och mer konsekvent än vad det har varit tidigare.

Sen har ju inte AMD lika djupa fickor som Nvidia att spenderar pengar på 1% av användarna heller Men beror ju vilken nisch man är ute efter, server, spel eller/och kontor.

Men oavsett domderar Windows på PC i alla fall.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Okt 2004

Har nu gjort en nyinstallation av xubuntu 16.04.

Fungerar fint

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2004

Innan någon testar kan jag ju nämna att den inte fungerar i Hyper-V, i alla fall för mig, kommer till skrivbordet men det är tomt så fastnar man där. 14.04 och även 15.10 fungerar bra under Hyper-V. Skall testa 16.04 i VMware senare.

Notebook Envy 15" 4K IPS 7500U 16GBDDR4@2133MHz 256GB NVMe USB-C
2016Ed. VIII Hero 6700K@4801MHz H₂O 32GB DDR4@3200MHz/cl15 950Pro 1080Ti 11GB H₂O
2014Ed. Z87-A 4790K@4900MHz NH-D14 16GB DDR3@2133MHz/cl11 1070FE 8GB
HTPC: GA-B85M-DS3H 4570S 16GB DDR3@1600MHz GTX970 4GB

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Okt 2004
Skrivet av the squonk:

Innan någon testar kan jag ju nämna att den inte fungerar i Hyper-V, i alla fall för mig, kommer till skrivbordet men det är tomt så fastnar man där. 14.04 och även 15.10 fungerar bra under Hyper-V. Skall testa 16.04 i VMware senare.

Se där.
Hur är det med virtualbox?
Tänkte ev köra in en virtuell xubuntu på macen med.

Trädvy Permalänk
Medlem
Plats
Örkelljunga, Skåne
Registrerad
Dec 2008

@the squonk: Kan meddela att det fungerar felfritt i VMware Workstation 12

Fractal Design Define XL | AMD Phenom 2 x6 1100 3,3Ghz | ASUS R9-280X-DC2 3BG | Kingston 16 GB RAM
Asus M4A88T-V EVO/USB3 | 120 GB SanDisk SSD | 1 TB WD Green

Trädvy Permalänk
Medlem
Registrerad
Sep 2011

Jag uppgraderade till detta från sentaste långtidsuppdaterade distribution (14.04). Som beskrivits i artikeln fick jag problem med mitt AMD-kort (ja, förutom att dessutom hela uppgraderingen kraschade i slutet av processen).

Distributionen fungerar nu, förutom att det inte går att byta från 640x480 (det står okänd skärmenhet i inställningen eller liknande).

Fanns det inte någon öppen drivrutin som artikeln beskrev som gör att man åtminstone kan få högre upplösning än 640x480?

Kan nämna att i pakethanteraren fanns redan något som heter fxglr eller liknande som beskrivs som någon "minimal" AMD-rutin.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2004
Skrivet av JimmBoow:

@the squonk: Kan meddela att det fungerar felfritt i VMware Workstation 12

Japp det gjorde det!

Skickades från m.sweclockers.com

Notebook Envy 15" 4K IPS 7500U 16GBDDR4@2133MHz 256GB NVMe USB-C
2016Ed. VIII Hero 6700K@4801MHz H₂O 32GB DDR4@3200MHz/cl15 950Pro 1080Ti 11GB H₂O
2014Ed. Z87-A 4790K@4900MHz NH-D14 16GB DDR3@2133MHz/cl11 1070FE 8GB
HTPC: GA-B85M-DS3H 4570S 16GB DDR3@1600MHz GTX970 4GB

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Sep 2007

Har nyligen gått över till Ubuntu 15.10 Gnome som system OS och fglrx fungerar ypperligt så när som grafikkortets klockning (R9 Fury) som inte riktigt hänger med. Hoppas dock att AMD inom snar framtid blir klara med sin Crimson-drivrutin för Linux.

Riggen: 2x Xeon E5-2670 @ 16x3,2 Ghz - Z9PE-D8 WS - Corsair 32GB RAM - GTX 1080 ti - Dell U3415W 34" - HyperX Predator PCIe/M.2 - 4x Samsung 840 500GB - Asus Xonar DX - 2x NH-U12S - 2x EVGA Supernova G2 850W - Obsidian 900D
NAS: FreeNAS @ HP Proliant MicroServer Gen 8 - Xeon E3-1230 V2 - 16Gb Kingston ECC RAM - Intel 530 120Gb - IBM m1015/LSI 9220-8i - 4x WD Red 3Tb

Trädvy Permalänk
Medlem
Plats
Sikfors
Registrerad
Feb 2007
Skrivet av skogsvilden:

Har nyligen gått över till Ubuntu 15.10 Gnome som system OS och fglrx fungerar ypperligt så när som grafikkortets klockning (R9 Fury) som inte riktigt hänger med. Hoppas dock att AMD inom snar framtid blir klara med sin Crimson-drivrutin för Linux.

Gnome.... lol.
Jävla skit ui, stödjer int ens sina egna tidigare versioner och kolla på koden, som att det är skrivet av en tolvåring. De skriker att gtk2 är spagettikåd men gtk3 är det sämsta som har hänt opensource sedan HURD. (höll tillbaka bra utveckling i flera år)

Edit: Utveklingsstörd 12åring

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Feb 2015

Försökte uppgradera min arbetsstation till 16.04 från min 15.10 med en massa extra programmeringsmiljöer men den pajade med budskapet att den inte lyckades reda ut alla beroenden.

Blev tvungen att ta en fullständig backup till min server, 1.2TB tar sin lilla tid. Sedan installera från grunden och är då tacksam för att jag partitionerat på ett vettigt sätt med extragrejorna och användarmappar på egna partitioner. Då gick det fort att installera, köra min sparade konfiguration och sedan återkoppla programmeringsmiljöerna till systemet.

På min laptop gick det sämre. När jag köpte den behöll jag windows10 som var förinstallerat och installerade Ubuntu MATE 15.10 vid sidan av och installerade inga programmeringsmiljöer. Den automatiska uppgraderingen till 16.04 hängde sig då den skulle städa bort konflikterande systemfiler och började en gång i timmen köra ett cron-jobb (minns inte vad). Efter fyra timmar avbröt jag och installerade Ubuntu 16.04 MATE på den enda ext4-partitionen efter att ha formaterat om och då gick det bra.

Jag tror att det hänger upp sig på alla PPA och andra extragrejor men det borde man kunna ordna...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2012

Även jag gick tillbaka till 14.04.4 just pga att jag har en AMD GPU på min laptop och att 16.04 är lite buggig på vissa ställen. Den här nya 'Ubuntu Software' funkade inte alls för nån applikation som jag ville installera, den hängde sig hela tiden.

Det enda positiva jag märkte med 16.04 är att Unity 7.4 är jävligt snygg och snappy, fyfan vad snabb den har blivit.

Jag stannar kvar på 14.04 ett tag till.

"Early to bed and early to rise, makes a man healthy, wealthy and wise."

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av Commander:

FGLRX har inte fungerat korrekt sen ja aldrig.... Dock lär det bli intressant sen när AMDGPU Pro lanseras på riktigt.

Tja vi får väl se vad som händer. Jag sitter på AMDGPU Pro-betan just nu. Stabilt men märklig transparens-bugg på svart backgrund i OpenGL.
Vulkanstödet är fortfarande tokdåligt, demos från LunarG's SDK krashar, men det är förståeligt.

Trädvy Permalänk
Medlem
Registrerad
Apr 2011
Skrivet av loevet:

@Durkadur: Precis som @dlq84 är inne på ovan blir det ju ett glapp mellan fglrx och när AMDGPU lanseras skarpt. AMD har ju en stökig historik med halvbakade drivrutiner för Linux, och att de helt skippar stöd för en ny version av den största Linuxdistributionen för konsumenter pekar ju tyvärr på att deras engagemang i Linux-plattformen fortfarande inte är där den borde vara. Men ja, förhoppningsvis blir deras arbete med AMDGPU-drivisarna både bättre och mer konsekvent än vad det har varit tidigare.

We've been informed by Oliver Grawert from Canonical that the proprietary AMD Catalyst (fglrx) driver has been temporarily removed the Ubuntu 16.04 LTS repositories, as it is not yet ported to X.Org Server 1.8. It will be added again as part of the first point release, Ubuntu 16.04.1 LTS.

Read more: http://news.softpedia.com/news/canonical-recommends-open-sour...

Vill man kommer man kunna använda fglrx i 16.04 så snart den portats till X.Org 1.8. Eller så kan man vänta på AMDGPU att släppas skarpt (något de allra flesta kommer vilja göra). AMDGPU är redan nu bättre än fglrx i många fall - http://www.phoronix.com/scan.php?page=article&item=ubuntu-160...

Är man beroende av fglrx idag så får man i värsta fall helt enkelt vänta några månader. Allt kommer att vara värt det för vi kommer att slippa fglrx(!).