Överklocka skärm i xubuntu...

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

Överklocka skärm i xubuntu...

Försöker överklocka min dell 34" till 80hz i xubuntu (fungerar klockrent i windows) men jag får det inte att fungera, provat massa olika saker men vette fan vad jag gör fel, nån som har något tips?

xubuntu 14.04
kernel 4.2.0-35-generic
Nvidia driver 358.16

xrandr -q:

Screen 0: minimum 8 x 8, current 6000 x 1440, maximum 16384 x 16384 DVI-I-0 disconnected (normal left inverted right x axis y axis) DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) DP-0 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) DP-2 connected 2560x1440+3440+0 (normal left inverted right x axis y axis) 527mm x 296mm 2560x1440 60.0*+ 2048x1536 60.0 2048x1152 59.9 1920x1440 75.0 60.0 1920x1200 60.0 59.9 1920x1080 60.0 59.9 59.9 50.0 60.1 60.0 1856x1392 75.0 60.0 1792x1344 75.0 60.0 1680x1050 84.9 74.9 69.9 60.0 59.9 1600x1200 85.0 75.0 70.0 65.0 60.0 1440x900 59.9 1400x1050 85.0 74.8 70.0 60.0 1360x768 60.0 59.8 1280x1024 85.0 75.0 60.0 1280x960 85.0 60.0 1280x800 59.8 1280x720 60.0 59.9 50.0 1152x864 85.1 85.0 75.0 75.0 70.0 60.0 1024x768 85.0 75.0 70.1 60.0 960x600 60.0 960x540 60.0 840x525 85.0 75.0 69.9 60.0 59.9 832x624 74.6 800x600 85.1 75.0 72.2 60.3 56.2 720x576 50.0 720x480 59.9 720x450 59.9 720x400 85.0 700x525 74.8 60.0 680x384 60.0 59.8 640x480 85.0 75.0 72.8 59.9 59.9 640x400 85.1 640x350 85.1 512x384 70.1 60.0 400x300 72.2 320x240 72.8 60.1 320x175 85.3 DP-3 disconnected (normal left inverted right x axis y axis) DP-4 connected 3440x1440+0+0 (normal left inverted right x axis y axis) 798mm x 335mm 3440x1440 60.0*+ 50.0 2560x1440 60.0 2560x1080 60.0 2048x1536 60.0 1920x1440 75.0 60.0 1920x1200 60.0 1920x1080 60.0 60.0 59.9 59.9 50.0 60.0 1856x1392 75.0 60.0 1792x1344 75.0 60.0 1720x1440 60.0 1680x1050 84.9 74.9 69.9 60.0 59.9 1600x1200 85.0 75.0 70.0 65.0 60.0 1440x900 59.9 1400x1050 85.0 74.8 70.0 60.0 1360x768 60.0 59.8 1280x1024 85.0 75.0 60.0 1280x960 85.0 60.0 1280x800 59.8 1280x720 59.9 50.0 1152x864 85.1 85.0 75.0 75.0 70.0 60.0 1024x768 85.0 75.0 70.1 60.0 960x600 60.0 960x540 60.0 840x525 85.0 75.0 69.9 60.0 59.9 832x624 74.6 800x600 85.1 75.0 72.2 60.3 56.2 720x576 50.0 720x480 59.9 720x450 59.9 720x400 85.0 700x525 74.8 60.0 680x384 60.0 59.8 640x480 85.0 75.0 72.8 59.9 59.9 640x400 85.1 640x350 85.1 512x384 70.1 60.0 400x300 72.2 320x240 72.8 60.1 320x175 85.3 DP-5 disconnected (normal left inverted right x axis y axis)

det jag provat mest är
cvt 3440 1440 80
Output: Modeline "3440x1440_80.00" 571.75 3440 3712 4088 4736 1440 1443 1453 1510 -hsync +vsync
sen kör jag: xrandr --newmode "3440x1440_80.00" 571.75 3440 3712 4088 4736 1440 1443 1453 1510 -hsync +vsync
och efter det xrandr --addmode DP-4 "3440x1440_80.00"

och det är där problemet börjar:

X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 47 Current serial number in output stream: 48

denna guide jag försöker följa: http://www.monitortests.com/forum/Thread-Guide-to-Nvidia-moni...
jag vet att den kan vara utdaterad, men jag hittar fan inget annat vettigt

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Har du "unlockat överklockning" såsom det står i länken, alltså angivit parametrarna i xorg.conf-filen? Tänker främst på HorizSync och VertRefresh samt inaktivering av UseEDIDFreqs.

Dator: i7 4960x | 32GB | Asus Rampage IV Formula | GTX 1080
OS: Slackware 64-bit current + multilib

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av eXpander_:

Har du "unlockat överklockning" såsom det står i länken, alltså angivit parametrarna i xorg.conf-filen? Tänker främst på HorizSync och VertRefresh samt inaktivering av UseEDIDFreqs.

Jo jag har ju det.. :/

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av pellski87:

Jo jag har ju det.. :/

Märkligt.

Hur ser din xorg.conf nu då?

*EDIT:
Har du två anslutna skärmar? Har du angivit rätt "Monitor" i xorg.conf?

Dator: i7 4960x | 32GB | Asus Rampage IV Formula | GTX 1080
OS: Slackware 64-bit current + multilib

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av eXpander_:

Märkligt.

Hur ser din xorg.conf nu då?

*EDIT:
Har du två anslutna skärmar? Har du angivit rätt "Monitor" i xorg.conf?

Ursäkta mitt sega svar, har varit ute och härjat med ungarna http://pastebin.com/Apu6KwCz sådär ser den ut, ja jag har 2 skärmar ikopplade och det bör vara rätt skärm under monitor... vette tusan

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av pellski87:

Ursäkta mitt sega svar, har varit ute och härjat med ungarna http://pastebin.com/Apu6KwCz sådär ser den ut, ja jag har 2 skärmar ikopplade och det bör vara rätt skärm under monitor... vette tusan

Krångligt. Jag skulle dock börja med att göra det lite enkelt, ta bort denna rad:

Option "metamodes" "DP-4: 3440x1440_60 +0+0, DP-2: 2560x1440_60 +3440+0"

Och kör bara med ena skärmen (din 34-tummare) för att testa om det fungerar då. Kanske kan även ta bort raden:

ModeLine "3440x1440_80.00" 571.75 3440 3712 4088 4736 1440 1443 1453 1510 -hsync +vsync

Det är nog det enda tipset jag kan ge dig, tyvärr. Fungerar det med en skärm så ligger felet där nånstans.

Dator: i7 4960x | 32GB | Asus Rampage IV Formula | GTX 1080
OS: Slackware 64-bit current + multilib

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av eXpander_:

Krångligt. Jag skulle dock börja med att göra det lite enkelt, ta bort denna rad:

Option "metamodes" "DP-4: 3440x1440_60 +0+0, DP-2: 2560x1440_60 +3440+0"

Och kör bara med ena skärmen (din 34-tummare) för att testa om det fungerar då. Kanske kan även ta bort raden:

ModeLine "3440x1440_80.00" 571.75 3440 3712 4088 4736 1440 1443 1453 1510 -hsync +vsync

Det är nog det enda tipset jag kan ge dig, tyvärr. Fungerar det med en skärm så ligger felet där nånstans.

Jag har provar med bara en skärm osv men det gör absolut ingen skillnad tyvärr

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

@pellski87:

Lite tips från den där länken du skickade, har du kollat "Pixel clock" värdet i Xorg.0.log-filen? Kanske den är satt för låg (eller för högt)?

Dator: i7 4960x | 32GB | Asus Rampage IV Formula | GTX 1080
OS: Slackware 64-bit current + multilib

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av eXpander_:

@pellski87:

Lite tips från den där länken du skickade, har du kollat "Pixel clock" värdet i Xorg.0.log-filen? Kanske den är satt för låg (eller för högt)?

DELL U3415W (DFP-6): 960.0 MHz maximum pixel clock

hittar jag i den loggen

provade xrandr --newmode "3440x1440_80" 960.0 3440 3712 4088 4736 1440 1443 1453 1510 -hsync +vsync
men samma skit ändå

hittade detta nu

[ 5.351] (**) NVIDIA(0): Not using HorizSync/VertRefresh ranges from the EDID for
[ 5.351] (**) NVIDIA(0): display device DELL P2416D (DFP-4) (Using EDID frequencies
[ 5.351] (**) NVIDIA(0): has been disabled on all display devices.)
[ 5.351] (**) NVIDIA(GPU-0): Mode Validation Overrides for DELL P2416D (DFP-4):
[ 5.351] (**) NVIDIA(GPU-0): NoMaxPClkCheck
[ 5.351] (**) NVIDIA(GPU-0): NoEdidMaxPClkCheck
[ 5.351] (**) NVIDIA(GPU-0): AllowNonEdidModes
[ 5.360] (--) NVIDIA(GPU-0): DELL P2416D (DFP-4): connected
[ 5.360] (--) NVIDIA(GPU-0): DELL P2416D (DFP-4): Internal DisplayPort
[ 5.360] (--) NVIDIA(GPU-0): DELL P2416D (DFP-4): 960.0 MHz maximum pixel clock

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Halmstad (Halland)
Registrerad
Nov 2013

Löser du det med 34:an så rapportera gärna tillbaka.
Har en likadan och skulle gärna också testa att överklocka skärmen en aning.

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av mrazster:

Löser du det med 34:an så rapportera gärna tillbaka.
Har en likadan och skulle gärna också testa att överklocka skärmen en aning.

Det är helt stendött med hjälp... provat ubuntuforums, alla möjliga irc kanaler etc.. Har du provar klocka den öht i ubuntu? tänkte om du får samma som mig eller om det är mina drivare som spökar? för det fungerar ju klockrent att köra den i 80hz.... med windows...

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

Jag har ingen koll på överklockning av skärm i Linux.
Hittade en kopia på min Xorg.conf fil som jag körde med min Korea skärm som kanske kan vara till hjälp.
Med denna kan jag välja 60Hz, 75Hz & 100Hz i Nvidia settings, nöjde mig med detta och vågade inte pilla mer i filen.

# Catleap
Section "Monitor"
Identifier "Monitor"
VendorName "Yamakasi"
ModelName "Catleap Q270 B2 Extreme"
Option "DPMS" "1"
Option "ExactModeTimingsDVI" "1"
# 100Hz
Modeline "2560x1440" 400 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
# 75Hz
Modeline "2560x1440" 300 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
# 60Hz
Modeline "2560x1440" 240 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
EndSection

Section "Device"
Identifier "Device"
VendorName "NVIDIA Corporation"
BoardName "NVIDIA GeForce 400 series and later"
Driver "nvidia"
Option "DynamicTwinView" "false"
Option "OnDemandVBlankInterrupts" "1"
Option "TripleBuffer" "1"
Option "BackingStore" "1"
Option "CursorShadow" "1"
Option "NoLogo" "1"
Option "IgnoreEDIDChecksum" "DFP-0"
Option "UseEdidFreqs" "0"
Option "SLI" "0"
Option "ModeValidation" "NoHorizSyncCheck,NoVertRefreshCheck,AllowNon60HzDFPModes,
NoWidthAlignmentCheck,NoDFPNativeResolutionCheck,NoMaxPClkCheck,NoEDIDMaxPClkCheck,
NoVesaModes,NoXServerModes,NoPredefinedModes,NoUserModes,
NoExtendedGpuCapabilitiesCheck,NoEDIDModes"
Option "UseEdid" "1"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen"
Device "Device"
Monitor "Monitor"
#Option "CustomEDID" "DFP-0:/etc/X11/edid-shimian.bin"
Option "MetaModes" "DFP-0: 2560x1440_100 +0+0"
SubSection "Display"
Depth 30
EndSubSection
EndSection

CPU: I5-3570K | RAM: 16GB (4x4GB) Corsair LP | MB: Asus Maximus V Gene Z77 | GPU: MSI Radeon RX580 Armor 8GB | Chassi: FD Arc mini R2 | PSU: CM700V | SSD: Crucial MX300 750GB | Monitor: Yamakasi Catleap 2B Extreme | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004
Skrivet av Lembritt:

Jag har ingen koll på överklockning av skärm i Linux.
Hittade en kopia på min Xorg.conf fil som jag körde med min Korea skärm som kanske kan vara till hjälp.
Med denna kan jag välja 60Hz, 75Hz & 100Hz i Nvidia settings, nöjde mig med detta och vågade inte pilla mer i filen.

# Catleap
Section "Monitor"
Identifier "Monitor"
VendorName "Yamakasi"
ModelName "Catleap Q270 B2 Extreme"
Option "DPMS" "1"
Option "ExactModeTimingsDVI" "1"
# 100Hz
Modeline "2560x1440" 400 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
# 75Hz
Modeline "2560x1440" 300 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
# 60Hz
Modeline "2560x1440" 240 2560 2592 2612 2692 1440 1443 1448 1480 +HSync -VSync
EndSection

Section "Device"
Identifier "Device"
VendorName "NVIDIA Corporation"
BoardName "NVIDIA GeForce 400 series and later"
Driver "nvidia"
Option "DynamicTwinView" "false"
Option "OnDemandVBlankInterrupts" "1"
Option "TripleBuffer" "1"
Option "BackingStore" "1"
Option "CursorShadow" "1"
Option "NoLogo" "1"
Option "IgnoreEDIDChecksum" "DFP-0"
Option "UseEdidFreqs" "0"
Option "SLI" "0"
Option "ModeValidation" "NoHorizSyncCheck,NoVertRefreshCheck,AllowNon60HzDFPModes,
NoWidthAlignmentCheck,NoDFPNativeResolutionCheck,NoMaxPClkCheck,NoEDIDMaxPClkCheck,
NoVesaModes,NoXServerModes,NoPredefinedModes,NoUserModes,
NoExtendedGpuCapabilitiesCheck,NoEDIDModes"
Option "UseEdid" "1"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen"
Device "Device"
Monitor "Monitor"
#Option "CustomEDID" "DFP-0:/etc/X11/edid-shimian.bin"
Option "MetaModes" "DFP-0: 2560x1440_100 +0+0"
SubSection "Display"
Depth 30
EndSubSection
EndSection

Najs! Ska kika igenom det sen, hur gjorde du en custom edid eller laddade du hem?

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)

Trädvy Permalänk
Medlem
Plats
Sturup
Registrerad
Jan 2007

Jag hade oxo problem som bara den att få det att funka, men till slut gick det. Kan posta mina .conf filer om du inte får det att funka med lembrittts filer.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012
Skrivet av pellski87:

Najs! Ska kika igenom det sen, hur gjorde du en custom edid eller laddade du hem?

Jag laddade hem dem ifrån något forum.
Med den kunde jag bara köra i 60Hz, så därför har jag kommenterat bort den raden.
Under mina försök så hade jag alltid bild i console, men i X var det ofta bara svart, när man tröttnade så var det lätt att editera filen i Nano och ta bort #, så fick jag 60Hz i X.

Sökte igenom ett otal forum och pusslade ihop min fil med dom flesta tips jag stötte på.
Googlade på "overclock yamakasi linux" och gick vidare därifrån.
Lycka till och ta alltid backup på xorg filen.

CPU: I5-3570K | RAM: 16GB (4x4GB) Corsair LP | MB: Asus Maximus V Gene Z77 | GPU: MSI Radeon RX580 Armor 8GB | Chassi: FD Arc mini R2 | PSU: CM700V | SSD: Crucial MX300 750GB | Monitor: Yamakasi Catleap 2B Extreme | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Plats
Piteå
Registrerad
Okt 2004

är det någon här som kan hjälpa mig med detta, har suttit med det till och från i 30 år snart känns det som. Blir fan inte klokare!

Har kört in Xubuntu 16.04 samt nvidia drivare 361.42 men får det ändå inte att fungera som sagt...

CPU: AMD Ryzen 1700x @ 3.8GHz || Mem: 16GB Corsair LPX 3000mhz || Mobo: Asus x370 Prime || GPU: EVGA Geforce GTX1070 SC || SSD: WD black 500GB m2 || OS: Linux Mint/Win 10 || Monitor: Dell 43" 4K P4317Q

Citera om du vill ha svar :)