Permalänk
Medlem

DNS namn med port strular?

Har ett underligt bekymmer.

har te.x

mydomain.com som i brandväggen tar emot på 80 och vidare till min synology på port 80 till IP *.5
mydomain.com:8282 som går mot en annan synology men i brandväggen så pekar den om till 80 och vidare till IP *.6
mydomain.com:8180 som går vidare mot min KODI på port 80 internt och IP*.83
mydomain.com:8380 som går vidare och på port 80 internt till en apache webserver på IP *.38

Problemet där är att när jag skriver mydomain.com:8282 så hamnar jag på synologyn som ligger på mitt interna ip *.5, alltså inte till *.6 som jag har pekat den till.
Har t.o.m tagit bort konfiken av vidarebefodringen av port 80 i brandväggen, men ändå hamnar 8282 på fel synology.

Min firefox plockar bort portnumren i adressfältet och går direkt på mydomain.com och bryr sig inte om porten jag skrivit dit, samma i IE.

De andra fungerar utan problem.
Men kan inte förstå varför de andra inte fungerar.
Kör nu, asuswrt, testade förut med dd-wrt och samma bekymmer även med pfsense och samma där.

Skjuter mina synology ut någon skum inställning på mitt interna nätverk eller vad?

Permalänk
Medlem

Har du provat att skriva explicit http://mydomain.com:8282?
Jag har upptäckt att flera browsers vägrar köra http om man bara skriver porten ibland. Dvs, att felet kanske sitter i browsern och inte alls där du felsöker...

Permalänk
Medlem
Skrivet av Talisker00:

Har du provat att skriva explicit http://mydomain.com:8282?
Jag har upptäckt att flera browsers vägrar köra http om man bara skriver porten ibland. Dvs, att felet kanske sitter i browsern och inte alls där du felsöker...

Testade att lägga till ? men den gör antingen en googlesökning eller går till http://mydomain.com direkt och plockar bort portnummret.

Permalänk
Medlem

Märkligt. Jag menade inget "?", utan bara att man skriver http:// före helt enkelt.
http://mydomain.com:8282

Permalänk
Medlem
Skrivet av Talisker00:

Märkligt. Jag menade inget "?", utan bara att man skriver http:// före helt enkelt.
http://mydomain.com:8282

haha, ja ok

men har testat det redan tidigare också

Permalänk
Medlem

Konstigt. Har du provat med någon telnet-klient för att se var trafiken hamnar för att utesluta browsers? Det går att köra exempelvis putty (putty -P 8282 -telnet mydomain.com). Nu känns det inte som om browsers är problemet, men det kan vara bra att utesluta så många saker som möjligt när man felsöker.

Permalänk
Medlem

Jag hade provat lite andra portar, tex med något som börjar på 9***.
Se om det blir någon skillnad.

"mydomain.com:8282 som går mot en annan synology men i brandväggen så pekar den om till 80 och vidare till IP *.6"
Vad menar du med "i brandväggen så pekar den om till 80" ? Hur ser regeln ut?

Permalänk
Medlem
Skrivet av Talisker00:

Konstigt. Har du provat med någon telnet-klient för att se var trafiken hamnar för att utesluta browsers? Det går att köra exempelvis putty (putty -P 8282 -telnet mydomain.com). Nu känns det inte som om browsers är problemet, men det kan vara bra att utesluta så många saker som möjligt när man felsöker.

Ska testa det.

Skrivet av Meega:

Jag hade provat lite andra portar, tex med något som börjar på 9***.
Se om det blir någon skillnad.

"mydomain.com:8282 som går mot en annan synology men i brandväggen så pekar den om till 80 och vidare till IP *.6"
Vad menar du med "i brandväggen så pekar den om till 80" ? Hur ser regeln ut?

ALL TCP 8282 192.168.0.6 80 VSERVER (Synology, fungerar ej)
ALL TCP 8380 192.168.0.38 80 VSERVER (apacke på windows, fungerar ej) UPDATE: Ändrade till 9292 då funkar den.
ALL TCP 80 192.168.0.5 80 VSERVER (synology, fungerar)
ALL TCP 8081 192.168.0.83 80 VSERVER (KODI, fungerar)