Permalänk
Medlem

har du tilgin som router?

Tjenare det är så att jag inte lyckas port forwarda och undrar om någon har en tilgin router som port forwardar?
Jag har gjort en regel/flera regler och angett rätt ip och portar men ändå så lyckas jag inte få ut servern på nätet.

Permalänk
Medlem

Sitter du bakom CGN? Har du testat att inaktivera alla inblandade brandväggar?

Permalänk
Medlem
Skrivet av LemonIllusion:

Sitter du bakom CGN? Har du testat att inaktivera alla inblandade brandväggar?

vad menas med CGN?
servern har ingen brandvägg(det är en NVR rättare sagt)
Routern verkar vara konstig eller så är det jag som är konstig. När jag anger portarna så måste jag spara 3 gånger för ibland så försvinner siffrorna på destination ports
har även försökt byta lösenord till inloggningen till routern utan vidare framgång. Lösenordet återställs efter omstart.

Permalänk
Medlem

verkar vara brandväggen som är i vägen, ska kolla på den nu. Såhär stod det på help sidan.

"Using the Port Forwarding page, you can provide local services (for example web hosting) for people on the Internet or play Internet games. To configure a service, game or other application, select the external connection (for example the Internet connection), select the computer hosting the service and add the corresponding firewall rule. You can also add/edit/delete rules without using the templates. In the presence of the firewall, anonymous Internet traffic is blocked.

You could also setup the gateway to forward any incoming traffic to some host on the LAN. This could be done on the corresponding connection page by entering LAN host IP address in the "DMZ host IP address" field."

lägger jag till ett undantag här eller är jag helt fel?

Permalänk
Medlem
Skrivet av 007onex:

vad menas med CGN?
servern har ingen brandvägg(det är en NVR rättare sagt)
Routern verkar vara konstig eller så är det jag som är konstig. När jag anger portarna så måste jag spara 3 gånger för ibland så försvinner siffrorna på destination ports
har även försökt byta lösenord till inloggningen till routern utan vidare framgång. Lösenordet återställs efter omstart.

CGN innebär att du inte har en egen extern IP-adress utan delar en med andra. Utan en extern IP-adress kan du inte komma åt ditt nätverk utifrån alls, så det kommer inte fungera även om din port forwarding är korrekt. Jämför IP-adressen på routerns WAN-interface med den som visas här.

EDIT: Du har en brandväggsregel för 100.64.1.18, vilket är en IP-adress reserverad för CGN. Det lär vara det som är problemet.

Permalänk
Medlem
Skrivet av LemonIllusion:

CGN innebär att du inte har en egen extern IP-adress utan delar en med andra. Utan en extern IP-adress kan du inte komma åt ditt nätverk utifrån alls, så det kommer inte fungera även om din port forwarding är korrekt. Jämför IP-adressen på routerns WAN-interface med den som visas här.

EDIT: Du har en brandväggsregel för 100.64.1.18, vilket är en IP-adress reserverad för CGN. Det lär vara det som är problemet.

låter kanske lite dum nu men jag hitta inte WAN interface.
ska jag ta bort den regeln eller?

edit:har nu stängt av brandväggen, kommer fortfarande inte ut när jag kollar på canyouseeme

Permalänk
Medlem
Skrivet av 007onex:

låter kanske lite dum nu men jag hitta inte WAN interface.
ska jag ta bort den regeln eller?

Det brukar stå på någon förstasida eller liknande i routern vad WAN IP är. Kan även stå bland inställningarna för DHCP-klienten. Jag har aldrig pillat på en Tilgin, så mest gissningar här.

Låt regeln vara. Jag antar att du fått routern från din ISP som tycker den ska vara där. Det är nog IP-adressen ISP:n använder för att administrera din router. Om du vill testa utan brandvägg borde det finnas någon knapp för att inaktivera den helt temporärt i testningssyfte, men jag är rätt säker på att det är CGN som är problemet.

Citat:

edit:har nu stängt av brandväggen, kommer fortfarande inte ut när jag kollar på canyouseeme

Har du något som lyssnar på porten? Annars kommer det inte synas att den är öppen i vilket fall.

Permalänk
Medlem
Skrivet av LemonIllusion:

Det brukar stå på någon förstasida eller liknande i routern vad WAN IP är. Kan även stå bland inställningarna för DHCP-klienten. Jag har aldrig pillat på en Tilgin, så mest gissningar här.

Låt regeln vara. Jag antar att du fått routern från din ISP som tycker den ska vara där. Det är nog IP-adressen ISP:n använder för att administrera din router. Om du vill testa utan brandvägg borde det finnas någon knapp för att inaktivera den helt temporärt i testningssyfte, men jag är rätt säker på att det är CGN som är problemet.

Har du något som lyssnar på porten? Annars kommer det inte synas att den är öppen i vilket fall.

ska jag lyssna med wireshark eller?
testade med att stänga av brandväggen utan framgång. Wan verkar inte vara som min publika ip adress

Permalänk
Medlem
Skrivet av 007onex:

ska jag lyssna med wireshark eller?

Nej, jag antar att du öppnar porten för att hosta någon form av server på den. Starta servermjukvaran så borde den svara på porten när du kör canyouseeme.

Citat:

testade med att stänga av brandväggen utan framgång. Wan verkar inte vara som min publika ip adress

Då är det CGN som är problemet. Vad har du för ISP? Bredband2 och Bahnhof är två vanliga som använder CGN.

Permalänk
Medlem
Skrivet av LemonIllusion:

Då är det CGN som är problemet. Vad har du för ISP? Bredband2 och Bahnhof är två vanliga som använder CGN.

bahnhof. routern kommer därifrån

Permalänk
Medlem
Skrivet av 007onex:

bahnhof. routern kommer därifrån

Logga in här och begär en publik IP-adress.

Permalänk
Medlem
Skrivet av LemonIllusion:

Logga in här och begär en publik IP-adress.

så nu har jag angett. Vad innebär detta nu? Vad gör jag sedan?

Edit: har inget internet hemma nu

Permalänk
Medlem
Skrivet av 007onex:

så nu har jag angett. Vad innebär detta nu? Vad gör jag sedan?

Det innebär att din router inom kort får en publik IP-adress. Jämför WAN IP på routern med sidan jag länkade igen och se till att de är samma. Är de det kommer dina port forwards troligtvis fungera nu, är de inte det kan du behöva vänta ett tag, kanske till imorgon för att du ska få din IP-adress.

Permalänk
Medlem
Skrivet av LemonIllusion:

Det innebär att din router inom kort får en publik IP-adress. Jämför WAN IP på routern med sidan jag länkade igen och se till att de är samma. Är de det kommer dina port forwards troligtvis fungera nu, är de inte det kan du behöva vänta ett tag, kanske till imorgon för att du ska få din IP-adress.

Jaha. Jag har inget internet just nu är det för att jag väntar på ip?

Permalänk
Medlem
Skrivet av LemonIllusion:

Sitter du bakom CGN? Har du testat att inaktivera alla inblandade brandväggar?

Skulle inte någon kunna skapa en guide om det där vad CGN och hur man kollar up det om man ligger bakom det hur man vet att man har en publik ip osv..... Tycker man ser det rätt ofta att folk har problem med portfowarding

Permalänk
Medlem
Skrivet av Sharaz:

Skulle inte någon kunna skapa en guide om det där vad CGN och hur man kollar up det om man ligger bakom det hur man vet att man har en publik ip osv..... Tycker man ser det rätt ofta att folk har problem med portfowarding

Ugh, mjaeäh. Bra idé, men det får hamna en bit ner på att-göra-listan. Det känns som det blir ett större projekt än jag har möjlighet att hantera just i och med att det kommer behöva innefatta både hur nätverk i allmänhet, IP-adresser, routrar, NAT/PAT, säkert DHCP och annat relevant fungerar. En guide ska ju behöva utbilda också, inte bara vara "så här löser du ditt problem" (enligt mig i alla fall) och vara lämplig även för de som precis börjar pilla med nätverk och servrande.

Skrivet av 007onex:

Jaha. Jag har inget internet just nu är det för att jag väntar på ip?

Det lär det vara, ja. Jag har själv inte Bahnhof, men instruktionerna jag gav dig har jag testat på flera andra forummedlemmar och för dem verkade det komma igång rätt snabbt.

Permalänk
Medlem
Skrivet av 007onex:

Jaha. Jag har inget internet just nu är det för att jag väntar på ip?

Startat om routern? Annars får du ringa bahnhof support.

Permalänk
Rekordmedlem
Skrivet av Sharaz:

Skulle inte någon kunna skapa en guide om det där vad CGN och hur man kollar up det om man ligger bakom det hur man vet att man har en publik ip osv..... Tycker man ser det rätt ofta att folk har problem med portfowarding

De olika ip klasserna finn listade på wikipedia och en guide skulle skilja beroende på operatör och hårdvara, det viktigasteär att man kan principerna för annars blir det många guider.
Privata ip-områden
10.0.0.0 - 10.255.255.255
172.16.0.0 - 172.31.255.255
192.168.0.0 - 192.168.255.255
Specialområdet för CGN
100.64.0.0/10 carrier-grade NAT
https://en.wikipedia.org/wiki/Private_network.

Ip utanför dessa områden är publika och "finns och routas" på internet.

Permalänk
Medlem

@LemonIllusion @mrqaffe: jag har tydligen CGN. Detta är för frustrerande, testat i en hel vecka nu utan framgång, får bli en lärdom till framtiden när jag har mitt eget internet att aldrig skaffa en router från ispn.(det är päronens internet) .

såhär ser det ut och mitt publika ip är inte desamma

Permalänk
Rekordmedlem
Skrivet av 007onex:

@LemonIllusion @mrqaffe: jag har tydligen CGN. Detta är för frustrerande, testat i en hel vecka nu utan framgång, får bli en lärdom till framtiden när jag har mitt eget internet att aldrig skaffa en router från ispn.(det är päronens internet) .

http://i.imgur.com/PNY7C4g.png
såhär ser det ut och mitt publika ip är inte desamma

CGN har inget med din router att göra, det beror på att operatören har slut på ipv4 adresser och vill dra ut på övergången till ipv6 ännu längre, det är en styggelse att vi inte lämnat ipv4 ännu och att kunderna inte pressar operatörerna mer om att de ska sluta med alla undanflykter de har mot att införa ipv6 överallt.

Permalänk
Medlem

@mrqaffe:
Jaha det är så det ligger till. Men hur gör jag då för att port forwarda.

Permalänk
Rekordmedlem
Skrivet av 007onex:

@mrqaffe:
Jaha det är så det ligger till. Men hur gör jag då för att port forwarda.

Antagligen som du gjort, men ditt problem är att du inte har nått att "forwarda" du kan inte nås av den trafiken innan du har en publik ipaddress.
Du måste alltså beställa en publik adress och vänta till du fått det och sedan kan du fortsätta med din egen konfigurering, troligen bör du brygga eller ta bort Tilginen om du vill använda Asusen som router.

Permalänk
Medlem

@mrqaffe: @LemonIllusion
jag tror att jag upptäckte vad jag är tvungen att göra. Jag måste nog skapa en ny koppling (se bild) där jag själv väljer om det ska vara dynamisk koppling eller statisk IPv6 koppling.
Jag knappade in en random "IP address / prefix length:" som ni ser.

Inget jag har gjort fel som ni kan upptäcka?

när jag skapar en ny regel så anger jag vilken koppling regeln ska gälla för (se bild), med min nya koppling så får jag felmeddelandet som ni ser är markerat med röd penna.

jag uttalar mig förmodligen fel men ni förstår mig hoppas jag

Permalänk
Rekordmedlem
Skrivet av 007onex:

@mrqaffe: @LemonIllusion
jag tror att jag upptäckte vad jag är tvungen att göra. Jag måste nog skapa en ny koppling (se bild) där jag själv väljer om det ska vara dynamisk koppling eller statisk IPv6 koppling.
Jag knappade in en random "IP address / prefix length:" som ni ser.
http://i.imgur.com/wJ4VcoK.png
Inget jag har gjort fel som ni kan upptäcka?

när jag skapar en ny regel så anger jag vilken koppling regeln ska gälla för (se bild), med min nya koppling så får jag felmeddelandet som ni ser är markerat med röd penna.
http://i.imgur.com/zjU0j5T.png

jag uttalar mig förmodligen fel men ni förstår mig hoppas jag

Nu var du rörig, du kan inte hitta på ipnummer och har du fixat så du har ett publikt ip till routerns waninterface ?

Permalänk
Medlem

@mrqaffe:
ip nummret jag angav var internet. jag får väl ett statiskt publikt ip av bahnhof

Permalänk
Medlem
Skrivet av 007onex:

@mrqaffe:
ip nummret jag angav var internet. jag får väl ett statiskt publikt ip av bahnhof

I princip ingen ISP ger dig en statisk ip om du inte har företagsabonnemang och/eller betalar extra för det.

Här får du en superguide för hur man fixar port forward på en Tilgin (förutsatt att du har samma som jag):
1. Kolla vad du har för publik ip-adress. Har du fortfarande något i spannet 100.64.0.0/10 så kontakta bahnhof och begär en publik ip-adress.
2. Logga in på routern och kontrollera under Inställningar -> Anslutningar att du har en DHCP-tilldelad, publik ip-adress.
3. Gå till Avancerad -> Port Forwarding och på ny regel så väljer du din dhcp-anslutning och trycker lägg till.
4. Källa: 0.0.0.0/0 (om forwardingen ska gälla alla). Destination: 192.168.x.x, lokala IPt på den dator som kör tjänsten. Protokoll/start/slut enligt vad du ska vidarebefordra.
5. Tryck verkställ. Tryck sedan 'save settings' uppe till höger vid logga-ut-knappen! Gör du inte detta så återställs det vid omstart.
6. Funkar det inte så starta om routern.
7. Game game game!

*edit*
Såg sen att du postat bilder. Spontant så känns din övre regel med 'anslutning: dhcp' korrekt, och den andra fel. Säker på att felet inte bara är att du inte har någon publik ip-adress?

Permalänk
Medlem
Skrivet av Kamouflage:

I princip ingen ISP ger dig en statisk ip om du inte har företagsabonnemang och/eller betalar extra för det.

Här får du en superguide för hur man fixar port forward på en Tilgin (förutsatt att du har samma som jag):
1. Kolla vad du har för publik ip-adress. Har du fortfarande något i spannet 100.64.0.0/10 så kontakta bahnhof och begär en publik ip-adress.
2. Logga in på routern och kontrollera under Inställningar -> Anslutningar att du har en DHCP-tilldelad, publik ip-adress.
3. Gå till Avancerad -> Port Forwarding och på ny regel så väljer du din dhcp-anslutning och trycker lägg till.
4. Källa: 0.0.0.0/0 (om forwardingen ska gälla alla). Destination: 192.168.x.x, lokala IPt på den dator som kör tjänsten. Protokoll/start/slut enligt vad du ska vidarebefordra.
5. Tryck verkställ. Tryck sedan 'save settings' uppe till höger vid logga-ut-knappen! Gör du inte detta så återställs det vid omstart.
6. Funkar det inte så starta om routern.
7. Game game game!

*edit*
Såg sen att du postat bilder. Spontant så känns din övre regel med 'anslutning: dhcp' korrekt, och den andra fel. Säker på att felet inte bara är att du inte har någon publik ip-adress?

såhär är det märker jag.
1.Min publika ip adress börjar på 94.254. så det lär inte vara några problem.
2.min portforwarding är korrekt.
3.en ny connection var inte lösningen så det tog jag bort.
4. allting verkar vara som det ska men på port forwarding testerna så syns inte jag

Permalänk
Medlem

@007onex:

Det snabbaste sättet att ta reda på ip till routern är www.whatismyip.com.
Har du en "publik" ip (inte nat:ad) så skapa bara en port forward från wan ip-> lan ip.
Givetvis måste även din host tillåta trafiken.

Permalänk
Medlem
Skrivet av 007onex:

såhär är det märker jag.
1.Min publika ip adress börjar på 94.254. så det lär inte vara några problem.
2.min portforwarding är korrekt.
3.en ny connection var inte lösningen så det tog jag bort.
4. allting verkar vara som det ska men på port forwarding testerna så syns inte jag

1. Bara för att dubbelkolla: Du kontrollerar din publika ip-adress via routerns gränssnitt va? Whatismyip och liknande sidor kommer se en publik ip även om du inte har det egentligen.

4. Vad är det för test du gör? Kan du starta en wireshark och se om du faktiskt får in någon trafik på den porten?

Har du stängt av eventuella brandväggar på datorn?

Permalänk
Medlem
Skrivet av _niko_:

@007onex:

Det snabbaste sättet att ta reda på ip till routern är www.whatismyip.com.
Har du en "publik" ip (inte nat:ad) så skapa bara en port forward från wan ip-> lan ip.
Givetvis måste även din host tillåta trafiken.

jag har en publik id som börjar på 94 och det ska fungera. Jag har portforwarda men någonstans så misslyckas det. Finns det något program jag kan kolla vart problemet ligger?