Plötsligt problem med inloggning i Ubuntu 16.04

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2009

Plötsligt problem med inloggning i Ubuntu 16.04

Hej,

För en månad eller två sedan så skaffade jag Linux (Ubuntu 16.04) då jag behövde det till några projekt, installerade det på en separat SSD så att jag dual bootar Windows samt Linux. Så jag är inte så jättevarm i kläderna när det kommer till Linux så känner mig lite vilsen i hur jag fixar detta problem, har googlat runt lite med i ärlighetsnamn har jag inte blivit mycket klokare på det. Skulle bli evigt tacksam om någon kunde peka mig i rätt riktning för att lösa problemet då informationen som ligger på disken är väldigt viktigt för mig.

För att göra en lång historia kort så det sista jag minns att jag gjorde var att installera texlive-full samt texmaker och drog igång lite beräkningar samt satte på en shutdown timer på 14 timmar, då beräkningarna skulle vara klara efter den tiden. Efter det åkte jag iväg i fyra dagar för att träffa släkten och nu idag när jag försöker logga in (efter jag skrivit lösenordet) så blinkar detta meddelandet till "/dev/sdc1: clean 791483/6283264 files, 14239727/25131264 blocks" och sen kastas jag tillbaks till inloggningsskärmen. Värt att nämna är kanske också att inloggningsskärmen är seg som sirap...

Så det känns lite som att allt fungerade ena dagen och sen helt plötsligt fungerade det inte nästa dag, Windows snurrar fin fint så verkar inte vara någon problem med hårdvaran. Vet inte om någon annan information behövs för att underlätta?

TLDR
Får upp /dev/sdc1: clean 791483/6283264 files, 14239727/25131264 blocks vid inloggningsförsök, hur fixar jag alternativt felsöker det?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Enklast är nog att kolla på diskarna från en Live-ISO. Kan vara så att något logikfel har inträffat på disken viket har skadat filsystemet. Det du kan göra från en live-ISO är i princip att köra program som bryter ut din hemkatalog.

Ett tips för framtiden är att du monterar din hemkatalog på en separat disk eller partition, då är den lättare att laga samt kan lättare tas backup på, till skillnad om den är katalog i din /-partition.

från programmen gparted och gpart kan du söka efter skadade partitioner och försöka montera dom för göra en backup

På Linux Mint ISO:n är Gparted med som standard, annars kan du installera det med sudo apt-get install gparted.
Den funktion som söker efter korrupta partitioner är gpart och installeras med sudo apt-get install gpart.
Funktionen är i Menyn Enhet - > Försök att rädda data (meny 4, val 2) i gparted.

Om du berättar mer om hur diskarna är upplagda så är det lättare att hjälpa dig.
Alla distributioner av Linux som bygger på Debian / Ubuntu och Mint har i princip samma kommandon och programutbud.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Medlem
Registrerad
Apr 2013

Låter som du har grafisk inloggning som inte lyckas starta din session vilket gör att du ser logskärmen medans den försöker starta din session för att falla tillbaka på loginhanteraren.

Testa att trycka ctrl+alt+f1 och se om du får en inloggningsprompt och kan logga in. För att komma tillbaka till den grafiska inloggningen trycker du ctrl+alt+f7.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Mar 2008

Så du startar datorn, ser någon grafisk greeter (display manager), när du försöker logga in ser du i stället framebuffern för ett ögonblick och sen startar greeter igen? Symtomen är typiska då X servern kraschar eller stänger av sig av någon anledning. Anledningen kan vara allt möjligt, som att display manager kraschar eller har felaktig konfig eller att desktopen inte startar av någon anledning. Det meddelandet du ser är det sista som skrevs till framebuffern innan X servern startade och det har inget att göra med felet.

För att hitta felet blir det till att felsöka. Kolla kernelns log, Xorg.0.log och loggar för display manager om det finns någon. Kolla också konfigurationen för dessa. Att guida den felsökningen över internet är inte så kul så jag säger som Red Foreman: I'd like to help, but not as much as I'd like not to.

Min gut feeling säger att du dragit in nya grafikdrivrutiner som kraschar X servern vid start. Om du behöver komma åt filerna snabbt så använd en livecd.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2009
Skrivet av OldComputer:

Enklast är nog att kolla på diskarna från en Live-ISO. Kan vara så att något logikfel har inträffat på disken viket har skadat filsystemet. Det du kan göra från en live-ISO är i princip att köra program som bryter ut din hemkatalog.

Ett tips för framtiden är att du monterar din hemkatalog på en separat disk eller partition, då är den lättare att laga samt kan lättare tas backup på, till skillnad om den är katalog i din /-partition.

från programmen gparted och gpart kan du söka efter skadade partitioner och försöka montera dom för göra en backup

På Linux Mint ISO:n är Gparted med som standard, annars kan du installera det med sudo apt-get install gparted.
Den funktion som söker efter korrupta partitioner är gpart och installeras med sudo apt-get install gpart.
Funktionen är i Menyn Enhet - > Försök att rädda data (meny 4, val 2) i gparted.

Om du berättar mer om hur diskarna är upplagda så är det lättare att hjälpa dig.
Alla distributioner av Linux som bygger på Debian / Ubuntu och Mint har i princip samma kommandon och programutbud.

Skrivet av aluser:

Låter som du har grafisk inloggning som inte lyckas starta din session vilket gör att du ser logskärmen medans den försöker starta din session för att falla tillbaka på loginhanteraren.

Testa att trycka ctrl+alt+f1 och se om du får en inloggningsprompt och kan logga in. För att komma tillbaka till den grafiska inloggningen trycker du ctrl+alt+f7.

Skrivet av Emaku:

Så du startar datorn, ser någon grafisk greeter (display manager), när du försöker logga in ser du i stället framebuffern för ett ögonblick och sen startar greeter igen? Symtomen är typiska då X servern kraschar eller stänger av sig av någon anledning. Anledningen kan vara allt möjligt, som att display manager kraschar eller har felaktig konfig eller att desktopen inte startar av någon anledning. Det meddelandet du ser är det sista som skrevs till framebuffern innan X servern startade och det har inget att göra med felet.

För att hitta felet blir det till att felsöka. Kolla kernelns log, Xorg.0.log och loggar för display manager om det finns någon. Kolla också konfigurationen för dessa. Att guida den felsökningen över internet är inte så kul så jag säger som Red Foreman: I'd like to help, but not as much as I'd like not to.

Min gut feeling säger att du dragit in nya grafikdrivrutiner som kraschar X servern vid start. Om du behöver komma åt filerna snabbt så använd en livecd.

Tack för hjälpen! Det slutade med att jag drog ner en LIVE-cd och bootade därifrån för att sedan flytta över filerna som ni föreslog, fungerade mycket bra! Så det verkar vara något fel på det grafiska då jag kom åt hårddisken från en LIVE-cd samt kunde logga in med hjälp av CTRL + ALT + F1 vid den vanliga inloggningsrutan i Ubuntu.

Jag började med att gå igenom lite loggfiler men insåg efter ett litet tag att det nog går snabbare att göra en ominstallation, kanske inte den mest lärorika lösning men nog den lättaste! Sitter och sätter upp min gamla utvecklingsmiljö för tillfället men allt verkar flytta på bra. Återigen tack för hjälpen!