NAS med Linux slutar svara, behörigheter fel?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005

NAS med Linux slutar svara, behörigheter fel?

Hej!

Jag kör en Zyxel NSA325v2 NAS som kör linux i botten vad jag förstått. Den har fungerat hur bra som helst väldigt länge. För några dagar sedan så märkte jag dock att jag inte kunde ta bort några mappar då jag inte hade behörighet. Det var då jag gjorde något dumt som jag inte riktigt har koll på

Jag loggade in i NAS:en via SSH och körde diverse kommandon som jag bara har halvhyfsad koll (jag vet vad de gör men jag är inte helt hundra på hur jag skulle använda dem, och jag vet inte heller exakt vilka jag körde eller vilket det var som ställde till det...). Det jag kommer ihåg är att jag körde bl.a chown och chgrp, samt att jag ändrade samtliga mappbehörigheter med chmod -R till 777. Jag vet inte exakt vilka mappar jag körde det på heller.

Det löste problemen med att jag inte hade behörighet att ändra vissa mappar och den fungerade fint samma dag men helt plötsligt märkte jag efter detta att jag inte kommer åt NSA via webinterface eller shares eller SSH. Den fungerar helt som den ska i ett par minuter efter att jag startat den, sen lägger den av helt. Jag kan pinga den hela tiden.

Om jag listar / får jag upp följande:
https://www.dropbox.com/s/ic97irat5tcvqo9/Sk%C3%A4rmklipp%202...
Säg till om ni vill veta hur det ser ut i undermappar...

Någon som kan hjälpa mig på vägen? Har provat att nollställa alla inställningar helt men det nollställde bara grundläggande inställningar. Misstänker att det är någon app som ska starta och som inte har rätt behörigheter och som därmed krashar hela NAS:en, kan det vara så?

Uppskattar all eventuell hjälp!

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2009

Vad händer om du skjuter in en ny/gammal firmware-version?
Jag har en likadan NAS stående hos mina föräldrar, men minns inte om man kan bocka i att nollställa nasen i samband med firmware-återställning eller inte.

Surf:: FD Define R3 | W10 Pro | Corsair TX650W | MSI P67A-GD65 B3 | i5-2500K@4.2GHz | 16GB Corsair Vengeance 1600MHz | GTX1060 | Be Quiet Pure Rock |
Htpc:: FD Node 304 | W10 Pro | CM Silent Pro M2 420W | ASRock H77M-ITX | Intel i5 2400 | Asus GT 630 | 8GB Corsair Vengeance 1600MHz | Arctic Cooling Alpine 11+
Server:: HP Proliant N54L | ESXI | XPEnology | 1SSD + 6HDD | 6Gb RAM

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av marmeladov:

Vad händer om du skjuter in en ny/gammal firmware-version?
Jag har en likadan NAS stående hos mina föräldrar, men minns inte om man kan bocka i att nollställa nasen i samband med firmware-återställning eller inte.

Provar! Tack för tips

Edit: Återställt firmware nu. Fanns inget val att nollställa NAS:en i samband med firmware-återställning. Har ju dessutom hållit in Reset-knappen på NAS:en. Nästa alternativ är att re-initiera NAS:en men då varnar den att all data försvinner, tolkar det som att all lagring försvinner och har ju ett par TB data på NAS:en som jag helst inte vill bli av med

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2009
Skrivet av TobiasStockholm:

Provar! Tack för tips

Kör hårt.

När din NAS slutat svara, hittar du den via Nas Starter Utility som finns att tanka ned från Zyxel?

edit: Annars bör nog kanske detta hjälpa, se sista punkten; håll inne reset-knappen i 16 sekunder för att göra en factory restore.
http://zyxel.nas-central.org/wiki/Reset_button

Surf:: FD Define R3 | W10 Pro | Corsair TX650W | MSI P67A-GD65 B3 | i5-2500K@4.2GHz | 16GB Corsair Vengeance 1600MHz | GTX1060 | Be Quiet Pure Rock |
Htpc:: FD Node 304 | W10 Pro | CM Silent Pro M2 420W | ASRock H77M-ITX | Intel i5 2400 | Asus GT 630 | 8GB Corsair Vengeance 1600MHz | Arctic Cooling Alpine 11+
Server:: HP Proliant N54L | ESXI | XPEnology | 1SSD + 6HDD | 6Gb RAM

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2009
Skrivet av TobiasStockholm:

Provar! Tack för tips

Edit: Återställt firmware nu. Fanns inget val att nollställa NAS:en i samband med firmware-återställning. Har ju dessutom hållit in Reset-knappen på NAS:en. Nästa alternativ är att re-initiera NAS:en men då varnar den att all data försvinner, tolkar det som att all lagring försvinner och har ju ett par TB data på NAS:en som jag helst inte vill bli av med

Ja, det är samma tips som jag skrev ovan. Enligt uppgift från länken jag postade så förlorar du inte datan på diskarna, men jag skulle nog göra backup på dem ändå, alternativt bara plugga ut dem men det är ingen garanti för att det går plugga in igen efter restore.

Surf:: FD Define R3 | W10 Pro | Corsair TX650W | MSI P67A-GD65 B3 | i5-2500K@4.2GHz | 16GB Corsair Vengeance 1600MHz | GTX1060 | Be Quiet Pure Rock |
Htpc:: FD Node 304 | W10 Pro | CM Silent Pro M2 420W | ASRock H77M-ITX | Intel i5 2400 | Asus GT 630 | 8GB Corsair Vengeance 1600MHz | Arctic Cooling Alpine 11+
Server:: HP Proliant N54L | ESXI | XPEnology | 1SSD + 6HDD | 6Gb RAM

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av marmeladov:

Kör hårt.

När din NAS slutat svara, hittar du den via Nas Starter Utility som finns att tanka ned från Zyxel?

edit: Annars bör nog kanske detta hjälpa, se sista punkten; håll inne reset-knappen i 16 sekunder för att göra en factory restore.
http://zyxel.nas-central.org/wiki/Reset_button

Se mitt redigerade inlägg ovan. Nas Starter Utility hittar den inte när den slutat svara, men hittar den dock innan den slutat svara. Har hållt in Resetknappen (5 sek efter andra pipet enligt manualen) redan, det nollställde bara grundläggande inställningar om IP, users, adminlösenord etc.

Helst hoppas jag på att någon Linux-guru kan förklara vad de olika mapparna på NAS:en ska ha för behörigheter, om det ser rätt ut eller heltokigt ut på bilden jag bifogat. Finns bara två användare på NAS:en vad jag förstått - admin och root.

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Nov 2009
Skrivet av TobiasStockholm:

Se mitt redigerade inlägg ovan. Nas Starter Utility hittar den inte när den slutat svara, men hittar den dock innan den slutat svara. Har hållt in Resetknappen (5 sek efter andra pipet enligt manualen) redan, det nollställde bara grundläggande inställningar om IP, users, adminlösenord etc.

Helst hoppas jag på att någon Linux-guru kan förklara vad de olika mapparna på NAS:en ska ha för behörigheter, om det ser rätt ut eller heltokigt ut på bilden jag bifogat. Finns bara två användare på NAS:en vad jag förstått - admin och root.

Ok. Ja, var försiktig så du inte tappar infon på diskarna som sagt. Om du "bara" resetar grundläggande info så kan du ju prova hålla inne längre för att se om det hjälper för att fabriksåterställa den helt.

Det om behörigheterna lämnar jag med varm hand över till någon annan
Har tyvärr ingen möjlighet att kolla behörigheterna på nasen hos mina föräldrar då jag bor styvt 95mil från dem, annars hade det ju gått lösa så.

Surf:: FD Define R3 | W10 Pro | Corsair TX650W | MSI P67A-GD65 B3 | i5-2500K@4.2GHz | 16GB Corsair Vengeance 1600MHz | GTX1060 | Be Quiet Pure Rock |
Htpc:: FD Node 304 | W10 Pro | CM Silent Pro M2 420W | ASRock H77M-ITX | Intel i5 2400 | Asus GT 630 | 8GB Corsair Vengeance 1600MHz | Arctic Cooling Alpine 11+
Server:: HP Proliant N54L | ESXI | XPEnology | 1SSD + 6HDD | 6Gb RAM

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av marmeladov:

Ok. Ja, var försiktig så du inte tappar infon på diskarna som sagt. Om du "bara" resetar grundläggande info så kan du ju prova hålla inne längre för att se om det hjälper för att fabriksåterställa den helt.

Det om behörigheterna lämnar jag med varm hand över till någon annan
Har tyvärr ingen möjlighet att kolla behörigheterna på nasen hos mina föräldrar då jag bor styvt 95mil från dem, annars hade det ju gått lösa så.

Har alltså redan provat att reseta den så mycket det går med reset-knappen, förlorade ingen data men det löste heller inte problemet. Misstänker att det inte påverkar behörigheterna på mapparna.

Uppskattar din hjälp ändå, kanske dyker upp någon annan som har samma NAS och kan kolla behörigheterna...

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Registrerad
Feb 2016

Har en gång i tiden lyckats med nåt liknande men då på en qnap...
Jag hade ingen kryptering av disken igång och visste att den va uppsatt med ext4 så det slutade med att jag tog ut disken och blåste rent NASen (mha nån guide jag hittade) och sen dess har det funkat finfint.
Med det sagt tror jag inte din data är i nån större fara om du inte har raidat diskarna och inte kör nån kryptering på dom. Då BÖR det räcka att ta ut dom, om initiera och stoppa i diskarna igen för att NASen ska fatta att det är nåt på dom.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av Napoleongl:

Har en gång i tiden lyckats med nåt liknande men då på en qnap...
Jag hade ingen kryptering av disken igång och visste att den va uppsatt med ext4 så det slutade med att jag tog ut disken och blåste rent NASen (mha nån guide jag hittade) och sen dess har det funkat finfint.
Med det sagt tror jag inte din data är i nån större fara om du inte har raidat diskarna och inte kör nån kryptering på dom. Då BÖR det räcka att ta ut dom, om initiera och stoppa i diskarna igen för att NASen ska fatta att det är nåt på dom.

Skickades från m.sweclockers.com

Kanske slutar med det. Provade att köra rekursiv behörighet 777 på alla mappar och filer som gick. Tyckte den höll sig vid liv lite längre men nu når jag det inte igen...

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Landskrona
Registrerad
Jan 2010
Skrivet av TobiasStockholm:

Kanske slutar med det. Provade att köra rekursiv behörighet 777 på alla mappar och filer som gick. Tyckte den höll sig vid liv lite längre men nu når jag det inte igen...

Varför man inte ska använda chmod 777

http://serverfault.com/questions/364677/why-is-chmod-r-777-de...

Moderkort: Asus P8Z77-V. HDD: SSD Intel 520 120gb, 1TB. CPU: I7 3770k. GPU: ASUS STRIX 1080.
Ram: Corsair Vengence 8gb. Cpukylare: Cooler master 612s. PSU: Corsair 650w. Chassi: Corsair Obsidian 650D.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av qwerty3225:

Jo jag är medveten om det
Trodde dock att jag körde chmod 777 bara på mappen som jag inte kunde ta bort eller flytta, men måste ha kört det på mer av misstag. Nu är jag desperat och bryr mig inte särskilt mycket, bara den vaknar till liv igen

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013
Skrivet av qwerty3225:

Provade just för skojs skull på en VM. Händer inte ett skit mer än att alla får tillgång till ens filer. Har man direktkontakt med NAS:en och är paranoid så kan man ju klippa internetkabeln med en bultsax. Om det däremot är ett problem i systemet och inte ens privata filer så skulle jag ha tagit bort den privata disken, installerat om och satt i den igen. Betydligt snabbare och säkrare.

Grundregeln som alla borde vidta är att system och privata filer aldrig ska ha med varandra att göra.

Jag har alltid en image av senaste /boot samt alla installerade program i en fil med installationsraderna typ sudo apt-get install gparted etc. Behöver systemet installeras om så kör jag en ny installation och monterar /home och /root utan att formatera dom och därefter kör installationsfilen och sedan uppdateringshanteraren i listen. Färdigt på <20 minuter samt alla inställningar/bakgrundsbilder är rätt.

filen "apt-get installs.sh" som ligger i min /home och /root: (filen ska ha 744 (rwxr--r--) eller 700 om man är paranoid (rwx------).

#!/bin/bash # Detta är en fil avsedd för att automatiskt installera program som behövs för # att använda systemet dagligen. Dessa program installeras normalt inte med en # standardsetup. Det är dock rekomendeat att dessa program används då det gör # det lättare att använda systemet överlag. #Updatera paketlistorna sudo apt-get update #systemprogram sudo apt-get installs btrfs-tools sudo apt-get install gnome-raw-thumbnailer sudo apt-get install gpart sudo apt-get install gparted sudo apt-get install hexedit sudo apt-get install gsmartcontrol sudo apt-get install htop sudo apt-get install lm-sensors sudo apt-get install numlockx #grafik sudo apt-get install agave sudo apt-get install rawstudio sudo apt-get install rawtherapee #Spel sudo apt-get install gnome-games sudo apt-get install hatari #Tillbehör sudo apt-get install furiusisomount sudo apt-get install dosbox sudo apt-get install dosemu #Utbildning sudo apt-get install stellarium #Upgradera alla installerade paket. sudo apt-get upgrade

Systemet jag kör är Linux Mint 17.3

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Medlem
Plats
Landskrona
Registrerad
Jan 2010

@OldComputer:

Tanken med inlägget var att eftersom han skrev "Provade att köra rekursiv behörighet 777 på alla mappar och filer som gick"

Plus att han inte kommer åt sin NAS via ssh. Länken beskriver nämligen varför vissa program som t.ex. ssh har en tendens att krasha om man ger vissa filer felaktiga rättigheter.

Moderkort: Asus P8Z77-V. HDD: SSD Intel 520 120gb, 1TB. CPU: I7 3770k. GPU: ASUS STRIX 1080.
Ram: Corsair Vengence 8gb. Cpukylare: Cooler master 612s. PSU: Corsair 650w. Chassi: Corsair Obsidian 650D.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

@qwerty3225: Det var därför jag skrev "Grundregeln som alla borde vidta är att system och privata filer aldrig ska ha med varandra att göra."

Med andra ord, Ditt system kan du ganska lätt återställa, För att skydda dina privata filer måste du ha åtkomst till dom vad som än händer då alla instanser i varje led är en fara när dom havererar, så du måste oavsett ha skydd mot att en hårddisk går sönder, att en raid-kontroller är kompatibel med en annan, att filen går att använda någon annan stans etc. etc. Utan denna säkerhet är informationen värdelös.

Enkelt sagt; Dina privata filer ska helt enkelt vara totalt oberoende av hårdvara, operativsystem eller program. Den dagen något av dessa inte längre är tillgängliga för dig så kommer din fil var noll och intet slumpmässigt innehåll.

Att TS inte kommer åt sin NAS är just ett sådant här problem, det måste gå att läsa ut den från något annat, antingen en backup, flytt av diskar etc. Rent tekniskt har det nu gått så lång tid att en ominstallation och återställning från en backup redan skulle varit klar för länge sedan.

@TobiasStockholm: Efterssom du bor i stockhom skulle jag kunna göra ett besök och se om det går att lösa på plats. Behöver i så fall info om vad datorn kör för något samt antal och hur stora diskar du har på NAS och dator.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005
Skrivet av OldComputer:

@qwerty3225: Det var därför jag skrev "Grundregeln som alla borde vidta är att system och privata filer aldrig ska ha med varandra att göra."

Med andra ord, Ditt system kan du ganska lätt återställa, För att skydda dina privata filer måste du ha åtkomst till dom vad som än händer då alla instanser i varje led är en fara när dom havererar, så du måste oavsett ha skydd mot att en hårddisk går sönder, att en raid-kontroller är kompatibel med en annan, att filen går att använda någon annan stans etc. etc. Utan denna säkerhet är informationen värdelös.

Enkelt sagt; Dina privata filer ska helt enkelt vara totalt oberoende av hårdvara, operativsystem eller program. Den dagen något av dessa inte längre är tillgängliga för dig så kommer din fil var noll och intet slumpmässigt innehåll.

Att TS inte kommer åt sin NAS är just ett sådant här problem, det måste gå att läsa ut den från något annat, antingen en backup, flytt av diskar etc. Rent tekniskt har det nu gått så lång tid att en ominstallation och återställning från en backup redan skulle varit klar för länge sedan.

@TobiasStockholm: Efterssom du bor i stockhom skulle jag kunna göra ett besök och se om det går att lösa på plats. Behöver i så fall info om vad datorn kör för något samt antal och hur stora diskar du har på NAS och dator.

Hej, har fortfarande inte lyckats lösa det. Skulle vara jättetacksam om du ville hjälpa till. NAS:en är en Zyxel NSA-325v2 och har en PC som kör Windows 10 och en Mac som kör OSX. Provade ta ur hårddisken och koppla till PC:n och tänkte flytta över all data till annan extern hårddisk men den får bara upp att den kör software RAID, och kommer inte åt datan trots att jag installerat drivrutiner för att läsa EXT2/3/4. Filsystemet på partitionen som datan ligger på rapporteras som eexxtt44 vilket ser konstigt ut :/

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005

Jag har lyckats få igång den igen. Inaktiverade alla "appar" i den och då slutade den hänga sig. Flyttade över all data till extern hårddisk och nollställde hela NASen. Dock är det ursprungliga problemet tillbaka, att filer jag laddat ner i NASen (med en app i NASen som körs som root) som laddas ner i en mapp som jag tror har behörigheter 755 (inte ändrat detta) men mapparna och filerna som skapas i den mappen kan jag varken flytta eller ta bort från andra datorer (inloggade som användare admin).

Får bara felmeddelande att behörighet saknas... Vill inte göra om samma misstag som förra gången, hur löser jag det på bästa sätt? Antar att det är fel att ge BARA DEN HUVUDMAPPEN behörigheter 777? Bättre att köra chown -R user:group? Vad ska jag äga den som för användare och grupp isf? @OldComputer

De användare som finns är:
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
gopher
ftp
nobody
rpc
rpcuser
nfsnobody
pcap
apache
xfs
ntp
nut
ldap
mysql
password
sysinit
avahi
admin
pc-guest
anonymous-ftp
sshd

Och de grupper som finns är:
root
nobody
nogroup
everyone
avahi
User

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av TobiasStockholm:

Jag har lyckats få igång den igen. Inaktiverade alla "appar" i den och då slutade den hänga sig. Flyttade över all data till extern hårddisk och nollställde hela NASen. Dock är det ursprungliga problemet tillbaka, att filer jag laddat ner i NASen (med en app i NASen som körs som root) som laddas ner i en mapp som jag tror har behörigheter 755 (inte ändrat detta) men mapparna och filerna som skapas i den mappen kan jag varken flytta eller ta bort från andra datorer (inloggade som användare admin).

Får bara felmeddelande att behörighet saknas... Vill inte göra om samma misstag som förra gången, hur löser jag det på bästa sätt? Antar att det är fel att ge BARA DEN HUVUDMAPPEN behörigheter 777? Bättre att köra chown -R user:group? Vad ska jag äga den som för användare och grupp isf? @OldComputer

De användare som finns är:
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
gopher
ftp
nobody
rpc
rpcuser
nfsnobody
pcap
apache
xfs
ntp
nut
ldap
mysql
password
sysinit
avahi
admin
pc-guest
anonymous-ftp
sshd

Och de grupper som finns är:
root
nobody
nogroup
everyone
avahi
User

Att du inte får tillgång till filerna är för att ROOT är en annan användare och du skall inte ha tillgång till dess filer.
Det första du borde fixa är att appen inte körs som root.

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3600Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005

Körde chown -R admin:nogroup på mappen och nu funkar det som det ska (iaf på de befintliga mapparna, vet inte hur det kommer funkar på nya mappar och filer?). Läst att det är så man hellre ska göra istället för att göra dem läs- och skrivbara för alla? Eller har jag gjort något dumt igen?

Vore det bra att göra så att appen inte körs som root? Hur lyckas jag med det isf?

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005

Samma problem med nya mappar, de skapas med behörigheten root:root
Hittade det här som verkar vara samma problem men förstår inte riktigt vad jag ska göra... http://superuser.com/questions/151911/how-to-make-new-file-pe...
Hur ska man lösa detta?

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2005

Okej mer framsteg
Lyckades ändra så att appen kördes som admin istället för root men då gav den en massa felmeddelanden, så den behöver nog köras som root.
Hittade en inställning i appen om UMask för nya filer den skapar, borde väl vara ok att sätta det till 000 istället för 1000 istället för som den står nu? Gör mig inget alls att filerna den skapar är åtkomliga för alla användare (det ska dem ändå vara).

Macbook Pro Retina 13" i5 16GB RAM 256GB SSD
HTPC i5-2500S 65W 8GB RAM 512GB SSD GTX970