Lyckades inte installera linux mint cinnamon

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2013

Lyckades inte installera linux mint cinnamon

Varning för rörig text, ska försöka få ihop allt så kortfattat som möjligt
Dator: Acer asipre tc-105

En usb-sticka på 16gb där jag har windows 10 (32 och 64bit) samt linux mint, överfört/installerat med yumi.

Installation av windows fungerar prima med usb-stickan, live boot med linux mint likaså, även under installation. (Live boota, trycka på "Install linux mint" och följa intruktionerna på skärmen) men efter installation så vill den att jag ska starta om datorn, jag gör så... Och den fastnar på acer loggan :/ Hårddisks led-lampan lyser aldrig.

Hårddisken är på 2TB men google svarade mig med att EXT4 inte ska ha några problem förrän 1EB.

Bios verkar vara rätt inställt också, datorn är köpt på elgiganten så det finns inte direkt många inställningar att ändra på.

Vart är felet tror ni?

Trädvy Permalänk
Medlem
Registrerad
Dec 2002

Om jag förstått dig rätt så har du en usbsticka med både windows10 samt linux mint på? Sen vill du installera båda OSen på datorn för dualboot? Gör så att du installerar windows först med en usb. Sedan har du en annan usb med linux på och installerar det efter. Så borde grub fixa så du kan dualboota. Dock rekommenderar jag att inte köra dualboot från samma disk. Skaffa en annan hdd isf och kör en installation på varje dig. Där du även tar ur disken som du INTE installerar på.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2013
Skrivet av fragwolf:

Om jag förstått dig rätt så har du en usbsticka med både windows10 samt linux mint på? Sen vill du installera båda OSen på datorn för dualboot? Gör så att du installerar windows först med en usb. Sedan har du en annan usb med linux på och installerar det efter. Så borde grub fixa så du kan dualboota. Dock rekommenderar jag att inte köra dualboot från samma disk. Skaffa en annan hdd isf och kör en installation på varje dig. Där du även tar ur disken som du INTE installerar på.

Som vanligt glömmer jag något Vill inte dualboota.

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av Etilaclya:

Som vanligt glömmer jag något Vill inte dualboota.

Och så med andra ord så installerade du linux mint på en annan disk eller installerade du över windows 10?

Edit: HDD lampan lyser inte för datorn kommer aldrig till det skede. Därav inget felmeddelande. Datorn vet inte vad den ska göra då den inte hittar det den behöver på disken. Vill du ha linux mint på datorn bara då? Förstår inte riktigt vad det är du vill när du skriver att installationen gick bra med windows 10 på stickan och sen att du körde installationen av linux men det funkade inte? Samtidigt som du inte vill dualboota?

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2013

Vill enbart ha linux på datorn. Installerade alltså över win10 då det ska BORT.

Vad jag menar med att win10 installationen gick bra är är att jag var tvungen att installera windows på datorn igen då jag testade att installera linux 2 gånger utan resultat

Hade win10 -> installerar över win10 med mint -> misslyckas -> installera windows igen

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

Det verkar vara problem med GRUB, eftersom den verkar fastna vid boot. Har du secure boot på eller av? Har du testat att göra USB-minnet med något annat program? Ex. Rufus eller dd för Windows. Hur är hårddisken partionerad?
Har själv inte riktigt förstått EFI-boot. Men för att boota med EFI måste USB-minnet vara formaterat med FAT32 och du behöver en boot partition på ca 200MB, formaterad med FAT32 med monteringspunkt /boot.

Skickades från m.sweclockers.com

CPU: I5-3570K | RAM: 16GB (4x4GB) Corsair LP | MB: Asus Maximus V Gene Z77 | GPU: MSI Radeon RX580 Armor 8GB | Chassi: FD Arc mini R2 | PSU: CM700V | SSD: Crucial MX300 750GB | Monitor: Yamakasi Catleap 2B Extreme | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av Etilaclya:

Vill enbart ha linux på datorn. Installerade alltså över win10 då det ska BORT.

Vad jag menar med att win10 installationen gick bra är är att jag var tvungen att installera windows på datorn igen då jag testade att installera linux 2 gånger utan resultat

Hade win10 -> installerar över win10 med mint -> misslyckas -> installera windows igen

Ah då e jag med

Skrivet av Lembritt:

Det verkar vara problem med GRUB, eftersom den verkar fastna vid boot. Har du secure boot på eller av? Har du testat att göra USB-minnet med något annat program? Ex. Rufus eller dd för Windows. Hur är hårddisken partionerad?
Har själv inte riktigt förstått EFI-boot. Men för att boota med EFI måste USB-minnet vara formaterat med FAT32 och du behöver en boot partition på ca 200MB, formaterad med FAT32 med monteringspunkt /boot.

Skickades från m.sweclockers.com

Secure boot eller liknande är mer troligt problem. Då han kunde boota live cd utan problem samt genomföra installationen så är det knappast fel på stickan.

Måste man inte inaktivera UEFI för att kunna installera linux? Eller har de ändrat på det? Eller är det linuxdisten själv som fixar det? Var ju problem med att man inte kunde installera linux i början pga det.

Får du möljlighet att välja vart han ska installera GRUB? Ellter sköter installationen det helt auto?

Prova detta: https://help.ubuntu.com/community/RecoveringUbuntuAfterInstal...
Eller http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2...

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Registrerad
Aug 2016

Har du EFI-boot på bioset så är det viktigt att USB/DVD-skivan sitter ansluten i maskinen _innan_ du slår på strömmen. Funkar det inte med USB-pinne (de _kan_ krångla i bios-läge) så är alternativet att prova köra på bränd DVD med linuxdistrubitionen.

Nu var det ett tag sedan jag strulade med detta men har för mig att _i_ BIOS måste du sedan välja uppstartsalternativ att det är linux-managern (från DVD/USB) du skall starta ifrån då du plötsligt har flera bootmanager-alternativ att välja mellan (varav en är för befintlig win10)

Har du inte haft USB/DVD insatt vid spänningspåslag så kommer inte dessa alternativa bootmanager upp över huvud taget i BIOS!!. - Detta tog mig ett tag att lura ut och det står väldigt lite om att mediat som man skall installera ifrån måste sitta i datorn _innan_ man slår på strömmen...

EFI-Bioset går nämligen igenom alla enheterna först innan något syns på skärmen vid strömpåslag och uppstart vilka enheter som är 'tillåtna' att installera 'OS' och 'manager' med hjälp av kryptonycklar och certifikat innan du ens kommer till boot-alternativ i Bioset (de stora linuxdistrubitionerna _har_ giltiga certifikat för EFI-start - något som Microsoft faktiskt har 'gett' till linux-världen, men samtidigt finns det också HW-plattformar där möjligheter till alternativa OS är helspärrat mha. EFI som tex. vissa windowsbaserade plattor mm.)

Gör du inte det utan skickar in USB/DVD efter start (och bios satt i compatible/legacy-läge för att över huvudtaget få den att bota från CD-rom som första alternativ) så får du aldrig upp de alternativen som gäller för EFI-baserade boot av linuxdistrubitionen och installation, utan linux installerar sig som om det var bios-start med partitionstabell på traditionellt sätt, men bioset i din dator vid nästa omstart tittar aldrig där över huvud taget vid start och därför så skiter det sig!!

Förmodligen har du också windows satt som default bootmanager inne i BIOS:et då dess bootmanager är kvar i EFI-partitionen även om du har tagit bort hela windows-partitionen och det hela hamnar blint.

Det här med EFI-boot och GPT-partitioner strular till en hel del då det är ganska nytt och obekant för de flesta och utanför kontrollen för OS-skaparna och man kanske måste läsa lite om det mha. google kanske specifikt för din moderkort innan man får linux-installation att fungera på en modernare dator med EFI-BIOS.

Dessutom kan beteendet varierar beroende vilken BIOS-version man har och om man kör BIOS:t i EFI-läge eller med denna avslagen i 'compatible/legacy'-läge (det sistnämnda fick jag aldrig att fungera mer än att man kunde installera linux på traditionellt sätt men ej boota från denna på HD:n efter installation omstart senare då den fortfarande envisas att starta enligt EFI...)

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2013

Orkade inte med skiten så jag kör Windows istället... INTE men det är då nära... Mitt tålamod är inte direkt det bästa :/

Lyckades installera det med hjälp av en dvd skiva! Så det har löst sig men detta...

Jag har googlat och försökt ett antal gånger men igen, utan resultat. CSGO startar fint men jag ser den aldrig på skärmen.. Men enligt steam så körs den :s

Nu till ljudet. Jag har ett externt ljudkort (asus xonar U7) ljud är 50/50 då systemljud, youtube etc fungerar men vid Skype/qtox så hörs inget (Felet är hos mig, det är testat och bekräftat :).. Mikrofonen fungerar inte heller...

Ska försöka mer imorgon och all hjälp uppskattas! Nu ska jag sova..

Ifall någon inte skulle förstå min ironi i början så.. Jag kör fortfarande Linux.