SSD Secure Erase via hdparm funkar inte!

Permalänk
Medlem

SSD Secure Erase via hdparm funkar inte!

hejj
försöker följa denna guide för att säkerradera min crucial ssd:
https://ata.wiki.kernel.org/index.php/ATA_Secure_Erase

när jag kör "hdparm -I /dev/X"
så får jag allt utom Security status.

jag kör vidare med " hdparm --user-master u --security-erase XXXXX /dev/X"

och då får jag:
"Issuing SECURITY_SET_PASS command, password="XXXXX", user=user, mode=high
SECURITY_SET_PASS: Input/output error"

testar detta : "sudo hdparm --user-master u --security-erase NULL /dev/X"
får:
"/dev/X permission denied"

har testat köra secure erase med hjälp av PartedMagic/HDDerase, men disken verkar inte stöda säker radering.

vad kan jag göra isf?
tacksam för svar

Permalänk
Medlem

Du har io error som resultat på första, sleepa datorn och väck, kör,det kommandot igen så ska du se att det tar. Händer varje gång

Alternativt om du har den på USB så ta loss och sätt i igen, funkar också.

Permalänk
Avstängd
Skrivet av AdAm25:

testar detta : "sudo hdparm --user-master u --security-erase NULL /dev/X"
får:
"/dev/X permission denied"

sudo räcker inte alltid, du måste
"sudo su"
och köra kommandot som superuser...

som exempel:
sudo hdparm --user-master u --security-erase NULL /dev/X funkar inte,
men
sudo su
hdparm --user-master u --security-erase NULL /dev/X kanske funkar...

Permalänk
Medlem

Det är inte ett sudo problem denna gång.

Permalänk
Medlem

tack för era svar, tyvärr har det inte hjälpt än, "sudo su" och köra kommandot efter viloläge ger samma i/o error