[Ubuntu 14.04] Problem med Network Manager (tror jag?)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013

[Ubuntu 14.04] Problem med Network Manager (tror jag?)

Hej!

Lite kort:

Jag har en extern enhet vars IP-adress är 192.168.0.10 och Port Number är 10940. Denna enhet vill jag koppla till min dator via Ethernet.

Min dator har en Ethernet port som enligt ifconfig är eth0. Jag har konfigurerat denna genom att i /etc/network/interfaces lägga till följande rader (allt annat är bortmarkerat):

auto eth0 iface eth0 inet manual address 192.168.0.12 netmask 255.255.255.0 auto eth0:0 iface eth0:0 inet static address 192.168.0.15 netmask 255.255.255.0

Tanken är att enheten ska kommunicera med datorn via eth0:0 (endast en väg - datorn skickar inget till enheten utan mottar endast data).

För att ta emot data från externa enheten skriver jag i terminalen:

sudo ifconfig eth0:0 192.168.0.15 up

Detta fungerar temporärt - efter allt mellan 10 sekunder till 5 minuter så slutar datorn att ta emot data från externa enheten och jag är tvungen att köra samma kommando ovan igen, och problemet upprepas om och om igen (allt mellan 10 sek - 5 min). Jag misstänker att det är Network Manager som strular och "flaggar ner" eth0:0 av någon anledning men har inte kommit fram till hur jag ska lösa problemet.

Datorn i fråga har även enl. ifconfig wlan0 och lo, och jag har testat att stänga av wlan0 (har en fysisk knapp för WiFi på datorn som sätter på/stänger av WiFi-kortet) men problemet ovan kvarstår. Jag har även testat att köra med två olika trådlösa nätverk (ett med 192.168.0.xxx och ett annat med 192.168.1.xxx) men har samma problem.

Har ni något tips på hur jag kan lösa detta problem, d.v.s. hur jag kan få eth0:0 att vara "flaggad upp" konstant?

Tack för hjälpen, och om det är något jag missat att lägga till så är det bara att fråga!

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av Icte:

Hej!

Lite kort:

Jag har en extern enhet vars IP-adress är 192.168.0.10 och Port Number är 10940. Denna enhet vill jag koppla till min dator via Ethernet.

Min dator har en Ethernet port som enligt ifconfig är eth0. Jag har konfigurerat denna genom att i /etc/network/interfaces lägga till följande rader (allt annat är bortmarkerat):

auto eth0 iface eth0 inet manual address 192.168.0.12 netmask 255.255.255.0 auto eth0:0 iface eth0:0 inet static address 192.168.0.15 netmask 255.255.255.0

Tanken är att enheten ska kommunicera med datorn via eth0:0 (endast en väg - datorn skickar inget till enheten utan mottar endast data).

För att ta emot data från externa enheten skriver jag i terminalen:

sudo ifconfig eth0:0 192.168.0.15 up

Detta fungerar temporärt - efter allt mellan 10 sekunder till 5 minuter så slutar datorn att ta emot data från externa enheten och jag är tvungen att köra samma kommando ovan igen, och problemet upprepas om och om igen (allt mellan 10 sek - 5 min). Jag misstänker att det är Network Manager som strular och "flaggar ner" eth0:0 av någon anledning men har inte kommit fram till hur jag ska lösa problemet.

Datorn i fråga har även enl. ifconfig wlan0 och lo, och jag har testat att stänga av wlan0 (har en fysisk knapp för WiFi på datorn som sätter på/stänger av WiFi-kortet) men problemet ovan kvarstår. Jag har även testat att köra med två olika trådlösa nätverk (ett med 192.168.0.xxx och ett annat med 192.168.1.xxx) men har samma problem.

Har ni något tips på hur jag kan lösa detta problem, d.v.s. hur jag kan få eth0:0 att vara "flaggad upp" konstant?

Tack för hjälpen, och om det är något jag missat att lägga till så är det bara att fråga!

"sudo ifconfig eth0:0 192.168.0.15 up" aktiverar bara interfacet, Kolla i loggarna vad som tar ner den igen om du måste aktivera det efter några minuter.

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3466Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Commander:

"sudo ifconfig eth0:0 192.168.0.15 up" aktiverar bara interfacet, Kolla i loggarna vad som tar ner den igen om du måste aktivera det efter några minuter.

Jag borde ha nämnt att jag är extremt okunnig med allt som har att göra med just "networking". Var kan jag hitta loggarna?

EDIT: Är det /var/log/syslog du vill att jag ska kolla i?

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007
Skrivet av Icte:

Jag borde ha nämnt att jag är extremt okunnig med allt som har att göra med just "networking". Var kan jag hitta loggarna?

EDIT: Är det /var/log/syslog du vill att jag ska kolla i?

14.04 är fortfarande utan systemd om jag minns rätt. Då kan du kolla dmseg, alternativt skriva dmesg --follow i terminalen för att se senaste loggar och vänta på tills den slutar att svara för att se om något har skrivits.

Sedan är jag något tveksam till, eth0:0 om det är giltigt.

Vad är meningen med denna setup om jag får fråga?

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3466Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Commander:

14.04 är fortfarande utan systemd om jag minns rätt. Då kan du kolla dmseg, alternativt skriva dmesg --follow i terminalen för att se senaste loggar och vänta på tills den slutar att svara för att se om något har skrivits.

Ska göra detta (blir imorgon då jag inte har tillgång till enheten idag)!

Öppnade /var/log/syslog och har hittat dessa meddelanden vilket sker under perioden connect->disconnect av externa enheten:

NetworkManager[1000]: <info> Auto-activating connection 'Wired connection 1'.
NetworkManager[1000]: <info> Activation (eth0) starting connection 'Wired connection 1'
NetworkManager[1000]: <info> (eth0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[1000]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[1000]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
NetworkManager[1000]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[1000]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[1000]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
NetworkManager[1000]: <info> (eth0): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[1000]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
NetworkManager[1000]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager[1000]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[1000]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
NetworkManager[1000]: <info> (eth0): device state change: config -> ip-config (reason 'none') [50 70 0]
NetworkManager[1000]: <info> Activation (eth0) Beginning DHCPv4 transaction (timeout in 45 seconds)
NetworkManager[1000]: <info> dhclient started with pid 7363
NetworkManager[1000]: <info> Activation (eth0) Beginning IP6 addrconf.
NetworkManager[1000]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
avahi-daemon[748]: Withdrawing address record for fe80::f2de:f1ff:fed3:ddd7 on eth0.
avahi-daemon[748]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::f2de:f1ff:fed3:ddd7.
avahi-daemon[748]: Interface eth0.IPv6 no longer relevant for mDNS.
dhclient: Internet Systems Consortium DHCP Client 4.2.4
dhclient: Copyright 2004-2012 Internet Systems Consortium.
dhclient: All rights reserved.
dhclient: For info, please visit https://www.isc.org/software/dhcp/
dhclient:
NetworkManager[1000]: <info> (eth0): DHCPv4 state changed nbi -> preinit
dhclient: Listening on LPF/eth0/f0:de:f1:d3:dd:d7
dhclient: Sending on LPF/eth0/f0:de:f1:d3:dd:d7
dhclient: Sending on Socket/fallback
dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3 (xid=0x1f1e717)
avahi-daemon[748]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::f2de:f1ff:fed3:ddd7.
avahi-daemon[748]: New relevant interface eth0.IPv6 for mDNS.
avahi-daemon[748]: Registering new address record for fe80::f2de:f1ff:fed3:ddd7 on eth0.*.
dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8 (xid=0x1f1e717)
avahi-daemon[748]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.0.15.
avahi-daemon[748]: New relevant interface eth0.IPv4 for mDNS.
avahi-daemon[748]: Registering new address record for 192.168.0.15 on eth0.IPv4.
dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12 (xid=0x1f1e717)
NetworkManager[1000]: <info> (eth0): IP6 addrconf timed out or failed.
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21 (xid=0x1f1e717)
dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 20 (xid=0x1f1e717)
NetworkManager[1000]: <warn> (eth0): DHCPv4 request timed out.
NetworkManager[1000]: <info> (eth0): canceled DHCP transaction, DHCP client pid 7363
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) started...
NetworkManager[1000]: <info> (eth0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
NetworkManager[1000]: <warn> Activation (eth0) failed for connection 'Wired connection 1'
NetworkManager[1000]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
NetworkManager[1000]: <info> (eth0): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[1000]: <info> (eth0): deactivating device (reason 'none') [0]
avahi-daemon[748]: Withdrawing address record for 192.168.0.15 on eth0.
avahi-daemon[748]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.0.15.
avahi-daemon[748]: Interface eth0.IPv4 no longer relevant for mDNS.
NetworkManager[1000]: <info> Auto-activating connection 'Wired connection 1'.
NetworkManager[1000]: <info> Activation (eth0) starting connection 'Wired connection 1'

Dold text

Säger detta något dig?

Skrivet av Commander:

Sedan är jag något tveksam till, eth0:0 om det är giltigt.

Vad är meningen med denna setup om jag får fråga?

Om jag har förstått det rätt är eth0:0 en virtuell network interface på eth0 vilket man kan använda sig av för kommunikation mellan enheten och datorn.

Meningen med denna setup är att få data från externa enheten, vilket är en typ av laser som kommunicerar via Ethernet (hade föredragit USB men inte möjligt i detta fall) till en dator och datorn omvandlar sedan strömmen av datan till visuell information. Strömmen av datan avbryts allt mellan 10 sek - 5 min (som jag specificerade ovan) för att sedan fortsätta så fort jag "flaggat upp" eth0:0.

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||