ISPConfig - Standardwebben byts ut mot senaste skapade sajt på IP

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2004

ISPConfig - Standardwebben byts ut mot senaste skapade sajt på IP

Ny märklig sak med ISPConfig och jag antar något felaktigt har hänt. De övriga servrarna med perfect server install funkar fint men den som strular på med övrigt har också ett annat problem.

Då man går in på serverns IP så hamnar man istället för serverns standard index.html på den senaste sajen som lades till. Hur löser vi detta?

Trädvy Permalänk
Medlem
Registrerad
Jul 2004

För det går på hostheaders? Testa en host isf.

CPU: I7 4770K Grafik: Poseidon Platinum GeForce GTX 980Ti Moderkort: Asus Maximus VI Hero Z87 RAM: 16Gb Corsair Dominator Platinum CL9 Nätagg: Corsair HX1050 Gold SSD: Corsair Force GT 240Gb SSHD: Seagate Desktop 4TB Låda: Corsair Graphite 600T

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2004

@Gurk: ? :/

Edit: I 000-default.conf har jag detta (se nedan). Det ska ju leda all trafik som inte är definierad i annan vhost vidare till standardmappen där jag då har serverns standard index.php. (Detta funkar fint på https men inte http.) Även blir det så att de kunder som inte väljer serverns IP inne i IPSConfig utan väljer Wildcard/* hamnar på senaste annan klient.

<VirtualHost *:80> # The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request's Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName www.example.com ServerAdmin webmaster@localhost DocumentRoot /var/www/html # Available loglevels: trace8, ..., trace1, debug, info, notice, warn, # error, crit, alert, emerg. # It is also possible to configure the loglevel for particular # modules, e.g. #LogLevel info ssl:warn ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined # For most configuration files from conf-available/, which are # enabled or disabled at a global level, it is possible to # include a line for only one particular virtual host. For example the # following line enables the CGI configuration for this host only # after it has been globally disabled with "a2disconf". #Include conf-available/serve-cgi-bin.conf </VirtualHost> # vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Trädvy Permalänk
Medlem
Registrerad
Jul 2004
Skrivet av -=*ThE_cRoW*=-:

Jag kanske missförstod frågan. Det såg ut som om du hade host headers för webbsidorna men anslöt med en ip-adress, då får du liknande fel.

CPU: I7 4770K Grafik: Poseidon Platinum GeForce GTX 980Ti Moderkort: Asus Maximus VI Hero Z87 RAM: 16Gb Corsair Dominator Platinum CL9 Nätagg: Corsair HX1050 Gold SSD: Corsair Force GT 240Gb SSHD: Seagate Desktop 4TB Låda: Corsair Graphite 600T

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2004

@Gurk: se min edit ovan och förklara vad du menar. Lite stressad så huvudet jobbar sakta men det du säger är rena grekiskan för mig så förklara gärna hela vägen

Edit: Jag löste mina problem med att skriva <VirtualHost 10.1.0.23:80> istället för * då det är serverns lokala IP.

Vet inte varför det blev så här men antagligen hade någon av klienterna valt serverns interna IP istället för standard * och bollen var i rullning.

Trädvy Permalänk
Medlem
Registrerad
Jul 2004
Skrivet av -=*ThE_cRoW*=-:

@Gurk: se min edit ovan och förklara vad du menar. Lite stressad så huvudet jobbar sakta men det du säger är rena grekiskan för mig så förklara gärna hela vägen

Edit: Jag löste mina problem med att skriva <VirtualHost 10.1.0.23:80> istället för * då det är serverns lokala IP.

Vet inte varför det blev så här men antagligen hade någon av klienterna valt serverns interna IP istället för standard * och bollen var i rullning.

Gött att det ordnade sig, men det är åt det hållet jag svamlade... man har flera webbsidor på samma ip-adress, men för att komma till rätt sida måste webbläsaren ha namnet på sidan den ska till med sig. Det är andemeningen med det som det står i under avsnittet "Virtual Host *:80" där uppe. Surfar man bara på ip-adressen så kan du få upp vilken sida som helst (mer eller mindre random) eller default-sidan för servern. Därav min, inte helt värdelösa, gissning på felet och grejen tekniker hasplar ur sig är virtual hosts eller host headers (för det är i headern på http-requesten som hostnamnet står).

CPU: I7 4770K Grafik: Poseidon Platinum GeForce GTX 980Ti Moderkort: Asus Maximus VI Hero Z87 RAM: 16Gb Corsair Dominator Platinum CL9 Nätagg: Corsair HX1050 Gold SSD: Corsair Force GT 240Gb SSHD: Seagate Desktop 4TB Låda: Corsair Graphite 600T

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2004

@Gurk: jag förstår och va ju bara jag som inte förstod vad du menade.

Kanske kan du också hjälpa mig med den här tråden? http://www.sweclockers.com/forum/trad/1449631-proftpd-konfigu...