Raspberry pi 3, brus i ljudet

Trädvy Permalänk
Medlem
Plats
Där borta
Registrerad
Jan 2009

Raspberry pi 3, brus i ljudet

Hejsan!

Jag har en Raspberry pi 3 som kör RetroPie, i testfasen använde jag en HDMI-skärm med inbyggda högtalare och då fungerade ljudet klanderfritt. Det var en skärm ej lämplig till min RetroPie så jag införskaffade en äldre DVI/VGA skärm och ett par enkla högtalare som drivs genom USB och använder 3.5mm kontakt för ljudet.
Det första jag gjorde var att skruva isär högtalarna för att kunna montera dem i mitt chassi men märker direkt ett konstant bakgrundsbrus i ljudet, 'noise'. Jag var rädd för att jag hade förstört något när jag demonterade högtalarna så jag köpte ett annat par snarlika högtalare i en annan butik.
Exakt samma brus här!

När jag googlade så verkar det vara "välkänt" om 3.5 porten används för ljud. Lösningen var att lägga till "disable_audio_dither=1" i config.txt. Det hjälpte inte alls.

Trött som jag var på detta så köpte jag en HDMI->VGA adapter men inbyggd 3.5mm kontakt för att få ljudet genom HDMI porten. Trots det så finns samma brus här.

Vad ska jag göra?

Edit:
Bruset är väldigt påtagligt och huvudvärksframkallande.

Mvh

Trädvy Permalänk
Medlem
Registrerad
Apr 2014

Hur ser bygget ut? Tänker mest om det kan komma störningar från annan elektronik.

Chassi: Fractal Design Define XL R2 Titanium
Grafikkort: ASUS GeForce GTX 660Ti 2GB
Nätaggregat: Silver Power SP-SS500 500W
CPU: Intel Core i7-2700K Processor 3500 MHZ
Moderkort: ASUS ROG MAXIMUS V FORMULA

Trädvy Permalänk
Medlem
Plats
Isla de Muerta
Registrerad
Okt 2009

Du har inte köpt en billig RPI3 på ebay då ?

Jag mins när jag köpte min RPI1, man kunde se på färgen på komponenterna var dom var tillverkade.
Vissa hade 3.5 Brus och vissa inte.

Testade med min RPI3, det brusar i mitt 3.5 utag med så du är inte unik.
HDMI ger mig dock kristallklart ljud till film och musik.

CPU: 1600x @ 4Ghz
RAM: 16GB
GPU: 1070 TI

Extremt prispressat monster som uppnår mina krav. Allt är köpt på rea

Trädvy Permalänk
Medlem
Plats
Långtbortistan
Registrerad
Mar 2007

RPi har en väldigt enkel DAC mellan CPUn och hörlursutgången så jag är inte förvånad att ljudet är kass. Lite mer överraskande är att ljudet är kass även med en HDMI/VGA-adapter, det hade jag inte väntat mig.

Att det låter bra om ljudet går över HDMI beror på att det är en digital signal som D/A-omvandlas i din TVs DAC som är många gånger bättre än den som sitter i RPi.

Edit: har du provat med ett annat nätaggregat? Ojämn ström kan orsaka många konstiga problem.
Skickades från m.sweclockers.com

Det finns bara två sorters hårddiskar: de som har gått sönder och de som skall gå sönder.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Är det pien eller de aktiva högtalarna som alstrar brus ? billiga prylar brukar alltid ge ett hörbart brus men det ska ju inte vara så starkt att det är störande.
Om du vill ha seriöst bra ljud från pien så finns det lösningar på det också för det går att hänga på en seriös ljudkrets och även förstärkare så du kan driva normala högtalare med "bygget" du kan ju kolla på kretsarna härifrån > https://www.hifiberry.com/

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Gotland
Registrerad
Jan 2008

Det är känt att retropie ger missljud över 3.5mm. De rekommenderar själva att man inte ska använda 3.5mm. det verkar vara en bugg i retropie och jag vet inte hur högt det ligger på deras priolista att lösa det.
Det här kan vara en lösning:
http://www.ebay.com/bhp/hdmi-audio-extractor
Jag har inte själv testat dem, men då går du runt problemet.

EDIT:
Alternativt använda ett usb ljudkort:
http://www.ebay.com/bhp/usb-sound-card

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Feb 2014
Skrivet av mrqaffe:

Om du vill ha seriöst bra ljud från pien så finns det lösningar på det också för det går att hänga på en seriös ljudkrets och även förstärkare så du kan driva normala högtalare med "bygget" du kan ju kolla på kretsarna härifrån > https://www.hifiberry.com/

Jag köpte mig en HiFiberry nyligen och måste säga att det funkar mycket bra! Kopplar hemmabiosystemet till den med optisk kabel (mitt system är gammal och har inte en phono/RCA-utgång) och sen HDMI till skärmen.

Trädvy Permalänk
Medlem
Registrerad
Nov 2016

@Igelkotten Igge:

Har du kollat på denna lösning:

https://forum.libreelec.tv/thread-388.html

???

^^^ Ovanstående har fungerat klockrent för mig iaf, ifrån att analog-output var brusigt i alla lägen utom 90% utmatning och över till att vara riktigt rent (för en icke audiofil som mig) i de lägen som jag bryr mig om i alla fall.