Behöver hjälp med SSH via Wireless Bridge

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013

Behöver hjälp med SSH via Wireless Bridge

Hej!

Försöker hålla mig kort som möjligt:

Har ett litet projekt på gång där vi har följande setup:

Dator1 (kopplad till Router 1 via WiFi) <-> Router1 (kopplat mot Internet) <-> Router2 (inställd i Wireless Bridge mode till Router1) <-> Dator2 (kopplad till Router2 via Ethernet)

Jag har alla enheters IP adresser och kan via denna setup ping:a Dator2 från Dator1 (och vice versa).

Dock har jag INTE möjlighet att köra SSH från Dator1 till Dator2 (eller åt andra hållet). D.v.s. kommandot

ssh -X Dator2_user@Dator2_IP

fungerar inte utan jag får felmeddelandet:

ssh: connect to host Dator2_IP port 22: Connection refused

där Dator2_IP är IP-adressen för Dator2.

Både datorerna kör f.ö. med Ubuntu 14.04 och routerna är av modellerna Linksys WRT1200AC med senaste firmware-uppdateringarna.

Har ni någon lösning på detta?

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Kan datorerna prata mha SSH på port 22 om de sitter anslutna till en och samma switch (inte trådlöst)? Då vet du om det är ditt nätverk eller dina datorer som bråkar.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av hasenfrasen:

Kan datorerna prata mha SSH på port 22 om de sitter anslutna till en och samma switch (inte trådlöst)? Då vet du om det är ditt nätverk eller dina datorer som bråkar.

Ja det fungerar bra. Kopplar jag både datorerna till samma router så fungerar det utan problem.

Det är just något med Wireless Bridge mode som orsakar problemet (tror jag) och jag antar att man med SSH måste passera denna också innan man kan gå vidare, eller?

EDIT: Jag kan f.ö. ping:a Dator2 från Dator1 (och vice versa) via detta nätverk och får svar tillbaka.

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Snabb fråga bara har du konfigurerat SSH filen "/etc/ssh/sshd_config"?

Fractal Design Define C TG || ASUS ROG STRIX B350-F Gaming || Ryzen 5 1600@3.8Mhz || Noctua NH-D15 || G.Skill 16GB 3200MHz CL14 Flare X || Asus GTX 1070 Dual 8GB || SSD 180GB || HDD 5TB || HDD 3TB || Corsair RM750x || Acer 27" XF270HUA

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2003

För att gå via en router (om den assignar lokala ip osv) måste du sätta "GatewayPorts yes" i /etc/ssh/sshd_config, annars fungerar inte ssh.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av Icte:

Ja det fungerar bra. Kopplar jag både datorerna till samma router så fungerar det utan problem.

Det är just något med Wireless Bridge mode som orsakar problemet (tror jag) och jag antar att man med SSH måste passera denna också innan man kan gå vidare, eller?

EDIT: Jag kan f.ö. ping:a Dator2 från Dator1 (och vice versa) via detta nätverk och får svar tillbaka.

Fungerar annan trafik?
Sitter det någon brandvägg i routrarna/servern? Ligger de i samma lager2-nät? (dvs. delar maskinerna samma nätverk, ex. 192.168.1.0/24?) Kör du NAT? Har du typ fail2ban aktiverat (kolla så det inte råkar vara blockat)?

WS: Bärbar workstation, 2 * Dell U2412M
HTPC: Intel NUC, Canton GLE 496, Yamaha RV-A830, Sanyo PLV-Z700
Server: Intel Xeon E3-1240@3.4 GHz, ESXi, 32GB RAM, 8*2TB RAID-Z2 + SSD-cache
Slösurf: MacBook Air 11,6", Samsung S8
Kamera: Canon EOS 5DII + 1DIII, Canon 100/2.8 Macro, Canon 70-200/2.8L, Canon 24-70/2.8L

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av nosnahoj:

För att gå via en router (om den assignar lokala ip osv) måste du sätta "GatewayPorts yes" i /etc/ssh/sshd_config, annars fungerar inte ssh.

Eh, va? Det är bara om du ska komma åt port-forwarding från andra maskiner som du behöver sätta det. Läs här: http://www.snailbook.com/faq/gatewayports.auto.html

WS: Bärbar workstation, 2 * Dell U2412M
HTPC: Intel NUC, Canton GLE 496, Yamaha RV-A830, Sanyo PLV-Z700
Server: Intel Xeon E3-1240@3.4 GHz, ESXi, 32GB RAM, 8*2TB RAID-Z2 + SSD-cache
Slösurf: MacBook Air 11,6", Samsung S8
Kamera: Canon EOS 5DII + 1DIII, Canon 100/2.8 Macro, Canon 70-200/2.8L, Canon 24-70/2.8L

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Duktig:

Snabb fråga bara har du konfigurerat SSH filen "/etc/ssh/sshd_config"?

Nej den är inte konfigurerad på varken av datorerna.

Skrivet av nosnahoj:

För att gå via en router (om den assignar lokala ip osv) måste du sätta "GatewayPorts yes" i /etc/ssh/sshd_config, annars fungerar inte ssh.

SSH fungerar utan någon konfiguration för mig annars till andra enheter? Det är endast via Wireless Bridge det inte gör det - kopplar jag Dator1 och Dator2 till samma router så går det att SSH:a utan problem.

Skrivet av zyberzero:

Fungerar annan trafik?
Sitter det någon brandvägg i routrarna/servern? Ligger de i samma lager2-nät? (dvs. delar maskinerna samma nätverk, ex. 192.168.1.0/24?) Kör du NAT? Har du typ fail2ban aktiverat (kolla så det inte råkar vara blockat)?

Brandväggen är påslagen i Router1 men Router2 har stängt ner sin och alla övriga inställningar förutom Wireless Bridge mode. NAT är påslagen i Router1 (ej i Router2), hittar inget om fail2ban men jag har mixtrat ytterst lite med inställningarna i båda routrarna och de är nästintill i Factory Default settings just nu (förutom att Router2 är satt i Wireless Bridge mode).

EDIT: Ja, all annan trafik fungerar. Har access till Internet från Dator2 också.

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Maj 2013

Vad ger:

ssh -vvv -X Dator2_user@Dator2_IP

Vad säger:

netstat -ntp --listen

på Dator2_IP?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Aene:

Vad ger:

ssh -vvv -X Dator2_user@Dator2_IP

Detta ger:

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 10.188.18.103 [10.188.18.103] port 22. debug1: connect to address 10.188.18.103 port 22: Connection refused ssh: connect to host 10.188.18.103 port 22: Connection refused

(10.188.18.103 är IP adressen för Dator2).

Skrivet av Aene:

Vad säger:

netstat -ntp --listen

på Dator2_IP?

Detta ger:

Active Internet connections (only servers) Proto Recv-Q Send-Q Local Adress || Foreign Address || State || PID/Programme name tcp || 0 || 0 127.0.1.1:53 || 0.0.0.0:* || LISTEN || 1501/dnsmasq tcp || 0 || 0 127.0.0.1:631 || 0.0.0.0:* || LISTEN || 1700/cupsd tcp6 || 0 || 0 ::1:631 || :::* || LISTEN || 1700/cupsd

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
Höör
Registrerad
Jun 2002

Det mest sannolika är att router 2 inte är korrekt konfigurerad eller att det är buggar i mjukvaran på den. Vad är det för routrar (märke/modell/firmware)?

Citera mig för svar.
Arch Linux

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Maj 2013

Active Internet connections (only servers) Proto Recv-Q Send-Q Local Adress || Foreign Address || State || PID/Programme name tcp || 0 || 0 127.0.1.1:53 || 0.0.0.0:* || LISTEN || 1501/dnsmasq tcp || 0 || 0 127.0.0.1:631 || 0.0.0.0:* || LISTEN || 1700/cupsd tcp6 || 0 || 0 ::1:631 || :::* || LISTEN || 1700/cupsd

Skumt, då verkar ju inte sshd ligga och lyssna på port 22 på Dator2_IP. Är sshd verkligen igång? Är den inte det skulle det förklara varför du får connection refused.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av Icte:

Brandväggen är påslagen i Router1 men Router2 har stängt ner sin och alla övriga inställningar förutom Wireless Bridge mode. NAT är påslagen i Router1 (ej i Router2), hittar inget om fail2ban men jag har mixtrat ytterst lite med inställningarna i båda routrarna och de är nästintill i Factory Default settings just nu (förutom att Router2 är satt i Wireless Bridge mode).

EDIT: Ja, all annan trafik fungerar. Har access till Internet från Dator2 också.

Vad har maskinerna för nätmask + IP? Tillhör de samma Lager2 nät? (dvs, använder de samma default-GW, DHCP-server etc?).

Har du någon brandvägg i servern? Typ iptables eller pf?

Fail2ban är en mjukvara du kan installera på din SSH-server för att blockera bruteforce-attacker.

WS: Bärbar workstation, 2 * Dell U2412M
HTPC: Intel NUC, Canton GLE 496, Yamaha RV-A830, Sanyo PLV-Z700
Server: Intel Xeon E3-1240@3.4 GHz, ESXi, 32GB RAM, 8*2TB RAID-Z2 + SSD-cache
Slösurf: MacBook Air 11,6", Samsung S8
Kamera: Canon EOS 5DII + 1DIII, Canon 100/2.8 Macro, Canon 70-200/2.8L, Canon 24-70/2.8L

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Dimman:

Det mest sannolika är att router 2 inte är korrekt konfigurerad eller att det är buggar i mjukvaran på den. Vad är det för routrar (märke/modell/firmware)?

Båda routrarna är av modellen Linksys WRT1200AC med de absolut senaste firmware uppdateringarna (kör ej någon 3:e parts firmware utan den som man får från Linksys via Firmware Update i routerns programvara).

Skrivet av Aene:

Active Internet connections (only servers) Proto Recv-Q Send-Q Local Adress || Foreign Address || State || PID/Programme name tcp || 0 || 0 127.0.1.1:53 || 0.0.0.0:* || LISTEN || 1501/dnsmasq tcp || 0 || 0 127.0.0.1:631 || 0.0.0.0:* || LISTEN || 1700/cupsd tcp6 || 0 || 0 ::1:631 || :::* || LISTEN || 1700/cupsd

Skumt, då verkar ju inte sshd ligga och lyssna på port 22 på Dator2_IP. Är sshd verkligen igång? Är den inte det skulle det förklara varför du får connection refused.

Detta kan mycket rimligt förklara problemet. SSHD är inget jag har mixtrst med - är det något speciellt jag bör sätts på i just Dator2?

Skrivet av zyberzero:

Vad har maskinerna för nätmask + IP? Tillhör de samma Lager2 nät? (dvs, använder de samma default-GW, DHCP-server etc?).

Har du någon brandvägg i servern? Typ iptables eller pf?

Fail2ban är en mjukvara du kan installera på din SSH-server för att blockera bruteforce-attacker.

Oj jävlar, detta var lite överkurs. Jag är inte super insatt i nätverk och routrar men ska se om jag kan svara på allt:

*Ska kolla upp nätmask och IP imorgon, återkommer med detta.
*Jag tror att de ska använda samma DHCP server. Det är inget jag direkt ställt in utan det enda som gjorts är.det jag beskrev i mitt första inlägg. Hur kollar jag upp detta?
*Det är ingen server utan båda datorerna kör med desktop versionen av Ubuntu - tanken är att Dator2 kommer att brukas enbart via SSH för att slippa använda skärm + tangentbord till denna då den och Router2 sitter på en mobil plattform. Båda datorerna innehåller en nära fräsch installation av Desktop Ubuntu med senaste uppdateringarna via apt-get installerade - iptables kan då vara påslaget om det är så default.
*Då hänger jag med! Nej, fail2ban har inte installerats.

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Om du inte har konfigurerat något i sshd_config, skulle jag börja där. Öppna sshd_config som sudo med valfria texteditor på följande sätt sudo vim /etc/ssh/sshd_config. På sista raden i filen lägger du till AllowUsers Användarnamn för att tillåta en användare ansluta till datorn via SSH. Lägg även till PermitRootLogin no, av säkerhetsskäll bör man aldrig tillåta root SSH till en dator/server.

Skulle överväga att använda så kallade SSH-nycklar med lösenord eller utan, följ denna guide om du är intresserad. Men det ökar din säkerhet ytterligare och konfigurera sshd_config så att du endast tillåter anslutningar med nycklar. Då kan man inte "bruteforce" sig in i ditt system.

Det är troligen inget fel på dina routrar i detta fallet för då hade inte fått Connection refused, du kommer åt datorn men tillåts inte ansluta (enkelt förklarat). Om du inte kommer åt datorn skulle mer troligt stå Destination Unreachable eller liknande.

Fractal Design Define C TG || ASUS ROG STRIX B350-F Gaming || Ryzen 5 1600@3.8Mhz || Noctua NH-D15 || G.Skill 16GB 3200MHz CL14 Flare X || Asus GTX 1070 Dual 8GB || SSD 180GB || HDD 5TB || HDD 3TB || Corsair RM750x || Acer 27" XF270HUA

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Hm, oftast är WiFi trafik isolerad från vanligt LAN i en router. Kika om du kan ställa om det.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av Icte:

Båda routrarna är av modellen Linksys WRT1200AC med de absolut senaste firmware uppdateringarna (kör ej någon 3:e parts firmware utan den som man får från Linksys via Firmware Update i routerns programvara).

Detta kan mycket rimligt förklara problemet. SSHD är inget jag har mixtrst med - är det något speciellt jag bör sätts på i just Dator2?

Oj jävlar, detta var lite överkurs. Jag är inte super insatt i nätverk och routrar men ska se om jag kan svara på allt:

*Ska kolla upp nätmask och IP imorgon, återkommer med detta.
*Jag tror att de ska använda samma DHCP server. Det är inget jag direkt ställt in utan det enda som gjorts är.det jag beskrev i mitt första inlägg. Hur kollar jag upp detta?
*Det är ingen server utan båda datorerna kör med desktop versionen av Ubuntu - tanken är att Dator2 kommer att brukas enbart via SSH för att slippa använda skärm + tangentbord till denna då den och Router2 sitter på en mobil plattform. Båda datorerna innehåller en nära fräsch installation av Desktop Ubuntu med senaste uppdateringarna via apt-get installerade - iptables kan då vara påslaget om det är så default.
*Då hänger jag med! Nej, fail2ban har inte installerats.

sshd är SSH-deamonen (*nix-språk för service/tjänst som det kallas i Windows). Prova att starta sshd på dator 2: "sudo service sshd restart". Får du några fel?

Ligger de på olika lager2-nät så routas dessa - då är min gissning att det är en brandvägg i någon av dina routrar som spökar (om du säger att det fungerar när du ansluter båda maskiner till samma router). Hur är maskinerna anslutna? Tråd till vardera router?

Som nån skrev, det kan också vara så att Linksys-maskinen separar trådlöst mot trådbundet, men isåfall borde inte ICMP fungera (protokollet som används vid ping).

WS: Bärbar workstation, 2 * Dell U2412M
HTPC: Intel NUC, Canton GLE 496, Yamaha RV-A830, Sanyo PLV-Z700
Server: Intel Xeon E3-1240@3.4 GHz, ESXi, 32GB RAM, 8*2TB RAID-Z2 + SSD-cache
Slösurf: MacBook Air 11,6", Samsung S8
Kamera: Canon EOS 5DII + 1DIII, Canon 100/2.8 Macro, Canon 70-200/2.8L, Canon 24-70/2.8L

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Maj 2013
Skrivet av Icte:

Detta kan mycket rimligt förklara problemet. SSHD är inget jag har mixtrst med - är det något speciellt jag bör sätts på i just Dator2?

Vad säger:

service ssh status

och:

service ssh start

på Dator2?

Trädvy Permalänk
Medlem
Registrerad
Jun 2006

Kanske är dumt att tipsa, men är du säker på att router 2's DHCP är avslagen. Om den är inställd till "Wireless Bridge mode" så borde den vara avstängd, men man vet ju aldrig...

Trädvy Permalänk
Medlem
Plats
Höör
Registrerad
Jun 2002
Skrivet av Duktig:

Om du inte har konfigurerat något i sshd_config, skulle jag börja där. Öppna sshd_config som sudo med valfria texteditor på följande sätt sudo vim /etc/ssh/sshd_config. På sista raden i filen lägger du till AllowUsers Användarnamn för att tillåta en användare ansluta till datorn via SSH. Lägg även till PermitRootLogin no, av säkerhetsskäll bör man aldrig tillåta root SSH till en dator/server.

Skulle överväga att använda så kallade SSH-nycklar med lösenord eller utan, följ denna guide om du är intresserad. Men det ökar din säkerhet ytterligare och konfigurera sshd_config så att du endast tillåter anslutningar med nycklar. Då kan man inte "bruteforce" sig in i ditt system.

Det är troligen inget fel på dina routrar i detta fallet för då hade inte fått Connection refused, du kommer åt datorn men tillåts inte ansluta (enkelt förklarat). Om du inte kommer åt datorn skulle mer troligt stå Destination Unreachable eller liknande.

Han skriver ju dock att om han bara kopplar om sladden (dator2) från router2 till router1 så fungerar det...

Gällande netstat, se till att köra det som root för att få ut all information, dvs 'sudo netstat -lpnt' på dator2. Det ska dock inte behövas egentligen om du har datorn igång och det fungerar ifall du kopplar kabeln i router1 men inte om du sen byter till router2.

Om du gör något annat när du kopplar om kablarna mellan de olika routrarna så får du beskriva det. Skriv gärna ut om IP-adresserna som tilldelas till dator2 ändras när den är kopplad till router1 respektive router2.

Citera mig för svar.
Arch Linux

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013

Löste problemet!

Problemet var att ssh-server INTE var installerad/konfigurerad på ett korrekt sätt - ominstallerade ssh-server och nu fungerar det!

Tack för hjälpen allihop!

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||