Applikation hittar inte .php fil (NGINX)

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Applikation hittar inte .php fil (NGINX)

Hej.

Har byggt och grejat med en applikation i VS 2015 tillsammans med Wamp på Windows 7.

Applikationen skickar en bild + lite annan information till .php filen på servern.

Allt har fungerat på localhost.
Startade en dedikerad server igår med CentOS 7.2 och NGINX, men det vill inte fungera.

Blev super nojig idag och tänkte om jag kanske gjort något fel i koden eftersom jag bara kört på localhost, men testade idag med en annan dator över nätverket och allt fungerade fin fint!

Allt är korrekt installerat på servern, som det är inte så att php krånglar.

Jag har ingen aning varför det inte vill fungera.
Jag får felmeddelandet i applikationen att den "inte kunde hitta" .php filen... (Vet inte hur säkert detta är dock.)

Skapade ett nytt server block med "rena" inställningar för att testa om det skulle kunna avlösa problemet, men det är fortfarande kvar.

nginx.conf:

server { listen 80; server_name upload.secretXXX.com; root /usr/share/nginx/html; # Load configuration files for the default server block. include /etc/nginx/default.d/*.conf; location / { } location ~ \.php$ { fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } }

Tack på förhand!

Speldator: [Intel Core i7 4790K] [ASUS Matrix GTX 780Ti x2] [ASUS MAXIMUS VII HERO] [Corsair Dominator Platinum 32GB] [Windows 7] [Logitech G400S] [Microsoft Ergonomic 4000] [BenQ XR3501 35" (HDMI)] [BenQ G900W 19" (VGA)]

Serverdator: [Intel Core i7 6850K] [ASUS X99-E WS] [Corsair Vengeance LPX 64GB] [2x Crucial MX300 1TB] [Cooler Master V1200] [CentOS 7]

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2006

location ~ \.php$ här har du din \ åt andra hållet.

Kan det vara det?

Trädvy Permalänk
Medlem
Plats
Gnosjö
Registrerad
Okt 2011

@Dalslandan:
prova med detta

server {
listen 80;
server_name upload.secretXXX.com;
root /usr/share/nginx/html;

index index.php;

# Load configuration files for the default server block.
include /etc/nginx/default.d/*.conf;

location / {
}

location ~ \.php$ {
fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
}
}

Moderkort:Asus SABERTOOTH Z77 | CPU:Intel Core i5 3570K | Kylare:vattenkylning GPU:Asus gtx680 2st DirectCUII | RAM:Corsair 16GB 1333Mhz |PSU: Fractal Design Newton R2, 1000W 80+ Modulär
"citera för svar" missförstå mig inte? för udda skrivning

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Mar 2008

Annars så tenderar det stå ävslöjande information i programmets loggar. T.ex. ta en titt i:
/var/log/nginx/ t.ex. error.log ?

Trädvy Permalänk
Medlem
Registrerad
Maj 2012
Skrivet av Jimi84:

Annars så tenderar det stå ävslöjande information i programmets loggar. T.ex. ta en titt i:
/var/log/nginx/ t.ex. error.log ?

Hittade felet i error.log

Tack!

Ibland tänker man inte särskilt långt. :3

Speldator: [Intel Core i7 4790K] [ASUS Matrix GTX 780Ti x2] [ASUS MAXIMUS VII HERO] [Corsair Dominator Platinum 32GB] [Windows 7] [Logitech G400S] [Microsoft Ergonomic 4000] [BenQ XR3501 35" (HDMI)] [BenQ G900W 19" (VGA)]

Serverdator: [Intel Core i7 6850K] [ASUS X99-E WS] [Corsair Vengeance LPX 64GB] [2x Crucial MX300 1TB] [Cooler Master V1200] [CentOS 7]

Trädvy Permalänk
Medlem
Plats
Gigabyte
Registrerad
Aug 2008

Vad stod det i loggen ?