Problem med Ubuntu på Virtual Box

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Problem med Ubuntu på Virtual Box

Jag har försökt skapa en VM maskin med Ubuntu där jag väljer att jag skapar en "Virtual Hard drive" och sedan har jag testat både "VDI", "VHD" samt "VMDK" och tilldelar de 8GB som minne. När jag sedan vill starta min virtuella maskin så säger den att den inte hittar en virtuell hårddisk, och om jag kollar i mappen där den virtuella hårddisken skulle sparas så finns det inte där.

Någon som vet vad det kan beror på?

Kan någon även vara snäll och berätta vad skillnaden är mellan "VDI", "VHD" och "VMDK"?

Tack på förhand!

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Gå in i File->Virtual Media Manager och se efter om något ser knas ut. Om du vill starta om från början, radera din virtuella maskin och gå sen in i Virtual Media Manager och ta bort eventuella "left overs" innan du börjar om.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av hasenfrasen:

Gå in i File->Virtual Media Manager och se efter om något ser knas ut. Om du vill starta om från början, radera din virtuella maskin och gå sen in i Virtual Media Manager och ta bort eventuella "left overs" innan du börjar om.

Jag har raderat och startat en ny ett par gånger, och det finns inget under "File->Virtual Media Manager". :/

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011

den skapar en virtuell disk när du initierar den (installerar något) så när du startar den, montera din installations iso.

Edit: Tryck Devices -> optical drives -> choose disk image

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av swehunter2000:

den skapar en virtuell disk när du initierar den (installerar något) så när du startar den, montera din installations iso.

Edit: Tryck Devices -> optical drives -> choose disk image

Jag hittar inte "Devices"?

Kanske var otydlig i mitt första inlägg. Problemet är att efter jag har skapat min VM, och startar den så får jag upp en ruta där jag ska välja "start-up disk", och det är den filen jag inte hittar. Den skulle väl ha skapats när jag gjorde min VM?

Använder VirtualBox om det hjälper

BTW. om jag går in i "File -> Virtual Media Manager" så ska det finnas en "Ubuntu.vdi" under "Hard disk", ändå kan denna inte hittas när jag vill starta min VM för första gången.

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av Naruori:

Jag hittar inte "Devices"?

Kanske var otydlig i mitt första inlägg. Problemet är att efter jag har skapat min VM, och startar den så får jag upp en ruta där jag ska välja "start-up disk", och det är den filen jag inte hittar. Den skulle väl ha skapats när jag gjorde min VM?

Använder VirtualBox om det hjälper

BTW. om jag går in i "File -> Virtual Media Manager" så ska det finnas en "Ubuntu.vdi" under "Hard disk", ändå kan denna inte hittas när jag vill starta min VM för första gången.

Det den frågar efter är inte din VM:s virtuella lagringsenhet, utan ett installationsmedia för operativsystemet du vill installera. Peka den till Ubuntu-skivavbildningen du laddat ner härifrån.

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011
Skrivet av Naruori:

Jag hittar inte "Devices"?

Kanske var otydlig i mitt första inlägg. Problemet är att efter jag har skapat min VM, och startar den så får jag upp en ruta där jag ska välja "start-up disk", och det är den filen jag inte hittar. Den skulle väl ha skapats när jag gjorde min VM?

Använder VirtualBox om det hjälper

BTW. om jag går in i "File -> Virtual Media Manager" så ska det finnas en "Ubuntu.vdi" under "Hard disk", ändå kan denna inte hittas när jag vill starta min VM för första gången.

Som jag skrev tidigare så kommer den inte att skapa den disken förrän det finns något att lagra på den. Montera din iso fil. så i rutan som kommer upp, välj ditt installationsmedia.

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2002
Skrivet av Naruori:

Kan någon även vara snäll och berätta vad skillnaden är mellan "VDI", "VHD" och "VMDK"?

Kort och gott är det att imagerna är byggda enligt ett visst format och därmed läsbara rakt av från andra virtualiserare/hypervisors.
VDI = Virtual Box Disk Image Format
VHD = Micorsoft Virtual Disk Image Format
VMDK = VMWare Virtual Disk Image Format

Om din plan är att köra Virtual Box, använd VDI!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2002
Skrivet av Naruori:

Jag hittar inte "Devices"?

Kanske var otydlig i mitt första inlägg. Problemet är att efter jag har skapat min VM, och startar den så får jag upp en ruta där jag ska välja "start-up disk", och det är den filen jag inte hittar. Den skulle väl ha skapats när jag gjorde min VM?

Använder VirtualBox om det hjälper

BTW. om jag går in i "File -> Virtual Media Manager" så ska det finnas en "Ubuntu.vdi" under "Hard disk", ändå kan denna inte hittas när jag vill starta min VM för första gången.

Det skall skapas en VDI med en gång i den katalog som är vald (eller Default Machine Folder enligt Preferences).
Försöker du lägga denna någon konstig stans? (i.e. rättighetsproblem?)
Försöker du skapa en dynamisk storleksallokerad disk, eller en statiskt allokerat disk? Om det senare, har du plats!?

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av LemonIllusion:

http://i.imgur.com/KFMuNCF.png
Det den frågar efter är inte din VM:s virtuella lagringsenhet, utan ett installationsmedia för operativsystemet du vill installera. Peka den till Ubuntu-skivavbildningen du laddat ner härifrån.

Aha! Ok, ska testa :). Tack!

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av LemonIllusion:

http://i.imgur.com/KFMuNCF.png
Det den frågar efter är inte din VM:s virtuella lagringsenhet, utan ett installationsmedia för operativsystemet du vill installera. Peka den till Ubuntu-skivavbildningen du laddat ner härifrån.

Hur vet jag vilken jag ska ladda ner? Tänkte köra Ubuntu 16.04, och jag använder idag Win10 64-bit.

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Jag får ett meddelande som säger "This kernel requires an x86-64 CPU but only deteced an i686 CPU. Unable to boot - please use a kernel appropiate for your CPU".

Vad är det som är problemet? All tips uppskattas!

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av Naruori:

Hur vet jag vilken jag ska ladda ner? Tänkte köra Ubuntu 16.04, och jag använder idag Win10 64-bit.

Vad sägs om 64-bitars Ubuntu 16.04.1?

Skrivet av Naruori:

Jag får ett meddelande som säger "This kernel requires an x86-64 CPU but only deteced an i686 CPU. Unable to boot - please use a kernel appropiate for your CPU".

Vad är det som är problemet? All tips uppskattas!

Aktivera virtualization i BIOS.

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av LemonIllusion:

Vad sägs om 64-bitars Ubuntu 16.04.1?

Aktivera virtualization i BIOS.

Hur gör jag det? Gillar inte att gå in och mecka i BIOS...och varför måste man ändra inne i BIOS för att få igång en virtuell maskin? :s

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av Naruori:

Hur gör jag det? Gillar inte att gå in och mecka i BIOS...och varför måste man ändra inne i BIOS för att få igång en virtuell maskin? :s

Du kan köra utan, men då får du inte tillgång till processorns inbyggda virtualiseringsfunktion och kan inte köra 64-bitars mjukvara. Om du inte vågar slå på en enkel funktion i BIOS, vad ska du med en virtuell maskin till?

hade fel om sämre prestanda utan vt-x/amd-v

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Registrerad
Jan 2016

Liknande problem

Jag tänkte stjäla denna tråd med för ett liknande problem.
Jag har Windows 10 Home och jag har aktiverat virtualiseringen i BIOS/EUFI men jag får fortfarande inte 64bit alternativen i Virtualbox för varken Ubuntu eller Kali eller någon annan OS. Då det inte finns någon Hyper-V i Win 10 Home har jag kört fast i vad mer jag kan göra.
Är det någon annan som råkat ut för liknande och har något förslag. Jag har googlat och kollat på youtube men alla förslagen är enligt oven, aktivera i bios och kolla upp hyper-v.

Trädvy Permalänk
Medlem
Plats
Falköping
Registrerad
Jan 2009
Skrivet av Naruori:

Hur gör jag det? Gillar inte att gå in och mecka i BIOS...och varför måste man ändra inne i BIOS för att få igång en virtuell maskin? :s

Länk

Länkade en kort förklaring om hur Virtualiseringen fungerar och varför det behövs aktiveras
Kolla så att di processor och moderkort har stöd för det. Sen så googlar du fram hur du kan aktivera funktionen i BIOS.

Sen ska det bara vara att köra

Asus Prime B350-Plus | Ryzen 7 1800X @ 4.6Ghz | Corsair Vengeance LP 2x8gb 3000Mhz | Asus GTX 1060 6GB |
Samsung 840 250Gb | Geeetech i3x

Trädvy Permalänk
Medlem
Registrerad
Jan 2016

@DeGreeZ: Jag har aktiverat virtualisering i BIOS men 64bit alternativet dyker ändå inte upp. Nu har jag avinstallerat Android Studio och avslutat Daemon tools bara för att experimimentera utan framgång