Problem med upplösning Surface Pro 4

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009

Problem med upplösning Surface Pro 4

Tja

Jag har en Surface Pro 4, den funkar perfekt förutom i skalning av fönster i spel.
Ex. Steam & Origin's menyer är knappt läsabara, pyttesmå helt enkelt. Det luriga är att väl inne i ett spel, ex. The Sims, Stardew Valley, eller Planet Coaster etc. så är miljöer och "gubbar" typ alltid rätt o skala. Men däremot text, dialogrutor och menyer på tok för små?

Har testat att ändra upplösning på datorn, men det verkar inte avhjälpa problemet.
Någon som har en idé om detta?

Toksmå dialogrutor by Niklas Spjuth, on Flickr

Här har vi samma problem med ex. Winamp...

Winamp toksmått... by Niklas Spjuth, on Flickr

Tack på förhand

Trädvy Permalänk
Medlem
Registrerad
Feb 2013

Jag har liknande problem på min pro 4. Jag har upptäckt att när jag har använt den som en laptop och sedan ansluter mina externa skärmar så blir skalningen fel på de externa skärmarna. Jag brukar då starta om datorn så rättar det till sig. Jag har dock aldrig testat ett spel på datorn eftersom det är min jobbdator, så det är främst i program det händer. Använder du en extern skärm?

Stationär: Phanteks Evolv Silver | 6800k @4,3 | Asus Strix Gaming | 8x4gb 3000MHz Vengeance | Evga G2 1000W | Asus GTX1080 Strix OC | Kraken x61
Skärm: AOC 35" AGON AG352UCG

Trädvy Permalänk
Medlem
Plats
Ulricehamn
Registrerad
Feb 2002

Tror detta har med den extremt dåliga skalningen av guit i windows att göra, inte så mkt du kan göra åt det förutom att möjligtvis köra skärmen i den korrekta upplösningen(2736x1824) men då kommer allt att bli väldigt smått också. Kollar du windows+i > system så är säkert skalning påslaget 125, 150% tex.

Of all the things Ive lost, I miss my mind the most

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av Le9:

Jag har liknande problem på min pro 4. Jag har upptäckt att när jag har använt den som en laptop och sedan ansluter mina externa skärmar så blir skalningen fel på de externa skärmarna. Jag brukar då starta om datorn så rättar det till sig. Jag har dock aldrig testat ett spel på datorn eftersom det är min jobbdator, så det är främst i program det händer. Använder du en extern skärm?

Ej extern skärm, men antar att problemet skulle kvarstå även då. Vill ju kunna använda datorn som en laptop fullt ut... :/

Skrivet av Mrwite:

Tror detta har med den extremt dåliga skalningen av guit i windows att göra, inte så mkt du kan göra åt det förutom att möjligtvis köra skärmen i den korrekta upplösningen(2736x1824) men då kommer allt att bli väldigt smått också. Kollar du windows+i > system så är säkert skalning påslaget 125, 150% tex.

Okej, tråkiga nyheter, rätt kass för en så dyr maskin... Kör med standardupplösningen, d.v.s den "rätta" och för datorn högsta möjliga 2736x1824...

Sjukt stor besvikelse detta... funkar ju på vilken annan windows laptop som helst, men inte denna trots fullfjädrat desktop läge i Windows

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011

har för mig att det funkade när jag ändrade upplösningen, och sedan startade om den...

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av swehunter2000:

har för mig att det funkade när jag ändrade upplösningen, och sedan startade om den...

Tja, ändrade till vad?

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011
Skrivet av ApeviaX:

Tja, ändrade till vad?

närmare 1080p, minns inte exakt Var ett tag sedan och har inga spel på surfacen just nu

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av swehunter2000:

närmare 1080p, minns inte exakt Var ett tag sedan och har inga spel på surfacen just nu

Check, testade det, blev lite skillnad, men inte tillräckligt... Dessutom så blev text och skärpa totalkass samt att fönstret ju skalar ner så synlig bildyta blev mindre... Hoppas man kan få en lösning på sikt, är ju som sagt inte bara i spel utan även i program det förekommer...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Hade samma problem med min Surface Pro 3, löste sig när jag ändrade lite i scaling.

https://support.microsoft.com/sv-se/help/3025083/windows-scal...

Citat:
  • Adjust display settings

Windows 10

Select Display > Change the size of text, apps, and other items, and then adjust the slider for each monitor.

Earlier Windows systems

Right-click the application, select Properties, select the Compatibility tab, and then select the Disable display scaling on high DPI settings check box.

  • Change application properties

In Explorer or on the Start menu, right-click the application name, select Properties, select the Compatibility tab, and then select the Disable display scaling on high DPI settings check box.

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2009
Skrivet av MaxieTheHatter:

Hade samma problem med min Surface Pro 3, löste sig när jag ändrade lite i scaling.

https://support.microsoft.com/sv-se/help/3025083/windows-scal...

Halloj

Tack för matnyttig info. Har dock ej löst mitt problem... Jag laddade ner "Process explorer" enligt rekommendation på sidan, såg där att de program jag har problem med har DPI Awareness status: Per-Monitor Aware. Detta innebär alltså enligt Microsoft följande:

"Per-Monitor Aware: Per-monitor DPI-aware. These applications check for the DPI when they are started, and adjusts the scale factor whenever the DPI value changes. These applications are not automatically scaled by the system. "

Om jag hajar rätt så är det där problemet ligger, alltså de programmer skalar inte automatiskt till rätt förhållanden... Hur fasen ska jag då lösa det?

Har testat detta:

"Adjust display settings

Windows 10

Select Display > Change the size of text, apps, and other items, and then adjust the slider for each monitor.

Earlier Windows systems

Right-click the application, select Properties, select the Compatibility tab, and then select the Disable display scaling on high DPI settings check box.

Change application properties

In Explorer or on the Start menu, right-click the application name, select Properties, select the Compatibility tab, and then select the Disable display scaling on high DPI settings check box."

Detta gör alltså ingen skillnad det heller...