Funtoo bootar inte på nvme (debian-sources) genkernel

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

Funtoo bootar inte på nvme (debian-sources) genkernel

Jag får inte debian-sources 4.8 att boota på min nvme (Samsung 961 - 128GB) vid/efter Funtoo-installation.
Såg det var fler som hade problem. Installationen och grub-install/boot-update funkar finfint utan fel.
Sedan exit chroot och umount, reboot.

"Determining root device...
Block device /dev/nvmen0n1p3 is not a valid root device...
Could not find the root block device in .
Please specify another value or: press Enter for the same, type "shell" for shell, or "q" to skip"

har testat gentoo-sources, samma fel.
Är det dåligt stöd för nvme eller är det min firmware på disken som är knas?

E: För tydligheten, fstab är i ordning, tre partitioner, ESP/boot, SWAP och /
Arch går att installera utan incidenter, jag kan kompilera kerneln manuellt och kolla flaggorna för nvm express, men debian-sources brukar kunna boota på vad skit som helst, gentoo-sources än mer (då jag sätter stödet för diverse HW själv).

I Arch Linux wiki läser jag att "It may be needed to add the nvme module to the MODULES array within /etc/mkinitcpio.conf to successfully boot into the root filesystem." som inte finns till Gentoo/Funtoo. Det går att kompilera mkinitcpio tool från Arch Linux men vet inte var under install jag får möjlighet att göra denna ändring riktigt.

Någon som kompilerar kernel och kör nvme här månne?

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
@foo
Registrerad
Jul 2008

Bygg en egen kärna så fungerar det.
Kan rekommendera Pappy's preconfigs för en stabil grund.
https://forums.gentoo.org/viewtopic-t-1051430.html

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Ennuj:

Bygg en egen kärna så fungerar det.
Kan rekommendera Pappy's preconfigs för en stabil grund.
https://forums.gentoo.org/viewtopic-t-1051430.html

Sant, drog in Gentoo på datorn igår kväll istället och aktiverade

Device Drivers --->
<*> NVM Express block device
[*] Open-Channel SSD target support --->

Funkade, fick dock RO på hela filsystemet, men det var slarv av mig Skall blåsa datorn någon dag i veckan istället och köra en install i lugn och ro.

i7
GTX
4K