[C#] min kod gör att jag får blue screen (Windows 7)

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

[C#] min kod gör att jag får blue screen (Windows 7)

Tja,

När jag kör min kod får jag blue screen.

notifyIcon1.BalloonTipIcon = ToolTipIcon.Info; notifyIcon1.BalloonTipText = "Ute"; notifyIcon1.BalloonTipTitle = "MammaKoll"; notifyIcon1.ShowBalloonTip(1000);

Mycket skumt tycker jag.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Okt 2008

Beror sannolikt inte direkt på din kod, utan t.ex. något drivrutinsproblem (grafikdrivaren kanske).

Blåskärmens meddelande avslöjar mer om vad den egentliga orsaken är.

Alternativt får du ställa in så en minnesdump genereras av Windows, och sedan ta en titt på dumpen i t.ex. WinDbg, vilket kan vara lite bökigt om man aldrig gjort det förut dock...

1800X, 1080 SLI, 4K

Trädvy Permalänk
Medlem
Registrerad
Jul 2014

Din kod som körs i usermode kan aldrig generera en bluescreen. Bara kod som körs i kernel mode kan det, vilket är t.ex drivrutiner och andra OS komponenter som körs som system.
Precis som @backfeed säger så är det en drivrutin som crashar pga din kod, mest troligt grafik drivis eller någon som hookar in i gfx drivisen, typ overlay program som overwolf etc.

Skickades från m.sweclockers.com

CASE: Corsair Obsidian 900D | CPU: Intel i7-8086k@5.4GHz | GPU: 2x AORUS GeForce® GTX 1080 Ti Waterforce WB Xtreme Edition 11G | MB: Asus ROG Maximus Formula X| NVMe: 1x 1TB Samsung 960 Pro PCIe | SSD: 1x 1TB Samsung 850 EVO | RAM: G.Skill Trident Z Black/White 32GB (2x16GB) / 3200Mhz / DDR4 / CL14 | PSU: Corsair HX1200i | COOLING: EKWB EK-KIT 1xXE360 1xXE420 1xXE240 | SCREENs: 1x40" 3x27" 1x34" UW | HEADPHONES: Logitech G933 | MOUSE: Mad Catz R.A.T 8 | KEYBOARD: Logitech G710+
https://valid.x86.fr/bjhxgj

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av backfeed:

Beror sannolikt inte direkt på din kod, utan t.ex. något drivrutinsproblem (grafikdrivaren kanske).

Blåskärmens meddelande avslöjar mer om vad den egentliga orsaken är.

Alternativt får du ställa in så en minnesdump genereras av Windows, och sedan ta en titt på dumpen i t.ex. WinDbg, vilket kan vara lite bökigt om man aldrig gjort det förut dock...

Skrivet av spawnstah:

Din kod som körs i usermode kan aldrig generera en bluescreen. Bara kod som körs i kernel mode kan det, vilket är t.ex drivrutiner och andra OS komponenter som körs som system.
Precis som @backfeed säger så är det en drivrutin som crashar pga din kod, mest troligt grafik drivis eller någon som hookar in i gfx drivisen, typ overlay program som overwolf etc.

Skickades från m.sweclockers.com

Skriver till er både.

Då jag kör det i ESXI så bör inte grafikdrivaren vara problemet?

Jag tror jag vet felet jag har inte lat till någon icon i själva koden kan det vara felet?

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Hedersmedlem
Plats
Uppsala
Registrerad
Jul 2001

Någonting är fel på något annat ställe också, oavsett om din kod stämmer eller inte.
Som de ovan säger så ska inte "vanlig kod" kunna krascha Windows, hur mycket du än försöker. Lyckas du så är något fel, antingen i Windows självt eller i någon drivrutin eller liknande som körs i högre privilege level än vanlig kod.

X370 Taichi / R7 1700 @ 3.75 GHz 1.2 V / 2x8 GB 3200 MHz CL16 / MSI GTX 1070 Gaming, OC / Samsung 960 EVO 500 GB / Corsair RM650x
LG G6 (H870)

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Har hittat felet bara för att jag inte hade någon icon i notifyIcon1 så hände detta.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av superegg:

Har hittat felet bara för att jag inte hade någon icon i notifyIcon1 så hände detta.

Det är bara en del av problemet, jag skulle gissa att du har ev problem med dina ram minnen och din kod triggade just den sektionen.

Kör memtest86 under natten och se om du får några errors.

Skickades från m.sweclockers.com

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011

Aldrig att det där fick din dator att blåskärma... Om du får den koden att skapa en blåskärm på en annan dator, ladda upp hela ditt projekt (om möjligt) då du i sånna fall har hittat en enorm bugg i windows..

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Calby:

Det är bara en del av problemet, jag skulle gissa att du har ev problem med dina ram minnen och din kod triggade just den sektionen.

Kör memtest86 under natten och se om du får några errors.

Skickades från m.sweclockers.com

Kör i EXSI så blir lite svårt att testa.

Skrivet av swehunter2000:

Aldrig att det där fick din dator att blåskärma... Om du får den koden att skapa en blåskärm på en annan dator, ladda upp hela ditt projekt (om möjligt) då du i sånna fall har hittat en enorm bugg i windows..

Det går inte att starta Windows utan måste repair den först, vare gång det händer.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av superegg:

Det går inte att starta Windows utan måste repair den först, vare gång det händer.

hmm, låter som att det ev. skulle vara några drivrutiner som spökar.
Eller om du har en trasig sektion på din lagring (SSD,HDD,Flash) som triggas av ditt program.

Om inte, rapportera denna bugg direkt till Microsoft.
Har du möjlighet att posta hela din kod?

Eller bara en .exe fil så vi kan testa om våra datorer buggar ihop med?

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Mar 2008

Titta i Event viewer för att hitta ett felmeddelande, där borde det stå vilken drivrutin som har fått fel.

[Fractal Design R5] [Intel i7 4790k + CM 212 Evo] [8Gb DDR3] [Asus Z97-A] [MSI GTX 970]
-------------------------------------------------------------------------------------------------------------------------------------
[Samsung Chronos 7] Intel i5-3210M (2,5Ghz), 6Gb DDR3, 1Tb, nVidia GT 640M 1024Mb GDDR5