Plex flytt av media library problem

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Plex flytt av media library problem

Hej Sweclockers

Har redan beskrivit mitt problem här så läs gärna:

https://forums.plex.tv/discussion/269951/moved-plex-library-a...

Vad tror ni?

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2002

Ta bort det gamla och låt den generera på nytt?

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Det vill jag inte göra för då försvinner all metadata och watch statistics för alla mina användare. Men jag har löst det nu, vet inte hur jag gjorde så fråga mig inte...

Jag tror det är unRAID parity check som gör att det går långsamt. Filerna finns men de timar ut för det tar så lång tid att accessa dem. hmm känns inte ideellt.

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Problemet är fortfarande inte löst. Fast det vart betydligt mer avancerat. Jag har lyckats komma fram till att network transfers på min Windows 2012 R2 som kör Plex failar med följande fel meddelande:

Denna kör som VM på en ESXI server. Jag har en Windows Server 2016 på samma ESXI maskin som kör i samma nätverk och igenom samma switch. Network transfers på den fungerar perfekt, samma sak på min stationära dator på samma nätverk. Så tror inte det är unRAID som är problemet här. Jag har testade följande:

* Ändrat network type/driver i ESXI = ingen skillnad
* Testade mapped drive och network share = ingen skillnad
* Stängt av FW = ingen skillnad

Någon som har en ide?

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2002

Himlen lär ju inte trilla ner för att din watch statistics försvinner

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2010

Ladda ner ett plugin för plex att synca vad du kikat på med trakt.tv och sedan borde du kunna lägga till allt på nytt så borde det synkas tillbaka från trakt.tv. till din plex

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av ciscodisco:

Ladda ner ett plugin för plex att synca vad du kikat på med trakt.tv och sedan borde du kunna lägga till allt på nytt så borde det synkas tillbaka från trakt.tv. till din plex

Såhär gjorde jag när jag flyttade mitt bibliotek till en ny server. Sedan dess har trakt.tv synkat med Plex och har koll på vad jag har sett. Grymt smidigt.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002

@AquaRelliux
Jag har också gjort den där resan.

Om du ska flytta media från en lagringsenhet till en annan och vill behålla statistik och coverart (utan att scanna/match om samt förlora metadata) mm. Det jag kom fram till var bästa sättet var att:

1. Kopiera media-filerna till den nya larningsplatsen (du har alltså dubbel uppsättning under en tid).
2. Lägg till dessa nya platser i Plex (Library settings).
3. En scanning kommer att triggas och all media kommer matchas ihop med den redan befintliga.
Trycker du tex på en film så kommer det finns en lite tvåa i hörnet och kollar du i detaljerna så finns två sökvägar till samma film.
4. När du har kollat att allt ser bra ut och matchningarna är klara så tar du bort sökvägen till den gamla lagringsenheten i Plex (Library settings).
5. En ny scan kommer att göras och de dubblerade sökvägarna tas bort.
6. Ta bort filerna på den gamla lagringsenheten.
7. Vipps så har du kvar all metadata om dina filmer/musik/bilder.

Rek. också att använda Trakt av andra anledningar tex att synka Watch/rating mellan Kodi och Plex

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Nu har jag löst problemet med flytten, det som kvarstår är dock det där felmeddelandet jag får vi kopiering. Någon som har en aning om det? Händer som sagt bara på den servern som kör Plex inga andra...

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002
Skrivet av AquaRelliux:

Nu har jag löst problemet med flytten, det som kvarstår är dock det där felmeddelandet jag får vi kopiering. Någon som har en aning om det? Händer som sagt bara på den servern som kör Plex inga andra...

Lite långsökt men har du provat att paketera den med Winrar och sen dela den i flera 700 Mb-filer?

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011
Skrivet av Mr_Lazy:

Lite långsökt men har du provat att paketera den med Winrar och sen dela den i flera 700 Mb-filer?

Förklara gärna hur du tänker och hur det ska lösa mitt problem?

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002
Skrivet av AquaRelliux:

Förklara gärna hur du tänker och hur det ska lösa mitt problem?

Som jag förstod det så kan du inte kopiera en av dina filer som är 8Gb stor.

Splitta upp den i mindre delar och kopiera flera mindre filer

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2001

Hoppar in här, men bara så jag förstår dig rätt mellan vilka system försöker du kopiera filen när du får felmeddelandet? Kopierar du till eller från unraid?

ASUS ROG Crosshair VII Hero| AMD Ryzen 7 2700X @4300MHz| EK based custom watercooling| Samsung 970 EVO 256 + 512GB M.2 NVMe| G.Skill Trident Z RGB 3600 MHz 32GB @3200 MHz 16-16-16-36-81 1T| MSI RX VEGA 64 Reference| LG 34UC88-B Freesync| EVGA SuperNova P2 1600W| Lian-Li PC-O11 Dynamic| Windows 10 LTSB

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Kopierar från unraid, men även läsning av filer och skrivning krashar med samma fel

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Okej after mycket felsökande har jag hittat felet. Jag installerade en Windows Server 2016 och satte den på det nätverket och VLAN som den gamla 2012 R2 server satt på. Då fick jag samma fel...
Efter det tänkte jag att det måste vara något med nätverket och där visade sig att jag hade rätt. unRAID och VLAN verkar inte lira så bra för så fort jag sätter en IP på unRAID på det VLAN som Windows Server 2012 R2 maskinen sitter på så går file transfers sönder. Det som är jätte konstigt är att det fungerar utmärkt på min andra Windows 2016 maskin som sitter på ett annat VLAN, men unRAID har en IP på också, det fungerar utmärkt där så vad är grejen?

Exempel på bilden. Jag testade nu och överföra en fil på VLAN2 till maskinen som fungerade d.v.s. öppna share med \\10.0.2.30\share på Win2016 maskinen som fungerade. Då fick jag samma fel! Så det verkar vara konsekvent över VLAN2 men jag förstår ej varför :/ har dubbel och trippel kollat switch config och ser inget fel där. Att föra över filer från VLAN2 till VLAN20 med Windows 2016 servrarna och network share på dem fungerar också utmärkt...

Ping fungerar i båda riktningar:

Använda jag \\10.0.2.30\share på VLAN2 WIN2016 maskinen så fungerar det också perfekt.

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.

Trädvy Permalänk
Medlem
Plats
Skarpnäck
Registrerad
Mar 2011

Om jag ska vara ärlig tror jag faktiskt detta är en bug i unRAID. Ska kolla med deras support.

Gaming:[Asus Zenith Extreme]-[AMD TR 1950X@4Ghz]-[Corsair Dominator 3066mhz 32GB]-[GTX 1080 Ti SLI]-[Samsung 960PRO 1TB]-[CL SMA8]:.
Server(ESXi):[Supermicro X10SDV-8C-TLN4F]-[Intel Xeon D1541]-[32GB ECC]-[32GB SataDom + 1TB Samsung 960EVO]:.
Server(unRAID):[Supermicro X10SL7-F]-[Intel Xeon 1240L V3]-[32GB ECC]-[40TB WD Re + 500GB Curcial MX100]:.