Forumdelen sponsras av

Får (delvis) ingen bild på Tv. Kompabilitetsproblem?

Trädvy Permalänk
Medlem
Registrerad
Maj 2017

Får (delvis) ingen bild på Tv. Kompabilitetsproblem?

Hej!

Jag har ett problem.

Jag har en datorskärm kopplad till VGA-utgången på grafikkortet (Geforce GT710) och tv kopplad till DVI-utgången på detsamma.
Problemet är att tvn inte hittas över huvud taget i Windows (7) och därför visas heller ingen bild på denna. Bild på datorskärmen fungerar dock felfritt. Kopplar jag ur VGAn till datorskärmen (och låter DVi till tvn sitta i) och startar om datorn så visas endast produktionsloggan och windowsloggan på tvn och sedan blir den svart. Kopplar jag då in VGAn till datorskärmen så visas skrivbord och allt på den men fortfarande inte på tvn.
Har de senatste drivrutinerna installerade till grafikkortet och alla kablar fungerar ju uppenbarligen som dom ska eftersom det går att få bild på båda skärmar (om än kort på tvn).
Det lutar alltså mot att det är någon form av inställning eller kompabilitetsproblem.
Nån som vet vad problemet kan vara?

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Har du kollat i manualen till tvn vad den stödjer för upplösning och uppdateringsfrekvens och valt nått den stödjer.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av mrqaffe:

Har du kollat i manualen till tvn vad den stödjer för upplösning och uppdateringsfrekvens och valt nått den stödjer.

Ja den stödjer 1024 X 764 men då allt tidigare har fungerat lite då och då (oftast efter ominstallation av Windows och då även drivrutiner för grafikkort) så har man fått upp båda skärmar och kunnat göra separata inställningar för varje skärm gällande frekvens, upplösning osv.

Just nu ligger datormskärmen på 1280 X 1024 och 60 Hz men även om jag skulle ändra ner till 800 X 600 så hittas ingen tv.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av Amanite:

Ja den stödjer 1024 X 764 men då allt tidigare har fungerat lite då och då (oftast efter ominstallation av Windows och då även drivrutiner för grafikkort) så har man fått upp båda skärmar och kunnat göra separata inställningar för varje skärm gällande frekvens, upplösning osv.

Just nu ligger datormskärmen på 1280 X 1024 och 60 Hz men även om jag skulle ändra ner till 800 X 600 så hittas ingen tv.

Skumt om det inte har med upplösningen eller uppdateringsfrekvensen att göra och att det funkar under booten, win bootar ju i vga men ökar sen upplösningen och det är ju då den slocknar. hade vga slocknat hade jag trott på strul men hdcp men det borde inte vara det som du beskriver felet.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av mrqaffe:

Skumt om det inte har med upplösningen eller uppdateringsfrekvensen att göra och att det funkar under booten, win bootar ju i vga men ökar sen upplösningen och det är ju då den slocknar. hade vga slocknat hade jag trott på strul men hdcp men det borde inte vara det som du beskriver felet.

Nej det är ett mysterium, utgången på kortet är ju DVI men ingången i tvn en HDMI så har en kabel med olika kontakter men denna är ju från fabrik och alltså inga adaptrar eller annat som kanske annars skulle kunna innebära problem.

Det märkliga är ju också att inget visas på tvn under booten eller winloggan vid start när VGA kabeln till datorskärmen är i. Bara när denna tas bort så att endast DVIn till tvn är aktiv.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av Amanite:

Nej det är ett mysterium, utgången på kortet är ju DVI men ingången i tvn en HDMI så har en kabel med olika kontakter men denna är ju från fabrik och alltså inga adaptrar eller annat som kanske annars skulle kunna innebära problem.

Det märkliga är ju också att inget visas på tvn under booten eller winloggan vid start när VGA kabeln till datorskärmen är i. Bara när denna tas bort så att endast DVIn till tvn är aktiv.

Så du blandar in hdmi, det är nästan alltid ett problem för hdmi och vga gillar inte varandra.
Hdmi kräver hdcp, vga stödjer inte hdcp, dvi fungerar med men kräver inte hdcp. Det blir alltså ofta strul om man försöker använda vga och hdmi samtidigt.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av mrqaffe:

Så du blandar in hdmi, det är nästan alltid ett problem för hdmi och vga gillar inte varandra.
Hdmi kräver hdcp, vga stödjer inte hdcp, dvi fungerar med men kräver inte hdcp. Det blir alltså ofta strul om man försöker använda vga och hdmi samtidigt.

Okej men jag har tre utgångar på mitt grafikkort, VGA, DVI och HDMI.
VGA går till datorskärmen.
DVI går till HDMI ingången på tv:n.
HDMI utgången på kortet används inte.

Det sjuka är som sagt att efter installation av Windows och drivrutiner till kortet så brukar det fungera med båda skärmar ett tag. Sedan så bara lägger det av. Nångång har tv-skärmen hittats om man startat och stängt av tvn nån gånger på rad, alltså precis som nån signal måste triggas fram till kortet för att tvn skall hittas. Men nu fungerar inte heller detta.
Har provat att ominstallera drivrutiner och grejs men det hjälper inte heller.

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Amanite: Kör HDMI-kabel rakt av om du ändå har det på kortet. Finns ingen vinst utan endast ökad risk för krångel att gå omvägar. Hur långa kablar kör du?

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av Laxpudding:

@Amanite: Kör HDMI-kabel rakt av om du ändå har det på kortet. Finns ingen vinst utan endast ökad risk för krångel att gå omvägar. Hur långa kablar kör du?

Till datorskärm 1m, till tv 5m.
Eftersom det funkar tidvis så tänkte jag ju slippa köpa en kabel som jag annars inte har nytta av om det inte skulle funka. Kan man på nått sätt aktivera eller avaktivera de olika portarna på grafikkortet? Eller iaf se om alla är aktiverade?
Har inte lyckats hitta någon inställning till detta varken i Windows eller i NVIDIA settings.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av Amanite:

Till datorskärm 1m, till tv 5m.
Eftersom det funkar tidvis så tänkte jag ju slippa köpa en kabel som jag annars inte har nytta av om det inte skulle funka. Kan man på nått sätt aktivera eller avaktivera de olika portarna på grafikkortet? Eller iaf se om alla är aktiverade?
Har inte lyckats hitta någon inställning till detta varken i Windows eller i NVIDIA settings.

Vilken typ av kabel är det du använder till tvn, hdmi eller dvi ? En noname 5meters hdmikabel kan ibland strula för det är ungefär där gränsen går för "dåliga kablar" 3m brukar funka i full hd även med ocertifierade kablar men 5m och längre strular ofta och funktionen kan tex påverkas av hur du har böjt kabeln.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Amanite: Svaret på den frågan får man dessvärre endast på ett enda sätt. 5 meter är annars en sådan mellan tumme-och-pekfingergräns för DVI. Moderna High-Speed HDMI-kablar är konstruerade för fungera efter mer krävande omständigheter än DVI-standarden en gång var tänkt för.

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av mrqaffe:

Vilken typ av kabel är det du använder till tvn, hdmi eller dvi ? En noname 5meters hdmikabel kan ibland strula för det är ungefär där gränsen går för "dåliga kablar" 3m brukar funka i full hd även med ocertifierade kablar men 5m och längre strular ofta och funktionen kan tex påverkas av hur du har böjt kabeln.

Kabeln jag använder har DVI hane på ena sidan (till datorn) och HDMI hane på andra sidan (till tvn).
Men om det varit kabeln som inte funkat så borde den väl aldrig funkat. Det har ju funkat tidigare, jag har inga skarpa böjar på kabeln heller. Känns ju mer som om det beror på nått med grafikkortet eller nån inställning.

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Amanite: Hur en kabel fungerar i praktiken är avhängd situationen den verkar i. Det kan vara så att det fungerar under gynnsamma omständigheter men att det i perioder uppstår störningar av rent elektrisk eller rentav emmisionsbaserad karaktär (typ radiovågor från Wifi och andra störkällor etc utanför din kontroll) som påverkar funktionen.

Oavsett vad: Det finns ingen tryck-på-den-här-knappen-lösning. Man måste systematisk ta bort potentiella felkällor och ringa in orsaken. Och att köra en ålderstigen teknik som en DVI-HDMI-kabel i en situation där det finns en mer beprövad lösning? Där har du punkt 1 på din felsökningslista. Och skulle det inte hjälpa är det aldrig fel att ha rätt sorts kabel redo ifall det nu blir nytt grafikkort eller något annat som byts ut längre fram.

Trädvy Permalänk
Medlem
Registrerad
Maj 2017
Skrivet av Laxpudding:

@Amanite: Hur en kabel fungerar i praktiken är avhängd situationen den verkar i. Det kan vara så att det fungerar under gynnsamma omständigheter men att det i perioder uppstår störningar av rent elektrisk eller rentav emmisionsbaserad karaktär (typ radiovågor från Wifi och andra störkällor etc utanför din kontroll) som påverkar funktionen.

Oavsett vad: Det finns ingen tryck-på-den-här-knappen-lösning. Man måste systematisk ta bort potentiella felkällor och ringa in orsaken. Och att köra en ålderstigen teknik som en DVI-HDMI-kabel i en situation där det finns en mer beprövad lösning? Där har du punkt 1 på din felsökningslista. Och skulle det inte hjälpa är det aldrig fel att ha rätt sorts kabel redo ifall det nu blir nytt grafikkort eller något annat som byts ut längre fram.

Jo det lutar ju mot nån form av uteslutningsmetod vilket jag ju alltid gör om jag har grejor hemma. Nu ville jag först höra med er här eftersom min uppfattning är att det finns väldigt mycket kunnigt folk här:)
Och chansen fanns ju faktiskt att det var nån inställning jag missat eller något annat man skulle aktivera på nått sätt.

Skickades från m.sweclockers.com