Linux och screentearing. The never ending story

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

Linux och screentearing. The never ending story

Har under många år av och till testat massor av olika linuxdistar. Manjaro, Arch, Linux mint, Ubuntu, mm
Det som är gemensamt för ALLA är att man har sceentearing vid en standardinstallation. Och varje gång en massa trixande för att få ordning på det.

Hårdvaran jag har kört har varit med Intel grafik, men på senare tid kör jag ett Nvidoa 1050Ti men det är samma problem där

Just nu testar jag Manjaro KDE med Nvidia 1050Ti och det är inget undantag. Screentearing from hell. Testar lite tips, men det blir inte bättre

NÄR ska Linuxdistarna få ordning på en så viktig sak?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2007

När? När någon nörd lessnar och gör så att det funkar. Tills dess får du nöja dig med hur det är, eller hjälpa till med att få en lösning.

Skickades från m.sweclockers.com

Ryzen 1700x @ Corsair 16gb 3200mhz lpx @ 512gb M2 pcie @ Gigabyte 7950 @ Msi x370 plus @ Evga 650 80+gold modulärt @ Fractal r5 @ Corsair hydro 110i @ Benq 144hz 1920-1080 24tum
i5 4670k @ Asus z-87a @ Corsair vx450 @ Corsair 16gb 1600mhz @ Fractal r3 @ 256gb Kingston
c2d e4400 @ 4gb noname @ 10tb+ @ noname chassi @ 128gb Kingston ssd

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003
Skrivet av sleepyoh:

När? När någon nörd lessnar och gör så att det funkar. Tills dess får du nöja dig med hur det är, eller hjälpa till med att få en lösning.

Skickades från m.sweclockers.com

Suck. Standard Linux community svar. Hjälp till och lös det själv.

Nu är det ju så att alla är inte programerare

Trädvy Permalänk
Avstängd
Registrerad
Nov 2012

Har ingen screentearing i Fedora 25 Gnome, Ubuntu Gnome eller Mint Cinnamon vid standardinstallation. Och i Mint Xfce och MATE byter man bara fönsterhanterare till compton som finns inkluderad i en standardinstallation så man bara ändrar i inställningarna.

Har intel grafik, skylake och kaby lake.

Trädvy Permalänk
Medlem
Registrerad
Mar 2010
Skrivet av niclasc:

Suck. Standard Linux community svar. Hjälp till och lös det själv.

Nu är det ju så att alla är inte programerare

Ja, men det är ju så det är tyvärr. Var samma sak med Windows innan Vista. VSync var av som default, så man fick tearing såvida man inte hade en grafikdriver som tvingade på det på skrivbordet.
Men jag håller med om att de flesta "användarvänliga" distros borde ha VSync på som standard vid det här laget.

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Jag har kört linux i många år men aldrig haft bekymmer med screentearing.
Visserligen använder jag ofta AMD hårdvara i linux men ändå.
När uppstår bekymret? I en DE eller när du spelar eller ser video?
Lider du alltid av screentearing?
Tycker det var tunt med information och beskrivning.

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av niclasc:

Har under många år av och till testat massor av olika linuxdistar. Manjaro, Arch, Linux mint, Ubuntu, mm
Det som är gemensamt för ALLA är att man har sceentearing vid en standardinstallation. Och varje gång en massa trixande för att få ordning på det.

Hårdvaran jag har kört har varit med Intel grafik, men på senare tid kör jag ett Nvidoa 1050Ti men det är samma problem där

Just nu testar jag Manjaro KDE med Nvidia 1050Ti och det är inget undantag. Screentearing from hell. Testar lite tips, men det blir inte bättre

NÄR ska Linuxdistarna få ordning på en så viktig sak?

Eftersom det är "vi" som skapar linuxdistarna mer eller mindre, så får "vi" hitta workarounds.
För nvidia är det en baggis. Kör du med propretiär nvidia drivrutin eller med nouveau?

Om du kör med propretiär nvidia så skapa ett script som körs vid start av din DE (första gången kan det ta lite tid, då det skall skapas lite nya conf-filer m.m. men när du gjort det här några gånger så tar det max ett par minuter om du ominstallerat datorn eller liknande.

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Saxat från Arch Linux wiki

"Avoid screen tearing

Tearing can be avoided by forcing a full composition pipeline, regardless of the compositor you are using. To test whether this option will work, run:
$ nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
This however has been reported to reduce the performance of some OpenGL applications and may produce issues in WebGL.
In order to make the change permanent, it must be added to the "Screen" section of your Xorg configuration file. When making this change, TripleBuffering should be enabled and AllowIndirectGLXProtocol should be disabled in the driver configuration as well. See example configuration below:
/etc/X11/xorg.conf.d/20-nvidia.conf
Section "Screen"
Identifier "Screen0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
Option "AllowIndirectGLXProtocol" "off"
Option "TripleBuffer" "on"
EndSection
If you do not have an Xorg configuration file, you can create one for your present hardware using nvidia-xconfig (see NVIDIA#Automatic configuration) and move it from /etc/X11/xorg.conf to the preferred location /etc/X11/xorg.conf.d/20-nvidia.conf."

https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#A...

i7
GTX
4K

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001

Jag har gjort som ovan i min xorg.conf. Det funkar mot tearing men i Gnome släpar fönstren långt efter muspekaren när man drar runt dem. För att komma till rätta med det har jag följande script:

/etc/profile.d/tearing.sh

export CLUTTER_VBLANK=none export __GL_SYNC_TO_VBLANK=1 export __GL_SYNC_DISPLAY_DEVICE=DFP-0 export __VDPAU_NVIDIA_SYNC_DISPLAY_DEVICE=DFP-0

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

@Dockland: Testade med:
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Då blev jag faktiskt av med screen tearing

Men jag har ingen /etc/X11/xorg.conf.d/20-nvidia.conf

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av niclasc:

@Dockland: Testade med:
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Då blev jag faktiskt av med screen tearing

Men jag har ingen /etc/X11/xorg.conf.d/20-nvidia.conf

Vad bra, ang *.conf, skapa den. I linux skriver du bara (i terminalen)

sudo nano /etc/X11/xorg.conf.d/20-nvidia.conf

...och trycker Enter så är den skapad. Du kan skapa en fil automagiskt i nvidia-settings GUI, bland inställningarna där. Skall kolla nästa gång jag är inne i linux.

Sedan i nano så klistrar du in, precis som i terminalen, med CTRL SHIFT och V
spara med CTRL +O (bokstaven, inte siffran noll) och stäng sedan fönstret med CTRL +W ähum... CTRL +X så klart.

Kolla upp övriga ev. parametrar som skall vara i 20-nvidia.conf

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

@Dockland: Menar du att jag ska lägga in "nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"" i 20-nvidia.conf?

Det är väl inte så den filen ska se ut

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Har inte heller upplevt tearing på Intel-grafik så länge composition är påslaget. Längesedan jag provade något grafikkort från Nvidia eller AMD i Linux.

Roten till allt ont finns såklart i det uråldriga härket som heter X.org som först släpptes någon gång när mammutarna vandrade på jorden. Det positiva är att lösningen på alla grafikproblemen stavas Wayland och är på god väg att ersätta X.org.

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av niclasc:

@Dockland: Menar du att jag ska lägga in "nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"" i 20-nvidia.conf?

Det är väl inte så den filen ska se ut

Japp.

Nope, så skall den inte se ut. Den kan se ut så här för dig, till exempel:

Section "Device" Identifier "Nvidia Card" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection Section "Screen" Identifier "Screen0" Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" Option "AllowIndirectGLXProtocol" "off" Option "TripleBuffer" "on" EndSection

Då bör det fungera för dig. Såvida du har en monitor bara. Har du fler monitors/monitorer (fan heter det?) så biten "{ ForceFullCompositionPipeline = On }" är det relevanta här. Klipp och klistra. Skiter det sig hjälper jag dig så du kommer på banan igen.

Edit:

Terminalen, se nedan:

Automatic configuration
The NVIDIA package includes an automatic configuration tool to create an Xorg server configuration file (xorg.conf) and can be run by:
# nvidia-xconfig

sedan kopierar du filen

If you do not have an Xorg configuration file, you can create one for your present hardware using nvidia-xconfig (see NVIDIA#Automatic configuration) and move it from /etc/X11/xorg.conf to the preferred location /etc/X11/xorg.conf.d/20-nvidia.conf

Om du inte redan skapat filen dvs

i7
GTX
4K

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Netgear:

Har inte heller upplevt tearing på Intel-grafik så länge composition är påslaget. Längesedan jag provade något grafikkort från Nvidia eller AMD i Linux.

Roten till allt ont finns såklart i det uråldriga härket som heter X.org som först släpptes någon gång när mammutarna vandrade på jorden. Det positiva är att lösningen på alla grafikproblemen stavas Wayland och är på god väg att ersätta X.org.

Ja, det skall bli gött. Än så länge är det buggigt som tusan för vissa DE och distributioner, så jag har disablat det.

i7
GTX
4K

Trädvy Permalänk
Medlem
Registrerad
Feb 2005

Vet att när man installerar ubuntu med intelgrafik är tearfree alternativet angett till False från start, lätt att ändra men något märkligt kan tyckas.

Trädvy Permalänk
Medlem
Plats
Finspång
Registrerad
Okt 2003

@Dockland: Tack för hjälpen.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007
Skrivet av Kamraten:

Vet att när man installerar ubuntu med intelgrafik är tearfree alternativet angett till False från start, lätt att ändra men något märkligt kan tyckas.

Till hyffsat moderna Intel-grafikkort så rekommenderas det att inte använda xf86-video-intel drivrutinen, utan istället använda den generiska modesetting drivrutinen. Och då finns inte TearFree som ett alternativ vad jag vet, det ska fungera automagiskt bara man använder en compositor. Jag höll på och mekade med det på min laptop för ett tag sedan, och efter att ha testat det mesta för att bli av med tearingen så visade sig lösningen vara att bara avinstallera xf86-video-intel. Ubuntu verkar redan valt att göra sig av med xf86-video-intel.

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Kamraten:

Vet att när man installerar ubuntu med intelgrafik är tearfree alternativet angett till False från start, lätt att ändra men något märkligt kan tyckas.

Det kan vara att det suger lite kräm/prestanda med den satt till "True" om man nu inte har tearing.
Har faktiskt inte upplevt tearing med Arch, Ubuntu, Funtoo på mitt nya bygge. (6900K med GTX 1080 och propretiära drivisarna från Nvidia) Däremot med mitt gamla GTX 960 på i7 4790K hade jag det ideligen. Märkligt och inte så konsekvent.

i7
GTX
4K

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av perost:

Till hyffsat moderna Intel-grafikkort så rekommenderas det att inte använda xf86-video-intel drivrutinen, utan istället använda den generiska modesetting drivrutinen. Och då finns inte TearFree som ett alternativ vad jag vet, det ska fungera automagiskt bara man använder en compositor. Jag höll på och mekade med det på min laptop för ett tag sedan, och efter att ha testat det mesta för att bli av med tearingen så visade sig lösningen vara att bara avinstallera xf86-video-intel. Ubuntu verkar redan valt att göra sig av med xf86-video-intel.

Just. Tack för påminnelsen. På mina Intel NUC hade jag ett helsefyr med tearing minns jag. Körde xfce på dessa, och stängde av default compositor och installerade compton. Lade till den i uppstart via compton -b har jag för mig och sedan rullade det på fint.

i7
GTX
4K