Råkade trixa bort min supoer key (win key)

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

Råkade trixa bort min supoer key (win key)

Skulle testa i3 lite lätt och gjorde en emerge på lite paket enl Gentoo Handbook so far so good, men valde Win key på configuration guide initialt, och nu har jag ingen super key alls. Är inne i Xfce och har avinstallerat allt i3 relaterat för nu, men vilken ändring har i3 gjort som gör att windows key/Super key inte reagerar längre? Helt död.

Alla mina shortcuts knutna till den tangenten fungerar inte längre i Xfce.

Har kollat keyboard.conf och där ser allt rätt ut och WINDOWSKEY är satt till YES.

Har dock inte startat om, men det är linux och skall inte behövas.

Jag trodde i min enfald att olika DE är helt oberoende av varandra, men så är nog inte fallet.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013

Vad händer om du kör xev i terminalen och trycker på Win-tangenten?

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Är ingen expert på detta, men även om du inte behöver starta om datorn efter du ändrat i en config fil behöver du fortfarande få ditt OS att ladda om inställningarna i den. Att starta om din DE tex kanske räcker, men tror inte det sker automatiskt.

För övrigt, har du kollat i XFCEs gui? Där finns inställningar för tangentbordet.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Provat att logga ut och in igen. Väldigt ofta så laddar det om rätt inställningar. Annars prova CTRL + ALT + BACKSPACE vilket laddar om din X-server från början. (Stäng alla program som går först.)

Vet att saker som NUM LOCK kan ändra sig utan att ändra belysningen för den när man växlar mellan CLI och GUI, kan vara samma sak här, dvs stäng av stödet för din Winkey i någon config-GUI, stäng och gör om.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

Nu har jag testat alla era förslag utan resultat. Win key/Super Key är stendöd.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Dockland:

Nu har jag testat alla era förslag utan resultat. Win key/Super Key är stendöd.

Även med xev? Du får ingen reaktion där?

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Icte:

Även med xev? Du får ingen reaktion där?

På allt utom super key. Jag testade revertera min keyboard to "system defaults" och startade om men ingen skillnad.
Tycker det är märkligt, som om xfce och i3 delar inställningarna på något vis. Det borde de inte göra kan jag tycka.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Dockland:

På allt utom super key. Jag testade revertera min keyboard to "system defaults" och startade om men ingen skillnad.
Tycker det är märkligt, som om xfce och i3 delar inställningarna på något vis. Det borde de inte göra kan jag tycka.

Ja, det låter som att något gått fel. Det lättaste att göra vore att ominstallera OS:et (p.g.a. "broken system"), kanske finns en fix men inget jag hittade via Google :/

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Icte:

Ja, det låter som att något gått fel. Det lättaste att göra vore att ominstallera OS:et (p.g.a. "broken system"), kanske finns en fix men inget jag hittade via Google :/

Nej, ominstall behövs aldrig i Gentoo eller Arch Linux. Det fixar kanske det aktuella problemet, men med risken jag gör samma misstag igen. Inte ett alternativ.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Kollat detta? https://unix.stackexchange.com/questions/44643/xfce-4-change-...

Annars kan det vara så att något korsat varandra eftersom båda bygger på X11, vilket gör att du åtminstone behöver installera om X11.

Själv kör jag ett delat system där [/] [/boot] [/home] [/root] [/usr] [/tmp] och [/var] är egna partitioner / diskar. Med avbilder på [/] och [/boot] samt alla config / installationer är i en .sh-fil.

Går extremt snabbt att återställa samt att blockera en inställning som strular med en hashtag (#). Klantar man sig gör man en återställning av senaste eller om det gått värre återställning av [/] och [/boot] och kör sedan sin .sh-fil Så är man återställd på mindre än 30 minuter.

Det bästa med detta är att din systembackup får plats på en diskett, om du bara väljer att spara aktiva ändringar, och inom några MB om du väljer att logga varje ändring reversibel.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2013
Skrivet av Dockland:

Nej, ominstall behövs aldrig i Gentoo eller Arch Linux. Det fixar kanske det aktuella problemet, men med risken jag gör samma misstag igen. Inte ett alternativ.

Nej ominstallation behövs inte oavsett Linux distribution, men när man inte hittar ett sånt här fel så är oftast en ominstallation den enklaste vägen. Förstår självfallet att du inte ger upp, kudos till dig! Men testa åtminstone att ominstallera X11 som @OldComputer skriver, det kan helt enkelt vara något i t.ex. en config fil som strular till Win-key. Kan ju även passa på att rekommendera att testa med en Live-disk för att se ifall din Win-key fungerar och inte är fysiskt trasig alt. att du kopplar i ett USB tangentbord och testar Win-key med denna (kan ha otur med hårdvaran också, även om det i detta fall inte är så troligt).

Main || Intel Core i7 980X @ 4.12GHz || ASUS Rampage III Gene || Corsair Vengeance 6x4GB @ 1800MHz || EVGA GTX 780 Reference || Creative Sound Blaster ZxR || 2x Intel 530 240 GB || Western Digital Blue WD10EZEX 1000 GB || ASUS VG248QE (no G-sync) ||
Laptop || Lenovo Thinkpad X220 4291-37G ||
Project: Pentium Clockbox || Intel Pentium G3258 ||

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av OldComputer:

Kollat detta? https://unix.stackexchange.com/questions/44643/xfce-4-change-...

Annars kan det vara så att något korsat varandra eftersom båda bygger på X11, vilket gör att du åtminstone behöver installera om X11.

Själv kör jag ett delat system där [/] [/boot] [/home] [/root] [/usr] [/tmp] och [/var] är egna partitioner / diskar. Med avbilder på [/] och [/boot] samt alla config / installationer är i en .sh-fil.

Går extremt snabbt att återställa samt att blockera en inställning som strular med en hashtag (#). Klantar man sig gör man en återställning av senaste eller om det gått värre återställning av [/] och [/boot] och kör sedan sin .sh-fil Så är man återställd på mindre än 30 minuter.

Det bästa med detta är att din systembackup får plats på en diskett, om du bara väljer att spara aktiva ändringar, och inom några MB om du väljer att logga varje ändring reversibel.

Ja det är ju en leksak och jag lär mig. Håller på att konfa useflags och uppdaterar, har lite cirkelberoenden i systemet. Försökte dra in plasma men det fixade jag inte. Lite för mastigt i nuläget.

Jag citerar ett klotter jag såg sprayat i en cykeltunnel i Tyresö
"Gör vad du vill, och när det går snett lär du dig mest"

i7
GTX
4K