Min Raspberry Pi-tråd

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017

Min Raspberry Pi-tråd

Jag fick min Raspberry Pi 3b idag, så tänkte starta en tråd där jag kan bombardera er med frågor efterhand som de dyker upp.

Jag börjar med SD-kort. Jag har ett 8GB Micro-SD, men ingenstans på min dator att koppla in det och installera Raspbian på. Skulle denna från Kjell & Co funka till det? https://goo.gl/H8LxrL

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Plats
/dev/random
Registrerad
Feb 2016

Har du möjlighet att koppla in 'vanliga' sd-kort så borde det fungera. Har du inte det är det kanske bättre med något i stil med:

https://www.kjell.com/se/sortiment/dator-natverk/datortillbeh...

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017
Skrivet av Naki:

Har du möjlighet att koppla in 'vanliga' sd-kort så borde det fungera. Har du inte det är det kanske bättre med något i stil med:

https://www.kjell.com/se/sortiment/dator-natverk/datortillbeh...

Ja, men den skulle ju funka också. Inte så farligt pris heller. Tack

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017

MÅSTE jag ha ett SD med OS på för att den ska starta alls? Jag kopplade in HDMI till skärm och en strömförsörjning. En röd diod lyser, men skärmen säger att den inte får signal. Finns det ett BIOS på sig från start, eller kräver det SD?

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Nov 2002

Kräver ett SD kort..

Pentium i5 3,30ghz
16gb ram
Crossfire HD radeon 7970..

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017

Skulle detta funka? https://goo.gl/8Pcxqe

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Plats
~/Karlstad
Registrerad
Dec 2005

Gå till Kjell och co. De säljer minneskort med förinstallerat OS på
https://www.kjell.com/se/sortiment/dator-natverk/enkortsdator/raspberry-pi/forinstallerat-minneskort-till-raspberry-pi-p88001

Ta inte illa upp men med tanke på dina frågor så är det nog en vettig idé.
Har för mig att de säljer en bok om pi också där du kan lära dig lite grunder etc.

Till skillnad från en "vanlig" dator så finns det inget BIOS på en pi. Det som händer när du stoppat i strömsladden är att processorn letar efter ett SD-kort, hittar den inget giltigt så händer inget mer. Om den hittar ett SD kort som är "rätt" så läser den sen från det och kör bootsekvensen enligt instruktionerna/filerna på SD-kortet.

Bara gammalt skräp...

Trädvy Permalänk
Medlem
Plats
/dev/random
Registrerad
Feb 2016
Skrivet av TheJonaz:

Nej, det är för stort.

https://www.raspberrypi.org/documentation/installation/sd-car...

Det 'ska' gå att boota raspberry pi 3 från usb-disk eller nätverk. Det är dock ganska mycket beta över det hela ännu. Så enklast är nog att gå till Kjell och skaffa ett micro-sd med os på och sedan utforska detta när du kommit igång.

https://www.raspberrypi.org/blog/pi-3-booting-part-i-usb-mass...
https://www.raspberrypi.org/blog/pi-3-booting-part-ii-etherne...

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2010

Kortet är inte för stort, 8GB är minimum för noobs men större funkar förstås också. Vill du köra som generell dator så är noobs bra men ska du exempelvis köra retropie så kan du installera det direkt.

Skickades från m.sweclockers.com

Edit: kom på att problemet förstås var formfaktorn och inte storleken, så kortet är för stort, det är ett SD kort och du behöver micro Sd.

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017

Jag installerade NOOBS på ett SD-kort, och startade min Pie, och som bilden visar så får jag bara upp en färgglad bild som blinkar till/från. Vad kan vara fel? BEHÖVER Pie 20A laddare? Kan det vara för att jag kör med 18A (det enda som fanns hemma när jag testade)?

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Registrerad
Sep 2011

18 ampere? menar du 1,8?

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017
Skrivet av m4gnify:

18 ampere? menar du 1,8?

Ja, sorry. 2.0 vill den ha, och jag kör 1.8

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org

Trädvy Permalänk
Medlem
Plats
Kungsbacka
Registrerad
Maj 2014
Skrivet av TheJonaz:

Ja, sorry. 2.0 vill den ha, och jag kör 1.8

Jag rekomenderar denna https://www.kjell.com/se/sortiment/el-verktyg/batteriladdare/... har den själv och funkar perfekt

Här är den officiella https://www.kjell.com/se/sortiment/el-verktyg/batteriladdare/...

Chassi: Antec GX500 / HDD: WD blue 1TB / CPU: i3 6100 @ 3,7 Ghz / GPU: Sapphire Radeon RX 560 Pulse 2 GB / Kylning: Intel stock och 3st i chassit 1xpush 2xpull / PSU: Fractal Fesign Integra M 450 / MB: MSI h110 PC MATE / RAM: Crucial Ballistix Sport 2x4GB 2400 Mhz / OS: Win10 Pro / Mus: Trust GXT 32 / TB: Logitech G110 / Ljud: Logitech Z906 och Arrogant bastard hurricane / Skärm: BenQ GW2470HE / Macbook late 2006 med Ubuntu /

Trädvy Permalänk
Medlem
Plats
~/Karlstad
Registrerad
Dec 2005
Skrivet av TheJonaz:

Jag installerade NOOBS på ett SD-kort, och startade min Pie, och som bilden visar så får jag bara upp en färgglad bild som blinkar till/från. Vad kan vara fel? BEHÖVER Pie 20A laddare? Kan det vara för att jag kör med 18A (det enda som fanns hemma när jag testade)?

http://i.imgur.com/pRZC3DI.jpg

Den där "bilden" är standard vid boot då den helt enkelt kollar så att GPU-fungerar. Däremot ska bilden bara visas en kortis(de flesta hinner nog inte se den om tv:n byter HDMI etc.. under tiden).
Om pajen stannar vid denna bild så kan det bero på:
-Installationen på minneskortet är korrupt
-Strömförsörjningen är för dålig

Till en Pi 3 rekommenderas en psu som kan leverera 2.5A(för att orka driva inkopplade prylar I USB-portarna också) men jag tycker att den borde starta ändå med 1.8A om du inte har kopplat in en massa prylar I USB. Kanske har du en budget-laddare som inte levererar 1.8A(trots att det star det)? Skulle iaf prova att hitta en ny psu.

Bara gammalt skräp...

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Mar 2017

Uppdatering: Tack alla som svarat! Jag har inte "hunnit" svara alla personligen, men min Pi funkar alldeles utmärkt nu. Jag håller på att installera ZoneMinder på den, så lär väl poppa upp fler frågor allt vart efter som, men för nu är allt OK!

Tack igen alla för er hjälp hittills, jag uppskattar det!

IRC: raven @ EFNet
Web: N/A
Mail: raven (a) sosdg.org