Ubuntu Server 17.04 Samba problem

Trädvy Permalänk
Medlem
Plats
Vikmanshyttan
Registrerad
Feb 2013

Ubuntu Server 17.04 Samba problem

Tjena!
Min server som kör Ubuntu Server 17.04 slutade dela ut sina samba shares så jag gick för att kolla. Efter lite felsökande testade jag att ominstallera samba men då händer detta:

username@hostname:/$ sudo apt remove samba Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies. libnss-winbind : Depends: samba-common (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed libpam-winbind : Depends: samba-common (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed python-samba : Depends: libwbclient0 (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed samba-common-bin : Depends: samba-common (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed samba-dsdb-modules : Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed samba-vfs-modules : Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed smbclient : Depends: samba-common (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: libwbclient0 (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed winbind : Depends: samba-common (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: libwbclient0 (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed Depends: samba-libs (= 2:4.5.8+dfsg-0ubuntu0.17.04.3) but 2:4.5.8+dfsg-0ubuntu0.17.04.2 is to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). username@hostname:/$

Om jag kör apt --fix-broken install händer detta:

username@hostname:/$ sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: libccid libpcsclite1 libpkcs11-helper1 opensc opensc-pkcs11 pcscd Use 'sudo apt autoremove' to remove them. The following additional packages will be installed: libsmbclient libwbclient0 python-samba samba-common samba-libs Suggested packages: python-gpgme The following packages will be upgraded: libsmbclient libwbclient0 python-samba samba-common samba-libs 5 to upgrade, 0 to newly install, 0 to remove and 3 not to upgrade. 9 not fully installed or removed. Need to get 0 B/6,504 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Preconfiguring packages ... (Reading database ... 141619 files and directories currently installed.) Preparing to unpack .../python-samba_2%3a4.5.8+dfsg-0ubuntu0.17.04.3_amd64.deb ... File "/usr/bin/pyclean", line 63 except (IOError, OSError), e: ^ SyntaxError: invalid syntax dpkg: warning: subprocess old pre-removal script returned error exit status 1 dpkg: trying script from the new package instead ... File "/usr/bin/pyclean", line 63 except (IOError, OSError), e: ^ SyntaxError: invalid syntax dpkg: error processing archive /var/cache/apt/archives/python-samba_2%3a4.5.8+dfsg-0ubuntu0.17.04.3_amd64.deb (--unpack): subprocess new pre-removal script returned error exit status 1 Traceback (most recent call last): File "/usr/bin/pycompile", line 35, in <module> from debpython.version import SUPPORTED, debsorted, vrepr, \ File "/usr/share/python/debpython/version.py", line 24, in <module> from ConfigParser import SafeConfigParser ImportError: No module named 'ConfigParser' *** Error in `/usr/bin/dpkg': munmap_chunk(): invalid pointer: 0x0000556c2ca56954 *** ======= Backtrace: ========= /lib/x86_64-linux-gnu/libc.so.6(+0x7908b)[0x7f4b9e05108b] /lib/x86_64-linux-gnu/libc.so.6(cfree+0x1f8)[0x7f4b9e05eed8] /usr/bin/dpkg(+0x20cd0)[0x556c2bb4fcd0] /usr/bin/dpkg(+0x21119)[0x556c2bb50119] /usr/bin/dpkg(+0x283cd)[0x556c2bb573cd] /usr/bin/dpkg(+0x17737)[0x556c2bb46737] /usr/bin/dpkg(+0x17915)[0x556c2bb46915] /usr/bin/dpkg(+0x17b5d)[0x556c2bb46b5d] /usr/bin/dpkg(+0xaed7)[0x556c2bb39ed7] /usr/bin/dpkg(+0x20c0b)[0x556c2bb4fc0b] /usr/bin/dpkg(+0x20e01)[0x556c2bb4fe01] /usr/bin/dpkg(+0xa962)[0x556c2bb39962] /usr/bin/dpkg(+0x72fd)[0x556c2bb362fd] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1)[0x7f4b9dff83f1] /usr/bin/dpkg(+0x743a)[0x556c2bb3643a] ======= Memory map: ======== 556c2bb2f000-556c2bb74000 r-xp 00000000 08:21 1310792 /usr/bin/dpkg 556c2bd74000-556c2bd77000 r--p 00045000 08:21 1310792 /usr/bin/dpkg 556c2bd77000-556c2bd78000 rw-p 00048000 08:21 1310792 /usr/bin/dpkg 556c2bd78000-556c2bf8c000 rw-p 00000000 00:00 0 556c2c9da000-556c2de8e000 rw-p 00000000 00:00 0 [heap] 7f4b9c87f000-7f4b9c895000 r-xp 00000000 08:21 1049093 /lib/x86_64-linux-gnu/libgcc_s.so.1 7f4b9c895000-7f4b9ca94000 ---p 00016000 08:21 1049093 /lib/x86_64-linux-gnu/libgcc_s.so.1 7f4b9ca94000-7f4b9ca95000 r--p 00015000 08:21 1049093 /lib/x86_64-linux-gnu/libgcc_s.so.1 7f4b9ca95000-7f4b9ca96000 rw-p 00016000 08:21 1049093 /lib/x86_64-linux-gnu/libgcc_s.so.1 7f4b9ca96000-7f4b9ce28000 rw-p 00000000 00:00 0 7f4b9ce28000-7f4b9ce33000 r-xp 00000000 08:21 1053654 /lib/x86_64-linux-gnu/libnss_files-2.24.so 7f4b9ce33000-7f4b9d032000 ---p 0000b000 08:21 1053654 /lib/x86_64-linux-gnu/libnss_files-2.24.so 7f4b9d032000-7f4b9d033000 r--p 0000a000 08:21 1053654 /lib/x86_64-linux-gnu/libnss_files-2.24.so 7f4b9d033000-7f4b9d034000 rw-p 0000b000 08:21 1053654 /lib/x86_64-linux-gnu/libnss_files-2.24.so 7f4b9d034000-7f4b9d03a000 rw-p 00000000 00:00 0 7f4b9d03a000-7f4b9d045000 r-xp 00000000 08:21 1053656 /lib/x86_64-linux-gnu/libnss_nis-2.24.so 7f4b9d045000-7f4b9d244000 ---p 0000b000 08:21 1053656 /lib/x86_64-linux-gnu/libnss_nis-2.24.so 7f4b9d244000-7f4b9d245000 r--p 0000a000 08:21 1053656 /lib/x86_64-linux-gnu/libnss_nis-2.24.so 7f4b9d245000-7f4b9d246000 rw-p 0000b000 08:21 1053656 /lib/x86_64-linux-gnu/libnss_nis-2.24.so 7f4b9d246000-7f4b9d25c000 r-xp 00000000 08:21 1053651 /lib/x86_64-linux-gnu/libnsl-2.24.so 7f4b9d25c000-7f4b9d45b000 ---p 00016000 08:21 1053651 /lib/x86_64-linux-gnu/libnsl-2.24.so 7f4b9d45b000-7f4b9d45c000 r--p 00015000 08:21 1053651 /lib/x86_64-linux-gnu/libnsl-2.24.so 7f4b9d45c000-7f4b9d45d000 rw-p 00016000 08:21 1053651 /lib/x86_64-linux-gnu/libnsl-2.24.so 7f4b9d45d000-7f4b9d45f000 rw-p 00000000 00:00 0 7f4b9d45f000-7f4b9d467000 r-xp 00000000 08:21 1053652 /lib/x86_64-linux-gnu/libnss_compat-2.24.so 7f4b9d467000-7f4b9d666000 ---p 00008000 08:21 1053652 /lib/x86_64-linux-gnu/libnss_compat-2.24.so 7f4b9d666000-7f4b9d667000 r--p 00007000 08:21 1053652 /lib/x86_64-linux-gnu/libnss_compat-2.24.so 7f4b9d667000-7f4b9d668000 rw-p 00008000 08:21 1053652 /lib/x86_64-linux-gnu/libnss_compat-2.24.so 7f4b9d668000-7f4b9d943000 r--p 00000000 08:21 1318020 /usr/lib/locale/locale-archive 7f4b9d943000-7f4b9d95b000 r-xp 00000000 08:21 1053659 /lib/x86_64-linux-gnu/libpthread-2.24.so 7f4b9d95b000-7f4b9db5b000 ---p 00018000 08:21 1053659 /lib/x86_64-linux-gnu/libpthread-2.24.so 7f4b9db5b000-7f4b9db5c000 r--p 00018000 08:21 1053659 /lib/x86_64-linux-gnu/libpthread-2.24.so 7f4b9db5c000-7f4b9db5d000 rw-p 00019000 08:21 1053659 /lib/x86_64-linux-gnu/libpthread-2.24.so 7f4b9db5d000-7f4b9db61000 rw-p 00000000 00:00 0 7f4b9db61000-7f4b9db64000 r-xp 00000000 08:21 1053647 /lib/x86_64-linux-gnu/libdl-2.24.so 7f4b9db64000-7f4b9dd63000 ---p 00003000 08:21 1053647 /lib/x86_64-linux-gnu/libdl-2.24.so 7f4b9dd63000-7f4b9dd64000 r--p 00002000 08:21 1053647 /lib/x86_64-linux-gnu/libdl-2.24.so 7f4b9dd64000-7f4b9dd65000 rw-p 00003000 08:21 1053647 /lib/x86_64-linux-gnu/libdl-2.24.so 7f4b9dd65000-7f4b9ddd7000 r-xp 00000000 08:21 1049147 /lib/x86_64-linux-gnu/libpcre.so.3.13.3 7f4b9ddd7000-7f4b9dfd6000 ---p 00072000 08:21 1049147 /lib/x86_64-linux-gnu/libpcre.so.3.13.3 7f4b9dfd6000-7f4b9dfd7000 r--p 00071000 08:21 1049147 /lib/x86_64-linux-gnu/libpcre.so.3.13.3 7f4b9dfd7000-7f4b9dfd8000 rw-p 00072000 08:21 1049147 /lib/x86_64-linux-gnu/libpcre.so.3.13.3 7f4b9dfd8000-7f4b9e196000 r-xp 00000000 08:21 1053644 /lib/x86_64-linux-gnu/libc-2.24.so 7f4b9e196000-7f4b9e395000 ---p 001be000 08:21 1053644 /lib/x86_64-linux-gnu/libc-2.24.so 7f4b9e395000-7f4b9e399000 r--p 001bd000 08:21 1053644 /lib/x86_64-linux-gnu/libc-2.24.so 7f4b9e399000-7f4b9e39b000 rw-p 001c1000 08:21 1053644 /lib/x86_64-linux-gnu/libc-2.24.so 7f4b9e39b000-7f4b9e39f000 rw-p 00000000 00:00 0 7f4b9e39f000-7f4b9e3c4000 r-xp 00000000 08:21 1049162 /lib/x86_64-linux-gnu/libselinux.so.1 7f4b9e3c4000-7f4b9e5c3000 ---p 00025000 08:21 1049162 /lib/x86_64-linux-gnu/libselinux.so.1 7f4b9e5c3000-7f4b9e5c4000 r--p 00024000 08:21 1049162 /lib/x86_64-linux-gnu/libselinux.so.1 7f4b9e5c4000-7f4b9e5c5000 rw-p 00025000 08:21 1049162 /lib/x86_64-linux-gnu/libselinux.so.1 7f4b9e5c5000-7f4b9e5c7000 rw-p 00000000 00:00 0 7f4b9e5c7000-7f4b9e5ed000 r-xp 00000000 08:21 1048977 /lib/x86_64-linux-gnu/ld-2.24.so 7f4b9e615000-7f4b9e7e0000 rw-p 00000000 00:00 0 7f4b9e7e6000-7f4b9e7e7000 rw-p 00000000 00:00 0 7f4b9e7e7000-7f4b9e7e9000 r--p 00000000 08:21 3016865 /usr/share/locale-langpack/en_GB/LC_MESSAGES/dpkg.mo 7f4b9e7e9000-7f4b9e7ec000 rw-p 00000000 00:00 0 7f4b9e7ec000-7f4b9e7ed000 r--p 00025000 08:21 1048977 /lib/x86_64-linux-gnu/ld-2.24.so 7f4b9e7ed000-7f4b9e7ee000 rw-p 00026000 08:21 1048977 /lib/x86_64-linux-gnu/ld-2.24.so 7f4b9e7ee000-7f4b9e7ef000 rw-p 00000000 00:00 0 7ffd33fb5000-7ffd33fd6000 rw-p 00000000 00:00 0 [stack] 7ffd33fe2000-7ffd33fe4000 r--p 00000000 00:00 0 [vvar] 7ffd33fe4000-7ffd33fe6000 r-xp 00000000 00:00 0 [vdso] ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall] E: Sub-process /usr/bin/dpkg exited unexpectedly username@hostname:/$

Jag är extremt n00b med linux så jag har verkligen ingen aning hur jag ska göra, någon som har en idé?

| i5 4690k 4.7GHz @ 1.245V på Luft | 16GB | R9 280X @ 1200MHz |

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Okt 2007

Du försöker ta bort ett paket som en massa andra paket du har installerade är beroende av. Det brukar vara lämpligare att installera om ett paket med:

sudo apt-get install --reinstall paketnamn

Vad händer om du kör det?