Jumbo frame funkar inte vet inget vart felet ligger i FreeNAS, switch, ESXI 5.5

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Jumbo frame funkar inte vet inget vart felet ligger i FreeNAS, switch, ESXI 5.5

Tjo,

Har börjat tröttat nu har hållit på ett tag men vet inte vart felet ligger i om det är FreeNAS eller ESXI eller switch (SG200-28) som gör att det inte funkar.

Jag har gjort en ESXI 5.5 vswitch distributed och jag har sätt allt på MTU 9000.

Och jag har gått in i switch och tryck på Jumbo frame.

Skulle behöva råd någon som har lust att skriva?

Känns som hjärnan är tom får inte fram mera ord kanske är för jag är trött jag uppdatera inlägget i morgon.

Edit:

ESXI 5.5:

vmnic4 0000:05:00.02 igb Up 1000Mbps Full 00:25:90:96:7b:42 9000 Intel Corporation I350 Gigabit Network Connection vmnic5 0000:05:00.03 igb Up 1000Mbps Full 00:25:90:96:7b:43 9000 Intel Corporation I350 Gigabit Network Connection

DVS Name Num Ports Used Ports Configured Ports MTU Uplinks SAN 5632 7 512 9000 vmnic5,vmnic4

FreeNAS:

switch (SG200-28):

Jag har provat

vmkping -d -s 4000 10.4.0.12

funkar inte

vmkping -d -s 1400 10.4.0.12

funkar.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003
Skrivet av superegg:

Tjo,

Har börjat tröttat nu har hållit på ett tag men vet inte vart felet ligger i om det är FreeNAS eller ESXI eller switch (SG200-28) som gör att det inte funkar.

Jag har gjort en ESXI 5.5 vswitch distributed och jag har sätt allt på MTU 9000.

Och jag har gått in i switch och tryck på Jumbo frame.

Skulle behöva råd någon som har lust att skriva?

Känns som hjärnan är tom får inte fram mera ord kanske är för jag är trött jag uppdatera inlägget i morgon.

Edit:

ESXI 5.5:

vmnic4 0000:05:00.02 igb Up 1000Mbps Full 00:25:90:96:7b:42 9000 Intel Corporation I350 Gigabit Network Connection vmnic5 0000:05:00.03 igb Up 1000Mbps Full 00:25:90:96:7b:43 9000 Intel Corporation I350 Gigabit Network Connection

DVS Name Num Ports Used Ports Configured Ports MTU Uplinks SAN 5632 7 512 9000 vmnic5,vmnic4

FreeNAS:

//i.imgur.com/YVl24nY.png

switch (SG200-28):

//i.imgur.com/r5o9tTO.png

Jag har provat

vmkping -d -s 4000 10.4.0.12

funkar inte

vmkping -d -s 1400 10.4.0.12

funkar.

Du startade om switchen efter att du slog på jumbo frames?
Fungerar det om du skippar switchen?

| Citera för svar! | Gilla bra inlägg! |

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av BrusE:

Du startade om switchen efter att du slog på jumbo frames?
Fungerar det om du skippar switchen?

Jag är inte säker man den bör funka det är bara att det inte går att pinga över en viss gräns.

Jag har hittat detta som gör att det inte går att pinga https://sbkb.cisco.com/CiscoSB/GetArticle.aspx?docid=8eb5312d... och jag har läst att det finns en bug på denna switch.

Jumbo frames är på och jag har starta om den.

Får testa det när jag kommer hem igen.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Vad har du för NIC i burkarna, det finns en del som "bara" klarar en storlek på 8996 och inte 9000. Borde inte vara ett problem när du pingar med en storlek på 4000 men kan vara värt att prova.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Xcorp:

Vad har du för NIC i burkarna, det finns en del som "bara" klarar en storlek på 8996 och inte 9000. Borde inte vara ett problem när du pingar med en storlek på 4000 men kan vara värt att prova.

Har Intel i350-T4.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Hedersmedlem
Plats
QuakeNet
Registrerad
Jul 2001

Har hört om mycket strul med LAGG och Jumbo Frames på FreeNAS. Det finns vissa som säger att du innan du skapar LAGG-gränssnittet måste sätta MTU 9000 på samtliga ingående interfaces, och sedan skapa LAGG-gränsssnittet och även sätta det till 9000.

SWECLOCKERS.COM :: If Quake was done today :: Serverrum
WS: Asus P9X79 :: Core i7 3820 :: 32 GB RAM :: Samsung 830 256 GB :: 2x Intel 910 400 GB PCIE :: PNY Geforce GTX 970 XLR8 :: Gigabyte Odin GT 800W :: 2x Samsung Syncmaster S27A950D
NAS: SuperMicro X10-SLM-F :: Core i3 4130T :: 24 GB Kingston ECC :: Ri-Vier RVS2-06A 12Bay 2U :: IBM M1015 (IT) :: Mellanox Connect2X SFP+ :: Intel XL710-QDA1 QSFP+ ::

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Kr^PacMan:

Har hört om mycket strul med LAGG och Jumbo Frames på FreeNAS. Det finns vissa som säger att du innan du skapar LAGG-gränssnittet måste sätta MTU 9000 på samtliga ingående interfaces, och sedan skapa LAGG-gränsssnittet och även sätta det till 9000.

Hehe har hittat felet man skulle skriva "mtu" och inte "MTU".

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Nytt problem load balancing funkar inte

Tjo,

Vill inte göra en ny tråd för detta.

Jag har nu fått LACP att funka på NFS men den vill inte använda load balancing så den skicka bara på en anslutning.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Det beror lite på vilken algoritm som används för lastbalanseringen, vanligt är att man gör det på MAC-adress och då udda/jämn sista byte. Testa att köra från en klient till samtidigt, och då helst med en "motstående" MAC-adress.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Xcorp:

Det beror lite på vilken algoritm som används för lastbalanseringen, vanligt är att man gör det på MAC-adress och då udda/jämn sista byte. Testa att köra från en klient till samtidigt, och då helst med en "motstående" MAC-adress.

Jag har ställt in den på ip adresseren.

"Testa att köra från en klient till samtidigt, och då helst med en "motstående" MAC-adress."

Hur ska jag få NFS på ESXI att använda flera vmk? Lägga dom på olika vlan?

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Dec 2008
Skrivet av superegg:

Jag har ställt in den på ip adresseren.

"Testa att köra från en klient till samtidigt, och då helst med en "motstående" MAC-adress."

Hur ska jag få NFS på ESXI att använda flera vmk? Lägga dom på olika vlan?

Du måste ha dubbla IP-adresser bland annat. Guiden nedan har ett annat SAN än din freenas men du borde se ungefär tänket.
https://www.youtube.com/watch?v=3wIi3E3Ji8A

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av jocke92:

Du måste ha dubbla IP-adresser bland annat. Guiden nedan har ett annat SAN än din freenas men du borde se ungefär tänket.
https://www.youtube.com/watch?v=3wIi3E3Ji8A

Ser jättebra ut dock så kör jag med ESXI 5.5U4 och den stöder inte NFS4.1.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Det hade underlättat lite med en beskrivning av mellan vad du försöker skicka data/använda LACP.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Xcorp:

Det hade underlättat lite med en beskrivning av mellan vad du försöker skicka data/använda LACP.

Jag försöker använda mig av NFS.

Men jag har läst på FreeNAS forum att det blir inte 2000 mbit utan man måste då köra med två NFS client som man kan göra med multipath men det funkar bara på version 4.1 och då jag använder mig av ESXI 5.5U4 som inte stöder den version så finns det väl inte mycket man kan göra utan att köpa bättre nätverkskort.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

@superegg: Om du kör lastbalansering på IP så kommer det inte spela någon roll hur många NFS-klienter du kör på den fysiska klienten (om du inte kör med flera IPs och krånglar). Varför inte köra NFS-servern som en VM, då är du ju inte bunden till den version som ESXI kör.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Xcorp:

@superegg: Om du kör lastbalansering på IP så kommer det inte spela någon roll hur många NFS-klienter du kör på den fysiska klienten (om du inte kör med flera IPs och krånglar). Varför inte köra NFS-servern som en VM, då är du ju inte bunden till den version som ESXI kör.

Det är sant.

"Varför inte köra NFS-servern som en VM, då är du ju inte bunden till den version som ESXI kör."

Jag håller på att bygga upp ett SAN med FreeNAS som os och jag har köpt en kraftfull serverdator för just det som ska används bara för lagning och jag har flera serverdator som behöver mera hårddiskutrymme.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666