Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Wallet i debian.

Jag försöker hjälpa en vän att lägga till en plånbok i Debian, jag är rätt ny på detta och har inte lyckats läsa mig till hur jag ska gå till väga. Plånboken i fråga finns på leocoin.org , men då jag tar hem filen så är den i *.gz format, packar upp denna och finner en fil som heter LEOcoin-qt, har inte en aning om vad jag ska göra med denna filen, hittar ingen information angående hur jag ska bete mig på nätet heller.

Mejlade deras support, och svaret jag fick var inte till någon större hjälp, detta skrev dom:

Aren't the files in the compressed .gz sufficient?
You could also try to use the source files on GitHub to manually install
from there in Linux.

Knallade in på GitHub och hittade filen jag söker, men förstår inte riktigt hur jag ska lyckas installera den.

Någons som känner för att hjälpa en nybörjare?

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Maj 2013

Vad får du om du kör:

$ file LEOcoin-qt

För OSX verkar det som man ska köra filen så det borde vara att köra:

$ ./LEOcoin-qt

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Jun 2006

Det är filer som skall köras som Aene påpekar i .gzippen. Packa upp zippen, gör programmet körbart i en terminal, så skall det fungera fint. Från katalogen där den körbara finns finns:

chmod +x ./LEOcoin
./LEOcoin

När jag testade så var jag tvungen att installera libqt5webkit5 för att kunna köra det, men det blir tydligt om du startar det från en terminal.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

$ file LEOcoin-qt
bernt@debian:~/Hämtningar/LEOcoin-2.1.2.0-Linux$ file LEOcoin-qt
LEOcoin-qt: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=9cb20a43a4dd10e22e6cab8ab01f49b917630585, not stripped

$ ./LEOcoin-qt

bernt@debian:~/Hämtningar/LEOcoin-2.1.2.0-Linux$ ./LEOcoin-qt
./LEOcoin-qt: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory
bernt@debian:~/Hämtningar/LEOcoin-2.1.2.0-Linux$

Verkar som om jag saknar något i systemet.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Jun 2006

Du behöver paketet libqt5widgets5.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av gusnan:

Du behöver paketet libqt5widgets5.

Lägger in det nu och testar igen få se.. Tack för hjälpen än så länge.

Edit --
Nu blir jag snart tokig på detta, plånboken startar som den ska. Men så dyker det upp att den ska uppdateras. Ska ta hem den "nya" filen få se vad det ger..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Detta står att läsa i readme filen, har gjort steg ett, vilket är att installera qmake .

First, make sure that the required packages for Qt5 development of your distribution are installed, for Debian and Ubuntu these are: apt-get install qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools build-essential libboost-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev libssl-dev libdb++-dev libminiupnpc-dev libqt5webkit5-dev then execute the following: qmake make

Då jag kör qmake i mappen src så ser allt ut att fungera.

Project MESSAGE: Building with UPNP support Project MESSAGE: Building with DBUS (Freedesktop notifications) support

Men när jag sedan ska köra make tar det stopp. Ska det läggas till något mer på make? Har fått en fil som heter "makefile", och på den är det ett hänglås.

Får felmeddelande

root@debian:/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src# make cd /home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb && CC=gcc CXX=g++ make OPT="-m64 -pipe -fstack-protector-all --param ssp-buffer-size=1 -O2" libleveldb.a libmemenv.a make[1]: Går till katalogen ”/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb” /bin/sh: 1: ./build_detect_platform: Permission denied Makefile:21: build_config.mk: Filen eller katalogen finns inte make[1]: *** Ingen regel för att skapa målet ”build_config.mk”. Stannar. make[1]: Lämnar katalogen ”/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb” Makefile:709: receptet för målet ”/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb/libleveldb.a” misslyckades make: *** [/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb/libleveldb.a] Fel 2 root@debian:/home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src#

Detta säger inte mig så mycket mer än att något inte gått som det skulle.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Feb 2004

Du har inte rättighet att köra build_detect_platform.
Testa:

chmod +x build_detect_platform

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av BuruZ:

Du har inte rättighet att köra build_detect_platform.
Testa:

chmod +x build_detect_platform

Hmm..

chmod: Kan inte komma åt 'build_detect_platform' : Filen eller katalogen finns inte

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Nov 2004

@mindflow: Står du i rätt mapp när du kör

chmod +x build_detect_platform

Prova annars

chmod +x /home/bernt/Hämtningar/LEOcoin-v3.0.6.3-linux64/64/src/src/leveldb/build_detect_platform

WS: MSI B350M Mortar | AMD Ryzen 7 1700 | PH-TC14PE | 32GB DDR4 3000MHz | 120GB Intel 530 | 2*500GB HDD | Asus R9 290X DCU2 4GB | 2*LG W2242PE
Router: Gigabyte GA-870-UD3 | AMD Phenom II x6 1055t @ 2600MHz, 1.25V | 12GB DDR3 | 2*250GB HDD @ RAID1 | 2TB HDD
Laptop: Thinkpad X220 4291-QF6

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Då var "make" avklarat, men hur vet jag på vilket sätt jag "startar" denna plånbok?

:-- edit

Hur får jag rätt på vilken fil det är jag ska köra? Fick en uppsjö av olika, men finns inget som talar om vilken som är körbar..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.