Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Drivrutiner grafik.

Håller på att försöka lära mig lite angående installera i Debian. Nu har jag fått igång pekplattan och wifi, men går bet på grafikkortet. Gick in på HP's sida och försökte få fram vad drivrutinerna heter, men fanns inga listade. Hur gör jag för att enklast få reda på vilka drivrutiner som saknas? Datorn i fråga heter

HP Pavilion Notebook - 15-ab124no

Operativet är Debian 9 Jessie - Cinnamon

Någon här som orkar förklara för en nybörjare, eller vet om någon bra guide om hur jag går till väga?

Tacksam för svar.

Ps. Har googlat en del, men inte fått någon bra förklaring på hur jag identifierar maskinvaran.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
/var/www
Registrerad
Maj 2008

@mindflow:

Vad är det för grafikkort?

got root?

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Apr 2009

Normalt sett behöver du inga andra grafikortsdrivrutiner än de som finns i kärnan.
Att hålla på med drivrutiner är Windowstänk.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Är det Intel eller AMD-grafik i datorn behöver du inte göra någonting. Deras drivrutiner är open source och levereras därför med din distro och hålls uppdaterade automatiskt.

Nvidia är lite annorlunda. Det finns en öppen Nvidia-drivare (Nouveau) men denna har inget officiellt stöd från Nvidia utan det är mer eller mindre ett hobbyprojekt från ett fåtal personer. Förmodligen är det oftast bättre att använda Nvidias proprietära drivrutin.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av edroon:

@mindflow:

Vad är det för grafikkort?

Just det jag inte vet, hittills har jag kunnat gå in på tillverkarens hemsida, sedan kollat vad drivrutinen heter där, efter det tagit hem motsvarande paket till debian, sedan fått det att fungera, men nu när jag försöker få fram drivrutiner på HP's sida så kommer det inte upp en enda drivrutin, och därmed är jag rökt på vad det sitter för PCI kort i den..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av Brisse:

Är det Intel eller AMD-grafik i datorn behöver du inte göra någonting. Deras drivrutiner är open source och levereras därför med din distro och hålls uppdaterade automatiskt.

Nvidia är lite annorlunda. Det finns en öppen Nvidia-drivare (Nouveau) men denna har inget officiellt stöd från Nvidia utan det är mer eller mindre ett hobbyprojekt från ett fåtal personer. Förmodligen är det oftast bättre att använda Nvidias proprietära drivrutin.

Står något om att "accelerator inte är installerad, och därför upplevs datorn som slö". Har ingen tillgång till att ändra upplösning eller något åt det hållet..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Skriv följande i terminalen och berätta vad du får för svar:

glxinfo | grep Device

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Hittade datorns specifikationer här:
https://support.hp.com/us-en/product/hp-pavilion-15-ab100-not...

Du har AMD-grafik.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av mindflow:

Just det jag inte vet, hittills har jag kunnat gå in på tillverkarens hemsida, sedan kollat vad drivrutinen heter där, efter det tagit hem motsvarande paket till debian, sedan fått det att fungera, men nu när jag försöker få fram drivrutiner på HP's sida så kommer det inte upp en enda drivrutin, och därmed är jag rökt på vad det sitter för PCI kort i den..

Får man fråga vad du menar med "motsvarande paket för debian" i detta fallet? Vad exakt har du installerat? Förmodligen har du gjort mer skada än nytta om du har installerat något extra.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

@Brisse: Denna dator har jag fått igång pekplatta och wifi, men har inte lagt in något för grafikkortet..

Vad heter paketet i debian? Söker jag på amd får jag en massa träffar, och är inte riktigt säker på vilket jag ska välja..

Hittade nu "amd-libopencl1" vilket ser ut att vara en bra kandidat..

Glömde lägga in svaret på din fråga:

glxinfo | grep Device ger mig llvmpipe (LLVM 3.9, 128 bits) (0xffffffff)

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av mindflow:

Söker jag på amd får jag en massa träffar, och är inte riktigt säker på vilket jag ska välja..

Du ska inte välja någonting. Du behöver inte ens sitta och leta. Vi har ju sagt att om man har AMD-grafik så är redan rätt drivrutiner inbyggda i Debian.

Det gäller förövrigt det mesta i Linux. Att sitta och leta drivrutiner på nätet är Windows-tänk, och när man går över till Linux bör man lämna det tankesättet bakom sig. Det är bara om man har någon speciell eller ovanlig hårdvara som man behöver tänka så.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av Brisse:

Det gäller förövrigt det mesta i Linux. Att sitta och leta drivrutiner på nätet är Windows-tänk, och när man går över till Linux bör man lämna det tankesättet bakom sig. Det är bara om man har någon speciell eller ovanlig hårdvara som man behöver tänka så.

Då grafiken inte fungerar som den ska så är det något som fattas, kan inte ändra upplösning, kan inte heller se x på terminal/fönster jag öppnat, så får stänga dem via Alt+F4 . Jag vet tyvärr inte riktigt vad jag ska göra för att få igång grafiken som det är tänkt.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av mindflow:

glxinfo | grep Device ger mig llvmpipe (LLVM 3.9, 128 bits) (0xffffffff)

Detta betyder att grafik emuleras på din CPU och att din GPU inte används. Något är fel med andra ord.

Skrivet av mindflow:

Hittade nu "amd-libopencl1" vilket ser ut att vara en bra kandidat..

Nej, opencl är ett API för GPGPU-compute. Det har du ingen nytta av i detta fallet.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

@Brisse: Ok. Hur kan jag lösa det problemet? Just nu har jag inte en aning om vad jag ska googla på, eller försöka rätta till i datorn.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007
Skrivet av mindflow:

Ok. Hur kan jag lösa det problemet? Just nu har jag inte en aning om vad jag ska googla på, eller försöka rätta till i datorn.

Debians Wiki har instruktioner för vilka paket man ska installera, så börja med det.

Tillägg: Hmm, fast instruktionerna visar hur man installerar xserver-xorg-video-ati, samtidigt som texten tidigare säger att det är xserver-xorg-video-amdgpu man vill ha för nyare grafikkort. Sen är det lite oklart vilken version av Debian du installerat, eftersom Debian 9 heter Stretch medan Jessie är Debian 8.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

De drivrutiner som medföljer Debian är väldigt gamla. Du kanske skulle testa Debian Testing och se om det fungerar? Då får du betydligt nyare drivrutiner.

Instruktioner för hur man går över till Debian Testing finns här:
https://wiki.debian.org/DebianTesting

Alternativt kan du testa någon annan Linux-distribution, som exempelvis de närbesläktade Ubuntu eller Mint. De har också betydligt nyare drivrutiner än vad Debian har.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av perost:

Debians Wiki har instruktioner för vilka paket man ska installera, så börja med det.

Tillägg: Hmm, fast instruktionerna visar hur man installerar xserver-xorg-video-ati, samtidigt som texten tidigare säger att det är xserver-xorg-video-amdgpu man vill ha för nyare grafikkort. Sen är det lite oklart vilken version av Debian du installerat, eftersom Debian 9 heter Stretch medan Jessie är Debian 8.

xserver-xorg-video-amdgpu används från och med GCN1.1 har jag för mig. Osäker på vilken generation trådskaparens GPU tillhör.

Edit: Trådskaparen har tydligen en Carizzo vilket är tredje generationens GCN. Därmed bör amdgpu användas.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av Brisse:

De drivrutiner som medföljer Debian är väldigt gamla. Du kanske skulle testa Debian Testing och se om det fungerar? Då får du betydligt nyare drivrutiner.

Instruktioner för hur man går över till Debian Testing finns här:
https://wiki.debian.org/DebianTesting

Alternativt kan du testa någon annan Linux-distribution, som exempelvis de närbesläktade Ubuntu eller Mint. De har också betydligt nyare drivrutiner än vad Debian har.

Jag lämnade Ubuntu eftersom det hade stora problem med mina bärbara datorer, har använt det lite på en del äldre datorer, men ville sig inte alls med nyare datorer. Har även testat Mint, men gav mig lika stora problem där. Debian använde jag mig utav till serverar för 10-12 år sedan, därför tänkte jag gå tillbaka till det. Tycker om Debian då det sällen gett mig några problem då det väl är igång..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av perost:

Debians Wiki har instruktioner för vilka paket man ska installera, så börja med det.

Tillägg: Hmm, fast instruktionerna visar hur man installerar xserver-xorg-video-ati, samtidigt som texten tidigare säger att det är xserver-xorg-video-amdgpu man vill ha för nyare grafikkort. Sen är det lite oklart vilken version av Debian du installerat, eftersom Debian 9 heter Stretch medan Jessie är Debian 8.

Tack för svar, fick igång grafiken via den länken du gav.

Glömde tacka för svar från andra som hjälpt mig. Återkommer säkerligen med fler frågor.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av mindflow:

Tack för svar, fick igång grafiken via den länken du gav.

Glömde tacka för svar från andra som hjälpt mig. Återkommer säkerligen med fler frågor.

Kul att det löste sig! Synd att det krävs manuella ingrepp för att det ska fungera dock.

Var det mikrokoden som saknades eller, så att du behövde installera firmware-amd-graphics eller firmware-linux-nonfree?

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

@Brisse: Jag använde mig av non-free . Men upptäckte något lite knepigt nu, då jag använt datorn en liten stund så tiltar den skrivbordet så menyn hamnar på höger sida av skärmen, då menar jag hela skrivbordet. Muspekaren går i stället för upp och ner till vänster och höger, sedan efter en liten stund tiltas det tillbaka och skrivbordet är riktigt. få se om jag får någon fason på detta, ska testa lite till innan det är läggdax. Problem är till för att lösas..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

En sak som slog mig nu, det är att då man installerar så frågar den efter paket som "saknas", men dessa paket är inget man kan lägga in på ett USB minne så man får med dem direkt? (Har ej sett någon information om denna biten då jag suttit och läst). Man skulle slippa en hel del problem på så vis, läste lite angående DebianTesting, men om jag förstått det rätt så är det paket man lägger till? Letade inte så mycket, men såg ingen full DVD eller liknande att ta hem, men ska läsa mer om det sedan, nu ska jag försöka få detta att fungera som det ska

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av mindflow:

En sak som slog mig nu, det är att då man installerar så frågar den efter paket som "saknas", men dessa paket är inget man kan lägga in på ett USB minne så man får med dem direkt?

Är man uppkopplad till internet så hämtar installationsprogrammet det som behövs direkt från Debians online repository.

Paket märkta "nonfree" är dock uteslutna och måste installeras manuellt eftersom Debian har en väldigt strikt policy mot användning av mjukvara som inte är fri öppen källkod.

Ubuntu och Mint har inte detta problemet eftersom de inte har lika strikt policy mot "nonfree" och där installeras firmware blobs direkt utan att fråga användaren.

Firmware blobs är små filer som tillhandahålls av hårdvarutillverkare, och krävs för att drivrutiner ska kunna kommunicera med hårdvara, men de är oftast proprietär mjukvara och är därför lite kontroversiella i GNU/Linux-världen.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Vore dock bra om dessa medföljde direkt, skulle bespara användaren mycket huvudbry dom första gångerna man installerar, som nybörjare är det rätt stora problem att hitta allt som behövs för att få en väl fungerande dator. Google har många svar på det mesta, men är ofta riktat till mer vana användare, och är därför ingen hjälp för mig. Tack för svar..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007
Skrivet av mindflow:

Vore dock bra om dessa medföljde direkt, skulle bespara användaren mycket huvudbry dom första gångerna man installerar, som nybörjare är det rätt stora problem att hitta allt som behövs för att få en väl fungerande dator. Google har många svar på det mesta, men är ofta riktat till mer vana användare, och är därför ingen hjälp för mig. Tack för svar..

Grejen är väl lite att Debian inte direkt riktar sig mot nybörjare. Använder man en mer nybörjarvänlig distro som t.ex. Ubuntu eller Mint (som båda i grunden är baserade på Debian) så ska sånt här som sagt fungera utan ingrepp. Med Debian, och särskilt då Debian Stable, så får man ofta räkna med lite handpåläggning för att få nyare hårdvara att fungera.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Antar att det bästa sättet att lära sig är att försöka, något av det man läser/gör fastnar, får se hur det går med denna datorn, vet inte varför den ändrar skrivbordet, men känns nästan som om det är en skärmsläckare som aktiveras. Har aldrig sett en dator bete sig på detta viset, inte så den tillomed tiltar musen så den går från sida till sida i stället för upp och ner.

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007

@mindflow: Det låter som att skärmen roteras. Det går ju att göra själv med t.ex. xrandr, men att det görs automatiskt har jag aldrig hört talas om. Men jag hittade detta, det kanske kan vara till någon hjälp.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009

Tack. Ska testa det i morgon, för nu får det räcka för ikväll, vill inte boota upp den igen då jag nu stängt av datorn..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Borlänge
Registrerad
Jan 2009
Skrivet av perost:

@mindflow: Det låter som att skärmen roteras. Det går ju att göra själv med t.ex. xrandr, men att det görs automatiskt har jag aldrig hört talas om. Men jag hittade detta, det kanske kan vara till någon hjälp.

Har nu försökt lösa mitt problem med roterande skrivbord, men då jag ej har denna ikon dom skriver om i sidan du länkade så kommer jag inte närmare en lösning, vart finns denna ikon? Något du vet? Jag använder mig av Cinnnamon .

Edit --

Hittade något under "Utseende", få se om det hjälper, skrivbordet är normalt än så länge i alla fall..

Edit igen --

Fungerade en liten stund, sedan roterade skrivbordet igen. Något förslag angående detta? Då jag öppnar Utseende igen så har den automatiskt ställt sig på "Moturs", trotts att jag satte den på "Normal". Ser ut som om den inte sparar mina inställningar..

Cpu: Intel Core i5 6600K | Ram: 16GB | HD: SSD SanDisk 128-GB | Western Digital 640-GB | Samsung 250-GB | Grafik: Nvidia Geforce GTX 760 Twin Frozr. | Moderkort: ASUSTeK COMPUTER INC. Z170-P. | PSU: 600w | Chassi: Fractal Design Define R4.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007

@mindflow: Kolla in denna bugrapport. Problemet verkar vara att skärmen roteras när Cinnamon känner av att datorn roteras, vilket kan vara lite buggigt. I nyare versioner av Cinnamon går det att stänga av i inställningarna, annars får man använda gsettings.