Filmuppspelningsproblem Linux Mint 17

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Filmuppspelningsproblem Linux Mint 17

Hårdvara MSI J1800 moderkort med 4 GB RAM med ett GTX 660 på en PCI-e 1x anslutning. Skärmen är en Philips FTV som visar upplösningen 1080p60 och ansluts med HDMI.

Problemet är följande, när jag spelar upp en video i 24 fps så hackar det till en kort stund varje sekund. Problemet visar sig samma även om jag kör det inbyggda grafikkortet. PCI-e länken är ansluten i 5 GBit och har som mest 37% utilization. Jag testade att dra igång glxgears och det flyter inte heller på bra, dvs små hack i grafiken. Om jag spelar upp ljud så är det aldrig några problem.

Jag har testat alla möjliga videodrivers i VLC men kan inte komma på var felet ligger. Filmen spelas upp från en intern SSD disk.

Jag antar att det skulle kunna ha något med att filmen spelas upp i 24 fps och att skärmen är på 60 hz? Men å andra sidan så ser en youtube 60 fps video ut likadan med ungefär samma hack.

Var ska jag börja felsökningen?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

Ser ut som problemet jag hade med DVI till HigSpeed HDMI adapter. Tog en äldre DVI till HDMI kabel istället, som inte har alla piggar, och nu flyter det på bra i 4K.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

@yrfhar: Menar du en single link adapter istället för en dual link? Varför ska man inte ha highspeed eller dual link? Jag hänger inte med.

Förresten har jag postat denna fråga i rätt forumsdel?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Låter som om du skulle kunna ha problem med bildfrekvenserna, skärmen och filmen har olika och de är inte jämna multiplar av varandra, vet dock inte hur du åtgärdar det på nått bra sätt.
Filmen är väl dessutom i 23,976 bilder per sekund och inte 24.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006
Skrivet av stoffe_83:

Hårdvara MSI J1800 moderkort med 4 GB RAM med ett GTX 660 på en PCI-e 1x anslutning. Skärmen är en Philips FTV som visar upplösningen 1080p60 och ansluts med HDMI.

Problemet är följande, när jag spelar upp en video i 24 fps så hackar det till en kort stund varje sekund. Problemet visar sig samma även om jag kör det inbyggda grafikkortet. PCI-e länken är ansluten i 5 GBit och har som mest 37% utilization. Jag testade att dra igång glxgears och det flyter inte heller på bra, dvs små hack i grafiken. Om jag spelar upp ljud så är det aldrig några problem.

Jag har testat alla möjliga videodrivers i VLC men kan inte komma på var felet ligger. Filmen spelas upp från en intern SSD disk.

Jag antar att det skulle kunna ha något med att filmen spelas upp i 24 fps och att skärmen är på 60 hz? Men å andra sidan så ser en youtube 60 fps video ut likadan med ungefär samma hack.

Var ska jag börja felsökningen?

Kör du med DVXA / DVXA2 eller inte i VLC, dvs att du använder hårdvaran att spela upp video eller mjuvarurenderat

Default är mjukvarurenderat i VLC dvs CPU gör hela jobbet.
Inte bekant med din TV men flesta TV brukar kunna visa 24 med auto, när sådan signal skickas..

Sen drivrutiner använd den proprietary nvidia drivrutin som Mint föreslår den funkar bra.

För tillfället en sketen Acer gaming laptop

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

skrev i fel tråd

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av ggustavsson:

Kör du med DVXA / DVXA2 eller inte i VLC, dvs att du använder hårdvaran att spela upp video eller mjuvarurenderat

DXVA och DXVA2 är Windows-specifika API så det blir ett definitivt nej eftersom trådskaparen kör Mint. I GNU/Linux-världen finns det ett flertal motsvarande API som exempelvis VDPAU, VA-API och OpenMAX.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Suomi Finland Perkele
Registrerad
Jun 2008

Har haft problem med VLC med senaste tiden så jag har kört med MPV istället.

PSN: TobaksHosto
Rota3: Intel Core i5 2500k - Asus GTX 680 DCII 2GB - Corsair Force 120gb - Fractal Design R3 - Corsair HX650
Spartanen: AMD PhenomII X3 720 BE - XFXRadeon 4850- Antec Three Hundred - 550W PSU

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av nick-li:

Har haft problem med VLC med senaste tiden så jag har kört med MPV istället.

Håller med om MPV. Fungerar mycket bra. Glöm inte lägga till "hwdec" i "/etc/mpv/mpv.conf" bara.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Jun 2015

Mycket Off-topic men...
Har också problem med filmuppspelning på en "kraftfull" dator, i Mint 18.1.
Red: Det hackar och emellanåt pausar filmer p.g.a nätverket inte "matar" filmen tillräckligt fort till VLC.

För mig är det nätverket som spökar, av någon anledning vill inte Mint använda högsta möjliga fart i Wifi överföringen från NAS.
Senast började Mint strula även med webbplatser.

Rensade disken och tänkte installera en nyare version av Mint, med bootbart minneskort gjort i Unetbootin men då fungerar inte grafiken med Mint18.2 eller 18.3?
Datorn i signatur med GTX970 grafikkort.

Testade gamla minneskortet med 18.1 som faktiskt fungerar med grafikkortet i datorn men då strular (iallafall har strulat med) nätverket.

Provar nu med andra Debian forkar...

Huvuddator: i5-6600K, GTX 970, 8GB DDR4 2660MHz, Maximus VIII Gene MK, 120GB SSD+250GB SSD+240GB SDD, Linux Mint 18.2/Win7

Mest använda datorn Acer E3-112: Linux Mint 18.1, helt fläktlös, N2830 500GB 750EVO. För surf+film+musik vid "nanna kudde dax.

Trädvy Permalänk
Medlem
Registrerad
Apr 2012
Skrivet av nick-li:

Har haft problem med VLC med senaste tiden så jag har kört med MPV istället.

Skrivet av Brisse:

Håller med om MPV. Fungerar mycket bra. Glöm inte lägga till "hwdec" i "/etc/mpv/mpv.conf" bara.

Tack för tipset, jag har installerat MPV från standard repen. Spelaren installerades men "/etc/mpv/mpv.conf" finns ej, däremot finns det en annan fil "/etc/mpv/encoding-profiles.conf" ska jaglägga till "hwdec" i den istället? Jag testade utan att ändra något och samma hackande finns kvar.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012
Skrivet av mrqaffe:

Låter som om du skulle kunna ha problem med bildfrekvenserna, skärmen och filmen har olika och de är inte jämna multiplar av varandra, vet dock inte hur du åtgärdar det på nått bra sätt.
Filmen är väl dessutom i 23,976 bilder per sekund och inte 24.

Helt korrekt mrgaffe!

Skrivet av Brisse:

DXVA och DXVA2 är Windows-specifika API så det blir ett definitivt nej eftersom trådskaparen kör Mint. I GNU/Linux-världen finns det ett flertal motsvarande API som exempelvis VDPAU, VA-API och OpenMAX.

Jag testade VDPAU under VLC men ingen skillnad, jag har propetiära Nvidia drivrutiner installerade, jag testade även med open source drivarna men ingen skillnad. Inte heller någon skillnad med det inbyggda grafikortet vilket jag inte riktigt förstått vad det är för kort faktiskt.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005
Skrivet av stoffe_83:

Tack för tipset, jag har installerat MPV från standard repen. Spelaren installerades men "/etc/mpv/mpv.conf" finns ej, däremot finns det en annan fil "/etc/mpv/encoding-profiles.conf" ska jaglägga till "hwdec" i den istället? Jag testade utan att ändra något och samma hackande finns kvar.

Du får skapa filen själv.

  • Öppna en terminal.

  • Skriv 'nano /etc/mpv/mpv.conf'

  • I nano skriver du 'hwdec' eller 'hwdec=vdpau'. Det förstnämnda väljer automatiskt rätt API, medans det sistnämnda tvingar vdpau.

  • Tryck ctrl+o och sedan enter för att spara filen.

Kör gärna mpv från terminalen efteråt så ser du om hårdvaruavkodning används eller ej.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Apr 2012
Skrivet av Brisse:

Du får skapa filen själv.

Kör gärna mpv från terminalen efteråt så ser du om hårdvaruavkodning används eller ej.

Tack! Jag testade både med 'hwdec' eller 'hwdec=vdpau' utan ' tecken förstås. Det gav ingen skillnad mot tidigare resultat. Den hackar till 1 gång per sekund nu oxå. Så här ser terminaloutput ut från mpv.

Citat:

(+) Video --vid=1 (*) (h264)
(+) Audio --aid=1 --alang=eng (*) (ac3)
(+) Subs --sid=1 --slang=eng (*) (f) (subrip)
[vo/opengl/x11] Disabling screensaver failed (4). Make sure the xdg-screensaver script is installed.
AO: [pulse] 48000Hz 5.1(side) 6ch float
Using hardware decoding (vdpau).
VO: [opengl] 1912x800 vdpau
AV: 00:00:28 / 02:02:21 (0%) A-V: 0.000

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Märkligt. Är det möjligt att testa någon annan upplösning/uppdateringsfrekvens på skärmen och se om problemet kvarstår?

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Jag tittade under Nvidia X Server Settings men det jag tror är den ruta där man ändrar uppdateringsfrekvens är gråad och går inte att ändra. Så här ser output ut från xrandr

Citat:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1280mm x 720mm
1920x1080 60.00*+ 59.94 50.00 29.97 25.00 24.00 23.97 60.05 60.00 50.04
1680x1050 59.95
1600x1200 60.00
1440x900 59.89
1400x1050 59.98
1280x1024 60.02
1280x960 60.00
1280x800 59.81
1280x720 59.94 50.00
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94 59.93
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Enligt xrandr kör du 1080p 60hz, sedan visas även andra möjliga lägen.

Du kan byta läge till exempelvis 1080p 59.94hz genom att skriva:
'xrandr --output HDMI-0 --mode 1920x1080 --rate 59.94'

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Jag gjorde ett experiment. Jag matade in detta, exakt samma fps som filmen.

xrandr --output HDMI-0 --mode 1920x1080 --rate 23.976216

Men det hjäpte inte, hacken är kvar. Det måste vara något annat tänker jag. Även glxgears hackar.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Nu bytte jag nätdel från en gammal AOpen FSP250-60GTA till en EVGA Supernova 750 G2 samt skruvade ur Nvidiakortet. J1800 inbyggda grafikkort heter visst bara Intel HD Graphics och verkar kunna driva runt en full hd film utan egentligen större problem. Dock blir jag inte klok på om den har stöd för Blueray uppspelning.

Men nu hackar inte grafiken längre..! Märkligt nog..? GTX660 kortet kanske inte fick tillräcklig bandbredd trots allt.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Då har jag testat mpv som mediaspelare, synd att den stödjer så få format. Annars är det rätt så okej. Jag testade att köra vdpauinfo

display: :0 screen: 0
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

Ska det se ut så här? Det verkar som att VDPAU inte är aktivterat trots allt? Hur gör man det? J1800 processor med integrerad grafik.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

Är det en Intel med integrerad grafik ska du använda VA-API istället för VDPAU. Finns inget stöd för VDPAU från Intel.

Intel - VA-API
Nvidia - VDPAU (och kommande NVDEC som ersätter gamla VDPAU)
AMD - VA-API, VDPAU, OpenMAX

Skumt att du tycker mpv spelar få format. Som så många andra fria mediaspelare så bygger det på ffmpeg som stödjer i princip allt man kan tänka sig.

Edit: För att förtydliga, så ska du ha 'hwdec=vaapi' i '/etc/mpv/mpv.conf'. Du kan använda 'vainfo' för att se vilka codec/format som stöds.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Vainfo ger detta.

vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Simple : VAEntrypointEncSlice
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointEncSlice
VAProfileH264ConstrainedBaseline: VAEntrypointVLD
VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSlice
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSlice
VAProfileH264StereoHigh : VAEntrypointVLD
VAProfileVC1Simple : VAEntrypointVLD
VAProfileVC1Main : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD
VAProfileNone : VAEntrypointVideoProc
VAProfileJPEGBaseline : VAEntrypointVLD

Så det verkar lovande. Hälften av de filmer som jag har med .mkv ändelse går ej att spela i mpv men däremot går de utmärkt att spela i vlc. Hur ställer jag in vlc för att använda VA-API?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Hittade varför inte mpv ville spela upp så många av mina filformat, det var för krångliga filnamn. När jag kortade ner dom så funkade dom att spela upp.

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

mpv spelarens problem är löst. Men nu ville jag titta på svtplay. Det gick sådär. Jag testade senaste versionen av Chromeium. Där det det samma problem med små hack och förmodligen använder inte Chromium vaapi när den försöker spela upp filmer. Firefox är det likadant med.

Jag skrev in detta i webbläsaren chrome://gpu/

Note: To properly save this page, select the "Webpage, Complete" option in the Save File dialog.
Graphics Feature Status
Canvas: Hardware accelerated
CheckerImaging: Disabled
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Disabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Software only. Hardware acceleration disabled
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Software only, hardware acceleration unavailable
WebGL: Hardware accelerated
WebGL2: Hardware accelerated
Driver Bug Workarounds
adjust_src_dst_region_for_blitframebuffer
clear_uniforms_before_first_program_use
decode_encode_srgb_for_generatemipmap
disable_framebuffer_cmaa
disable_post_sub_buffers_for_onscreen_surfaces
msaa_is_slow
scalarize_vec_and_mat_constructor_args
Problems Detected
Accelerated video decode is unavailable on Linux: 137247
Disabled Features: accelerated_video_decode
Accelerated video encode is unavailable on Linux
Disabled Features: accelerated_video_encode
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Disable partial swaps on Mesa drivers (detected with GL_RENDERER): 339493
Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
On Intel GPUs MSAA performance is not acceptable for GPU rasterization: 527565
Applied Workarounds: msaa_is_slow
Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
Applied Workarounds: disable_framebuffer_cmaa
Disable partial swaps on Mesa drivers (detected with GL_VERSION): 339493
Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
Decode and encode before generateMipmap for srgb format textures on os except macosx: 634519
Applied Workarounds: decode_encode_srgb_for_generatemipmap
adjust src/dst region if blitting pixels outside read framebuffer on Linux Intel: 664740
Applied Workarounds: adjust_src_dst_region_for_blitframebuffer
Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
Accelerated rasterization has been disabled, either via blacklist, about:flags or the command line.
Disabled Features: rasterization
Raster is using a single thread.
Disabled Features: multiple_raster_threads
Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
Disabled Features: native_gpu_memory_buffers
Checker-imaging has been disabled via finch trial or the command line.
Disabled Features: checker_imaging
Version Information
Data exported 12/1/2017, 7:41:24 AM
Chrome version Chrome/62.0.3202.94
Operating system Linux 4.10.0-40-generic
Software rendering list version 13.13
Driver bug list version 10.30
ANGLE commit id unknown hash
2D graphics backend Skia/62 e74b41c6c84638d5a9ee6d254a715bcd9e17c603-
Command Line /usr/lib/chromium-browser/chromium-browser --disable-new-tab-first-run --enable-user-scripts --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version=27.0.0.187 --enable-pinch --flag-switches-begin --flag-switches-end
Driver Information
Initialization time 136
In-process GPU false
Passthrough Command Decoder false
Supports overlays false
Sandboxed true
GPU0 VENDOR = 0x8086, DEVICE= 0x0f31
Optimus false
Optimus false
AMD switchable false
Driver vendor NVIDIA
Driver version 384.90
Driver date
Pixel shader version 1.30
Vertex shader version 1.30
Max. MSAA samples 8
Machine model name
Machine model version
GL_VENDOR Intel Open Source Technology Center
GL_RENDERER Mesa DRI Intel(R) Bay Trail
GL_VERSION 3.0 Mesa 12.0.6
GL_EXTENSIONS GL_3DFX_texture_compression_FXT1 GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_performance_monitor GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_trinary_minmax GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_storage_buffer_object GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sync GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_window_pos GL_ATI_blend_equation_separate GL_ATI_draw_buffers GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shader_integer_mix GL_EXT_shader_samples_identical GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_INTEL_performance_query GL_KHR_context_flush_control GL_KHR_debug GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_MESA_pack_invert GL_MESA_texture_signed_rgba GL_MESA_window_pos GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_OES_EGL_image GL_OES_read_format GL_S3_s3tc GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
Disabled Extensions GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent
Window system binding vendor SGI
Window system binding version 1.4
Window system binding extensions GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_multisample GLX_EXT_create_context_es_profile GLX_EXT_create_context_es2_profile GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_import_context GLX_EXT_texture_from_pixmap GLX_EXT_visual_info GLX_EXT_visual_rating GLX_MESA_copy_sub_buffer GLX_OML_swap_method GLX_SGI_swap_control GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_INTEL_swap_event
Window manager Mutter (Muffin)
XDG_CURRENT_DESKTOP X-Cinnamon
GDMSESSION cinnamon
Compositing manager Yes
Direct rendering Yes
Reset notification strategy 0x8261
GPU process crash count 0
System visual ID 32
RGBA visual ID 111
Compositor Information
Tile Update Mode One-copy
Partial Raster Enabled
GpuMemoryBuffers Status
ATC Software only
ATCIA Software only
DXT1 Software only
DXT5 Software only
ETC1 Software only
R_8 Software only
R_16 Software only
RG_88 Software only
BGR_565 Software only
RGBA_4444 Software only
RGBX_8888 Software only
RGBA_8888 Software only
BGRX_8888 Software only
BGRA_8888 Software only
RGBA_F16 Software only
YVU_420 Software only
YUV_420_BIPLANAR Software only
UYVY_422 Software only

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007

Det är alltså detta moderkortet du har?

https://www.msi.com/Motherboard/J1800I-/Specification

Ser ju en aning underdimensionerat ut om så är fallet.
Hade du modifierat 1X porten för att få plats med GTX 660-kortet?

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

@stoffe_83:
Tror inte någon av de populära webbläsarna har hårdvaruaccelererad videouppspelning i Linux. Möjligtvis kan man få det att fungera i Chromium men jag är osäker. I Firefox går det inte alls, oavsett operativsystem. GNOME Webb, tidigare känd som Epiphany använder GStreamer och kan därför använda VA-API om man installerar paketet 'gstreamer1.0-vaapi'. Verkar ganska buggigt dock, iallafall på min AMD-burk.

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Registrerad
Apr 2012
Skrivet av krigelkorren:

Det är alltså detta moderkortet du har?

https://www.msi.com/Motherboard/J1800I-/Specification

Ser ju en aning underdimensionerat ut om så är fallet.
Hade du modifierat 1X porten för att få plats med GTX 660-kortet?

Ja på båda frågorna.

@Brisse Hur gör jag för att spela upp film från svtplay utan att det hackar? Går det att göra med mpv? Hur gör jag då i så fall?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX

Trädvy Permalänk
Medlem
Plats
~/
Registrerad
Dec 2005

@stoffe_83:
Tror inte det är möjligt med svtplay.

Youtube däremot fungerar genom att skriva mpv följt av en länk i terminalen. Exempel:

PRIME X370-PRO | R7 1700X | NH-D15 | 32GiB DDR4-2400 CL14 | 500GiB 850 EVO | 3TiB WD Red | 500GiB HDD | Nitro R9 Fury | SuperNOVA 750 G2 | Define S | MG279Q | HD650 | Ducky Secret | Ducky One 2 | Debian Sid

Trädvy Permalänk
Medlem
Plats
Flen
Registrerad
Jul 2001
Skrivet av stoffe_83:

Ja på båda frågorna.

@Brisse Hur gör jag för att spela upp film från svtplay utan att det hackar? Går det att göra med mpv? Hur gör jag då i så fall?

Går nog inte utan att leka pirat med Pirateplayer/svtplay-dl.

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Aha okej. Jag förstår.

Jag har bytt moderkort nu till en detta.

Citat:

System: Host: HTPC Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: Mobo: ASUSTeK model: M2N-VM DVI v: Rev x.xx
Bios: American Megatrends v: 0905 date: 12/19/2008
CPU: Quad core AMD Phenom 9850 (-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 19999
clock speeds: max: 2499 MHz 1: 2499 MHz 2: 2499 MHz 3: 2499 MHz
4: 2499 MHz
Graphics: Card: NVIDIA GK106 [GeForce GTX 660] bus-ID: 02:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz
GLX Renderer: GeForce GTX 660/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio: Card-1 NVIDIA GK106 HDMI Audio Controller
driver: snd_hda_intel bus-ID: 02:00.1
Card-2 NVIDIA MCP67 High Definition Audio
driver: snd_hda_intel bus-ID: 00:07.0
Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network: Card-1: NVIDIA MCP67 Ethernet
driver: forcedeth port: b880 bus-ID: 00:0a.0
IF: enp0s10 state: down mac: <filter>
Card-2: 3Com 3c905 100BaseTX [Boomerang]
driver: 3c59x port: dc00 bus-ID: 01:07.0
IF: enp1s7 state: unknown speed: 100 Mbps duplex: full
mac: <filter>
Drives: HDD Total Size: 20.0GB (73.6% used)
ID-1: /dev/sda model: SATA_SSD size: 20.0GB
Partition: ID-1: / size: 18G used: 14G (79%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 0.54GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 61.0C mobo: N/A gpu: 0.0:46C
Fan Speeds (in rpm): cpu: 1819 sys-1: 0
Info: Processes: 199 Uptime: 10 min Memory: 1058.9/5965.8MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Det är ingen skillnad på de hack i videos som är trots att jag har en mycket snabbare dator nu. Glxgears hackar fortfarande trots att jag har ett GTX660 med propetiära drivrutiner installerade. Det måste vara skärmen eller Mint installationen som är fel..?

LS-120 Superdisk drive köpes!

i7 3770K, 750 GB SSD, 18 TB HDD, 32 GB RAM.
Nvidia Geforce 970 GTX