Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2004

Newbie problem i BSD

Försöker migrera min mailserver från Ubuntu till FreeBSD, och jag följer denna guiden: http://www.purplehat.org/?page_id=4

Hur som helst, redan på första sidan stötte jag på inkonsekvenser och sedan nånting som ledde till errors.

Jag får detta felmeddelande:

Citat:

===> p5-Locale-gettext-1.07 depends on package: perl5>=5.24<5.25 - found
===> p5-Locale-gettext-1.07 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===> Configuring for p5-Locale-gettext-1.07
env: /usr/local/bin/perl5.24.1: No such file or directory
*** Error code 127

Stop.
make[5]: stopped in /usr/ports/devel/p5-Locale-gettext
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/misc/help2man
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/autoconf
*** Error code 1

Stop.
make: stopped in /usr/ports/www/apache24

Vad jag kan se i det är att den letar efter "/usr/local/bin/perl5.24.1" jag har dock en något som ser ut att vara en nyare variant där, "perl5.24.3".

Hur kan jag gå vidare med detta?

Trädvy Permalänk
Medlem
Plats
Där min VPN visar att jag är såklart
Registrerad
Jan 2005

Saknas den helt? Gör isf en symlink.

# ln -s /usr/local/bin/perl5.24.3 /usr/local/bin/perl5.24.1

EDIT: ... uhh du försöker installera via pkg va och inte freeports?

'pkg install perl5' ger dig vilken version?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2004
Skrivet av Undie:

Saknas den helt? Gör isf en symlink.

# ln -s /usr/local/bin/perl5.24.3 /usr/local/bin/perl5.24.1

EDIT: ... uhh du försöker installera via pkg va och inte freeports?

'pkg install perl5' ger dig vilken version?

Nej jag försökte installera via ports, visade sig att mitt träd inte var uppdaterat.

Fick hjälp via freebsd irc, mycket trevligt folk.

Mycket att sätta sig in i nu, har inte pillat mycket med BSD innan, lite erfarenhet från pfsense bara men det är det lilla.

Trädvy Permalänk
Medlem
Registrerad
Nov 2009

portsnap fetch portsnap update

för att uppdatera ports

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2004
Skrivet av Usling:

portsnap fetch portsnap update

för att uppdatera ports

Tror jag har tagit mig förbi alla hinder nu.

Hoppade den guiden som jag länkade till i första posten och gav mig på iRedMail i stället, vilket ger i stort sett samma setup som den som jag försökte ge mig på.

Har haft ett par problem längs vägen där med men tror jag har kommit runt allting, håller nu på och "bygger" en "clean" install med allt som jag lärde mig från förra i rätt ordning osv.

Men en annan fråga dök upp i mitt huvud, hur håller man ports-trädet uppdaterat och "bygger" nytt när det behövs (uppdateringar, buggar, säkerhetshål) utan att man förstör den installation man har??
Detta ska ju helst ske med någon form av regelbundenhet och enkelhet.

Trädvy Permalänk
Medlem
Registrerad
Nov 2009
Skrivet av Nebudchanezzer:

Tror jag har tagit mig förbi alla hinder nu.

Hoppade den guiden som jag länkade till i första posten och gav mig på iRedMail i stället, vilket ger i stort sett samma setup som den som jag försökte ge mig på.

Har haft ett par problem längs vägen där med men tror jag har kommit runt allting, håller nu på och "bygger" en "clean" install med allt som jag lärde mig från förra i rätt ordning osv.

Men en annan fråga dök upp i mitt huvud, hur håller man ports-trädet uppdaterat och "bygger" nytt när det behövs (uppdateringar, buggar, säkerhetshål) utan att man förstör den installation man har??
Detta ska ju helst ske med någon form av regelbundenhet och enkelhet.

FreeBSD har en riktigt grym handbok:
Om du installerat program via ports: https://www.freebsd.org/doc/handbook/ports-using.html
Ports = program du kompilerar själv från källkoden med make install
Uppgradera alla ports:

portupgrade -ai

Om du installerat via packages: https://www.freebsd.org/doc/handbook/pkgng-intro.html
Packages = du tankar hem en färdigkompilerad binär fil, pkg install (som de flesta linux-distar gör, typ ubuntu)
För att uppgradera packages

pkg upgrade

Jag tycker det är bäst att hålla sig till ett av sätten när man installerar program, men båda funkar.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2004
Skrivet av Usling:

FreeBSD har en riktigt grym handbok:
Om du installerat program via ports: https://www.freebsd.org/doc/handbook/ports-using.html
Ports = program du kompilerar själv från källkoden med make install
Uppgradera alla ports:

portupgrade -ai

Om du installerat via packages: https://www.freebsd.org/doc/handbook/pkgng-intro.html
Packages = du tankar hem en färdigkompilerad binär fil, pkg install (som de flesta linux-distar gör, typ ubuntu)
För att uppgradera packages

pkg upgrade

Jag tycker det är bäst att hålla sig till ett av sätten när man installerar program, men båda funkar.

Fick rådet att försöka hålla mig till ett av sätten och eftersom installern för iRedMail använder ports så fick det bli ports, det tog ett par försök men nu har jag fått till så att allt kommer därifrån.

Har även installerat webmin och tyvärr så är det så att det påstår att jag har några paket som behöver uppdateras, hur blir man av med det?

Så nån gång i veckan behöver man köra:

"portsnap fetch extract update" + "portupgrade -ai" ?

EDIT: portupgrade fungerade inte... "Command not found"

Trädvy Permalänk
Medlem
Plats
Sundets Pärla?
Registrerad
Okt 2007
Skrivet av Nebudchanezzer:

Fick rådet att försöka hålla mig till ett av sätten och eftersom installern för iRedMail använder ports så fick det bli ports, det tog ett par försök men nu har jag fått till så att allt kommer därifrån.

Har även installerat webmin och tyvärr så är det så att det påstår att jag har några paket som behöver uppdateras, hur blir man av med det?

Så nån gång i veckan behöver man köra:

"portsnap fetch extract update" + "portupgrade -ai" ?

EDIT: portupgrade fungerade inte... "Command not found"

Du behöver installera portsupgrade med något av följande:
cd /usr/ports/ports-mgmt/portupgrade/ && make install clean
pkg install portupgrade

Det finns andra alternativ. Själv använder jag Synth.
Några av fördelarna med Synth är att den kan uppgradera flera ports parallellt och bygger dem i en "ren" miljö.
Tidigare körde jag Portmaster.

Celeron 300A @ 450MHz

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2004
Skrivet av mayo:

Du behöver installera portsupgrade med något av följande:
cd /usr/ports/ports-mgmt/portupgrade/ && make install clean
pkg install portupgrade

Det finns andra alternativ. Själv använder jag Synth.
Några av fördelarna med Synth är att den kan uppgradera flera ports parallellt och bygger dem i en "ren" miljö.
Tidigare körde jag Portmaster.

Tyckte synth lät bra, men när jag kör det efter att jag har kört iRedMails installations-script får jag en massa fel jag inte förstår mig på, har försökt att googla en del på det, men det är inte mycket som jag förstår av det där...

Skrivet av synth output:

Querying system about current package installations.
Stand by, comparing installed packages against the ports tree.
Encountered issue with net/py-ipaddress or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of net/py-ipaddress) does not exist.
Scan of net/py-ipaddress failed, it will not be considered.
Encountered issue with dns/py-idna or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of dns/py-idna) does not exist.
Scan of dns/py-idna failed, it will not be considered.

devel/scons scan aborted because dependency could not be located.
py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/scons) does not exist.
Scan of databases/mysql57-client failed, it will not be considered.
Encountered issue with www/webpy or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of www/webpy) does not exist.
Scan of www/webpy failed, it will not be considered.
Encountered issue with www/py-beautifulsoup or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of www/py-beautifulsoup) does not exist.
Scan of www/py-beautifulsoup failed, it will not be considered.

textproc/xml2rfc scan aborted because dependency could not be located.
py27-setuptools>0:devel/py-setuptools@py27 (required dependency of textproc/xml2rfc) does not exist.
Scan of devel/sope3 failed, it will not be considered.
Encountered issue with devel/py-pytz or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-pytz) does not exist.
Scan of devel/py-pytz failed, it will not be considered.
Encountered issue with security/py-bcrypt or its dependencies
=> py27-cffi>=1.1.0:devel/py-cffi@py27 (required dependency of security/py-bcrypt) does not exist.
Scan of security/py-bcrypt failed, it will not be considered.
Encountered issue with devel/py-asn1crypto or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-asn1crypto) does not exist.
Scan of devel/py-asn1crypto failed, it will not be considered.
Encountered issue with www/py-requests or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of www/py-requests) does not exist.
Scan of www/py-requests failed, it will not be considered.
Encountered issue with security/py-pycrypto or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of security/py-pycrypto) does not exist.
Scan of security/py-pycrypto failed, it will not be considered.
Encountered issue with devel/py-setuptools_scm or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-setuptools_scm) does not exist.
Scan of devel/py-setuptools_scm failed, it will not be considered.
Encountered issue with textproc/py-chardet or its dependencies
=> py27-pytest-runner>0:devel/py-pytest-runner@py27 (required dependency of textproc/py-chardet) does not exist.
Scan of textproc/py-chardet failed, it will not be considered.

mail/pyzor scan aborted because dependency could not be located.
py27-setuptools>0:devel/py-setuptools@py27 (required dependency of mail/pyzor) does not exist.
Scan of mail/spamassassin failed, it will not be considered.
Encountered issue with devel/py-lxml or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-lxml) does not exist.
Scan of devel/py-lxml failed, it will not be considered.
Encountered issue with devel/py-pytest-runner or its dependencies
=> py27-setuptools_scm>=1.15.0:devel/py-setuptools_scm@py27 (required dependency of devel/py-pytest-runner) does not exist.
Scan of devel/py-pytest-runner failed, it will not be considered.
Encountered issue with devel/py-Jinja2 or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-Jinja2) does not exist.
Scan of devel/py-Jinja2 failed, it will not be considered.
Encountered issue with security/py-openssl or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of security/py-openssl) does not exist.
Scan of security/py-openssl failed, it will not be considered.
Encountered issue with security/py-certifi or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of security/py-certifi) does not exist.
Scan of security/py-certifi failed, it will not be considered.
Encountered issue with devel/py-cffi or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-cffi) does not exist.
Scan of devel/py-cffi failed, it will not be considered.
Encountered issue with mail/pyzor or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of mail/pyzor) does not exist.
Scan of mail/pyzor failed, it will not be considered.
Encountered issue with textproc/py-MarkupSafe or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of textproc/py-MarkupSafe) does not exist.
Scan of textproc/py-MarkupSafe failed, it will not be considered.
Encountered issue with net/py-netifaces or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of net/py-netifaces) does not exist.
Scan of net/py-netifaces failed, it will not be considered.
Encountered issue with devel/scons or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/scons) does not exist.
Scan of devel/scons failed, it will not be considered.
Encountered issue with dns/py-dnspython or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of dns/py-dnspython) does not exist.
Scan of dns/py-dnspython failed, it will not be considered.
Encountered issue with net/py-urllib3 or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of net/py-urllib3) does not exist.
Scan of net/py-urllib3 failed, it will not be considered.
Encountered issue with devel/py-six or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-six) does not exist.
Scan of devel/py-six failed, it will not be considered.
Encountered issue with ftp/py-pycurl or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of ftp/py-pycurl) does not exist.
Scan of ftp/py-pycurl failed, it will not be considered.
Encountered issue with devel/py-babel or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-babel) does not exist.
Scan of devel/py-babel failed, it will not be considered.
Encountered issue with security/py-cryptography or its dependencies
=> py27-cffi>=1.7:devel/py-cffi@py27 (required dependency of security/py-cryptography) does not exist.
Scan of security/py-cryptography failed, it will not be considered.
Encountered issue with net/py-pysocks or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of net/py-pysocks) does not exist.
Scan of net/py-pysocks failed, it will not be considered.
Encountered issue with textproc/xml2rfc or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of textproc/xml2rfc) does not exist.
Scan of textproc/xml2rfc failed, it will not be considered.
Encountered issue with devel/py-enum34 or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-enum34) does not exist.
Scan of devel/py-enum34 failed, it will not be considered.
Encountered issue with databases/py-sqlite3 or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of databases/py-sqlite3) does not exist.
Scan of databases/py-sqlite3 failed, it will not be considered.
Encountered issue with devel/py-pycparser or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of devel/py-pycparser) does not exist.
Scan of devel/py-pycparser failed, it will not be considered.
Encountered issue with databases/py-sqlalchemy10 or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of databases/py-sqlalchemy10) does not exist.
Scan of databases/py-sqlalchemy10 failed, it will not be considered.
Encountered issue with databases/py-MySQLdb or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of databases/py-MySQLdb) does not exist.
Scan of databases/py-MySQLdb failed, it will not be considered.
Encountered issue with databases/py-gdbm or its dependencies
=> py27-setuptools>0:devel/py-setuptools@py27 (required dependency of databases/py-gdbm) does not exist.
Scan of databases/py-gdbm failed, it will not be considered.
Scanning existing packages.
progress: 22.74%
progress: 38.91%
progress: 62.52%
progress: 69.88%
progress: 75.58%
Queue integrity lost! (Synth must exit)
Unfortunately, the system upgrade failed.