"Plocka ut" drivrutin ur installationsmedia, (Windows Server 2012Rs) för att använda på annat installationsmedia? (HyperV Server 2012 R2))

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

"Plocka ut" drivrutin ur installationsmedia, (Windows Server 2012Rs) för att använda på annat installationsmedia? (HyperV Server 2012 R2))

Ibland gör man saker krångligare än vad de måste vara, så även den här gången, det är jag säker på...
Jag har en HP ML 350 G5, som kör Microsoft Windows Server Essentials 2012 R2. Planen var att "förbereda för framtiden" och köra Hyper-V Server 2012 R2, i stället för Windows Server, och köra Windows Server på den. Mest för övningens skull. Men jag kan inte ens installera Hyper-V. Windows Server hittade diskarna, installerade snällt, och var sen färdigt. Hyper-V hittar diskarna, men vägrar installera, hävdandes att diskarna inte är bootbara. Jag ANTAR att det är något med drivrutinerna som gör det, så det första jag gjorde var så klart letade efter drivrutiner att mata den med under installationen, men det verkar inte finnas. Sitter en "HP Smart Array E200i" integrerad i de här burkarna, och boot-disk är en SAS RAID-1 array.

Alternativet blir ju att köra Windows Server, med enbart Hyper-V tjänsten installerad, men det skapar kraftigt mycket mer overhead, så det vill jag försöka undvika...

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Om du vet vilken CP* drivare (typ via floppy/iso) du lär lägga till vid installationstillfället av Hyper-V kan jag förmodligen leta reda på den. HPE har gjort om sin jämra sajt nyligen så det går ju inte att hitta länge!

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003
Skrivet av hasenfrasen:

Om du vet vilken CP* drivare (typ via floppy/iso) du lär lägga till vid installationstillfället av Hyper-V kan jag förmodligen leta reda på den. HPE har gjort om sin jämra sajt nyligen så det går ju inte att hitta länge!

Jag har ju ingen jävla aning om vad den heter... Det är ju till "Smart Array P200i", men därifrån till vad HP kallar saker... Fan vet.

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Registrerad
Sep 2012

Kan du inte använda double driver?

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

Till vad då/ hur då? Jag behöver, tror jag, drivrutinen för att låta Microsofts Hyper-V Server OS installera på systemet. Drivrutinen för det installerade OS'ett har jag i HP's SPP, men eftersom den vägrar godta att SAS diskarna är bootbara, kommer jag inte så långt...
Jag är rent av så desperat att jag tittat på att installera Hyper-V på ett USB minne, moderkortet har dedikerad USB port på insidan, så att ingen "råkar" plocka ut det, men jag har inget USB minne av "rätt sort". (det måste identifiera sig som fast lagringsmedia, inte som vanliga USB minnen som identifierar sig som "removable storage", tydligen...)
Efter som idealet är att den faktiskt bootar på sin SAS array, så försöker jag hoppa igång det först, och kan jag inte hitta en lösning där, så är det troligare att jag kör Windows Server med bara Hyper-V, än att jag kör på USB, men man ska aldrig säga aldrig.

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Packa upp cp020624.exe mha 7zip och lägg på en USB som du låter installationen söka av (additional driver).
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_8...

http://h50146.www5.hpe.com/products/software/oe/linux/mainstr...

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Apr 2002

Har du skapat en array med bootdisken?

Define R5 Titanium | EVGA SuperNOVA 750 G2 | ASRock Z77 Extreme4 | Intel i5 3750k @ 4Ghz | Cooler Master 212 Evo | 16GB Corsair XMS3 PC12800 | Gigabyte GTX1070 | Intel SSD 530 120Gb | Asus VG248QE | Win 7 Ultimate x64

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003
Skrivet av hasenfrasen:

Packa upp cp020624.exe mha 7zip och lägg på en USB som du låter installationen söka av (additional driver).
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_8...

http://h50146.www5.hpe.com/products/software/oe/linux/mainstr...

Jag provar, förhoppningsvis i morgon eftermiddag/kväll. Återkommer med resultat, tack så här långt.

Skrivet av PointMan:

Har du skapat en array med bootdisken?

Japp, och det märkliga är att både boot, och storage volymerna syns. Men när man säger till installationen att använda 148gB (RAID 1 SAS - OS volymen) så vägrar den. Bara för att, så plockade jag bort befintlig partition, och skapade en ny, vilket VERKADE fungera, men med samma resultat, inte godkänd för installation, för att den inte är"bootbar". Varpå jag plockade ut båda diskarna och smällde i de som "brukar" sitta där, med Windows Server 2012 Essentials R2, och bootade datorn från dem... Jag ska prova och hiva i Windows Server skivan i morgon med, så jag inte blivit dum i huvudet, och gjort något annorlunda, men den installationen som ligger där var snäll och hoppade över från skiva utan problem... HP's officiella 148gB SAS diskar alla fyra. Något till åren komna, vid det här laget, men va fan...

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Apr 2002
Skrivet av -=Mr_B=-:

Jag provar, förhoppningsvis i morgon eftermiddag/kväll. Återkommer med resultat, tack så här långt.

Japp, och det märkliga är att både boot, och storage volymerna syns. Men när man säger till installationen att använda 148gB (RAID 1 SAS - OS volymen) så vägrar den. Bara för att, så plockade jag bort befintlig partition, och skapade en ny, vilket VERKADE fungera, men med samma resultat, inte godkänd för installation, för att den inte är"bootbar". Varpå jag plockade ut båda diskarna och smällde i de som "brukar" sitta där, med Windows Server 2012 Essentials R2, och bootade datorn från dem... Jag ska prova och hiva i Windows Server skivan i morgon med, så jag inte blivit dum i huvudet, och gjort något annorlunda, men den installationen som ligger där var snäll och hoppade över från skiva utan problem... HP's officiella 148gB SAS diskar alla fyra. Något till åren komna, vid det här laget, men va fan...

Ok, då borde det @hasenfrasen skrev hjälpa dig. Windows hittar inte drivrutinen till RAID controllern.

Define R5 Titanium | EVGA SuperNOVA 750 G2 | ASRock Z77 Extreme4 | Intel i5 3750k @ 4Ghz | Cooler Master 212 Evo | 16GB Corsair XMS3 PC12800 | Gigabyte GTX1070 | Intel SSD 530 120Gb | Asus VG248QE | Win 7 Ultimate x64

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

Livet ställde krav på vardagen så det blev inte i dag, möjligen blir det inte innan helgen. Jag återkommer oavsett när det blir.

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Aug 2009

Alla drivrutiner ska finnas i mapp C:\Windows\System32\DriverStore\FileRepository, brukar själv plocka dom därifrån vid behov och dom brukar oftast gå bra att installera mha pnputil.

Corsair Carbide 330R | Corsair RM650X | MSI Z87-G45 GAMING | i7-4770K | Kingston 16GB DDR3-1600 | Asus GTX980-4GD5 | Samsung 850 Evo 1TB | Hitachi Travelstar 2.5" 1TB | Logitech G810 | Logitech G402 | Audio Technica ATH-M50 | BenQ BL2411PT IPS

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

Fast de drivrutinerna är till för det installerade OS'ett, och hjälper inte under installationsfasen? Tror jag. Jag har fortfarande inte haft en möjlighet att testa hasenfrasen's lösning ovan, jag hyser vissa förhoppningar om att det ska gå.

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Maj 2003

Jag tänker inte ens låtsas att jag förstår vad som pågår. För en vecka sedan slet jag ut de två diskarna i RAID 1 som den logiska volymen jag vill ha OS'ett på består av, ersatte dem med två andra, och (återskapade) den logiska volymen på dem. Tom, så klart. Startade om datorn, och körde installationen för Hyper-V Server 2012 R2. Och fick felmeddelandet som sa att datorn inte kunde boota på den nyskapade partitionen. Startade om datorn, och försökte installera igen, på samma partition, samma felmeddelande. Bytte till en annan skiva, bara i fall om att, och fick samma felmeddelande. Så jag "bestämde" mig för att det nog var drivrutins-stöd som saknades.
Beväpnad med filerna från ovan, och glad i hågen tänkte jag att i DAG ska det fan bli av. Stänger av datorn, stoppar i de här diskarna som ska användas, verifierar att ja, jag är medveten om att det har bytts diskar, och ja, jag vill aktivera dem, och ja, jag vet att det kan betyda dataförlust, fan HP, ni är inte ens här, och ni irriterar mig i alla fall... boota någon gång, så jag får se om mitt USB minne är lösningen.

Tror ni inte datorn anser att den logiska enheten är fullt bootbar nu?
Vad i helvete...
Hela tråden, och en hel vecka (som jag iofs inte haft tid att ägna åt det här i alla fall) helt förspilld. Och så säger folk att jag är bra på datorer. Jag tror jag ska börja med en ny hobby, knyppling, eller något...
Tack för all hjälp. Jag kan inte svara på om drivrutinen hade fungerat eller inte, eftersom det av någon outgrundlig anledning behagade fungera utan i dag...

Så nu ska jag sparka igång en annan hyper-V server här hemma, leka av all hjärtans lust, och lyfta över det till ML350'n när jag är redo för att testköra, på ett praktiskt sätt. Det får nog bli nästa vecka dock, för den här känns det som om jag ska ligga under täcker vara sjuk, hosta och snörvla. Men det går säkert över strax efter att snön töar bort igen.

Allting jag skriver är om inget annat uttrycks, min åsikt! Ingenting måste vara dagens sanning enligt din åsikt, och gör du antaganden baserade på mina åsikter hoppas jag att du övervägt mer än bara just min åsikt.