Forumdelen sponsras av

Trädvy Permalänk
Medlem
Registrerad
Dec 2017

HDMI switch + PC = Problem

Hej!
Jag har precis införskaffat en hdmi switch för att göra det enklare för mig att byta mellan min PC och mina spelkonsoller.
Det problem som jag upplever är att om jag startar upp min dator så ser det ut som när grafikkortet får problem, dvs. färgerna på både bios och windows är felaktiga regnbågsfärger (Lite dåligt beskrivet men här är en bild på det:

).
För att åtgärda detta så måste jag koppla in min PC direkt till projektorn för att sedan ansluta den tillbaka till switchen igen, då fungerar allting korrekt. Är det någon som har stött på liknande problematik tidigare? Jag har googlat runt ett tag nu men lyckas inte finna några lösningar.

Min utrustning:

Projektor: Epson EH-TW5300
HDMI switch: HDSW4 ( https://www.wish.com/c/55c55809dfe24952d739fffa )

Operativsystem: Windows 7 Professional 64-bit
Grafikkort: MSI Radeon R9 390X GAMING 8G
Processor: Intel(R) Core(TM) i5-6600K

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Troligen funkar det inte för att switchen är för dålig och bildkällorna därför upplever det som att du kopplar in dem när du växlar i stället för att de tror att de är inkopplade hela tiden. Det kan även vara en dålig kabel.
Prova att köra med bara en bildkälla ansluten i switchen och växla ändå och se vad som händer.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Dec 2017

@mrqaffe: Hej! Tack för din idé och ett snabbt svar!
Problemet jag upplever visar sig inte när jag växlar kanal på switchen utan när själva utrustningen startas om.
Jag testade med ny kabel samt att endast ha datorn inkopplad i hdmi switchen, dock kvarstår problemet.
jag upptäckte dock en ny nivå av själva problematiken och den är som följer:

Om jag lämnar projektorn påslagen så kan jag starta om datorn hur många gånger som helst utan att några problem uppstår. Om jag däremot startar om projektorn så dyker problemet upp igen (Detta oavsett om datorn har varit påslagen hela tiden). För att åtgärda felet räcker det även med att dra ut projektorn från switchen och sedan ansluta den igen. Problemet är isolerat till min PC då jag kan starta om projektorn med spelkonsollen (Nintendo switch) aktiv utan att få detta underliga fenomen. Jag har även senaste drivrutiner för mitt grafikkort.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av Nephalen:

@mrqaffe: Hej! Tack för din idé och ett snabbt svar!
Problemet jag upplever visar sig inte när jag växlar kanal på switchen utan när själva utrustningen startas om.
Jag testade med ny kabel samt att endast ha datorn inkopplad i hdmi switchen, dock kvarstår problemet.
jag upptäckte dock en ny nivå av själva problematiken och den är som följer:

Om jag lämnar projektorn påslagen så kan jag starta om datorn hur många gånger som helst utan att några problem uppstår. Om jag däremot startar om projektorn så dyker problemet upp igen (Detta oavsett om datorn har varit påslagen hela tiden). För att åtgärda felet räcker det även med att dra ut projektorn från switchen och sedan ansluta den igen. Problemet är isolerat till min PC då jag kan starta om projektorn med spelkonsollen (Nintendo switch) aktiv utan att få detta underliga fenomen. Jag har även senaste drivrutiner för mitt grafikkort.

Antagligen så identifierar sig switchen på ett konstigt sätt, bättre enheter har logik i sig som gör att respektive apparat "inte märker" att man växlar men de enklare bara växlar likt om man kopplad om kabeln och då kan det krävas omstart av apparaterna för att allt ska funka, de kan alltså ersätta kabelflyttande men inte växla under drift utan kräver omstart av apparaterna för att all handskakning ska fungera.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Dec 2017

jag har testat och experimenterat en hel del men inte kommit fram med en lösning på detta, dock har jag en kompromiss som jag ändå tycker fungerar helt okej.
Jag stänger av hdmi switchen när jag inte använder den och har den bara igång när jag väl behöver, då uppstår inte problemet eftersom att alla enheter startas samtidigt. Stort tack för förklaringen iaf, jag får se om jag fixar en bättre switch vid ett senare tillfälle.