Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

Minecraft server

Hej.

Hoppas jag.lägger frågan på rätt ställe nu.
Försöker att lägga upp en Minecraft server till min son och hans kompisar.
Har laddat ner servern o startat den och där funkar den på lokal IP adress.
Har öppnat porten i routern och i Windows brandvägg och kolla min IP ute på nätet och även kollat så min port är öppen och det är den. Ändå kan jag inte logga in via nätet.

Har en ubiquiti amplifi som huvud router och en asus rt66 som ligger i mediabrygga för att datorerna står i ett annat rum. Har öppnat porten i ubiquiti men i Asien kan jag inte göra något sådant.

Någon som har en idé på vad jag gör för fel?

Mvh
Andreas

Trädvy Permalänk
Medlem
Plats
/var/www
Registrerad
Maj 2008
Skrivet av andy_hstad:

Hej.

Hoppas jag.lägger frågan på rätt ställe nu.
Försöker att lägga upp en Minecraft server till min son och hans kompisar.
Har laddat ner servern o startat den och där funkar den på lokal IP adress.
Har öppnat porten i routern och i Windows brandvägg och kolla min IP ute på nätet och även kollat så min port är öppen och det är den. Ändå kan jag inte logga in via nätet.

Har en ubiquiti amplifi som huvud router och en asus rt66 som ligger i mediabrygga för att datorerna står i ett annat rum. Har öppnat porten i ubiquiti men i Asien kan jag inte göra något sådant.

Någon som har en idé på vad jag gör för fel?

Mvh
Andreas

Hej Andreas.

vad har du för adress till server, kan kolla om du har rätt port öppen?

got root?

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Vet inte hur din router fungerar men man måste oftast göra en port-forwarding från porten på det externa IP till porten på ditt interna IP.
Fungerar det mot det interna IP från annan datorn än den där servern är igång?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@edroon: Hej. Har kollat porten via ismyport Open och det är den.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2010

hur är asus routern inställd?
Hur har du kollat att porten är öppen?
Fungerar någon annan port?

Edit: lite sen

Ingen aning om hur bra ismyport men då är ju frågan snarare, hur försöker du ansluta till MC servern? Vad får du för fel när du försöker

Maximus X Hero - 8700k @5.1GHz - H115i - 32GB LPX@3466MHz - MSI 980Ti Gaming - EVGA SuperNova 750 G2 - Asus vg248qe - FD R5

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@Pake: Hej portforward är gjort och porten är öppen enligt ismyport.com kör jag på det interna nätverket så funkar det jättebra.

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@Elghinnarisa: Asusen är lagt som en mediabrygga, repetera med sladd från den andra routern så då skall brandvägg och sådant vara avstängt vad jag fattade det som. Kan det vara den som är problemet?

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Vad är din externa IP på routern?
Många operatörer kör ju med NAT nu och i så fall fungerar det inte då du inte har en publik IP-adress.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2005
Skrivet av andy_hstad:

Hej.

Hoppas jag.lägger frågan på rätt ställe nu.
Försöker att lägga upp en Minecraft server till min son och hans kompisar.
Har laddat ner servern o startat den och där funkar den på lokal IP adress.
Har öppnat porten i routern och i Windows brandvägg och kolla min IP ute på nätet och även kollat så min port är öppen och det är den. Ändå kan jag inte logga in via nätet.

Har en ubiquiti amplifi som huvud router och en asus rt66 som ligger i mediabrygga för att datorerna står i ett annat rum. Har öppnat porten i ubiquiti men i Asien kan jag inte göra något sådant.

Någon som har en idé på vad jag gör för fel?

Mvh
Andreas

Ditt nätverk ser ut som följande om jag förstått rätt
Internet -> Ubiquiti -> RT66 -> Grabbens dator. Korrekt?

Har du möjlighet att koppla en dator direkt mot Ubiquitin och testa om den kan nå Minecraft-servern via det interna IP:t?

Om inte så gör din RT66 antagligen något du inte vill att den gör. Du nämnde att den aggerar "mediabrygga", vilket får mig att tänka att den inte ska NAT:a, men deras definition kan vara annorlunda av vad en "mediabrygga" gör.

Ifall den NAT:ar så har du dubbel-NAT, och det kan skapa sådana problem som du upplever.

Intel i7-5960x @ 4.5GHz 1.273v | 64GB DDR4 @ 2400MHz CL14 | 120GB SSD Sysdisk | 1TB SSD Speldisk

Trädvy Permalänk
Medlem
Plats
/var/www
Registrerad
Maj 2008

Vad får man för felmeddelande när man försöker joina servern? kolla loggarna.

se till att de skriver porten (e.x. 96.44.143.26:25567)

got root?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@Soir: kan detta hjälpa dig att förstå och ja ske hjälpa mig att förstå
https://www.asus.com/us/support/FAQ/114552/

Får prova att köra till Ubiquiti direkt och se. Kanske är bättre att sätta asusen i repete läge?
Valde media bright för att då kör man sladd imellan.

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@edroon: har provat med och utan port. Får upp time out Gail to connect

Trädvy Permalänk
Medlem
Registrerad
Apr 2015

Sitter sladden från ubiquiti till asusen i WAN på asusen?
Sätt den i en vanlig port i stället för WAN och se om det hjälper.

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av andy_hstad:

Hej.

Hoppas jag.lägger frågan på rätt ställe nu.
Försöker att lägga upp en Minecraft server till min son och hans kompisar.
Har laddat ner servern o startat den och där funkar den på lokal IP adress.
Har öppnat porten i routern och i Windows brandvägg och kolla min IP ute på nätet och även kollat så min port är öppen och det är den. Ändå kan jag inte logga in via nätet.

Har en ubiquiti amplifi som huvud router och en asus rt66 som ligger i mediabrygga för att datorerna står i ett annat rum. Har öppnat porten i ubiquiti men i Asien kan jag inte göra något sådant.

Någon som har en idé på vad jag gör för fel?

Mvh
Andreas

Kan du ansluta till servern från annan dator på ditt nätverk, inte bara lokalt? Här kan man tänka sig att prova med en dator som är ansluten både till Asusen och till Amplifin.

När du kollat att detta funkar så kan du ge dig på portforwarden igen och dubbelkolla att du har portforwardat rätt port till rätt port på din grabbs dator. Att något verktyg säger att porten är öppen men att det ändå inte funkar talar bara om hur dåligt dessa verktyg funkar.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@Yomster: då kan jag prova efter jobbet. Bara på på med förslag. Vill gärna få igång det

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

Kom på en sak till behöver ubiquiti stå i brygga läget för att köra med 2 st routrar?

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av andy_hstad:

Kom på en sak till behöver ubiquiti stå i brygga läget för att köra med 2 st routrar?

Det är jag ganska säker på att den inte ska. Den agerar ju router och jag gissar att andra enheter ansluter till den också. Din andra router har du ju konfigurerat till att inte längre vara router.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@giplet: får prova detta. Finns det något bra verktyg för att kolla om porten är öppen?

Kanske bättre att hyra en server istället...

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av andy_hstad:

@giplet: får prova detta. Finns det något bra verktyg för att kolla om porten är öppen?

Kanske bättre att hyra en server istället...

Det enda som finns är verktyg där du kör ett speciellt program på datorn som agerar server och ställer in det till att svara på den specifika port som du ställt in. Men det behövs inte. Är du noggrann när du ställer in så blir det rätt.

Men gå igenom stegen jag har listat ovan och återkom med resultatet. Inte säkert att det är just din portforward som är problemet.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Registrerad
Maj 2012

Som någon annan skrev, kolla att din router verkligen får ett publikt IP och inte ett internt hos din ISP.
gå till t.ex whatismyip.com och jämför med WAN IP i din router. Kan vara så att din ISP stoppar dig från att öppna portat mot internet. I vissa fall måste man begära att få ett publikt IP.
Har du andra port forwarding som fungerar?
Använder du ASUS-routern som en switch i andra rummet för att bara dra en kabel dit? I så fall är mitt då att köpa en riktig switch och sätta där för att undvika problem.

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@Pake: när jag kollar på whats my ip så får jag en ip som heter 90.255.71.xxx borde vara rätt?
Kollar på is my port open och söker på det ip nr och port 25565 så säger den öppen.

Anledning till att jag har asusen är att där är skrivare server i den + att att jag har en hårddisk kopplad till den för att kunna titta på bilder och dyligt direkt i tv och på telefoner. Funkar väldigt bra.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2005
Skrivet av andy_hstad:

@Pake: när jag kollar på whats my ip så får jag en ip som heter 90.255.71.xxx borde vara rätt?
Kollar på is my port open och söker på det ip nr och port 25565 så säger den öppen.

Anledning till att jag har asusen är att där är skrivare server i den + att att jag har en hårddisk kopplad till den för att kunna titta på bilder och dyligt direkt i tv och på telefoner. Funkar väldigt bra.

90.255.71.0/24 kommer upp som Vodafones. Logga gärna in i Ubiquitin och kolla vad den säger är ditt WAN IP på ditt WAN interface. Stämmer det med ovan?

Intel i7-5960x @ 4.5GHz 1.273v | 64GB DDR4 @ 2400MHz CL14 | 120GB SSD Sysdisk | 1TB SSD Speldisk

Trädvy Permalänk
Medlem
Registrerad
Maj 2012
Skrivet av andy_hstad:

@Pake: när jag kollar på whats my ip så får jag en ip som heter 90.255.71.xxx borde vara rätt?
Kollar på is my port open och söker på det ip nr och port 25565 så säger den öppen.

Anledning till att jag har asusen är att där är skrivare server i den + att att jag har en hårddisk kopplad till den för att kunna titta på bilder och dyligt direkt i tv och på telefoner. Funkar väldigt bra.

När du tittar på whatismyip.com får du alltid se en publik IP men det betyder inte att det är samma som din router har. Din ISP kan nämligen tilldela dig egna IP-nummer som inte är publika mot övriga internet. Så därför måste du jämföra det IP-numret mot vad din router rapportera som WAN IP.

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

@giplet: Okej då har jag provat. Jag satt grabben dator på wifi dirket till amplifi och min egna på kabel till asusen. Kolla så att grabbens dator fick en annan ip och testa att logga in lokalt till den och det va inga problem. Kolla sen i amplifin att det va samma ip nr där till nätet som det va när jag kolla på whatsmy ip.Ändra ip till det som va på grabbens datorn nu i portforwarden kolla även där på whatsmyips hemsida och dem hittade porten som öppen. Men kan inte logga ip på server via ip den Internets adressen

Jag fattar ingenting..

Trädvy Permalänk
Moderator
Registrerad
Aug 2007

Jag har svårt att hänga med hur du egentligen testar. Vilken dator ligger servern på? Kan du koppla upp från den andra datorn till servern?

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av andy_hstad:

@giplet: Okej då har jag provat. Jag satt grabben dator på wifi dirket till amplifi och min egna på kabel till asusen. Kolla så att grabbens dator fick en annan ip och testa att logga in lokalt till den och det va inga problem. Kolla sen i amplifin att det va samma ip nr där till nätet som det va när jag kolla på whatsmy ip.Ändra ip till det som va på grabbens datorn nu i portforwarden kolla även där på whatsmyips hemsida och dem hittade porten som öppen. Men kan inte logga ip på server via ip den Internets adressen

Jag fattar ingenting..

min gissning är att du har NAT adresser från din leverantör, om du har Bahnhof så måste man logga in och begära en wan ip. jag tror t o m jag har fått fast ip. Den har inte ändrat sig på 1 år. Oavsett om saker å ting är avstängda. Kanske bara är ren tur iofs. Men om jag inte missminner mig. Jag använder www.mittip.se

Det kan också underlätta lite om du har möjlighet att rita hur det ser ut. Det är alltid lättare att se en bild än att försöka föreställa sig det med bara ord. Det enda du ska behöva göra är att öppna porten/samt brandväggen till den datorn som har servern igång. Servern kör du med fast ip internt.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Aug 2008

Kan de vara så att unifi inte stödjer att loopa genom externa interfacet. D.v.s. du försöker nå den publika ip:n (utisda/wanport) från insidan.

När ni gör tester mot publika ip:n var är ni anslutna?

Stationär: i7 6700k @ 4.4GHz | 32GB DDR4 | Asus Impact VIII | 1080ti Waterforce 2.1GHz | Evolv-ITX | Intel 750 400GB + 1TB 850 evo | K70rgb strafe silent | G600 | Acer XB271HU | Qnix 2710
Homelab: I3 6100 | 16GB DDR4 | Node304 | 6x 4TB 7.2k | 850 250GB
Bärbart: Lenovo Carbon X1 | Shield Tablet 32GB | Galaxy S8 |

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2005
Skrivet av andy_hstad:

@giplet: Okej då har jag provat. Jag satt grabben dator på wifi dirket till amplifi och min egna på kabel till asusen. Kolla så att grabbens dator fick en annan ip och testa att logga in lokalt till den och det va inga problem. Kolla sen i amplifin att det va samma ip nr där till nätet som det va när jag kolla på whatsmy ip.Ändra ip till det som va på grabbens datorn nu i portforwarden kolla även där på whatsmyips hemsida och dem hittade porten som öppen. Men kan inte logga ip på server via ip den Internets adressen

Jag fattar ingenting..

Vänta, försöker du nå Minecraft servern inifrån genom att använda ditt publika IP?

Det är fullt möjligt att du inte har NAT Hairpinning på Ubiquitin, och detta kommer alltså inte att fungera.

Du kan skicka mig ditt IP via PM så testar jag härifrån om det går att komma åt servern.

Intel i7-5960x @ 4.5GHz 1.273v | 64GB DDR4 @ 2400MHz CL14 | 120GB SSD Sysdisk | 1TB SSD Speldisk

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Okt 2010

Hej. Vill tacka alla som har försökt hjälpa mig men inser att detta är inget för mig. Har alldeles för dålig kunskap om hur man skall göra så jag tror jag hyr en server plats som barnen kan få spela på.

Tack för all hjälp.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Mar 2011
Skrivet av andy_hstad:

Hej. Vill tacka alla som har försökt hjälpa mig men inser att detta är inget för mig. Har alldeles för dålig kunskap om hur man skall göra så jag tror jag hyr en server plats som barnen kan få spela på.

Tack för all hjälp.

www.swedishhost.se har bra kvalitet