Arch + certbot + svenska tecken?

Trädvy Permalänk
Medlem
Plats
Säter
Registrerad
Apr 2005

Arch + certbot + svenska tecken?

Har sökt runt men inte hittat hur jag gör med svenska tecken i domännamnet och letsencrypt.
Måste jag kompilera en custom certbot där stöd för idn finns eller stöds det redan nu? Jag har version 0.20.0-1 och stöd för idn kom tydligen redan i version 0.9.
Jag har konverterat namnet i en idn-konverterare online och satt in som domännamn i serverblocket för den domänen men certbot klagar på challenges.
Servern kör arch linux med nginx.

///

Trädvy Permalänk
Medlem
Registrerad
Apr 2002
Skrivet av M3Johan:

Har sökt runt men inte hittat hur jag gör med svenska tecken i domännamnet och letsencrypt.
Måste jag kompilera en custom certbot där stöd för idn finns eller stöds det redan nu? Jag har version 0.20.0-1 och stöd för idn kom tydligen redan i version 0.9.
Jag har konverterat namnet i en idn-konverterare online och satt in som domännamn i serverblocket för den domänen men certbot klagar på challenges.
Servern kör arch linux med nginx.

Om namnet du anger är t.ex. www.xn--rksmrgs-5wao1o.se så borde det bara funka, tycker jag

Intel i7 6850k || Asus X99-A II || Evga GTX 980Ti || Kingston HyperX Fury 2666 64GB || Samsung 950 Pro 512GB || XB270HU 1440p IPS G-Sync

Trädvy Permalänk
Medlem
Plats
Säter
Registrerad
Apr 2005

Ja precis det är en sådan harang jag angett i serverblocket.

Men efter lite mer googlande så fann jag detta hos Letsencrypt.

Citat:

If you are getting this message:

Citat:

Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.

It is because Let’s Encrypt has currently disabled the TLS-SNI-01 challenge363 due to a security report. If you need to renew or issue a certificate right now, you should most likely use the HTTP-01 challenge. Certbot developer @bmw provided some helpful instructions1.3k, copied here for convenience:

If you’re serving files for that domain out of a directory on that server, you can run the following command:

sudo certbot --authenticator webroot --webroot-path <path to served directory> --installer nginx -d <domain>

If you’re not serving files out of a directory on the server, you can temporarily stop your server while you obtain the certificate and restart it after Certbot has obtained the certificate. This would look like:

sudo certbot --authenticator standalone --installer nginx -d <domain> --pre-hook "service nginx stop" --post-hook "service nginx start"

These hooks will cause Certbot to automatically stop your server to obtain certificates and then start it again. After running a command like this once, Certbot will remember your settings so certbot renew will work in the future.

For other people who find this issue, this affects some of our other plugins as well such as the Apache plugin. All the advice above is identical except you should replace nginx with apache in the different CLI options.

///

Trädvy Permalänk
Medlem
Registrerad
Aug 2014

@M3Johan: idn + punycode stöds till 100% av letsencrypt. Jag rekommenderar att använda certbot-auto för smidigast konfiguration. Du kan registrera ditt domännamn direkt i Unicode eller i ACE encoded ASCII om du så vill - det gör ingen skillnad.

Mer info här: https://punycode.io/

Z170-WS | Intel 6700K | Dominator 2x16GB 3000MHz | Samsung 950 Pro 2x512GB NVMe RAID0 | MSI 1080 Gaming X | Seasonic 520 Fanless | 7260 HMV-AC | Fractal Design Define R4 | Noctua NH-U12S@475RPM | Noctua P12@475RPM x5
Supermicro X10SLL-F | Supermicro 1U SC813MT-300C | XEON E3 1231v3 | Hynix 4x8GB ECC | 840 EVO | WD 6x 4TB RE
x220 | IPS | i7 | SSD | 9-cell

Trädvy Permalänk
Medlem
Plats
Säter
Registrerad
Apr 2005
Skrivet av ggwp:

@M3Johan: idn + punycode stöds till 100% av letsencrypt. Jag rekommenderar att använda certbot-auto för smidigast konfiguration. Du kan registrera ditt domännamn direkt i Unicode eller i ACE encoded ASCII om du så vill - det gör ingen skillnad.

Mer info här: https://punycode.io/

Det löste sig efter att jag följt instruktionen på länken i mitt förra inlägg .
Det var inte fel hos mig. 😊

///