Ingen bild när Linux startar

Trädvy Permalänk
Medlem
Registrerad
Jan 2006

Ingen bild när Linux startar

Hej
Jag har försökt installera flera linux distributioner på min dator och fått samma fel varje gång. Felet är att såfort linux ska starta så får jag ingen bild till skärmen och inget mer händer.

Datorspeccs:
CPU: E8400
Moderkort: Asus P5Q DELUXE
Grafikkort: Nvidia Geforce 460 768mb
SSD: Crucial 128 gb
Usb sticka med linuxet: 16 GB

Första distron jag prövade, försök 1: Senaste Debian netinstall. Efter installation ser jag listan där man kan välja Debian. Därefter står det att jag ska skriva lösenordet för krypterade LVM. Skriver det sen står det något att LVM inte fungerar och skärmen blir svart och ingen bild.
Första distron jag prövade, försök 2: Senaste Debian netinstall utan LVM. Efter installation ser jag listan där man kan välja Debian. Därefter ser jag någon text och skärmen blir svart och ingen bild.
Andra distron jag prövade: Senaste Ubuntu x64 17.10. Efter att ha tryckt på install Ubuntu blir skärmen svart och ingen bild.
Tredje distron jag prövade: Linux Mint senaste x64 cinnamon. Skärmen blir svart och ingen bild om jag försöker testa Linux mint (man installerar det genom att starta det från ison). Det fungerar dock att köra Linux Mint i kompabilitetsläget då all bild genereras av cpu'n.

Därefter så märkte jag att Linux mint med gpu grafik gick att starta på en annan dator utan problem från samma usb sticka. Så felet är i min dator och jag tror det är något med att grafikkortet inte klarar av att visa Linux.

Varför får jag ingen bild när jag ska starta linux distributioner?

All datorprestanda kan jämföras i kronor och ören (kr/poäng). Exempel: Prestanda/krona på grafikkort | Shadowk på YouTube | www.intrnet.se

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Mar 2008

Starta i kompatibilitetsläge och installera/välj nvidias drivrutiner istället för de inbyggda. Antagligen har ditt grafikkort inte stöd som default bara.

Trädvy Permalänk
Avstängd
Registrerad
Nov 2012

Testa med Fedora eller Antergos.

Alla distros du har testat är i grunden Debian eftersom Ubuntu och Mint baseras på Debian.

Trädvy Permalänk
Medlem
Registrerad
Jan 2006

Jag har testat med Fedora och samma problem. Ingen bild efter GRUB utan bara svart skärm. Fedora hade dock basic graphics som jag installerade operativsystemet med. Nu så får jag denna error när jag installerar Nvidia original grafikkortsdrivrutinen:
https://i.imgur.com/8Se54NE.jpg

Detta trots att jag redan installerat "kernel-devel" som det stod att jag skulle göra. Vet någon hur man gör kernel-source-path grejjen?

All datorprestanda kan jämföras i kronor och ören (kr/poäng). Exempel: Prestanda/krona på grafikkort | Shadowk på YouTube | www.intrnet.se

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2007

Glöm det jag skrev, kika här.

https://www.if-not-true-then-false.com/2015/fedora-nvidia-gui...

Pain in the bunghole, ugh.

Rpm-fusion är ett repo där alla non-free paket finns till fedora https://rpmfusion.org/
Bör finnas nvidia drivrutiner där att färdigt installera för dig, slipper du underhålla det själv...

Generellt laddar man inte ner program från tredjepart, utan låter sin pakethanterare sköta det åt en, jag tolkar det som att du fick dina drivrutiner från nvidia, i Linux är det väl generellt inte så man bör gå tillväga.

Ryzen 1700x @ Corsair 16gb 3200mhz lpx @ 512gb M2 pcie @ Gigabyte 7950 @ Msi x370 plus @ Evga 650 80+gold modulärt @ Fractal r5 @ Corsair hydro 110i @ Benq 144hz 1920-1080 24tum
i5 4670k @ Asus z-87a @ Corsair vx450 @ Corsair 16gb 1600mhz @ Fractal r3 @ 256gb Kingston
c2d e4400 @ 4gb noname @ 10tb+ @ noname chassi @ 128gb Kingston ssd

Trädvy Permalänk
Medlem
Registrerad
Jan 2006

Okej. Jag fick valet att uppdatera Fedora. Jag startade då om och uppdaterade. När jag hade skrivit in lösen och loggat in i datorn så fick jag svart skärm. Det hände ingenting alls. Startade om och samma problem.
Nu så har jag kommit på en lösning som jag ska välja och det är att åka och köpa Windows 10. Linux kanske det blir i framtiden någon gång när det fungerar out of the box.

All datorprestanda kan jämföras i kronor och ören (kr/poäng). Exempel: Prestanda/krona på grafikkort | Shadowk på YouTube | www.intrnet.se

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av michael123:

Okej. Jag fick valet att uppdatera Fedora. Jag startade då om och uppdaterade. När jag hade skrivit in lösen och loggat in i datorn så fick jag svart skärm. Det hände ingenting alls. Startade om och samma problem.
Nu så har jag kommit på en lösning som jag ska välja och det är att åka och köpa Windows 10. Linux kanske det blir i framtiden någon gång när det fungerar out of the box.

Kan förstå frustrationen, Windows 10 kan nog vara ett bra val i det läget.
Tror inte du skall hålla andan när det kommer till att fungera out of the box, det är helt upp till tillverkaren när det kommer till sådan hårdvarusupport.

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Det är inte så att bilden är på en annan skärm?

Signatur raderad, se reglerna för mer info.

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012
Skrivet av michael123:

Okej. Jag fick valet att uppdatera Fedora. Jag startade då om och uppdaterade. När jag hade skrivit in lösen och loggat in i datorn så fick jag svart skärm. Det hände ingenting alls. Startade om och samma problem.
Nu så har jag kommit på en lösning som jag ska välja och det är att åka och köpa Windows 10. Linux kanske det blir i framtiden någon gång när det fungerar out of the box.

Varför inte köpa ett nyare grafikkort, istället för att lägga pengar på Windows?

Skickades från m.sweclockers.com

Chassi: FD Arc mini R2 | PSU: CM700V | MB: Asus Maximus V Gene Z77 | CPU: I5-3570K | RAM: 16GB Corsair LP | GPU: MSI Radeon RX580 Armor 8GB | SSD: Crucial MX300 750GB | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Plats
root
Registrerad
Jan 2004

Hej @Michael123 ! så här gör alltid jag !
1/ kollar först om det finns stöd för mitt nvidia kort här
2/ finns det så gör som det står på sidan & hittills har det ej det fallerat för mig !

Trädvy Permalänk
Medlem
Registrerad
Maj 2006

Knepigt om du inte kommer förbi Grub, men låter ju som du har installerat och kan logga in?

Är det det grafiska gränssnittet som du inte får upp? Kan vara problem med Gnome (som egentligen löses med dnf update) som du kommer åt via terminalen med Ctrl-alt-f2 tex . Kör du LiveUSB, kan du testa köra startx för att kringå problemet och installera.

Trädvy Permalänk
Medlem
Plats
Salem
Registrerad
Mar 2004

Hej, jag kör Ubuntu 16.04 LTS med ett gammalt GTX 460.
När jag startar så ser jag Grub men sedan blir skärmen svart tills Linux startat och jag kan logga in.
Installerade från LiveUSB och det fungerade helt okej.

Man made the electrolyte to make us see the horrors in the dark.