Raspbian + Putty = Access Denied

Permalänk
Medlem

Raspbian + Putty = Access Denied

Hejsan svejsan!

Håller för fullt på att försöka koppla upp min RPI3 genom ssh på mitt wifi-nätverk här hemma. Har fått det att fungera för ett bra tag sen när jag körde enbart OSMC på maskinen, men nu när jag installerat Raspbian så kan jag verkligen inte få till det.

Har testat allt jag hittat på nätet, alltifrån att ändra root-permission på RPIns ssh_config-fil, ändrat lösenord, ändrar portar fram och tillbaka, fixat statisk ip i routern. Har testat precis allt men det vill inte fungera.

När jag startar putty så får den upp terminalen där jag ska skriva in användarnamn och lösenord. Skriver in standard-uppgifter (use: pi, pw: raspberry) som jag inte har ändrat vad jag vet, men när jag skriver in lösenordet så tuggar den i några sekunder, sen ger mig "Access Denied" och så kommer jag inte vidare.

Har någon en lösning på vad man gör i ett sånt här fall? Har letat som en idiot ända sen igår kväll, halva natten och under hela dagen idag men inte hittat något vettigt alls.

Tack på förhand för hjälpen!

Permalänk
Medlem

kommer du in med det om du provar lokalt? dvs med skärm å tangentbord.

Permalänk
Medlem

Har du installerat SSH-tjänsten, trycker du i SSH i putty?

sudo apt install openssh-client

sudo apt install openssh-server

Permalänk
Medlem
Skrivet av swehunter2000:

kommer du in med det om du provar lokalt? dvs med skärm å tangentbord.

Hur menar du nu? Menar du på RPIn lokalt eller vart tänker du att jag ska testa?

Permalänk
Medlem

Har du testat att installera om Raspbian och börja om från scratch? Just "Access Denied" känns kanske lite mysko men om jag inte minns fel har Raspbian by default SSH låst.

"As of the November 2016 release, Raspbian has the SSH server disabled by default. It can be enabled manually from the desktop"
https://www.raspberrypi.org/documentation/remote-access/ssh/

Permalänk
Medlem
Skrivet av fisken92:

Har du installerat SSH-tjänsten, trycker du i SSH i putty?

sudo apt install openssh-client

sudo apt install openssh-server

Nej enligt nätet ska det vara förinstallerat men avaktiverat som standard i Raspbian och att man får aktivera det manuellt med diverse kommandon i terminalen i Raspbian. Men om det är så enkelt så är det ju gött. Får testa det iaf.

Permalänk
Hedersmedlem

Lite osäker på exakt vad du testat, mwn SSH är ju inte ingång som standard i raspbian längre.
här finns beskrivningar på hur du smäller igång det igen:
https://www.raspberrypi.org/documentation/remote-access/ssh/

Skickades från m.sweclockers.com

Själv kör jag headless så jag lade in en fil man damn ssh på SDkortet för att lösa det här.

Permalänk
Medlem
Skrivet av DeGreeZ:

Hej! Är det så att du kör headless? Eller kan du koppla upp mot en skärm och logga in med samma användarnamn och lösenord?

Är uppkopplad mot skärm med tangentbord och mus! Misstänker att du menar logga ut på RPIn och sen logga in med samma uppgifter som jag skriver in i Putty eller?

Skrivet av gonace:

Har du testat att installera om Raspbian och börja om från scratch? Just "Access Denied" känns kanske lite mysko men om jag inte minns fel har Raspbian by default SSH låst.

"As of the November 2016 release, Raspbian has the SSH server disabled by default. It can be enabled manually from the desktop"
https://www.raspberrypi.org/documentation/remote-access/ssh/

Har en helt fräsch installation sen igår natt. Fick formatera om + installera om Raspbian pga den hängde sig mitt i installationen första gången...

Permalänk
Medlem
Skrivet av vompen:

Nej enligt nätet ska det vara förinstallerat men avaktiverat som standard i Raspbian och att man får aktivera det manuellt med diverse kommandon i terminalen i Raspbian. Men om det är så enkelt så är det ju gött. Får testa det iaf.

Det kan vara så enkelt!

Permalänk
Medlem
Skrivet av DeGreeZ:

Juste, du behöver lägga till en tom ssh fil i SDkortet. Skapa en fil, döp den till ssh och sen ska du kunna ssha till den

Har testat detta, men fungerade inte. La filen på sd-kortet, stoppade in i RPin, startade upp den sen var filen borta som det stod i beskrivningen att den skulle vara. Men sen händer inget mer.

Skrivet av Söderbäck:

Lite osäker på exakt vad du testat, mwn SSH är ju inte ingång som standard i raspbian längre.
här finns beskrivningar på hur du smäller igång det igen:
https://www.raspberrypi.org/documentation/remote-access/ssh/

Skickades från m.sweclockers.com

Har just följt de stegen bland annat och den ger ifrån sig att SSH är igång/aktiverat etc, men uppenbarligen är det något som strular för det fungerar inte att koppla upp sig...

Permalänk
Medlem

copy paste:

sudo systemctl enable ssh && sudo systemctl start ssh

Permalänk
Medlem

@vompen: Men kan du koppla upp rin RPi emot en skärm och logga in då? Så kan du ju alltid köra en "tail -f /var/log/auth.log" och se varför du får access denied?

Permalänk
Medlem
Skrivet av etnica33:

copy paste:

sudo systemctl enable ssh && sudo systemctl start ssh

Redan testat detta, ger inga resultat alls. Fortfarande samma att den ger access denied när man skriver in lösenordet..

Permalänk
Medlem
Skrivet av gonace:

@vompen: Men kan du koppla upp rin RPi emot en skärm och logga in då? Så kan du ju alltid köra en "tail -f /var/log/auth.log" och se varför du får access denied?

Står en massa kod och meddelanden innan, men detta var väl det som var tydligast om vad som var "fel"

Failed password for pi from <min dators IP> port 52400 ssh2

Permalänk
Medlem
Skrivet av fisken92:

Har du installerat SSH-tjänsten, trycker du i SSH i putty?

sudo apt install openssh-client

sudo apt install openssh-server

Skrivet av gonace:

Har du testat att installera om Raspbian och börja om från scratch? Just "Access Denied" känns kanske lite mysko men om jag inte minns fel har Raspbian by default SSH låst.

"As of the November 2016 release, Raspbian has the SSH server disabled by default. It can be enabled manually from the desktop"
https://www.raspberrypi.org/documentation/remote-access/ssh/

Skrivet av DeGreeZ:

Juste, du behöver lägga till en tom ssh fil i SDkortet. Skapa en fil, döp den till ssh och sen ska du kunna ssha till den

Skrivet av Söderbäck:

Lite osäker på exakt vad du testat, mwn SSH är ju inte ingång som standard i raspbian längre.
här finns beskrivningar på hur du smäller igång det igen:
https://www.raspberrypi.org/documentation/remote-access/ssh/

Skickades från m.sweclockers.com

Själv kör jag headless så jag lade in en fil man damn ssh på SDkortet för att lösa det här.

Skrivet av etnica33:

copy paste:

sudo systemctl enable ssh && sudo systemctl start ssh

till alla ovan: SSH är redan aktiverat, annars skulle han inte få få "Access denied" efter att ha skrivit in ett lösenord. han skulle få connection refused.

Skrivet av vompen:

Hur menar du nu? Menar du på RPIn lokalt eller vart tänker du att jag ska testa?

Koppla in en skärm och tangentbord till raspberryn och prova logga in med user:pi pw:raspberry. funkar det?

Permalänk
Medlem
Skrivet av swehunter2000:

till alla ovan: SSH är redan aktiverat, annars skulle han inte få få "Access denied" efter att ha skrivit in ett lösenord. han skulle få connection refused.

Koppla in en skärm och tangentbord till raspberryn och prova logga in med user:pi pw:raspberry. funkar det?

Hmm nej det fungerade inte. Det ligger en profil/användare som heter pi i raspbian redan, men lösenordet verkar inte stämma. Inte undra på varför det inte fungerar att logga in... Men då är frågan varför den har något annat när jag inte ens har angett eller ändrat något lösenord...?

Permalänk
Hedersmedlem

@swehunter2000 sant! Good point there!

Skickades från m.sweclockers.com

Permalänk
Medlem

@swehunter2000: Jag länkade till guiden för att han kan ha missat ett steg, han kan ha fått igång sshd men att den är konfigurerad att inte acceptera annslutningar.

Sedan tyckte jag att han kunde taila auth.log men det nappade han inte på

@vompen: Tycker inte att jag ser att du svarat på om du kan koppla in din RPi till en skräm och logga in på den på så vis?

Permalänk
Medlem
Skrivet av gonace:

@swehunter2000: Jag länkade till guiden för att han kan ha missat ett steg, han kan ha fått igång sshd men att den är konfigurerad att inte acceptera annslutningar.

Sedan tyckte jag att han kunde taila auth.log men det nappade han inte på

Är inte så avancerad av mig, men vet inte vad du vill ha mer än det jag skrev i senaste svaret på vad som stod i loggen.. hehe..

EDIT: den har ju autologin vad jag vet, men som jag svarade på swehunter2000s svar så verkar inte lokal inloggning fungera. Användaren pi finns men lösenordet verkar inte stämma av någon märklig anledning. Kör jag på autologin dock så får jag ut informationen som jag bidrog med senare (+ lite fler textrader som inte i mina ögon säger så mycket jämfört med den raden jag skrev som svar till dig)...

Permalänk
Medlem

@vompen: Kan du logga in med någon användare med tangentbord och skärm?

Permalänk
Medlem

@vompen: Skulle vara intressant om du kan koppla in din RPi till en skärm/tv och dra i ett tangentbord och se om du kan logga in då?

Permalänk
Medlem
Skrivet av swehunter2000:

@vompen: Kan du logga in med någon användare med tangentbord och skärm?

Skrivet av gonace:

@vompen: Skulle vara intressant om du kan koppla in din RPi till en skärm/tv och dra i ett tangentbord och se om du kan logga in då?

Testade att logga ut och testa "other" under users men fungerade inte. Men jag startade om och fick autologin och av ren nyfikenhet testade jag att ändra lösenord i menyn för raspbian till standard "raspberry". När det var klart loggade jag ut, testa att logga in och den kom in direkt samtidigt som en ruta om just SSH och dess aktivering skett dök upp och pekade på att jag behövde byta lösen. Sagt och gjort. Bytte lösenord, startade om RPIn och testade sedan att logga in på Putty och voila, fungerade direkt!

Så på något sätt har den väl "blivit av" med lösenordet för raspbian och utan ett kommer man ingenstans. Men nu fungerar det verkar det som!

Tack så mycket för hjälpen allihopa!!

Permalänk
Medlem
Permalänk
Medlem

Jag har samma problem som vompen. Jag har logga in direkt med skärm+tangtbord vid pi3. Men när jag ska logga in via min pc (win10) så får jag access denied ändå. Har satt SSH till enable men det funkar ändå inte. Ip adressen har jag fått via min router till min pi3