Hyper-V Core 2016 startar om sig

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Hyper-V Core 2016 startar om sig

Först ska jag säga att jag hade en Hyper-V 2012 core på en annan server som bete sig lite som denna.
Men det enda jag flyttat över från den är 2 minnen och en hårddisk som inte var bootbar eller hade OS i sig.

Det servern gör är att den startar upp och jobbar som vanligt sedan helt plötslig ca ett dygn senare så startar den bara om sig och på något sätt så bootar den inte från den disk som är default som har Hyper-V core i sig.
Jag blir tvungen att stänga av den med powerknappen och starta igång den då bootar den som det ska.

Kollar jag i Hyper-V loggen så säger den bara i Error

"The previous system shutdown at 17:59:17 on ‎2018-‎02-‎13 was unexpected."

"The SNMP Service encountered an error while accessing the registry key SYSTEM\CurrentControlSet\Services\SNMP\Parameters\TrapConfiguration."

och en Critial
"The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly."

Kör jag fjärrskrivbordet in i den så säger den med blå text att det finns viktiga uppdatering men när jag söker efter uppdateringar så säger den at det inte finns något fast jag väljer "All updates"

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av TheCazz:

Först ska jag säga att jag hade en Hyper-V 2012 core på en annan server som bete sig lite som denna.
Men det enda jag flyttat över från den är 2 minnen och en hårddisk som inte var bootbar eller hade OS i sig.

Det servern gör är att den startar upp och jobbar som vanligt sedan helt plötslig ca ett dygn senare så startar den bara om sig och på något sätt så bootar den inte från den disk som är default som har Hyper-V core i sig.
Jag blir tvungen att stänga av den med powerknappen och starta igång den då bootar den som det ska.

Kollar jag i Hyper-V loggen så säger den bara i Error

"The previous system shutdown at 17:59:17 on ‎2018-‎02-‎13 was unexpected."

"The SNMP Service encountered an error while accessing the registry key SYSTEM\CurrentControlSet\Services\SNMP\Parameters\TrapConfiguration."

och en Critial
"The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly."

Kör jag fjärrskrivbordet in i den så säger den med blå text att det finns viktiga uppdatering men när jag söker efter uppdateringar så säger den at det inte finns något fast jag väljer "All updates"

Vad säger DMP filerna?

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Ska erkänna att jag inte visste vad det var men har hittat en bra guide på Microsoft så den är aktiverad och klar tills imorgon då jag misstänker detta kommer hända igen.
Har dock inte hittat någon bra guide på dumpchk.exe för att installera på min dator för att kunna får över och läsa DMP filen.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

@TheCazz:

ladda sen ner whocrashed den kan läsa dmp filen och ge ett hum om vad som händer.

http://www.resplendence.com/whocrashed

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Dec 2004

Hmmm...

Jag har haft 4st idag på min main desktop.

https://imgur.com/a/MAkWK

Har ett par andra i loggen men de har jag förklaring på iaf..

Det fanns en gång en båt...

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

Oftast så är de drivrutiner som ställer till det eller hårdvarefel.

Men som sagt kolla länken till programet som jag skrev ovan, då kommer ni kunna få svar

Skickades från m.sweclockers.com

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Apr 2002

Kör ett test på minnena i några timmar.

Define R5 Titanium | EVGA SuperNOVA 750 G2 | ASRock Z77 Extreme4 | Intel i5 3750k @ 4Ghz | Cooler Master 212 Evo | 16GB Corsair XMS3 PC12800 | Gigabyte GTX1070 | Intel SSD 530 120Gb | Asus VG248QE | Win 7 Ultimate x64

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av PointMan:

Kör ett test på minnena i några timmar.

Slöseri med tid, bättre att kolla vad DMP filen säger och sedan gå utifrån det.

Annars om du vill kolla RAM så kan jag starkt rekommendera memtest86

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Just nu så "väntar" jag på att den ska crasha men det har inte hänt än

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Hände nu men hittade ingen DMP fil där den ska vara
Körde denna guide
https://docs.microsoft.com/sv-se/windows-server/administratio...

Jag misstänker den blev raderad då jag är tvungen att starta om den en gång till då den ska boota rätt och "wmic RECOVEROS get OverwriteExistingDebugFile" var satt på 1
Har ändrat den till 0

Hoppas det hjälper till nästa gång, gillar inte detta, är rädd att OS ska bli dåliga.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av TheCazz:

Hände nu men hittade ingen DMP fil där den ska vara
Körde denna guide
https://docs.microsoft.com/sv-se/windows-server/administratio...

Jag misstänker den blev raderad då jag är tvungen att starta om den en gång till då den ska boota rätt och "wmic RECOVEROS get OverwriteExistingDebugFile" var satt på 1
Har ändrat den till 0

Hoppas det hjälper till nästa gång, gillar inte detta, är rädd att OS ska bli dåliga.

Hej,
DMP filen raderas inte för att du rebootar, isf så är det något annat som är fel.
Då är det inge "critical" i den bemärkelse att du BSOD

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2009

Har haft liknande problem, slutade med att jag migrerade över servrarna till en ESXi host.

TL;DR: Byt till en trevligare Hypervisor

Workstation : Dell XPS 9570 | i7-8750H | 2x8GB DDR4 | 512GB NVME | GTX 1050TI Max-Q

Server : Fujitsu Primergy | i3 4130T | 16GBDDR3 ECC | ESXi 6.5

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av wille61:

Har haft liknande problem, slutade med att jag migrerade över servrarna till en ESXi host.

TL;DR: Byt till en trevligare Hypervisor

Jag gillar Hyper-V =P billigare än ESXi med, men det är ju bara jag

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Registrerad
Apr 2005
Skrivet av Calby:

Hej,
DMP filen raderas inte för att du rebootar, isf så är det något annat som är fel.
Då är det inge "critical" i den bemärkelse att du BSOD

Hmm då börjar jag undrar vad som är fel.
Har än så länge inte hänt idag "peppar peppar" Men vet inte riktigt vad man ska göra annars.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005
Skrivet av wille61:

Har haft liknande problem, slutade med att jag migrerade över servrarna till en ESXi host.

TL;DR: Byt till en trevligare Hypervisor

Körde innan ESXi hos en vän för ett antal år sen och det var segt och åt minne.
Kanske blivit bättre den gratis versionen som var då

Har för mig då i alla fall att den var begränsad att man inte kunde exportera eller göra backup.
Kanske ändrat sig sedan då

Men jag gillar Hyper-V, har stort sätt fungerar hur bra som helst och har kört sedan den kom ut gratis utan några problem.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2009

Finns ju ett gäng att välja på, har kört Hyper-V, ESXi, Xenserver samt ProxMox. ESXi är tveklöst bäst enligt mig när det gäller användarvänlighet, support m.m. Däremot kostar det ju en slant om man vill ha en lite större miljö, detta körs mest inom jobbet mao.

Proxmox är vanligt bland hemmapulare, bygger på KVM i grunden och är rätt lätt att förstå sig på, rekommenderas om du ledsnar på Hyper-V.. :- )

Workstation : Dell XPS 9570 | i7-8750H | 2x8GB DDR4 | 512GB NVME | GTX 1050TI Max-Q

Server : Fujitsu Primergy | i3 4130T | 16GBDDR3 ECC | ESXi 6.5

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Körde minnestestet nu och var inget fel.
Skumt är det och mer skumt är det när den bootar fel och när man startar om den igen så blir det rätt.

Trädvy Permalänk
Medlem
Registrerad
Apr 2005

Såg att jag inte hade uppdaterad BIOS så jag gjorde de nu.
Sedan disablade "Max CPUID Value Limit" för den är ju för Windows XP