Ingen bild efter bios flash MSI B350M Mortar

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Ingen bild efter bios flash MSI B350M Mortar

Har ett MSIB350 Mortar som oftast inte fungerade med dubbla grafikkort.

Googlade ganska rejält men hittade inget som var relevant, men däremot hittade jag en ny version av UEFI. Glad i hågen installerade jag den och hoppades på att mina problem skulle göra försvinna som en avlöning. Tyvärr fick jag fler...

Nu har jag ingen bild förrän jag kommer in i OS. Försöker jag komma in i UEFI så har jag bara en svart skärm. Samma sak om jag försöker komma in i boot menyn. Jag kan alltså inte boot up på en USB sticka för att start freedos och flasha tillbaka därifrån. En bios reset resulterar bara i svart skärm.

Det enda jag kan komma på fungerar är att flasha om från linux då det är det jag har installerat som OS just nu men jag hittar inget om hur jag kan göra det, allt jag hittar är att göra en bootbar USB med freedos och flasha om därifrån...

Förslag mottages tacksamt.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2007

Har du provat att ta ut ett av grafikkorten? Sen efter bios flashen och reset kan det vara så att onboard Graphics är enable, så du kan ju prova och koppla skärmen till onboard istället.

Min tanke (och långt ifrån expert) är just att onboard kör igång först och när den slår över till OS kommer rätt signal till grafikkort och skärmen. Som när man kopplar en dator till TV att man inte får bild innan man kommit in i OS (beroende på TV, vilken onboard utgång etc som används).

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Har testat med 0,1 och 2 grafikkort med samma resultat.

Glömde skriva att den processor jag använder är en Ryzen 7 1700x så den saknar inbyggd GPU. Men har nu testat onboard också, den kan ju kanske skicka signalen den vägen iaf på något sätt med tyvärr det resultatet att jag inte fick bild överhuvudtaget.

Bytte jag till det diskreta kortet så fick jag bild från OS igen.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2004

Dubbla grafikkort stöds väl inte officiellt av B350-chipsetet? Det är ju inte ditt huvudproblem just nu, men räkna inte med att det ska funka även om du får ordning på BIOS.

Intel: Asrock Z370 Extreme M4|8700K@4.9|Noctua DH15|G.Skill Flare X 3200@4000 17-19-19-39 32GB|MSI 1080TI Gaming X|Samsung 960 EVO 1TB
AMD: MSI B350 Tomahawk|RyzenR5 1600X|Fractal Design Celsius S24|Corsair Vengeance@2933 32GB|Asus 970|Samsung830 SSD

Trädvy Permalänk
Medlem
Plats
Västra Aros
Registrerad
Apr 2004

B350 stödjer Crossfire men inte SLI, dock endast i 16x/4x mode, Vad är det för grafikkort du kör med?

i7-7700K, Pentium G4560, Ryzen 2700X, Ryzen 1600X, Geforce 1080

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Mar 2016

DisplayPort eller hdmi?
Testa att byta det

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av ArKAN:

B350 stödjer Crossfire men inte SLI, dock endast i 16x/4x mode, Vad är det för grafikkort du kör med?

Sapphire RX580 Pulse

Skrivet av johanlillja:

DisplayPort eller hdmi?
Testa att byta det

Skickades från m.sweclockers.com

Testat båda...

Blir nog att köpa en billig AM4 processor med inbyggd GPU och testa med det...

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

Du kan kanske göra en usb-bootenhet som automatiskt startar flashningen, eller så kan du öva in kommandona så du kan skriva in dem blint.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2013

Har du en cd/dvd-läsare kan du testa att boota/reflasha från den, de brukar ligga före hårddisken i bootordningen.
Alternativt så kan du koppla ur hårddisken tillfälligt, då kommer datorn inte kunna bota från den och du kan då boota från en USB-sticka och göra din bios flashning därifrån.

Kom på en sak till...
Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2013

@robertlindgren82: Hur har det gått för dig?

Trädvy Permalänk
Medlem
Registrerad
Aug 2012

B350 can't share the 16 lanes 3.0 reserved for vgas between two slots. That would be required for an x8/x8 setup. Therefor the B350 can just offer the vga slot that is permanently at 16 PCI-E 3.0 lanes and a 2.0 slot with just 4 lanes. For SLI both slots for the vgas need to run at x8 minimum. Crossfire is allowed even at x4. Of course it would suck with 3.0 x16/2.0 x4 because the card in the 2.0 slot would be muach limited slowing down the primary card and causing massive micro stuttering. B350 is simply not meant for multi gpu setups. You will need an X370 chipset based board.

Jag skulle köpt x370 moderkort för dubbel gpu.

i5 8400 All cores clocked to 4015MHz
R5 1600X @ 4.3GHz https://valid.x86.fr/g5aaif

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av ByteBitten:

@robertlindgren82: Hur har det gått för dig?

Har inte hunnit testa något mer.
Jag har bara ett kort insatt nu och hoppas varje gång att burken startar
Ska se om det blir bättre med en 2400G som jag tänkt köpa idag.

Skrivet av Decimal:

B350 can't share the 16 lanes 3.0 reserved for vgas between two slots. That would be required for an x8/x8 setup. Therefor the B350 can just offer the vga slot that is permanently at 16 PCI-E 3.0 lanes and a 2.0 slot with just 4 lanes. For SLI both slots for the vgas need to run at x8 minimum. Crossfire is allowed even at x4. Of course it would suck with 3.0 x16/2.0 x4 because the card in the 2.0 slot would be muach limited slowing down the primary card and causing massive micro stuttering. B350 is simply not meant for multi gpu setups. You will need an X370 chipset based board.

Jag skulle köpt x370 moderkort för dubbel gpu.

Jo, jag är och var fullt medveten om begränsningarna med ett B350 kort. Men då spelande inte är min första prio såg jag inte det som ett problem.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Efter inköp av ny processor med inbyggd gpu kom jag fram till att det nog är något fel på moderkortet. Jag fick bild med den nya processorn men inte något användbart. Flimmer och en bild som inte uppdaterades, samtidigt.

I ett annat moderkort fungerade det klockrent.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2004

@robertlindgren82: Mortar funkade inte ens om du lade på BIOS-version 7A37v1B? - Den versionen krävs ju för nyaste Raven ridge.

Intel: Asrock Z370 Extreme M4|8700K@4.9|Noctua DH15|G.Skill Flare X 3200@4000 17-19-19-39 32GB|MSI 1080TI Gaming X|Samsung 960 EVO 1TB
AMD: MSI B350 Tomahawk|RyzenR5 1600X|Fractal Design Celsius S24|Corsair Vengeance@2933 32GB|Asus 970|Samsung830 SSD