Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Dec 2002

Debian och WiFi

Hej jag håller på och sätter upp en Debian maskin för Folding@home. Den är "headless" och jag confar den via SSH. Men jag har lite problem att ansluta till mitt Wifi. Jag har fått ordning på USB-stickan så den verkar leva. Jag har följt den här guiden på Debian wiki men kommer inte längre.

Såhär ser min /etc/network/interfaces ut:

# This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). source /etc/network/interfaces.d/* # The loopback network interface auto lo iface lo inet loopback # The primary network interface allow-hotplug enp3s0 iface enp3s0 inet dhcp #WiFi auto wlx74da3828a946 iface wlx74da3828a946 inet dhcp wpa-ssid Mitt nätverk wpa-psk hexnyckelxxxxxxxx....

Saken är den att det är ett mellanslag i SSID för mitt nätverk. Därför den inte kan ansluta?

# ifup wlx74da3828a946 Internet Systems Consortium DHCP Client 4.3.5 Copyright 2004-2016 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ Listening on LPF/wlx74da3828a946/74:da:38:28:a9:46 Sending on LPF/wlx74da3828a946/74:da:38:28:a9:46 Sending on Socket/fallback DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 7 DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 7 DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 13 DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 13 DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 14 DHCPDISCOVER on wlx74da3828a946 to 255.255.255.255 port 67 interval 7 No DHCPOFFERS received. No working leases in persistent database - sleeping.

Hade ju kunna kört trådat nätverk, det funkar, men där jag vill ha maskinen stå har jag inte tillgång till det. Väldigt ringrostig på *nix, och har aldrig kört debian förr. Så all hjälp uppskattas!

Arbetshäst: AMD PhII X6 1100T@3,9GHz|16GiB DDR3|Gigabyte 890XA-UD3|HD6970 x-fire|Samsung 840Pro|Vattenkyld
HEPC: AMD Fusion E350|6GiB DDR3|NES-chassi|Allt inbyggt, inkl.nätagg|XBMC| NAS: AMD Fusion E450|4GiB DDR3|4TiB RAID-Z|FreeNAS 8.3

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002

Har inte möjlighet att testa själv, men om du misstänker problem med mellanslaget så vore min första tanke att testa citationstecken kring namnet:

wpa-ssid "Mitt nätverk"

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Dec 2002

Yes det har jag, men glömde ta med det i inlägget. Både " och ' har jag provat.

Arbetshäst: AMD PhII X6 1100T@3,9GHz|16GiB DDR3|Gigabyte 890XA-UD3|HD6970 x-fire|Samsung 840Pro|Vattenkyld
HEPC: AMD Fusion E350|6GiB DDR3|NES-chassi|Allt inbyggt, inkl.nätagg|XBMC| NAS: AMD Fusion E450|4GiB DDR3|4TiB RAID-Z|FreeNAS 8.3

Trädvy Permalänk
Medlem
Plats
Sturup
Registrerad
Jan 2007

Jag brukar kolla på arch's fantastiska hemsida när jag behöver hjälp med sådant:
https://wiki.archlinux.org/index.php/Wireless_network_configu...

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Å, ä, ö och mellanslag ska inte användas i ett ssid då de tecknen egentligen inte ingår i standarden utan bara alfanumeriska asciitecken tillåts om man följer reglerna strikt.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Dec 2002

Ahaa det kan ju var en förklaring till att det blir problem

Arbetshäst: AMD PhII X6 1100T@3,9GHz|16GiB DDR3|Gigabyte 890XA-UD3|HD6970 x-fire|Samsung 840Pro|Vattenkyld
HEPC: AMD Fusion E350|6GiB DDR3|NES-chassi|Allt inbyggt, inkl.nätagg|XBMC| NAS: AMD Fusion E450|4GiB DDR3|4TiB RAID-Z|FreeNAS 8.3

Trädvy Permalänk
Medlem
Plats
Sturup
Registrerad
Jan 2007

Hade liknande problem med iscsi för ett tag sedan. Linux maskinerna fungerade det på men Windows kunde inte ansluta, var ett understreck som sabbade allt har jag för mig 😀

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Gävle
Registrerad
Dec 2002

Så nu håller jag på och försöker ansluta till ett annat nätverk där SSID är utan mellanslag eller specialtecken. Men den vägrar.

Har lagt till nya nätverksnamnet och nyckeln i configen men den tar det inte. Samma sak att den står och inte får ett IP.

Försöker jag köra iwconfig manuellt så tar den kommandot utan felmeddelande eller nått men den ansluter inte. Varför talar den inte om vad som går fel? Typ att man har fel SSID så den inte hittar nätverket eller att nyckeln inte funkar eller vad det kan vara. Men nej, den säger ingenting.

# iwconfig wlx74da3828a946 essid NÄTVERK key s:abdef12345HEXNYCKEL # iwconfig wlx74da3828a946 wlx74da3828a946 unassociated Nickname:"<WIFI@REALTEK>" Mode:Managed Frequency=2.462 GHz Access Point: Not-Associated Sensitivity:0/0 Retry:off RTS thr:off Fragment thr:off Encryption key:off Power Management:off Link Quality:0 Signal level:0 Noise level:0 Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Nätverket kör WPA2-PSK förresten

Arbetshäst: AMD PhII X6 1100T@3,9GHz|16GiB DDR3|Gigabyte 890XA-UD3|HD6970 x-fire|Samsung 840Pro|Vattenkyld
HEPC: AMD Fusion E350|6GiB DDR3|NES-chassi|Allt inbyggt, inkl.nätagg|XBMC| NAS: AMD Fusion E450|4GiB DDR3|4TiB RAID-Z|FreeNAS 8.3

Trädvy Permalänk
Medlem
Plats
root
Registrerad
Jan 2004

inget nytt egentligen i dagsläget allt annat än wpa2 Aes(med självfallet Wps avstängt) med ett långt pass borde betyda dags att se över en del basala saker saker