Flasha IBM M1015 till P20

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011

Flasha IBM M1015 till P20

Hej

Idag fick jag mina sas kort. På dom stor SAS9220-8i.
Jag läste att man måste flacha kort så att dom ska fungerar som det ska i FreeNAS.
Min tanke var att köra FreeNAS eller NAS4free (men inte virtuellt.)
Min fråga är måste jag göra det eller inte?

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Dec 2015

Du måste inte flasha.
Men ska du köra t.ex. ZFS behöver du flasha till IT-mode.
Att tänka på är att raid 5 på kontroller utan write cache är mindre bra. 9220-8i saknar write cache.

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av jhws:

Du måste inte flasha.
Men ska du köra t.ex. ZFS behöver du flasha till IT-mode.
Att tänka på är att raid 5 på kontroller utan write cache är mindre bra. 9220-8i saknar write cache.

Hej

Min tanke är att köra raid 10, inte raid 5.

Men ska jag flasha kort i min server PC eller ska jag göra det i vanligt PC.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

@njanja: Gör det i din server med te.x bootUSB du kan skapa en med Rufus.

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Dec 2015
Skrivet av njanja:

Hej

Min tanke är att köra raid 10, inte raid 5.

Men ska jag flasha kort i min server PC eller ska jag göra det i vanligt PC.

mvh
Njanja

Jag kan inte tipsa om vilken dator du ska flasha kortet med. Det finns trådar som du kan läsa som ger dig mer handfasta tips.
Men om du ska köra raid från ditt 9220 så vet jag inte riktigt varför du ska flasha det.
Enda syftet med att flasha till IT mode är när man ska köra filsystem som ZFS.

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Maj 2008

Eftersom du antagligen vill köra ZFS i Freenas så bör du flasha till IT mode, yes.

En server här, några servrar där.

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av moron:

Eftersom du antagligen vill köra ZFS i Freenas så bör du flasha till IT mode, yes.

Jag vet att man behöver flasha kortet , men hittar inte något pålitligt guide att göra det.
Alla guider som jag läste på nätet och alla som flashar i stor sätt får fel.
Ingen som pratar vilka kommandon ska man köra vilka filer ska man använda.
Hur man vet om kortet är flashat eller inte.
Alla säger samma sak:" Du ska flasha till IT mode.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av njanja:

Jag vet att man behöver flasha kortet , men hittar inte något pålitligt guide att göra det.
Alla guider som jag läste på nätet och alla som flashar i stor sätt får fel.
Ingen som pratar vilka kommandon ska man köra vilka filer ska man använda.
Hur man vet om kortet är flashat eller inte.
Alla säger samma sak:" Du ska flasha till IT mode.

mvh
Njanja

Läs manualerna?
Jag flashade mitt kort utan problem tog ca 10min

Skickades från m.sweclockers.com

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2009
Skrivet av njanja:

Jag vet att man behöver flasha kortet , men hittar inte något pålitligt guide att göra det.
Alla guider som jag läste på nätet och alla som flashar i stor sätt får fel.
Ingen som pratar vilka kommandon ska man köra vilka filer ska man använda.
Hur man vet om kortet är flashat eller inte.
Alla säger samma sak:" Du ska flasha till IT mode.

mvh
Njanja

Sök i forumet på M1015 goddammit: https://www.sweclockers.com/forum/trad/1298054-flasha-ibm-m10...

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av beh:

Säger inte så mycket. Som jag ser folk har fortfarande massa problem att flasha.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Registrerad
Apr 2009
Skrivet av njanja:

Säger inte så mycket. Som jag ser folk har fortfarande massa problem att flasha.

mvh
Njanja

Varför provar du inte istället för att förutspå massa problem som troligen inte kommer ske?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2009

@njanja: Vilka problem upplever du?

Trädvy Permalänk
Medlem
Registrerad
Maj 2002
Skrivet av njanja:

Säger inte så mycket. Som jag ser folk har fortfarande massa problem att flasha.

När jag flashade mitt LSI9211-8i så följde jag guiden på servethehome.com (länkas till bland annat i sweclockers-tråden). Skulle säga att den mesta infon finns där. Får du problem med t.ex. UEFI finns det tips i kommentarerna på hur det löses.

Trädvy Permalänk
Moderator
Plats
Umeå
Registrerad
Mar 2011

@njanja: Nu hjälper inte det här dig då du redan har korten, men ifall du får för dig att köpa fler i framtiden så skulle jag föreslå dig att köpa kort med rätt firmware direkt ur kartong. Ifall du köper från eBay så kostar de mer eller mindre lika mycket som ett M1015.

#16825771

"The more you learn, the more you realize how little you know."

Trädvy Permalänk
Medlem
Plats
Kalix
Registrerad
Nov 2005
Skrivet av Kalaspuffar:

Varför provar du inte istället för att förutspå massa problem som troligen inte kommer ske?

Killen kanske inte vill bricka sitt kort?

Jag följde en guide på FreeNas forumet iirc, tog typ 5min för att jag var paranoid men allt gick felfritt.

i5 2500K: 4.4GHz||16GB 1600MHz||ASUS P8Z77-V PRO||Phanteks PH-TC14PE
MSI GTX 980 Gaming||Corsair Force 2 80GB|| Fractal Design Newton r2 650W M
Asus xonar essence STX|| Antec p280
Dell u2711, Sennheiser hd650, Logitech g502, fUnc f30r, KeyTronic kt2001 Ergoforce.
Server: x10SL7-F, Xeon E3 1230v3, 32GB Samsung ECC ram, 6x3TB WD RED, FD Node 804.

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Skulle rekommendera att flasha kortet med ett moderkort som har bios (helst ett serverkort). Processen blir smidigare genom att göra allt i en DOS-miljö och finns mindre som kan gå fel. EFI-shells har jag haft varierande framgång med, beror mycket på vilket moderkort som använts i min erfarenhet.

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av jhws:

Jag kan inte tipsa om vilken dator du ska flasha kortet med. Det finns trådar som du kan läsa som ger dig mer handfasta tips.
Men om du ska köra raid från ditt 9220 så vet jag inte riktigt varför du ska flasha det.
Enda syftet med att flasha till IT mode är när man ska köra filsystem som ZFS.

Förstår din tanke, men det finns andra användningsområden också!
Jag t.ex kör den flashad till IT-mode för att kunna köra passthrough på hårddiskar direkt in i min plex vm på min ESXi server. Av den enkla anledningen att jag inte raidar diskarna eller kör datastores.

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
Norrköping
Registrerad
Okt 2004
Skrivet av JamSod:

Skulle rekommendera att flasha kortet med ett moderkort som har bios (helst ett serverkort). Processen blir smidigare genom att göra allt i en DOS-miljö och finns mindre som kan gå fel. EFI-shells har jag haft varierande framgång med, beror mycket på vilket moderkort som använts i min erfarenhet.

Håller med JamSod!
Jag lyckades inte på min bruksdator med EFI-shell. Gick däremot väldigt bra på mitt Supermicro moderkort som sitter i servern. Har dessutom IPMI på den, så kunde ändå sköta allt från min vanliga dator

$ grep parts /home/pwntato/thermaltake_core_v21
specs: core i7 6700k, 16GB vengeance lpx, asus maximus viii gene, asus strix 980ti, evga 850p2, samsung 850 evo 250GB, samsung 850 evo 1tb, wd green 1TB

$ echo citera gärna om du vill ha svar snabbare >> /home/pwntato/quote

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av Kalaspuffar:

Varför provar du inte istället för att förutspå massa problem som troligen inte kommer ske?

Skrivet av beh:

@njanja: Vilka problem upplever du?

Skrivet av BergHa:

Killen kanske inte vill bricka sitt kort?

Jag följde en guide på FreeNas forumet iirc, tog typ 5min för att jag var paranoid men allt gick felfritt.

Skrivet av JamSod:

Skulle rekommendera att flasha kortet med ett moderkort som har bios (helst ett serverkort). Processen blir smidigare genom att göra allt i en DOS-miljö och finns mindre som kan gå fel. EFI-shells har jag haft varierande framgång med, beror mycket på vilket moderkort som använts i min erfarenhet.

Hej
Jag har två server moderkort, så det är inte problem.

Skrivet av pwntato:

Förstår din tanke, men det finns andra användningsområden också!
Jag t.ex kör den flashad till IT-mode för att kunna köra passthrough på hårddiskar direkt in i min plex vm på min ESXi server. Av den enkla anledningen att jag inte raidar diskarna eller kör datastores.

Hej
Jag har en till sever, med plex, webbserver, pfsense o.s.v. Denna NAS som jag bygger ska inte vara virtuellt utan ren NAS med möjlighet att uppdatera (sätta mer minne flera HDD-s) och underhålla om HDD-s går sönder.
Tanke är att den ska ersätta alla mina andra NAS.

Skrivet av pwntato:

Håller med JamSod!
Jag lyckades inte på min bruksdator med EFI-shell. Gick däremot väldigt bra på mitt Supermicro moderkort som sitter i servern. Har dessutom IPMI på den, så kunde ändå sköta allt från min vanliga dator

Jag har rätt PC att utföra flashning, men folk svarar inte på min fråga utan jag får svar från dom så här: "Det tar 5 min, jag följde denna guide , det är bara att testa o.s.v. " Jag har redan lagt mycket pengar på den, och eftersom den med flashingen tar så mycket tid och energi och får mig att uppleva samma sak en gång till. Samma sak hände när jag försökte att få igång pfsense virtuellt med vlans.
Fick aldrig nån hjälp från sweclokers, utan fick bara negativ skit.

Jag vill inte bli negativ och vill inte att folk får en bild av mig att jag är jobbig och besvärlig dude, som saknar massa erfarenhet..
När jag ställer frågan hur ska jag flasha kortet, då är jag ute efter vilka steg jag ska utföra, vilka filer jag ska använda, från vilken sidan ska jag ladda filer osv. Jag hoppas att ni förstår min syfte med allt detta.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Plats
Kalix
Registrerad
Nov 2005
Skrivet av njanja:

Jag har rätt PC att utföra flashning, men folk svarar inte på min fråga utan jag får svar från dom så här: "Det tar 5 min, jag följde denna guide , det är bara att testa o.s.v. " Jag har redan lagt mycket pengar på den, och eftersom den med flashingen tar så mycket tid och energi och får mig att uppleva samma sak en gång till. Samma sak hände när jag försökte att få igång pfsense virtuellt med vlans.
Fick aldrig nån hjälp från sweclokers, utan fick bara negativ skit.

Jag vill inte bli negativ och vill inte att folk får en bild av mig att jag är jobbig och besvärlig dude, som saknar massa erfarenhet..
När jag ställer frågan hur ska jag flasha kortet, då är jag ute efter vilka steg jag ska utföra, vilka filer jag ska använda, från vilken sidan ska jag ladda filer osv. Jag hoppas att ni förstår min syfte med allt detta.

mvh
Njanja

Så att folk har länkat till guider och tipsat om sidor där du hittar fler guider är inte nog? Någon ska copypasta en guide hit till den här tråden eller helt enkelt skriva en ny en?

Kan tänka mig att du till slut känns som att du bara får negativa saker om du fortsätter fråga efter hjälp när du redan fått helt ok svar.

i5 2500K: 4.4GHz||16GB 1600MHz||ASUS P8Z77-V PRO||Phanteks PH-TC14PE
MSI GTX 980 Gaming||Corsair Force 2 80GB|| Fractal Design Newton r2 650W M
Asus xonar essence STX|| Antec p280
Dell u2711, Sennheiser hd650, Logitech g502, fUnc f30r, KeyTronic kt2001 Ergoforce.
Server: x10SL7-F, Xeon E3 1230v3, 32GB Samsung ECC ram, 6x3TB WD RED, FD Node 804.

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Processen för att flasha ett 9220-8i bör vara densamma som ett M1015 om jag inte har fel. Vilket moderkort har du tänkt att använda för att flasha ditt kort? Ett kort med ett komplett BIOS (inget UEFI alls) är lämpligast. Vilken modell av sas-kort har du? Är det ett LSI 9220-8i, IBM M1015 eller Dell Hxx? Processen för att flasha olika kort kan skilja sig lite.

Läs igenom detta: https://forums.freenas.org/index.php?resources/detailed-newco...
Här går man igenom flashningsprocessen i detalj. Om det fortfarande är oklart så kom gärna med frågor efter du läst igenom den där.

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av JamSod:

Processen för att flasha ett 9220-8i bör vara densamma som ett M1015 om jag inte har fel. Vilket moderkort har du tänkt att använda för att flasha ditt kort? Ett kort med ett komplett BIOS (inget UEFI alls) är lämpligast. Vilken modell av sas-kort har du? Är det ett LSI 9220-8i, IBM M1015 eller Dell Hxx? Processen för att flasha olika kort kan skilja sig lite.

Läs igenom detta: https://forums.freenas.org/index.php?resources/detailed-newco...
Här går man igenom flashningsprocessen i detalj. Om det fortfarande är oklart så kom gärna med frågor efter du läst igenom den där.

Hej

Moderkort som jag har heter ASUS P10S-M WS.
Här kommer bilder på kortet:
https://www.dropbox.com/s/luh8g4nyhslkxwj/IMG_20180225_112002...
https://www.dropbox.com/s/wacuvka4tojcsc5/IMG_20180225_112015...

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Mar 2002

@njanja: Nu vill jag inte hälla salt i såren eller vara negativ, men om man har lite speciella krav och det man vill uppnå kanske inte riktigt är något man finner hos en vanlig återförsäljare så kanske man heller inte riktigt kan klaga på svaren som man får, och man kanske får ta tiden det tar att lägga på att läsa på om ämnet och prova själv.
Annars så finns det ju diverse färdiga NAS-lösningar redan som inte kräver så avancerade handpåläggningar.

Edit: Jag såg precis att FreeNAS (iX Systems) säljer färdiga lösningar, detta kanske passar dig bättre?
http://www.freenas.org/freenas-mini/
http://www.freenas.org/freenas-certified-servers/
http://www.freenas.org/truenas/

Lycka till.

Marantz NR1605, Rotel RB1090, Ino Audio piPs
Audio-Gd NFB-11 (2015), Objective2+ODAC RevB, Audeze LCD-2 Rosewood, Monoprice M1060

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av BergHa:

Så att folk har länkat till guider och tipsat om sidor där du hittar fler guider är inte nog? Någon ska copypasta en guide hit till den här tråden eller helt enkelt skriva en ny en?

Kan tänka mig att du till slut känns som att du bara får negativa saker om du fortsätter fråga efter hjälp när du redan fått helt ok svar.

Hej

Länkar till guider hjälpte inte så mycket. Tror att jag ger upp, synd att skiten kostade min 20k. Kanske är bäst att sälja allt eller att vänta på nån som kan skriva ordentligt guide för den. (steg för steg).

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011
Skrivet av backspace:

@njanja: Nu vill jag inte hälla salt i såren eller vara negativ, men om man har lite speciella krav och det man vill uppnå kanske inte riktigt är något man finner hos en vanlig återförsäljare så kanske man heller inte riktigt kan klaga på svaren som man får, och man kanske får ta tiden det tar att lägga på att läsa på om ämnet och prova själv.
Annars så finns det ju diverse färdiga NAS-lösningar redan som inte kräver så avancerade handpåläggningar.

Edit: Jag såg precis att FreeNAS (iX Systems) säljer färdiga lösningar, detta kanske passar dig bättre?
http://www.freenas.org/freenas-mini/
http://www.freenas.org/freenas-certified-servers/
http://www.freenas.org/truenas/

Lycka till.

Hej

Jag har redan flera NAS, 4 st Netgear and 1 Synology.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011

Hej

Jag satt kortet i PC, och såg att den har den version av FV. Se bilden. Hur ska jag vet om det är IT-mode eller IR-mode?
https://www.dropbox.com/s/45kh7rp7c5u08og/IMG_20180225_152847...

Ber om ursäkt. Fel forum.

Startade flashning och fick meddelande där står: "No LSI SAS adapters found". Tar lite tid men jag tror att jag är på rätt väg.

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av njanja:

Hej

Jag satt kortet i PC, och såg att den har den version av FV. Se bilden. Hur ska jag vet om det är IT-mode eller IR-mode?
https://www.dropbox.com/s/45kh7rp7c5u08og/IMG_20180225_152847...

Den nämner ju JBOD så bör ju vara i it mode redan.

Www.letmegooglethat.com/?q=Jbod

Skickades från m.sweclockers.com

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Att den nämner JBOD tyder på att den är i IR mode så vitt jag vet. De flesta som flashar till IT mode brukar ta bort kortets BIOS på köpet. Vill du ha kvar kortets BIOS TS? Den enda fördelen med att ha kvar det är att man i många fall kan boota från en disk kopplat till kortet. De flesta brukar ta bort BIOS:et eftersom det tar längre tid att boota systemet samt att de har bootdisk kopplat till moderkortets SATA-portar.

Får du fortfarande felmeddelandet att inga LSI kort hittas? Det är nog på grund av att du har ett relativt nytt moderkort (som därmed inte stödjer vissa kommandon som äldre BIOS stödjer). Och det är i dessa fall man brukar behöva krångla med EFI baserad flashning. Jag är ganska okunnig när det kommer till flasning från ett EFI-shell och har själv bara haft problem med det så jag rekommenderar ett äldre moderkort som har BIOS istället för UEFI.

Om du går in på kortets BIOS (CTRL+H i din bild) kanske du kan få reda på om kortet är flashat eller inte. FW på 20 tyder på att det nyligen är flashat uppdatering i alla fall.

Trädvy Permalänk
Medlem
Plats
44°45'38.5"N 17°11'19.4"E
Registrerad
Jun 2011

Hej igen

Undrar om jag har gjort rätt eller inte. Kortet visas inte mer i BIOS när jag startar PC.
Jag får den när jag kör sas2flash.efi -list

https://www.dropbox.com/s/04cmrzindqvd5d2/IMG_20180225_225435...

mvh
Njanja

Server
FUJITSU PRIMERGY TX100 S3P XE E3-1220V2 3.5-8MB 8GB/2X500GB

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av njanja:

Hej igen

Undrar om jag har gjort rätt eller inte. Kortet visas inte mer i BIOS när jag startar PC.
Jag får den när jag kör sas2flash.efi -list

https://www.dropbox.com/s/04cmrzindqvd5d2/IMG_20180225_225435...

mvh
Njanja

Kom på hur du hade kunnat sett om de va IT om du kör raid kort så kan dom knte läsa från SMART.
Så kolla om du får smart info från hdd får du de så har du IT

Skickades från m.sweclockers.com

Supermicro X9SRI-F | Xeon E5-2690 v2 | 128GB 1600MHz RDIMM | Dell Perc H200 (9211-8i IT) | Windows Server 2016 DataCenter med Hyper-V