Bredbandsbolaget och utgående epost

Trädvy Permalänk
Medlem
Registrerad
Jul 2015

Bredbandsbolaget och utgående epost

Bredbandsbolaget har just nu stora problem med utgående epost via SMTP server. Nyligen har en uppdatering för email systemet gjorts och den har påverkat SMTP för klient mjukvara såsom outlook, thunderbird etc. Har varit i kontakt med supporten, tror ni dom har en lösning på problemet

Helt otroligt!

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2006

Är frågan här om Bredbandsbolaget har en lösning?

Svaren är väl:
1. Ja, de har det, men det tar lite tid att implementera den.
2. Nej, de har de inte, men det tar lite tid att hitta på och implementera den.

Oavsett så är situationen samma för dig. Hör av dig till supporten mer och be att få prata med någon second line eller dylikt om det är viktigt för dig att få utgående epost att fungera.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Oavsett deras problem så är det ofta dumt att låsa sig till en operatörs email då man för det mesta blir av med den om man byter operatör, man brukar få mindre problem om man har en helt egendriven mailtjänst eller någon oberoende komersiell som inte är bunden mot operatören.
Man bör tänka igenom hur viktigt det är att domänen inte ändras om man byter operatör, ibland är det oviktigt men ibland skapar det stora problem och mycket jobb.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Jul 2015
Skrivet av Killbom:

Är frågan här om Bredbandsbolaget har en lösning?

Svaren är väl:
1. Ja, de har det, men det tar lite tid att implementera den.
2. Nej, de har de inte, men det tar lite tid att hitta på och implementera den.

Oavsett så är situationen samma för dig. Hör av dig till supporten mer och be att få prata med någon second line eller dylikt om det är viktigt för dig att få utgående epost att fungera.

Tydligen så är många drabbade, så om dom hade haft en lösning så hade jag redan fått den. Supporten sa att vi kan tyvärr inte hjälpa dig för tillfället.

Skrivet av mrqaffe:

Oavsett deras problem så är det ofta dumt att låsa sig till en operatörs email då man för det mesta blir av med den om man byter operatör, man brukar få mindre problem om man har en helt egendriven mailtjänst eller någon oberoende komersiell som inte är bunden mot operatören.
Man bör tänka igenom hur viktigt det är att domänen inte ändras om man byter operatör, ibland är det oviktigt men ibland skapar det stora problem och mycket jobb.

Givetvis men det är ju ett helt annat scenario, men nu betalar jag bredbandsbolaget och jag är fortfarande kund hos dom. Utgående SMTP har som det ser ut nu, legat nere i 8-9 dagar. Vi lever i en modern tid och en ISP ska inte misslyckas så här katastrofalt med en av deras tjänster.

Trädvy Permalänk
Medlem
Plats
Blekinge
Registrerad
Jan 2017

Fungerar fasen fortfarande inte, helt sanslöst.

Trädvy Permalänk
Medlem
Registrerad
Jul 2015
Skrivet av Pierre72:

Fungerar fasen fortfarande inte, helt sanslöst.

Eller hur...

Det är rätt illa och killen på supporten hade inget gott att berätta om situationen heller, trots att han nu är BBB anställd.

Om detta tar veckor måste jag nog börja förbereda mig på en större förändring gällande mitt avtal.

Trädvy Permalänk
Hedersmedlem
Registrerad
Jul 2001
Skrivet av mrqaffe:

Oavsett deras problem så är det ofta dumt att låsa sig till en operatörs email då man för det mesta blir av med den om man byter operatör, man brukar få mindre problem om man har en helt egendriven mailtjänst eller någon oberoende komersiell som inte är bunden mot operatören.
Man bör tänka igenom hur viktigt det är att domänen inte ändras om man byter operatör, ibland är det oviktigt men ibland skapar det stora problem och mycket jobb.

Senast jag hade Bbb tvingade de alla att gå genom deras smtp för utgående mail på port 25. Alltså oavsett om du hade mail från någon annan eller rullar egen mailserver. Då blir det ett ganska stort problem att den ligger nere. Jag har även fått mina (egenvalda) lösenord postade till mig i klartext på baksidan av ett vykort, från det här företaget, i samband med att de lanserat nya tjänster. I min mening är de närmast kriminellt inkompetenta.

Bienvenido a la maldad

Trädvy Permalänk
Medlem
Plats
Blekinge
Registrerad
Jan 2017

Funkar fortfarande inte, men snälla BBB vad sysslar ni med!?

Trädvy Permalänk
Medlem
Registrerad
Jul 2015

@Aphex: Kriminellt och upprörande för att säga något. Tror dock många av internet leverantörerna inte sköter det här med den privata sfären på ett adekvat sätt. Vilken ISP kör du på för närvarande om jag får fråga?

Jag sitter och funderar om det inte är dags att lämna dom, har varit trogen dom länge vilket inte har varit så konstigt, har endast haft små problem under årens lopp och jag är ganska kunnig / belevrad att inte orsaka problem på egen hand.

PS: Jag överväger just nu bahnhof.

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

@Tequilla:

De bytte för ett tag sedan server, har du testat inställningarna här? För mig funkar det att skicka och ta emot även fast BBB är opålitliga

https://www.bredbandsbolaget.se/e-post.html

Asus P8P67 | i7 2600k | Corsair H80 | Asus GTX 770 OC | 8GB | Corsair TX650W | Fractal Design R3 | Intel 520 240GB

Macbook Pro Retina 15'' 2.6Ghz | 16GB | 512GB Late 2013

Trädvy Permalänk
Medlem
Registrerad
Jul 2015

@joeldeluxe: Holy crap, mina inställningar på default har alltid varit under port 587 sista 2 åren men inte SSL och nu med SSL vill klienten ha 465 på default, skrev 587 istället och ser faktiskt ut som att jag har skickat iväg ett email. Hallelulja!

Och ja opålitliga var det rätta uttrycket.

Skulle tro att BBB's interna utbildning kommer att inkludera denna tråden då deras egen ej kommer upp i adekvat kompetens nivå

PS: Supporten är verkligen så kass.

Trädvy Permalänk
Medlem
Registrerad
Jul 2015

Den lösningen som delgavs tidigare i tråden verkar nu ha upphört, har inte kunnat skicka email åter igen på 2 dagar...

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Sep 2006

Jag använt ett användarnamn och lösenord till att skicka mejl som bredbandsbolaget skickat till mig för flera år sedan, för ett par dagar sedan fungerar det inte... och de svarar ej via support. Dåligt!

Jag testade med tänkbara andra användarnamn, och hittade ett som fungerar!!! Hur fan kan de ändra mitt användarnamn utan att säga till mig?!?

Nu fungerar i alla fall mitt mejl igen.

Tips, testa din mejl-adress som användarnamn.

Trädvy Permalänk
Medlem
Registrerad
Jul 2015

@KkkkkkTzs: fungerade inte, jag avvaktar så länge.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018

Hej - hakar på denna tråd..
Jag kör med egen mailserver, och jag fick problem att skicka mail när Bredbandsbolaget började ha problem med sina mailservrar och gjorde om att man måste logga in med sin email adress istället för användare.
Även fast jag lägger upp mina rätta uppgifter så fungerar det inte utan att jag måste ha en mailklient uppkopplad mot min bredbands brevlåda som ligger och frågar efter nya mail 1gång i minuten - utan klienten igång så får jag inte skicka mail via min egna mailserver.

Om det är någon annan här som kör egen mailserver med bredbandsbolaget och upplever samma problem?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Hej - hakar på denna tråd..
Jag kör med egen mailserver, och jag fick problem att skicka mail när Bredbandsbolaget började ha problem med sina mailservrar och gjorde om att man måste logga in med sin email adress istället för användare.
Även fast jag lägger upp mina rätta uppgifter så fungerar det inte utan att jag måste ha en mailklient uppkopplad mot min bredbands brevlåda som ligger och frågar efter nya mail 1gång i minuten - utan klienten igång så får jag inte skicka mail via min egna mailserver.

Om det är någon annan här som kör egen mailserver med bredbandsbolaget och upplever samma problem?

Jag kör egen server och behöver använda Bredbandsbolagets utgående SMTP-relä. Det skickas inte mail utåt varje dag så jag kan bara säga att det fungerade fram till 26 april, men inte idag. Jag fick idag (04:42 imorse) ett bounce, "Undelivered Mail Returned to Sender".

Edit: Mailet som jag fick "bounce" för imorse skickades ursprungligen tidig morgon söndag, 29 april. Utgående mail slutade alltså fungera för mig mellan torsdagen 26 april och söndagen 29 april.

BBB:s server svarar från och med idag med: 535 5.7.0 authentication failed

Fram till för någon månad sedan kunde jag skicka mail utan att logga in. Sen började jag få felmeddelanden att jag måste kolla mail innan jag får skicka mail.

Citat:

550 5.7.1 <example@example.com>... Relaying denied: You must check for new mail before sending mail. (in reply to RCPT TO command)

Jag använder sedan någon månad tillbaka SASL-auth (med postfix+cyrus, och stunnel för SSL), med samma användarnamn och lösenord som fungerat på webb-portalen. Testade precis och det fungerar fortfarande på webbportalen. Dock fick jag inte logga in på deras webbmail med samma info, och det gick inte heller med samma lösenord för epostadressen kopplat till det användarnamnet. Kanske olika?

De kanske har ändrat till att man behöver logga in med sin @bredband.net-adress, men det hade jag inte tid att testa innan de till råga på allt precis påbörjade någon underhållning av sin webbsida. Jag får inte logga in alls där längre.

Citat:

Vi är snart tillbaka

Just nu jobbar vi med uppdateringar för att göra Bredbandsbolagets hemsida ännu bättre.

Suck...

Nedan följer exempel på två test innan det hela gick ned. Först med att ta bort SASL-auth, och sen med SASL-auth igen.

Citat:

May 4 11:42:00 mail postfix/smtp[62904]: 24183FEBC2: to=<example@example.com>, relay=smtp-bredband-net.localhost[127.0.0.1]:10465, delay=1.9, delays=0/0.01/1.5/0.41, dsn=5.7.1, status=bounced (host smtp-bredband-net.localhost[127.0.0.1] said: 550 5.7.1 <example@example.com>... Relaying denied: You must check for new mail before sending mail. (in reply to RCPT TO command))

May 4 11:48:10 mail postfix/smtp[63069]: 5474CFEBC3: to=<example@example.com>, relay=smtp-bredband-net.localhost[127.0.0.1]:10465, delay=1.7, delays=0/0.01/1.7/0, dsn=4.7.0, status=deferred (SASL authentication failed; server smtp-bredband-net.localhost[127.0.0.1] said: 535 5.7.0 authentication failed)

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003

Uppdatering på mitt eget inlägg:

Jag hade tidigare ett lösenord på bara 8 tecken, och använde portal-användarnamnet vid SMTP SASL Auth mot smtp.bredband.net port 465 (SSL med hjälp av stunnel). Det slutade uppenbarligen att fungera i slutet av april.

Jag fick inte logga in på webbmailen med samma lösenord som för portalen, så jag valde att testa ändra lösenordet. Nu när jag ändrade mitt lösenord på BBB ser jag att deras policy säger minst 9 tecken. Hur som haver så har jag nu ett nytt lösenord, som fungerar både för portalen och webbmailen.

Jag kan även meddela att jag nu kan skicka mail via deras SMTP-relä igen.

Citat:

May 4 12:15:58 mail postfix/smtp[63972]: 19D76FEBC5: to=<example@example.com>, relay=smtp-bredband-net.localhost[127.0.0.1]:10465, delay=2.1, delays=0/0.01/1.6/0.47, dsn=2.0.0, status=sent (250 2.0.0 w44AFubc002786 Message accepted for delivery)

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002

Hjälpte en person som hade ett konto Loopia och ett hos BBB där vi skulle få in båda mailen i div enheter.
TL DR, vi flyttade allt till Loopia från BBB för de strulade så mycket med sin mail så det var inte värt tiden. De har olika instruktioner på sin hemsida vad gäller SSL och portar, på vissa enheter fungerade den ena på andra enheter den andra. I vissa fall så fungerade vissa inställningar som redan fanns i en telefon, försökte man använda samma uppgifter för att ansluta en ny så fungerade det inte öht.

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003

För de som vill veta mer om hur jag gör så kör jag postfix kompilerat med stöd för cyrus-sasl.

En fil för användarnamn, som man kör via postmap:

cat << EOF > /path/to/sasl_passwd [smtp-bredband-net.localhost]:10465 your.email@bredband.net:PASSWORD123 EOF postmap /path/to/sasl_passwd

Del av main.cf:

relayhost = [smtp-bredband-net.localhost]:10465 smtp_sasl_auth_enable = yes smtp_sasl_security_options = noanonymous smtp_sasl_password_maps = hash:/path/to/sasl_passwd

stunnel:

pid = /var/run/stunnel.pid options = NO_SSLv2 options = NO_SSLv3 sslVersion = TLSv1.2 socket = l:TCP_NODELAY=1 socket = r:TCP_NODELAY=1 delay = yes [smtp-relay] client = yes accept = 127.0.0.1:10465 connect = smtp.bredband.net:465 verify = 2 CAfile = /usr/local/etc/ssl/cert.pem

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018
Skrivet av kai:

Uppdatering på mitt eget inlägg:

Jag hade tidigare ett lösenord på bara 8 tecken, och använde portal-användarnamnet vid SMTP SASL Auth mot smtp.bredband.net port 465 (SSL med hjälp av stunnel). Det slutade uppenbarligen att fungera i slutet av april.

Jag fick inte logga in på webbmailen med samma lösenord som för portalen, så jag valde att testa ändra lösenordet. Nu när jag ändrade mitt lösenord på BBB ser jag att deras policy säger minst 9 tecken. Hur som haver så har jag nu ett nytt lösenord, som fungerar både för portalen och webbmailen.

Jag kan även meddela att jag nu kan skicka mail via deras SMTP-relä igen.

Har inte sett att man måste ha 9 tecken, ska pröva att byta och se ifall det hjälper.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018

Kör egen dns också och får SPF fail, när jag skickar.

The original message was received at Fri, 4 May 2018 19:10:57 +0000
from ua-85-227-X-XXX.cust.bredbandsbolaget.se [85.227.X.XXX]

----- The following addresses had permanent fatal errors -----
<name@domain.se>
(reason: 550 5.7.23 <name@domain.se>: Recipient address rejected: Message rejected due to: SPF fail - not a...orized. Please see http://www.openspf.net/Why?s=mfrom;id=lasse@domain.se;ip=91.1...

----- Transcript of session follows -----
... while talking to mail.domain.se.:
>>> RCPT To:<name@domain.se> ORCPT=rfc822;name@domain.se
<<< 550 5.7.23 <name@domain.se>: Recipient address rejected: Message rejected due to: SPF fail - not authorized. Please see http://www.openspf.net/Why?s=mfrom;id=lasse@domain.se;ip=91.1...
550 5.1.1 <name@domain.se>... User unknown

Så här ser ext-domain-se ut, någon som vet vad de rätta skall vara?

IN SPF "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:62.127.194.0/27 ip4:195.54.99.192/27 ip4:213.150.131.0/27 -all"
IN TXT "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:62.127.194.0/27 ip4:195.54.99.192/27 ip4:213.150.131.0/27 -all"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Kör egen dns också och får SPF fail, när jag skickar.

The original message was received at Fri, 4 May 2018 19:10:57 +0000
from ua-85-227-X-XXX.cust.bredbandsbolaget.se [85.227.X.XXX]

----- The following addresses had permanent fatal errors -----
<name@domain.se>
(reason: 550 5.7.23 <name@domain.se>: Recipient address rejected: Message rejected due to: SPF fail - not a...orized. Please see http://www.openspf.net/Why?s=mfrom;id=lasse@domain.se;ip=91.1...

----- Transcript of session follows -----
... while talking to mail.domain.se.:
>>> RCPT To:<name@domain.se> ORCPT=rfc822;name@domain.se
<<< 550 5.7.23 <name@domain.se>: Recipient address rejected: Message rejected due to: SPF fail - not authorized. Please see http://www.openspf.net/Why?s=mfrom;id=lasse@domain.se;ip=91.1...
550 5.1.1 <name@domain.se>... User unknown

Så här ser ext-domain-se ut, någon som vet vad de rätta skall vara?

IN SPF "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:62.127.194.0/27 ip4:195.54.99.192/27 ip4:213.150.131.0/27 -all"
IN TXT "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:62.127.194.0/27 ip4:195.54.99.192/27 ip4:213.150.131.0/27 -all"

Jag har inget SPF record i min DNS då detta strulat så in i helvete när jag försökt använda det.

Mail som jag skickar från mig till gmail kommer inte från "smtp.bredband.net" eller något sånt. De härstammar från "megamailservers.eu".

Received: from mail92c50.megamailservers.eu (mail73c50.megamailservers.eu. [91.136.10.83]) by mx.google.com with ESMTPS id c19-v6si12860087pgw.613.2018.05.04.04.04.50 for <example@gmail.com> (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Fri, 04 May 2018 04:04:52 -0700 (PDT) Received-SPF: pass (google.com: domain of me@mydomain.se designates 91.136.10.83 as permitted sender) client-ip=91.136.10.83; Authentication-Results: mx.google.com; spf=pass (google.com: domain of me@mydomain.se designates 91.136.10.83 as permitted sender) smtp.mailfrom=me@mydomain.se X-Authenticated-User: myuser@bredband.net Received: from mail.mydomain.se (c-XXX.XXX.cust.bredbandsbolaget.se [X.X.X.X]) (authenticated bits=0) by mail92c50.megamailservers.eu (8.14.9/8.13.1) with ESMTP id w44B4i18023624 for <example@gmail.com>; Fri, 4 May 2018 11:04:47 +0000

Edit: Nej nu spiller jag ljug. Jag har visst SPF i min DNS. (Google-delen behövs nog inte.)

TXT "v=spf1 a:mail.mydomain.se mx include:bredband.net include:_spf.google.com -all"

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018

Bytte lösenord till 9 tecken i hopp om att allt skulle fungera. Det fungera att skicka mail från min mailserver i flera timmar men sedan fick jag samma "fel" som tidigare.

This is the mail system at host domain.se.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.
For further assistance, please send mail to postmaster.
If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<dennis@domain.se>: host smtp.bredband.net[91.136.8.208] said: 550 5.7.1
<dennis@domain.se>... Relaying denied: You must check for new mail before
sending mail. (in reply to RCPT TO command)
Reporting-MTA: dns; domain.se
X-Postfix-Queue-ID: 453121901059
X-Postfix-Sender: rfc822; lasse@domain.se
Arrival-Date: Sun, 6 May 2018 09:54:27 +0200 (CEST)

Drog igång min Raspberry Pi där jag satt upp en mailklient att kontrollera efter "nya" mail 1 ggr/min mot BBB, och efter ett antal minuter så fungerar det åter igen att maila från min mailserver.

Några förslag på lösning på detta?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Bytte lösenord till 9 tecken i hopp om att allt skulle fungera. Det fungera att skicka mail från min mailserver i flera timmar men sedan fick jag samma "fel" som tidigare.

This is the mail system at host domain.se.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.
For further assistance, please send mail to postmaster.
If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<dennis@domain.se>: host smtp.bredband.net[91.136.8.208] said: 550 5.7.1
<dennis@domain.se>... Relaying denied: You must check for new mail before
sending mail. (in reply to RCPT TO command)
Reporting-MTA: dns; domain.se
X-Postfix-Queue-ID: 453121901059
X-Postfix-Sender: rfc822; lasse@domain.se
Arrival-Date: Sun, 6 May 2018 09:54:27 +0200 (CEST)

Drog igång min Raspberry Pi där jag satt upp en mailklient att kontrollera efter "nya" mail 1 ggr/min mot BBB, och efter ett antal minuter så fungerar det åter igen att maila från min mailserver.

Några förslag på lösning på detta?

Vad kör du för mailserver och hur är den inställd för att skicka mail?

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018
Skrivet av kai:

Vad kör du för mailserver och hur är den inställd för att skicka mail?

Kör postfix och transport inställt att skicka med smtp via deras relä.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Kör postfix och transport inställt att skicka med smtp via deras relä.

Kan du posta den relevanta delen av din konfiguration? Hur skiljer den sig från min, ovan?

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018
Skrivet av kai:

Kan du posta den relevanta delen av din konfiguration? Hur skiljer den sig från min, ovan?

Delar av Main.cf

#### MY CONFIGURATION ####

daemon_directory = /usr/libexec/postfix
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix/samples
readme_directory = /usr/share/doc/postfix/README_FILES

myhostname = mydomain.se
mydomain = mydomain.se

inet_interfaces = all
inet_protocols = all

mydestination =
localhost.$mydomain,
localhost,
$mydomain

mynetworks_style = subnet

mynetworks = 192.168.50.0/24 192.168.0.0/24 127.0.0.0/8 [::1]/128 [fe80::]/10 [2001:16d8:cc55::]/48 [2001:470:28:69b::]/64

relay_domains = $mydestination

# Use /etc/postfix/transport instead
#relayhost = smtp.bredband.net

in_flow_delay = 1s
masquerade_domains = mydomain.se
masquerade_exceptions = root
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
home_mailbox = Mail/
smtpd_banner = $myhostname ESMTP

# Mapping to replace local fantasy email addresses by valid Internet addresses.
# This mapping happens ONLY when mail leaves the machine; not when you send mail between users on the same machine.
smtp_generic_maps = hash:/etc/postfix/generic

################################################################################
# DOVECOT SASL
################################################################################
smtpd_sasl_path = inet:localhost:12345
smtpd_sasl_type = dovecot

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes

smtp_sasl_password_maps=hash:/etc/postfix/sasl-passwords
smtp_sasl_mechanism_filter = digest-md5
smtp_sasl_security_options=
smtp_tls_wrappermode = yes
smtp_tls_security_level = encrypt

# Fixar så att det skrivs in att den som sänder e-post är authenticated sender i utgående mail
smtpd_sasl_authenticated_header = yes

Transport
domain.se :
* smtp:smtp.bredband.net:587

Sasl-passwords
[smtp.bredband.net]:587 användarnamn@bredband.net:lösenord

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Delar av Main.cf

#### MY CONFIGURATION ####

daemon_directory = /usr/libexec/postfix
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix/samples
readme_directory = /usr/share/doc/postfix/README_FILES

myhostname = mydomain.se
mydomain = mydomain.se

inet_interfaces = all
inet_protocols = all

mydestination =
localhost.$mydomain,
localhost,
$mydomain

mynetworks_style = subnet

mynetworks = 192.168.50.0/24 192.168.0.0/24 127.0.0.0/8 [::1]/128 [fe80::]/10 [2001:16d8:cc55::]/48 [2001:470:28:69b::]/64

relay_domains = $mydestination

# Use /etc/postfix/transport instead
#relayhost = smtp.bredband.net

in_flow_delay = 1s
masquerade_domains = mydomain.se
masquerade_exceptions = root
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
home_mailbox = Mail/
smtpd_banner = $myhostname ESMTP

# Mapping to replace local fantasy email addresses by valid Internet addresses.
# This mapping happens ONLY when mail leaves the machine; not when you send mail between users on the same machine.
smtp_generic_maps = hash:/etc/postfix/generic

################################################################################
# DOVECOT SASL
################################################################################
smtpd_sasl_path = inet:localhost:12345
smtpd_sasl_type = dovecot

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes

smtp_sasl_password_maps=hash:/etc/postfix/sasl-passwords
smtp_sasl_mechanism_filter = digest-md5
smtp_sasl_security_options=
smtp_tls_wrappermode = yes
smtp_tls_security_level = encrypt

# Fixar så att det skrivs in att den som sänder e-post är authenticated sender i utgående mail
smtpd_sasl_authenticated_header = yes

Transport
domain.se :
* smtp:smtp.bredband.net:587

Sasl-passwords
[smtp.bredband.net]:587 användarnamn@bredband.net:lösenord

Har du med "smtp_sasl_auth_enable = yes" någonstans? Jag ser den inte. Default är "no" och det skulle förklara ditt problem.

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.

Trädvy Permalänk
Medlem
Registrerad
Maj 2018
Skrivet av kai:

Har du med "smtp_sasl_auth_enable = yes" någonstans? Jag ser den inte. Default är "no" och det skulle förklara ditt problem.

Har lagt till "smtp_sasl_auth_enable = yes" så nu har jag både smtp och smtpd satta till yes.

Får följande SPF fel...

May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: connect from unknown[192.168.40.20]
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: Anonymous TLS connection established from unknown[192.168.40.20]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: 8E005190009D: client=unknown[192.168.40.20], sasl_method=PLAIN, sasl_username=lasse
May 08 22:58:20 server.DOMAIN.se postfix/cleanup[19701]: 8E005190009D: message-id=<d836a01f-de7c-abb4-8bdc-39230c72aa5b@DOMAIN.se>
May 08 22:58:20 server.DOMAIN.se opendkim[605]: 8E005190009D: DKIM-Signature field added (s=default, d=DOMAIN.se)
May 08 22:58:20 server.DOMAIN.se postfix/qmgr[17980]: 8E005190009D: from=<lasse@DOMAIN.se>, size=796, nrcpt=1 (queue active)
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: disconnect from unknown[192.168.40.20] ehlo=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=6
May 08 22:58:21 server.DOMAIN.se dovecot[988]: imap(lasse): Connection closed (IDLE running for 0.001 + waiting input for 0.007 secs, 2 B in + 10 B out, state=wait-input) in=1077 out=27195
May 08 22:58:22 server.DOMAIN.se postfix/smtp[19702]: warning: smtp.bredband.net[91.136.8.208]:587 offered no supported AUTH mechanisms: 'LOGIN'
May 08 22:58:22 server.DOMAIN.se postfix/smtp[19702]: 8E005190009D: to=<dennis@DOMAIN.se>, relay=smtp.bredband.net[91.136.8.208]:587, delay=2.2, delays=0.17/0.05/1.4/0.66, dsn=2.0.0, status=sent (250 2.0.0 w48KwLI1016127 Message accepted for delivery)
May 08 22:58:22 server.DOMAIN.se postfix/qmgr[17980]: 8E005190009D: removed
May 08 22:58:26 server.DOMAIN.se postfix/smtpd[19703]: connect from mail85c50.megamailservers.eu[91.136.10.95]
May 08 22:58:26 server.DOMAIN.se postfix/smtpd[19703]: Anonymous TLS connection established from mail85c50.megamailservers.eu[91.136.10.95]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
May 08 22:58:27 server.DOMAIN.se postgrey[359]: action=pass, reason=triplet found, client_name=mail85c50.megamailservers.eu, client_address=91.136.10.95, recipient=lasse@DOMAIN.se
May 08 22:58:27 server.DOMAIN.se postgrey[359]: cleaning up old logs...
May 08 22:58:27 server.DOMAIN.se postfix/smtpd[19703]: 86D55190009D: client=mail85c50.megamailservers.eu[91.136.10.95]
May 08 22:58:27 server.DOMAIN.se postfix/cleanup[19701]: 86D55190009D: message-id=<201805082058.w48KwPI1016174@mail18c50.megamailservers.eu>
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: mail85c50.megamailservers.eu [91.136.10.95] not internal
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: not authenticated
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: no signature data
May 08 22:58:27 server.DOMAIN.se postfix/qmgr[17980]: 86D55190009D: from=<>, size=4649, nrcpt=1 (queue active)
May 08 22:58:27 server.DOMAIN.se postfix/local[19705]: 86D55190009D: to=<lasse@DOMAIN.se>, relay=local, delay=0.85, delays=0.77/0.03/0/0.05, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER")
May 08 22:58:27 server.DOMAIN.se postfix/qmgr[17980]: 86D55190009D: removed
May 08 22:58:27 server.DOMAIN.se postfix/smtpd[19703]: disconnect from mail85c50.megamailservers.eu[91.136.10.95] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
May 08 22:58:31 server.DOMAIN.se dovecot[988]: imap-login: Login: user=<lasse>, method=PLAIN, rip=192.168.40.20, lip=192.168.50.5, mpid=19712, TLS, session=<vC98DLhrFfnAqCgU>

SPF i zone filen
IN TXT "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.101.64/26 ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:91.136.10.0/24 ip4:91.136.12.0/24 ip4:91.136.14.0/24 ip4:62.127.194.0/27 -all"

Förstår inte att jag får fel att behöva kontrollera mail innan jag får skicka med via min mailserver - mailservrar kontrollerar inte mail utan det är klienter som kontrollerar - hur har BBB gjort?!?

Enligt mig så har inte BBB någon autentisering
May 08 18:12:59 server.DOMAIN.se postfix/smtp[14717]: warning: smtp.bredband.net[91.136.8.208]:587 offered no supported AUTH mechanisms: ‘LOGIN'

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2003
Skrivet av Texan123:

Har lagt till "smtp_sasl_auth_enable = yes" så nu har jag både smtp och smtpd satta till yes.

Får följande SPF fel...

May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: connect from unknown[192.168.40.20]
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: Anonymous TLS connection established from unknown[192.168.40.20]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: 8E005190009D: client=unknown[192.168.40.20], sasl_method=PLAIN, sasl_username=lasse
May 08 22:58:20 server.DOMAIN.se postfix/cleanup[19701]: 8E005190009D: message-id=<d836a01f-de7c-abb4-8bdc-39230c72aa5b@DOMAIN.se>
May 08 22:58:20 server.DOMAIN.se opendkim[605]: 8E005190009D: DKIM-Signature field added (s=default, d=DOMAIN.se)
May 08 22:58:20 server.DOMAIN.se postfix/qmgr[17980]: 8E005190009D: from=<lasse@DOMAIN.se>, size=796, nrcpt=1 (queue active)
May 08 22:58:20 server.DOMAIN.se postfix/smtpd[19693]: disconnect from unknown[192.168.40.20] ehlo=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=6
May 08 22:58:21 server.DOMAIN.se dovecot[988]: imap(lasse): Connection closed (IDLE running for 0.001 + waiting input for 0.007 secs, 2 B in + 10 B out, state=wait-input) in=1077 out=27195
May 08 22:58:22 server.DOMAIN.se postfix/smtp[19702]: warning: smtp.bredband.net[91.136.8.208]:587 offered no supported AUTH mechanisms: 'LOGIN'
May 08 22:58:22 server.DOMAIN.se postfix/smtp[19702]: 8E005190009D: to=<dennis@DOMAIN.se>, relay=smtp.bredband.net[91.136.8.208]:587, delay=2.2, delays=0.17/0.05/1.4/0.66, dsn=2.0.0, status=sent (250 2.0.0 w48KwLI1016127 Message accepted for delivery)
May 08 22:58:22 server.DOMAIN.se postfix/qmgr[17980]: 8E005190009D: removed
May 08 22:58:26 server.DOMAIN.se postfix/smtpd[19703]: connect from mail85c50.megamailservers.eu[91.136.10.95]
May 08 22:58:26 server.DOMAIN.se postfix/smtpd[19703]: Anonymous TLS connection established from mail85c50.megamailservers.eu[91.136.10.95]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
May 08 22:58:27 server.DOMAIN.se postgrey[359]: action=pass, reason=triplet found, client_name=mail85c50.megamailservers.eu, client_address=91.136.10.95, recipient=lasse@DOMAIN.se
May 08 22:58:27 server.DOMAIN.se postgrey[359]: cleaning up old logs...
May 08 22:58:27 server.DOMAIN.se postfix/smtpd[19703]: 86D55190009D: client=mail85c50.megamailservers.eu[91.136.10.95]
May 08 22:58:27 server.DOMAIN.se postfix/cleanup[19701]: 86D55190009D: message-id=<201805082058.w48KwPI1016174@mail18c50.megamailservers.eu>
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: mail85c50.megamailservers.eu [91.136.10.95] not internal
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: not authenticated
May 08 22:58:27 server.DOMAIN.se opendkim[605]: 86D55190009D: no signature data
May 08 22:58:27 server.DOMAIN.se postfix/qmgr[17980]: 86D55190009D: from=<>, size=4649, nrcpt=1 (queue active)
May 08 22:58:27 server.DOMAIN.se postfix/local[19705]: 86D55190009D: to=<lasse@DOMAIN.se>, relay=local, delay=0.85, delays=0.77/0.03/0/0.05, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f- -a "$USER")
May 08 22:58:27 server.DOMAIN.se postfix/qmgr[17980]: 86D55190009D: removed
May 08 22:58:27 server.DOMAIN.se postfix/smtpd[19703]: disconnect from mail85c50.megamailservers.eu[91.136.10.95] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
May 08 22:58:31 server.DOMAIN.se dovecot[988]: imap-login: Login: user=<lasse>, method=PLAIN, rip=192.168.40.20, lip=192.168.50.5, mpid=19712, TLS, session=<vC98DLhrFfnAqCgU>

SPF i zone filen
IN TXT "v=spf1 mx a ip6:2001:470:28:69b::/48 a:smtp.bredband.net ip4:195.54.101.64/26 ip4:195.54.107.64/27 ip4:195.54.101.0/26 ip4:195.54.99.8 ip4:195.54.127.128/26 ip4:91.136.10.0/24 ip4:91.136.12.0/24 ip4:91.136.14.0/24 ip4:62.127.194.0/27 -all"

Förstår inte att jag får fel att behöva kontrollera mail innan jag får skicka med via min mailserver - mailservrar kontrollerar inte mail utan det är klienter som kontrollerar - hur har BBB gjort?!?

Enligt mig så har inte BBB någon autentisering
May 08 18:12:59 server.DOMAIN.se postfix/smtp[14717]: warning: smtp.bredband.net[91.136.8.208]:587 offered no supported AUTH mechanisms: ‘LOGIN'

Det ringer en klocka för mig att jag sett det där för just submission-porten, 587, hos Bredbandsbolagets relä.

Eftersom de inte tillåter login via submission (port 587) så är det ett krav att först loggat in och kollat sin mail innan. Helt klart dumt av de att inte ha LOGIN som val efter STARTTLS även via submission. Ska slänga ett öga på det under dagen.

Byt till att använda port 465 och implicit SSL istället. Antingen via stunnel, eller med postfix 3.0 och senare smtp_tls_wrappermode. Båda finns beskrivna i deras TLS readme.

http://www.postfix.org/TLS_README.html

[Ny] speldator: Fractal Design Meshify C, Core i7-8700k @ 4.9 GHz luftkyld med Cryorig R1 Universal, Asrock Z370 Fatal1ty Professional Gaming i7, 64 GB Corsair Dominator Platinum @ 3466 MHz (XMP), ASUS Strix GTX 970, Win10 Pro, Acer XB271HU Bild 1 Bild 2
(F.d. speldator: Fractal Design Define R2, Core i5 750 2.67 GHz @ 3.5 GHz (4 GHz Turbo) luftkyld med Hyper 212, 16 GB DDR3, ASUS Strix GTX 970, Win10 Pro)
Server: Xeon E3-1226v3 3.3 GHz, 32 GB ECC DDR3, VMware ESXi 6
10 Gbps direktkopplad fiber mellan speldator och server, med bland annat spelbiblioteket via en FreeNAS-VM.