Mappade enheter i Rpi3 har försvunnit

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Aug 2006

Mappade enheter i Rpi3 har försvunnit

Hej!

Har idag uppdaterat Raspbian i min RPi3, efter uppdateringen har mina mappade nätverksenheter försvunnit.

Om jag försöker mounta dom manuellt, får jag följande resultat:

pi@raspberrypi:~ $ sudo mount -a
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

"Hostarna" ligger inte nere, når dom utan problem från övriga datorer i nätverket.

Vad kan ha hänt?

Tack på förhand!

Mvh

Jonas

Trädvy Permalänk
Medlem
Registrerad
Mar 2012

Länge sen jag höll på med det men hade något liknande problem. I mitt fall har för mig att hade att göra med inkompatibla SMB-versioner. Testa att lägga till "vers=1.0" efter de andra argumenten i fstab och se om det fungerar då. Man bör dock inte köra v1 permanent p.g.a. säkerhetsrisker.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Aug 2006

Tack!

Så här ser min fstab ut, hur ska jag göra det tillägget du rekommenderade?

proc /proc proc defaults 0 0
PARTUUID=5544234c-01 /boot vfat defaults 0 2
PARTUUID=5544234c-02 / ext4 defaults,noatime 0 1
# a swapfile is not a swap partition, no line here
# use dphys-swapfile swap[on|off] for that
//192.168.0.5/x /home/pi/Shares/T cifs username=x,password=x 0 0
//192.168.0.4/usbshare3 /home/pi/Shares/U cifs username=x,password=x 0 0
//192.168.0.4/usbshare2 /home/pi/Shares/V cifs username=x,password=x 0 0
//192.168.0.2/Volume_1 /home/pi/Shares/W cifs username=x,password=x 0 0
//192.168.0.2/Volume_2 /home/pi/Shares/X cifs username=x,password=x 0 0
//192.168.0.3/Volume_1 /home/pi/Shares/Y cifs username=x,password=x 0 0
//192.168.0.3/Volume_2 /home/pi/Shares/Z cifs username=x,password=x 0 0

Mvh

Jonas

Trädvy Permalänk
Medlem
Registrerad
Mar 2012

Testa att lägga till "vers=1.0" utan citattecken i varje mount före "username=x" eller efter "password=x" (kommaseparerat tror jag det ska vara). Det kräver dock att du har SMBv1 aktiverat på systemet som hostar filerna. Jag vet inte vilken version du har kört tidigare. v1 är t.ex. inaktiverat i Windows 10 numera p.g.a. säkerhetsrisker. Du kan även prova nyare versioner som 2.1 eller 3.0 och se om det gör någon skillnad. Jag vet inte ens om detta har något med ditt problem att göra, men i mitt fall var det detta som orsakade problem. Då var det dock p.g.a att SMBv1-stödet patchades bort i Windows 10 som det gick sönder, kör numera med argumentet ver=3.0 i mina mounts. Varför du skulle få problem med SMB-versioner när du uppdaterat Raspbian vet jag egentligen inte.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Aug 2006

Tack för hjälpen!

Det fungerade utmärkt att göra som du sade. Ska testa med 3.0 också.

Testade också med en helt ren installation av Raspbian, för att utesluta att mina egna tillägg ställer till problem.
Installerade Raspbian och mountade en enhet precis som jag gjort tidigare, inga problem.
Körde sudo apt-get update, sudo apt-get upgrade, startade om, och då fungerade det inte att mounta på det gamla sättet. Märkligt!

Mvh

Jonas

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av Lilak:

Tack för hjälpen!

Det fungerade utmärkt att göra som du sade. Ska testa med 3.0 också.

Testade också med en helt ren installation av Raspbian, för att utesluta att mina egna tillägg ställer till problem.
Installerade Raspbian och mountade en enhet precis som jag gjort tidigare, inga problem.
Körde sudo apt-get update, sudo apt-get upgrade, startade om, och då fungerade det inte att mounta på det gamla sättet. Märkligt!

Mvh

Jonas

Låter konstigt, men kan inte tillräckligt mycket om Linux för att gissa varför Men det fungerade med "ver=1.0" efter update alltså? Ja, testa med t.ex. 3.0 eller 2.1 då också, 1.0 bör man som sagt inte köra. Helst ska du nog avaktivera det på systemet som hostar filerna också om möjligt.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Aug 2006

Japp, efter update fungerar det med ver=1.0. Före update fungerar det utan.

Mvh

Jonas

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Aug 2006

Fungerar inte med något annat än ver1.0.

Mvh

Jonas