[ESXI] passthrough USB hub

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

[ESXI] passthrough USB hub

Tjo,

Har nu lyckas fått igång GPU så nu får jag bild efter mycket jobb men nu som är kvar är att få igång USB hub.

Jag har en lång USB kabel från min serverdator till en USB hub där jag har mus & tangentbord och USB mic men jag får det inte att funka.

Om jag passthrough fel så kommer jag inte kunna använda USB portar på serverdator till något annat än så just till den VM.

Några förslag som kan lösa mitt lila problem?

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Apr 2013

Kör host usb device iställer för usb controller så är det bara resp usb device du tappar.

Vad är syftet?

Trädvy Permalänk
Medlem
Registrerad
Jul 2017

Går det verkligen att passera igenom en hel USB-hubb med ESXi? Är det inte så att att du måste passa igenom individuella USB-enheter som du vill köra snarare än hubben?

För bäst hjälp, försök att svara på alla frågor som ställs i ett inlägg. Då slipper vi fråga om samma sak fler gånger, och du får hjälp snabbare.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av aluser:

Kör host usb device iställer för usb controller så är det bara resp usb device du tappar.

Vad är syftet?

Går inte ta bort usb controller den som finns där. Ha en VM som speldator tills det kommer några bra GPU till ett okej pris.

Skrivet av pv2b:

Går det verkligen att passera igenom en hel USB-hubb med ESXi? Är det inte så att att du måste passa igenom individuella USB-enheter som du vill köra snarare än hubben?

Jag vet inte om den klara av en hel hubb därför jag undra om det gick.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

usb device USB HID

Efter lite tester så verka det som att den kan hämta allt som är på hubben vet dock inte om det funkar men den upptäcker det.

Nu till ett nytt problem ESXI klara inte av att usb device HID så mus och tangentbord funkar inte.

Några förslag?

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002

Jag skulle köra någon variant av USB over Ethernet, hårdvarulösning eller mjukvarulösning.

https://www.digi.com/products/usb-and-serial-connectivity/usb...
http://www.usb-over-network.com/usb-over-network.html

Passthrough fungerar inte alltid är min erfarenhet

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Jan 2009
Skrivet av superegg:

Efter lite tester så verka det som att den kan hämta allt som är på hubben vet dock inte om det funkar men den upptäcker det.

Nu till ett nytt problem ESXI klara inte av att usb device HID så mus och tangentbord funkar inte.

Några förslag?

Varför behöver du tangentbord och mus i ESXi-management? Du kan koppla upp dig remote via vSphere Web Client och administrera det mesta på ESXi-hosten.

Intel Core i5 4670K | Noctua NH-D14 | MSI Z87 G-45 Gaming | Kingston 1600mhz 4x4gb | Asus Turbo 1060 6Gb | Samsung 840 Evo 250gb | Intel 520 Series 240gb | Western Digital caviar black 1Tb | Fractal Design Define R4 Black Pearl | Corsair 750HX | Win 10 64bit | Philips 273E 1920x1080 | Logitech G900 | Razer Blackwidow | Sennheiser PC360 G4me | Samsung Galaxt S9+ |

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Mr_Lazy:

Jag skulle köra någon variant av USB over Ethernet, hårdvarulösning eller mjukvarulösning.

https://www.digi.com/products/usb-and-serial-connectivity/usb...
http://www.usb-over-network.com/usb-over-network.html

Passthrough fungerar inte alltid är min erfarenhet

Ser två problem då behöver jag en till dator som kan vara USB server åt min VM server och den verka kostar över $150.

Skrivet av InCyBoy:

Varför behöver du tangentbord och mus i ESXi-management? Du kan koppla upp dig remote via vSphere Web Client och administrera det mesta på ESXi-hosten.

https://www.sweclockers.com/forum/trad/1439771-flytta-ut-dato...

Fast en VM istället.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Maj 2008

Som jag förstår problemet så vill du inte köra passthrough på hela din USB-controller? Har du bara en på moderkortet?

Enklast är att köpa ett billigt pcie-kort med USB och köra det som passthrough.

En server här, några servrar där.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av moron:

Som jag förstår problemet så vill du inte köra passthrough på hela din USB-controller? Har du bara en på moderkortet?

Enklast är att köpa ett billigt pcie-kort med USB och köra det som passthrough.

Ska snart dra iväg och köpa denna https://www.inet.se/produkt/5406016/kontrollerkort-pcie-4st-u....

Problemet är att jag kanske inte har några PCI-E plaster lediga därför ville jag lösa det på andra sätt men om jag har räknat rätt så ska jag ha någon PCI-E ledig men lite tur.

Mitt moderkort: http://www.supermicro.com.tw/products/motherboard/xeon/c600/x...

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Jan 2003
Skrivet av superegg:

Ska snart dra iväg och köpa denna https://www.inet.se/produkt/5406016/kontrollerkort-pcie-4st-u....

Problemet är att jag kanske inte har några PCI-E plaster lediga därför ville jag lösa det på andra sätt men om jag har räknat rätt så ska jag ha någon PCI-E ledig men lite tur.

Mitt moderkort: http://www.supermicro.com.tw/products/motherboard/xeon/c600/x...

Kolla först att du har ledig kortplats och även att springan på chassits bakplåt för instickskorten är bred nog att klara USB-kontakter på tvären. Mitt fractal design har för smala springor, hade problem med exakt det USB-kortet.

Skickades från m.sweclockers.com

Datorparken över tid: Pentium 150MHz non-MMX @208MHz OC (1997-1998), Dual PentiumII-350 @2x350MHz (1998-2008), DEC Alpha 21164 @500MHz (1999-2001), Pentium4 @2.53GHz (2004-2008), Athlon x2 be2300 @2x1.9GHz (2008-2011, 2017), C2D(laptop) @2x2.53GHz (2008-2011), PhenomII x4 910e @4x2.6GHz (2011-2012, 2018-), Dual Opteron 6140 @2x8x2.6GHz inkl. virtuell Win8 + GPU (2011-2017), Atom Avoton C2550 @4x2.4GHz (2014-), i7 8700 @6x3.2GHz inkl. virtuell Win10 + GPU (2017-)
Färgnyckel: Desktop/spel (primärt windows), Server (primärt *nix), Wks/Server (primärt *nix).

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Oegat:

Kolla först att du har ledig kortplats och även att springan på chassits bakplåt för instickskorten är bred nog att klara USB-kontakter på tvären. Mitt fractal design har för smala springor, hade problem med exakt det USB-kortet.

Skickades från m.sweclockers.com

Nu sitter den i serverdator. Du råka väl inte veta vart man kan ladda ner driver känner att jag inte har löst att jobba med en cd skriva?

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Registrerad
Jan 2003

@superegg: Om windows, testa denna drivaren: http://www.ti.com/product/TUSB7340/toolssoftware

Delock har inga egna drivare online, och jag har inte heller nåt att läsa cd:n med, utan jag laddade ner från Texas Instruments (som tillverkar kontrollerkretsen) enligt ovan då det begav sig. Det ska vara den kretsen, om inte tillverkningsprocessen ändrats eller Inet skickat något annat än det som bilden visar. Är det fel så säger installationen ifrån.

Datorparken över tid: Pentium 150MHz non-MMX @208MHz OC (1997-1998), Dual PentiumII-350 @2x350MHz (1998-2008), DEC Alpha 21164 @500MHz (1999-2001), Pentium4 @2.53GHz (2004-2008), Athlon x2 be2300 @2x1.9GHz (2008-2011, 2017), C2D(laptop) @2x2.53GHz (2008-2011), PhenomII x4 910e @4x2.6GHz (2011-2012, 2018-), Dual Opteron 6140 @2x8x2.6GHz inkl. virtuell Win8 + GPU (2011-2017), Atom Avoton C2550 @4x2.4GHz (2014-), i7 8700 @6x3.2GHz inkl. virtuell Win10 + GPU (2017-)
Färgnyckel: Desktop/spel (primärt windows), Server (primärt *nix), Wks/Server (primärt *nix).

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016
Skrivet av Oegat:

@superegg: Om windows, testa denna drivaren: http://www.ti.com/product/TUSB7340/toolssoftware

Delock har inga egna drivare online, och jag har inte heller nåt att läsa cd:n med, utan jag laddade ner från Texas Instruments (som tillverkar kontrollerkretsen) enligt ovan då det begav sig. Det ska vara den kretsen, om inte tillverkningsprocessen ändrats eller Inet skickat något annat än det som bilden visar. Är det fel så säger installationen ifrån.

Jag har lyckas installera drivaren dock kom jag på att den behöver ström så får fixa det när jag har tid.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666